Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Problem mit Loginscript unter Vista

Mitglied: TuXHunt3R

TuXHunt3R (Level 3) - Jetzt verbinden

05.10.2007, aktualisiert 18.10.2012, 4883 Aufrufe, 4 Kommentare

Hallo ans Forum

Ich habe ein Problem mit meinem Loginscript (Batch) in meiner Heimdomäne.

Immer wenn ich mich an meinem Vista-Client einlogge, bleibt das Loginscript stehen und bringt mir folgende Meldung beim Löschen des Laufwerks P (Befehl: net use P: /delete):

01.
There are open files and/or incomplete directory searches pending on the connection to P:.
02.

03.
Is it OK to continue disconnecting and force them closed? (Y/N) [N]: y
Dieses Phänomen tritt nur auf meinem Vista-Client auf (Vista Business), bei einem Login an einem 2003 Enterprise Server SP2 oder an den XP Pro SP2 Clients tritt das Phänomen nicht auf. Ich habe auch schon das Loginscript stehen lassen und remote per Computerverwaltung geschaut, ob irgendwo auf dem Server offene Dateien in meinem P-Laufwerk sind. Das komische daran ist ja, dass zu diesem Zeitpunkt keine der Dateien im entsprechenden Ordner geöffnet ist. Hat irgendjemand dafür eine Erklärung?

Domäne enthält 3 XP Clients, einen Vista Business Client sowie zwei Server, die mit Windows 2003 Enterprise Edition laufen. Der eine Server übernimmt die Aufgaben des Domänencontrollers, des DNS-Servers, des DHCP-Servers, des Fileservers sowie des Intranet-Webservers (IIS 6.0). Auf diesem Server läuft ein zweiter Server mit Virtual PC 2007. Auf diesem läuft ein Apache 2 Webserver (XAMPP).

Das Loginscript sieht im Prinzip so aus (Beispiel):

01.
::Alle möglichen Laufwerke trennen
02.
if exist G: (
03.
net use G: /delete
04.
)
05.
::usw (alle Buchstaben von G: bis Z:)
06.

07.
:: User auswählen
08.
if "%username"=="suppenkasper" goto suppenkasper
09.
::usw, alle 5 User sind hier aufgelistet
10.

11.
:suppenkasper
12.
net use G: \\server\share$
13.
::usw. Die jeweiligen Laufwerke werden pro User verbunden.
Das P-Laufwerk ist übrigens das Persönliche Laufwerk (Homeshare) jedes Users (\\server\%username%$)


Also, hat jemand eine Ahnung, wieso das Script unter Vista zickt?
Mitglied: 51705
05.10.2007 um 21:04 Uhr
Hast du Ordner-Umleitungen definiert?
Bitte warten ..
Mitglied: TuXHunt3R
05.10.2007 um 22:12 Uhr
Nicht dass ich wüsste....
Was genau meinst du mit Ordnerumleitungen?

Edit: Ist das irgendeine versteckte Funktion von Vista, die ich vergessen habe zu deaktivieren?
Bitte warten ..
Mitglied: TuXHunt3R
07.10.2007 um 23:17 Uhr
Zwischenstand:

Mir ist in den Sinn gekommen, dass mein Wallpaper ja auf meinem P-Laufwerk liegt, d.h. auf dem dem hier betroffenen Laufwerk. Ich habe also das Wallpaper weggenommen und ein Standard-Wallpaper von Windows verwendet. Beim erneuten Login kam die Fehlermeldung aber trotzdem wieder, an dem kann es also nicht liegen. Wisst ihr noch was?
Bitte warten ..
Mitglied: TuXHunt3R
01.11.2007, aktualisiert 18.10.2012
Habe das Disconnecten der Netzlaufwerke nun anders gelöst. Statt mit "if exist" zu überprüfen, ob das Laufwerk existiert und es dann zu disconnecten, habe ich folgendes gemacht:

Am Anfang des Scripts steht folgender Befehl:
01.
net use * /d /y
Mit dem * werden einfach alle Netzlaufwerke ausgewählt, mit /d werden diese gelöscht und mit /y werden eventuelle Meldungen mit "Yes" bestätigt!

Bis jetzt habe ich keine Probleme mehr gehabt. Ich betrachte daher den Beitrag als gelöst!


Danke an bastla für den Tipp im Beitrag
https://www.administrator.de/forum/anmelde-bzw-abmeldescripts-%c3%bcbers ...
Bitte warten ..
Ähnliche Inhalte
Windows Update
SUSID im Loginscript
gelöst Frage von EmheonivekWindows Update1 Kommentar

Liebe Community, es wurden Windows PCs mit Acronis bespielt, ohne vorher ein Sysprep durchzuführen. Leider haben nun circa 100 ...

Windows Server
Loginscript wird nicht verarbeitet
Frage von franksigWindows Server17 Kommentare

Hallo zusammen, Ich hab mal wieder ein leidiges Loginscriptproblem, Ausgangslage: es git eine GPO Namens "Loginskript-Produktion" ich habe dort ...

Windows Userverwaltung
Java via Loginscript deinstallieren
gelöst Frage von MarkBeakerWindows Userverwaltung5 Kommentare

Hallo zusammen, da Java ab nächstem Jahr Lizenzpflichtig wird, möchte ich in einer Windows Domaine alle Java Versionen von ...

Windows Server

Bitlocker Key per Batch - Loginscript ablegen

Frage von dgrebnerWindows Server5 Kommentare

Guten Tag, ein Kunde von uns setzt bei allen seinen Notebooks Bitlocker zur Verschlüsselung ein. Da bisher jeder User ...

Neue Wissensbeiträge
Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 1 StundeInternet

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 22 StundenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Windows 10

Windows 10 - Programme laufen schneller, wenn Sie mit Administratorrechten ausgeführt werden

Erfahrungsbericht von 1Werner1 vor 2 TagenWindows 1013 Kommentare

Moin, das wollte ich erst nicht glauben, aber es ist so. Wenn Ihr ein Programm mit Administratorrechten unter Windows ...

Sicherheits-Tools
Putty hat heftige Bugs korrigiert!
Information von Lochkartenstanzer vor 3 TagenSicherheits-Tools8 Kommentare

Moin, Wie man aus herauslesen kann, sind in den Versionen vor 0.71 gravierende Bugs, die es angeraten erscheinen lassen, ...

Heiß diskutierte Inhalte
Hardware
Telefonanlagen - Welche gibt es
Frage von Xaero1982Hardware38 Kommentare

Nabend Zusammen, ich suche eine neue TK Anlage und mein Auftraggeber will jetzt was völlig neues - State of ...

Server-Hardware
Kompatibilität Tray für HP Proliant DL385 G10 vs. G8, G9
Frage von chris123Server-Hardware19 Kommentare

Hallo, weiß einer der hier anwesenden, ob die Trays für 2,5 " HDDs zwischen einem DL 385 G10 und ...

Outlook & Mail
Office 365 mit Email-Profil installieren
gelöst Frage von 139221Outlook & Mail18 Kommentare

Hallo, kurz zu meiner Person: Vor ungefahr 10 Jahren habe ich eine Umschuldung zum Fachinformatiker für Systemintegration gemacht aber ...

LAN, WAN, Wireless
Intel(R) PRO Wireless 3945ABG
gelöst Frage von Leon509LAN, WAN, Wireless15 Kommentare

Hallo, habe ein Laptop Fujitsu (Intel, 4GB, 2GHz, Windos10, Intel(R) PRO/Wireless 3945ABG ) ein O2 DSL Anschluss Home50. Leider ...