Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Samba - Problem mit den Profilen

Mitglied: Vatras

Vatras (Level 1) - Jetzt verbinden

24.09.2006, aktualisiert 26.09.2006, 4881 Aufrufe, 7 Kommentare

Guten Abend zusammen,

ich habe folgendes Problem mit meinem Samba Server:

Es existiert eine Domäne "Servus" an dich ich mich bereits mit einem Client erfolgreich angemeldet habe. Jedoch kann ich mich nur mit einem Benutzer z.B. "Client" erfolgreich an die Domäne anmelden. Versuche ich es mit anderen Benutzern (Unix und Samba Account existiert) schlägt die Integration fehl.
Außerdem kann ich das Benutzerprofil von "Client" nicht in dem Verzeichnis finden,das ich dafür angegeben habe (siehe Auszug aus meiner smb.conf) Besser gesagt finde ich es überhaupt nicht auf dem Server obwohl es ja da sein muss, da Änderungen, z.B am Desktop übernommen werden. Ich benutze als Clients OS WinXP (Profil serverseitig speichern ist aktiviert). Hier nun ein Auszug aus der smb.conf:

[global]
workgroup = REINNET
server string = Samba %v
logon path = /srv/samba/profiles/%U
domain logons = yes
os level = 65
preferred master = yes
domain master = yes
wins support = yes
invalid users = amd
read only = no
profile acls = Yes



[netlogon]
comment = Domäne Logon
path = /srv/samba/netlogon/
guest ok = yes

[profiles]
comment = Netzwerk Profil
path = /srv/samba/profiles/%U

Ich bin noch Neuling auf dem Gebiet und bin für jeden Tipp dankbar, da ich absolut nicht mehr weiter weiß.

Danke im Voraus für eure Hilfe

Vatras
Mitglied: DERMOLCH
25.09.2006 um 11:56 Uhr
Es gibt in der Registry einen String der die Art der Verschlüsselung zu einen Domäne regelt. Den sollte man auf 0 oder 1 setzen und dann mal probieren. Such mal in der Registry nach :

signorseal und verändere dort man den Wert bei der Workstation die sich nicht einloggen kann. Vergleiche mal den Wert in der registry des rechners der sich anmelden läßt. Würd mich mal interessieren ob das dann geht ....
Bitte warten ..
Mitglied: pfoe
25.09.2006 um 12:14 Uhr
wegen den Servergespeichterten Profilen:

Passen die Sicherheitseinstellungen deines Profilordners au fdem Client?

ggf kann man das auch, wenns muckt über die MMC anpassen

im Reiter Konsole -auf Snap-in Hinzufügen/entfernen gehen und Gruppenrichtlinie hinzufügen!

Gruppenrichtlinie öffnen, dort auf Computerkonfiguration – Administrative Vorlagen – System – Anmeldung - Eigentümer von servergespeicherten Profilen nicht prüfen *Aktivieren

Wichtig: ServicePack4 muss installiert sein auf W2k

Greez PFoE
Bitte warten ..
Mitglied: Vatras
25.09.2006 um 14:20 Uhr
Zunächst mal danke für eure Antorten!

@der MOLCH:
Es handelt sich um ein und den selben Client, nur der Benutzer ist ein anderer. Den signorseal-Wert habe ich schon geändert.

@pfoe
werde ich umgehend ausprobieren sobald ich zu hause bin.

Habe ich vielleicht irgendwelche Pfade falsch angegeben? Die Rechte auf dem Server sind zu Testzwecken so vergeben, dass jeder auf "profiles" zugreifen kann.

MFG

Vatras
Bitte warten ..
Mitglied: Guenni
25.09.2006 um 15:43 Uhr
@Vatras

Hi,

Ändere das …
logon path = /srv/samba/profiles/%u
... mal um in:
logon path = \\%L\profiles\%U

Da Windows sich dort anmeldet, muß der Pfad auch windowskonform
angegeben werden(nicht /, sondern \).

%L ist der Netbiosname des Servers.

Grüße
Günni
Bitte warten ..
Mitglied: Vatras
25.09.2006 um 19:22 Uhr
Guten Abend zusammen,

ich habe den Pfad jetzt folgendermaßen abgeändert:
"logon path = \\%L\profiles\%U"

Aber es funktioniert immer noch nicht. Jetzt kann sich kein Benutzer mehr am System
anmelden. Habt ihr noch andere Ideen oder Anregungen. Bin echt am verzweifeln.
Muss ich noch irgendwelche Unterordner erstellen oder etwas in der Richtung?

Beim anmelden mit dem WinXP Client bekomme ich folgende Fehlermeldung:
"Das System kann den angegebenen Pfad nicht finden".

"Testparm" meldet keinerlei syntaktische Fehler!


Gruß,

Vatras
Bitte warten ..
Mitglied: Guenni
26.09.2006 um 14:25 Uhr
@Vatras

Hi,

[profiles]
comment = Netzwerk Profil
path = /srv/samba/profiles/%U

Lass hier am Ende das /%U weg.
Das Verzeichnis muß für alle beschreibbar sein:

chmod 777 /srv/samba/profiles

Das Userverzeichnis %U ist ja nicht die Freigabe,
sondern profiles. Sorry, hatte ich übersehen.

Unter [global] trag noch
interfaces = IP_des_Servers/Subnetzmaske ein.

Es existiert eine Domäne "Servus" ....

Ist Servus der Computername des Servers? Aus Sicht der Windows-Clients ist
workgroup=reinnet der Domänenname.

Hast du für die Clients ein Computerkonto(Unix- und Samba-Account) erstellt?

Zuerst eine Gruppe:

groupadd gruppenname(z.B.: clients)

Dann das Konto:

useradd -g clients -d /dev/null -s /bin/false -c "NT-Computer" computername$

Und der Samba-Account

smbpasswd -a -m computername$

Das $ am Ende nicht vergessen, das deutet für das System, dass
es sich um einen Maschinen-Account handelt.

Grüsse
Günni
Bitte warten ..
Mitglied: Vatras
26.09.2006 um 17:55 Uhr
Hi

@Günni

Es hat tatsächlich nur an dem Parameter "%U" gelegen. Bei der Domäne hatte ich mich vertippt, sorry. Die Domäne heißt "reinnet" und der Server "servus".

Tausend Dank für deine Hilfe. Es funktioniert jetzt alles wunderbar.
Werde dich weiterempfehlen

Gruß,

Vatras
Bitte warten ..
Ähnliche Inhalte
Samba
Samba Authentifizierungsproblem
Frage von Phill93Samba7 Kommentare

Hallo, ich habe hier einen Samba Server der mir Kopfzerbrechen verursacht. Wenn ich mich von einem Windows Rechner (Domäne) ...

Server
NAS SAMBA Login
Frage von MarabuntaServer16 Kommentare

Hi, Bin gerade im Urlaub und habe festgetellt,dass ein SAMBA Login mit einer russischen IP erfolgreich war. Was ist ...

Samba
Samba - Ordnerlöschen verhindern
Frage von WaishonSamba5 Kommentare

Moin zusammen, hier ein weiterer Post aus der Reihe "Samba und warum funktioniert das in Windows nicht!" :) Infos: ...

Debian
Samba Druckertreiber hinterlegen
Frage von Fenris14Debian7 Kommentare

Guten Tag, ich weiß es gibt einige Tutorials zu diesem Thema. Habe mir auch verschiedenste angesehen, aber irgendwie will ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 2 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 4 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk33 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless23 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing22 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

Virtualisierung
Gebrauchte Server Hardware als Virtualisierungs-"Spielwiese"?
Frage von NixVerstehenVirtualisierung19 Kommentare

Einen wunderschönen guten Morgen zusammen, ich möchte mich gerne etwas tiefer mit dem Thema Virtualisierung beschäftigen und dazu ein ...