Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VPDN zwischen Cisco 1600 IOS 11.2 und 2600 IOS 12.1

Mitglied: Flogge

Flogge (Level 1) - Jetzt verbinden

07.10.2006, aktualisiert 03.01.2007, 5572 Aufrufe, 4 Kommentare

Hallo Community

Ich habe ein Cisco Konfigurationsproblem das ich leider nicht alleine lösen kann.
Ich habe 2 Cisco 1600er Router welche sich über eine Telefonanlage auf einem Cisco 2600 Router über ISDN einwählen. Der 2600 besitzt dazu 2 Bri Schnittstellen. Jeder ClientRouter (1600) wählt sich auf einer eigenen Nummer Bri beim AccessRouter (2600) ein. Dies klappt auch zuverlässig. (Vorweg, es handelt sich um einen Testaufbau, da ich keine Internetanschlüsse nutzen kann simuliert meine Telofonanlage das Internet ) Die PC´s an den Clientroutern nutzen den RDP Terminaldienst auf einem Server hinter dem Access Router.

Nun zu meinem Problem
Da dies natürlich nicht in Klartext über das Internet (Telefonanlage ) übertragen werden soll habe ich mich für VPN entschieden. In diesem Fall für vpdn. Ich habe die betreffenden Zeilen in den Konfigurationen markiert, denn die Einwahl klappt hervorragend, aber es wird die vpnd Anweisung einfach ignoriert. Die VPDN Strecke soll nur zwischen den Routern existieren und nicht bis zum Server gehen.

Was mache ich falsch? Ich hoffe ihr wisst Rat.


Konfiguration eines Client Routers (Cisco 1600) Die Konfiguration des Client-2Router ist sinngemäß identisch
01.
!
02.
version 11.2
03.
service timestamps debug datetime msec
04.
service timestamps log datetime msec
05.
no service password-encryption
06.
no service udp-small-servers
07.
no service tcp-small-servers
08.
!
09.
hostname Client-1Router
10.
!
11.
enable secret 5 $1$n.rg$2xkrdsPVtvjOZY5GEI1S/0
12.
!
13.
username AccessRouter password 0 Passwort
14.
ip subnet-zero
15.
no ip domain-lookup
16.
vpdn enable
17.
vpdn outgoing e-sirius.com AccessRouter ip 192.168.2.1
18.
isdn switch-type basic-net3
19.
!
20.
interface Ethernet0
21.
 ip address 192.168.3.1 255.255.255.0
22.
 no ip directed-broadcast
23.
 no ip proxy-arp
24.
 no logging event subif-link-status
25.
 media-type 10BaseT
26.
!
27.
interface Serial0
28.
 no ip address
29.
 no logging event subif-link-status
30.
 shutdown
31.
!
32.
interface BRI0
33.
 no ip address
34.
 no ip directed-broadcast
35.
 encapsulation ppp
36.
 no logging event subif-link-status
37.
 dialer pool-member 1
38.
 ppp authentication chap callin
39.
!
40.
interface Dialer1
41.
 description Verbindung zu Router AccessRouter
42.
 ip address 192.168.4.2 255.255.255.0
43.
 no ip directed-broadcast
44.
 no ip proxy-arp
45.
 encapsulation ppp
46.
 no logging event subif-link-status
47.
 dialer remote-name AccessRouter
48.
 dialer string 21
49.
 dialer load-threshold 100 either
50.
 dialer pool 1
51.
 dialer-group 1
52.
 no fair-queue
53.
 ppp authentication chap callin
54.
 ppp multilink
55.
!
56.
ip classless
57.
ip route 0.0.0.0 0.0.0.0 192.168.4.1
58.
ip route 192.168.1.0 255.255.255.0 192.168.4.1
59.
ip route 192.168.2.0 255.255.255.0 192.168.4.1
60.
access-list 102 permit tcp host 192.168.3.2 host 192.168.1.1 eq 3389
61.
access-list 102 deny   ip any any
62.
dialer-list 1 protocol ip list 102
63.
!
64.
line con 0
65.
 transport input none
66.
 stopbits 1
67.
line vty 0 4
68.
 login local
69.
!
70.
End
Konfiguration des Cisco 2600er Routers

01.
!
02.
version 12.1
03.
service timestamps debug datetime msec
04.
service timestamps log datetime msec
05.
no service password-encryption
06.
!
07.
hostname AccessRouter
08.
!
09.
enable secret 5 $1$n.rg$2xkrdsPVtvjOZY5GEI1S/0
10.
!
11.
username Client-1Router password 0 Passwort
12.
username Client-2Router password 0 Passwort
13.
!
14.
!
15.
!
16.
!
17.
no ip subnet-zero
18.
no ip finger
19.
no ip domain-lookup
20.
!
21.
vpdn enable
22.
no vpdn logging remote
23.
no vpdn logging user
24.
!
25.
vpdn-group 1
26.
 accept-dialin
27.
  protocol l2f
28.
  virtual-template 1
29.
 terminate-from hostname Client-1Router
30.
 local name AccessRouter
31.
!
32.
isdn switch-type basic-net3
33.
isdn voice-call-failure 0
34.
partition flash 2 8 8
35.
!
36.
!
37.
!
38.
!
39.
!
40.
!
41.
interface Ethernet0/0
42.
 ip address 192.168.2.1 255.255.255.0
43.
 no ip proxy-arp
44.
!
45.
interface TokenRing0/0
46.
 no ip address
47.
 shutdown
48.
 ring-speed 16
49.
!
50.
interface BRI1/0
51.
 no ip address
52.
 encapsulation ppp
53.
 dialer pool-member 1
54.
 isdn switch-type basic-net3
55.
 isdn send-alerting
56.
 ppp authentication chap callin
57.
!
58.
interface BRI1/1
59.
 no ip address
60.
 shutdown
61.
 isdn switch-type basic-net3
62.
!
63.
interface BRI1/2
64.
 no ip address
65.
 encapsulation ppp
66.
 dialer pool-member 2
67.
 isdn switch-type basic-net3
68.
 isdn send-alerting
69.
 ppp authentication chap callin
70.
!
71.
interface BRI1/3
72.
 no ip address
73.
 shutdown
74.
 isdn switch-type basic-net3
75.
!
76.
interface Virtual-Template1
77.
 ip unnumbered Ethernet0/0
78.
 ppp authentication chap
79.
!
80.
interface Dialer1
81.
 description Verbindung zu Router Client-1Router
82.
 ip address 192.168.4.1 255.255.255.0
83.
 no ip proxy-arp
84.
 encapsulation ppp
85.
 dialer pool 1
86.
 dialer remote-name Client-1Router
87.
 dialer idle-timeout 120 either
88.
 dialer string 11
89.
 dialer load-threshold 100 either
90.
 dialer-group 1
91.
 ppp authentication chap callin
92.
 ppp multilink
93.
!
94.
interface Dialer2
95.
 description Verbindung zu Router Client-2Router
96.
 ip address 192.168.6.1 255.255.255.0
97.
 no ip proxy-arp
98.
 encapsulation ppp
99.
 dialer pool 2
100.
 dialer remote-name Client-2Router
101.
 dialer idle-timeout 120 either
102.
 dialer string 12
103.
 dialer load-threshold 100 either
104.
 dialer-group 2
105.
 ppp authentication chap callin
106.
 ppp multilink
107.
!
108.
ip classless
109.
ip route profile
110.
ip route 0.0.0.0 0.0.0.0 192.168.2.254
111.
ip route 192.168.1.0 255.255.255.0 192.168.2.254
112.
ip route 192.168.3.0 255.255.255.0 192.168.4.2
113.
ip route 192.168.4.0 255.255.255.0 Dialer1
114.
ip route 192.168.5.0 255.255.255.0 192.168.6.2
115.
ip route 192.168.6.0 255.255.255.0 Dialer2
116.
no ip http server
117.
!
118.
access-list 102 permit tcp host 192.168.3.2 host 192.168.1.1 eq 3389
119.
access-list 102 deny   ip any any
120.
access-list 103 permit tcp host 192.168.5.2 host 192.168.1.1 eq 3389
121.
access-list 103 deny   ip any any
122.
dialer-list 1 protocol ip list 102
123.
dialer-list 2 protocol ip list 103
124.
!
125.
line con 0
126.
 transport input none
127.
 stopbits 1
128.
line aux 0
129.
line vty 0 4
130.
 login local
131.
!
132.
end
IP,s und Telefonnummern

Client PC1 192.168.3.2
Client PC2 192.168.5.2
Client-1Router Ethernet 0 192.168.3.1
Client-1Router Bri0 192.168.4.2 Tel: 11
Client-2Router Ethernet 0 192.168.5.1
Client-2Router Bri0 192.168.6.2 Tel: 12
AccessRouter Bri1/0 192.168.4.1 Tel: 21
AccessRouter Bri1/2 192.168.6.1 Tel: 22
AccessRouter Ethernet0/0 192.168.2.1
IP-Cop Firewall Rote Schnittstelle 192.168.2.254
IP-Cop Firewall Grüne Schnittstelle 192.168.1.254
Terminal Server 192.168.1.1

Gruß Flogge
Mitglied: aqui
07.10.2006 um 18:24 Uhr
Was sagt den ein "debug vpdn event/errors/packet" etc. beim Verbindungsaufbau ??

Laut Ciscos Beschreibung www.cisco.com/en/US/products/sw/iosswrel/ps1828/products_configuration_guide_chapter09186a0080087302.html
initiiert ja der Dialin Knoten den Tunnel, da ist es fraglich ob es auch direkt zwischen 2 Routern klappt. Wie gesagt ein debug der vpdn Funktion sollte da schon Licht ins Dunkel bringen...
Bitte warten ..
Mitglied: Flogge
09.10.2006 um 11:54 Uhr
Danke für deine schnelle Antwort aqui

Habe es natürlich sofort heute morgen ausprobiert, den der Testaufbau steht in der Firma und ich kam am Samstag nicht dran.

Ich habe sowohl im 2600 er als auch im 1600 die Debugfunktionen aktiviert und zusätzlich noch
l2f-events
l2f-errors
l2f-packets

Aber nichts, nicht ein Log erscheint. Da ich noch absoluter Cisco Greenhorn bin und bis dahin diese Funktion noch nicht kannte habe ich sie testweise auf dialer angewant, und siehe da ich bekam einige Meldungen.

Mir drängt sich die Erkenntniss auf das die VPDN Funktion in meiner Config brachliegt und rein gar nichts bewirkt.

Meine Config habe ich nach der Beschreibung die du genannt hast erstellt, konnte das aber nicht 1 zu 1 umsetzen zb. kann ich im 2600er werde im Ethernet Interface noch im virtual-template interface den Befehl encapsulation ppp anwenden. Der Befehl ist zwar vorhanden wird aber nicht in die config geschrieben.

Das Dokument lässt mich denken das es sich dort um eine Verbindung zwischen 2 Routern handelt, ist das nicht so? Ist der 1600er in meinem Fall nicht der Dialin Knoten?
Zum Licht im Dunkeln, noch sehe ich es nicht ich hoffe du/ihr habt noch ein paar Ideen was bei mir falsch läuft.

Sollte ich komplett auf dem Holzweg sein, bitte sagt es mir kann ich mein Ziel etwas mit einem anderen ansatz besser erreichen? Z.b. mit dem Interface Typ Tunnel leider schweigt sich mein Cisco Buch darüber aus und so weis ich nicht ob das überhaupt mit einer Wählverbindung funktioniert welche ja aus kostengründen nicht immer offen sein soll.

Grüße Flogge
Bitte warten ..
Mitglied: aqui
13.10.2006 um 20:54 Uhr
Debugst du mit einer Telnet Verbindung auf dem Router ????
Da musst du "term mon" eingeben sonst landet der Debug Output an der Konsole im Nirwana. Oder wenn du logging enabled hast im Logg das du mit "show logg" einsehen kannst.

Zeigen sich in der Tat keine debug outputs weder mit term mon in der Telnet Session noch an der Konsole ist überhaupt gar keine irgendgeartete VPN Funktion aktiv.
Da ist dann noch ein großer Kinken in der Konfig vermute ich mal. PPP muss auf dem Dialer Interface unbedingt aktiv sein denn bei HDLC müsstest du sonst immer eine dedizierte Zuweisung aufs Interface machen was die Konfig nur unnötig erschwert. Warum der Encapsulation Mode nicht angezeigt wird ist komisch aber normal wenn dies die default Einstellung ist, denn die wird in der Konfig nie angezeigt.
Vielleicht solltest du als Alternative einfach nur einen einfachen Crypto GRE Tunnel konfigurieren, das erfordert aber ein Crypto fähiges IOS auf den Systemen.
Bitte warten ..
Mitglied: Flogge
03.01.2007 um 08:46 Uhr
Danke für die Hilfe,
Hatte leider nicht immer Zeit zu antworten, es war sehr stressig in der letzten Zeit.
Das hier beschriebene Problem war meine Projektarbeit für den IHK Abschluss Fachinformatiker Systemintegration. Mittlerweile habe ich alles bestanden und darf mich auch so nennen .
Bis dato hatte ich noch nie mit Cisco gearbeitet und bin ins kalte Wasser gesprungen. Danke nochmal für die Hilfe, du hast mir sehr geholfen.

Grüße
Florian
Bitte warten ..
Ähnliche Inhalte
iOS
IOS 11.2 verfügbar
Information von sabinesiOS

Das neue iOS Update soll das Problem lösen, die bei denen Benachrichtigungen einen wiederholten Neustart des Homescreens auslösen.

Switche und Hubs
CISCO 3548XL IOS installieren?
gelöst Frage von twicefaceSwitche und Hubs3 Kommentare

Guten Tag, ich habe mir vor ca. einer Woche 2 Cisco 3548XL gekauft. Der eine funktioniert tadellos angemacht, konfiguriert, ...

LAN, WAN, Wireless
Cisco IOS Load Balancing
gelöst Frage von PharITLAN, WAN, Wireless2 Kommentare

Hallo allerseits, bevor ich mir einen zweiten Internetanschluss anschaffe, wollte ich mal folgendes fragen: Mein Cisco 891er hat nur ...

iOS

IOS 11.2 Probleme mit Drittanbieter Kabeln und Face ID

Tipp von sabinesiOS

Nach dem Update auf die aktuelle Version 11.2 kann es zu Problemen mit Drittanbieter Kabeln kommen, die Lösung hier ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 6 StundenInternet2 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 10 StundenWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 1 TagWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 1 TagSicherheit6 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
Switche und Hubs
Medienkonverter mit 12 oder 24 Ports gesucht
Frage von wmuellerSwitche und Hubs24 Kommentare

Guten Morgen, ich bin auf der Suche nach einem größeren Medienkonverter, der "stumpf" 1:1 die Ports auf über ein ...

Windows Server
Uhren gehen immer wieder falsch
Frage von killtecWindows Server23 Kommentare

Hallo, ich habe folgende Konstellation: 1. Physischer DC Div. Virtuelle DC's auf Hyper-V Servern Die Hyper-V-Server, der Physische DC ...

Batch & Shell
Mit findstr batch doppelte zeilen einer txt löschen
Frage von Burningx2Batch & Shell21 Kommentare

Hi Vor einer weile habe ich im netzt einen windows shell befehl gefunden mit welchem man über die konsole ...

Verschlüsselung & Zertifikate
Netzwerkfreigabe Verschlüsselung
Frage von grill-itVerschlüsselung & Zertifikate20 Kommentare

Moin zusammen, sicher nutzen hier die ein oder anderen ein Produkt zur Verschlüsselung von Netzwerkfreigaben/-laufwerken auf denen hochsensible Daten ...