Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst WebDav auf SBS 2011 läuft einfach nicht.

Mitglied: Pressmar

Pressmar (Level 1) - Jetzt verbinden

11.01.2014, aktualisiert 11:50 Uhr, 4783 Aufrufe, 10 Kommentare

Hallo,

ich möchte auch einem SBS 2011 SP1 Standard mit IIS 7.0 und auf einem Server 2007 SP2 mit IIS 6.0 eine webdav freigabe zum laufen zu bringen. Ich habe mich zumindest beim SBS 2011 an die Anleitung :

http://www.iis.net/learn/install/installing-publishing-technologies/ins ...

gehalten. Der SBS hat ein gültiges Multidomain-Zertifikat (Geotrust) was auch wunderbar z.B. mit Firefox und IE funktioniert sowohl von der Internen IP wie auch über WAN funktioniert. Wenn ich jetzt mit einem Windows 7 oder einem Windows 8 Rechner direkt oder über Netdrive darauf zugreifen will bekomme ich die Fehlermeldung "Der eingegebene Ordner ist ungültig. Wählen Sie einen anderen Ordner" bzw. bei Netdrive wir einfach nichts verbunden.

Ich habe inzwischen "Jeder" für den Ordner, die Freigabe, das virtuelle Verzeichnis Webdav-Einstellung berechtigt um ein Rechte Problem zuverhindern. Außerdem habe ich zum Test schon die SSL -Verschlüsselung rausgenommen und es dann über http:// versucht - immer mit dem gleichen Problem.

Mir fällt einfach keine Lösung oder eine Strategie ein um hier weiter zukommen. Ergänzen möchte ich noch das die Rechner jeweils ohne Problem eine Webdav Verbindung zum Strato Hidrive oder eine lokalen Synology 1813+ aufbauen können.

Für Hilfe oder eine rettende Idee wäre ich super dankbar.
Danke Oliver


Anbei noch das Log-File des Servers. Windows 7 direkt ergibt den beschriebenen Fehler. Firefox und IE ergeben einen Fehler 500

#Software: Microsoft Internet Information Services 7.5
#Version: 1.0
#Date: 2014-01-11 10:26:06
#Fields: date time s-ip cs-method cs-uri-stem cs-uri-query s-port cs-username c-ip cs(User-Agent) sc-status sc-substatus sc-win32-status time-taken


Windows 7 direct over https or http
2014-01-11 10:26:06 192.168.30.11 OPTIONS /dav - 443 - 178.26.108.235 Microsoft-WebDAV-MiniRedir/6.1.7601 500 19 5 593
2014-01-11 10:26:34 192.168.30.11 OPTIONS /dav - 80 - 178.26.108.235 Microsoft-WebDAV-MiniRedir/6.1.7601 500 19 5 234



Windows 7 Firefox over https or http
2014-01-11 10:27:04 192.168.30.11 GET /dav - 80 - 178.26.108.235 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+rv:26.0)+Gecko/20100101+Firefox/26.0 500 19 5 62
2014-01-11 10:27:19 192.168.30.11 GET /dav - 443 - 178.26.108.235 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+rv:26.0)+Gecko/20100101+Firefox/26.0 500 19 5 93

// Windows 7 IE over https or http
2014-01-11 10:45:16 192.168.30.11 GET /dav - 443 - 178.26.108.235 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko 500 19 5 31
2014-01-11 10:45:20 192.168.30.11 GET /dav - 80 - 178.26.108.235 Mozilla/5.0+(Windows+NT+6.1;+WOW64;+Trident/7.0;+rv:11.0)+like+Gecko 500 19 5 46

Mitglied: colinardo
LÖSUNG 11.01.2014, aktualisiert 14.01.2014
Hallo Oliver,
habe gerade mal nachgeschaut, und kann dein Problem in der Default-Site nachvollziehen. Habe dann mal testweise eine neue Site auf einem anderen Port angelegt, darauf WebDav eingerichtet und konnte mich sofort ohne die geschilderte Fehlermeldung verbinden.
Alternativ mach es mal folgendermaßen: Lege ein neues Virtuelles Verzeichnis für WebDAV an und folge dann folgender Anleitung (die mit dem blauen Häkchen): http://social.technet.microsoft.com/Forums/de-DE/ffb13c6a-dbc5-41f0-92a ...

Grüße Uwe
Bitte warten ..
Mitglied: Pressmar
11.01.2014, aktualisiert um 18:47 Uhr
Hallo Uwe,

vielen Dank für deine Mühe und den Tipp. Die alternative Variante hab ich schon versucht. Leider auch ohne Erfolg. Deinen Tipp mit erstellen einer neuen Webseite und dort einem Virtuellen Verzeichnis auf anderen Ports (z.B. http: 81 und https: 444) - die ports im router hab ich geöffnet - hat bei mir leider auch zu keinem anderen Ergebnis geführt. immer noch das gleiche thema. wobei es mit diesen ports wohl schwieriger wäre von außerhalb aus einem öffentlichen netz darauf zuzugreifen, oder?
Kannst du dir da einen Reim drauf machen?

Aber danke schon mal und
LG Oliver
Bitte warten ..
Mitglied: colinardo
11.01.2014, aktualisiert um 19:11 Uhr
Zitat von Pressmar:
wobei es mit diesen ports wohl schwieriger wäre von außerhalb aus einem öffentlichen netz
darauf zuzugreifen, oder?
ja, aber man könnte es stattdessen mit Virtual Hosts im IIS machen um auf den selben Ports unterschiedliche Seiten zu hosten.
Kannst du dir da einen Reim drauf machen?
im moment nicht, da doch sehr viele Fehlerquellen eine Rolle spielen können.
muss da bei Zeiten noch mal nach schauen

Grüße Uwe
Bitte warten ..
Mitglied: keine-ahnung
11.01.2014 um 19:27 Uhr
Zitat von Pressmar:

Moin,
auf anderen Ports (z.B. http: 81 und https: 444)
hast Du die gewürfelt oder wie kommst Du auf diese lustigen Zahlen ?

LG, Thomas
Bitte warten ..
Mitglied: loonydeluxe
LÖSUNG 11.01.2014, aktualisiert 14.01.2014
Hab hier grad nur einen Server 2012 R2 zum Nachschauen, keinen SBS 2011, aber hier meine Konfigurationsschritte:
- Site anlegen mit Bindung, mit oder ohne SSL erstmal egal
- Authentifizierung mit Domänen-Auth oder Standardauth, dort ggf. noch die eigene Domäne als Standarddomäne eintragen, damit nicht soetwas wie Benutzer@Domäne erforderlich ist.
- Das "Verzeichnis durchsuchen" aktivieren
- WebDAV aktivieren
- eine WebDAV-Erstellungsregel erzeugen: In jedem Verzeichnis dürfen "Alle Benutzer" Lesen, Schreiben, Quelle (alles weitere wird über Sicherheitsberechtigungen geregelt)
- Die IIS_IUSRS (bei meinem Domänenmemberserver, nicht-DC eine lokale Gruppe) benötigen Leserechte
- Die betreffenden Benutzer sollten Lese-/Schreibrechte haben
- in den WebDAV-Einstellungen habe ich die Verbfilterung deaktiviert
- Firewall für den entsprechenden Port geöffnet, ggf. Portforwarding am Router/Firewall

Bei Zugriff über SSL sollten die Clients dem Zertifikat des Webservers vertrauen, ggf. solltest du in den SSL-Einstellungen SSL erzwingen und auch in den WebDAV-Einstellungen erforderlich machen, um nicht-verschlüsselte Verbindungen zu verhindern.

--> erster Test im Browser im lokalen Netzwerk: Der Verzeichnisinhalt sollte angezeigt werden
--> zweiter Test über den Explorer im lokalen Netzwerk: Das WebDAV-Verzeichnis sollte sich unter Angabe des Benutzernamens/Kennworts hinzufügen lassen (ggf. Domäne beim Benutzernamen mit angeben)
--> dritter Test über Explorer von einem Remote-Netzwerk: Das WebDAV-Verzeichnis sollte sich unter Angabe des Benutzernamens/Kennworts hinzufügen lassen (ggf. Domäne beim Benutzernamen mit angeben)
Bitte warten ..
Mitglied: Pressmar
12.01.2014, aktualisiert um 16:16 Uhr
zum testen einfach die Portweiterleitung ums eins vergrößert - ist ja nur test
Bitte warten ..
Mitglied: Pressmar
14.01.2014 um 12:36 Uhr
Hallo Zusammen,

also ich habe die Sache jetzt gelöst. Ich konnte mit den Anleitungen leider keine Verbindung zum WebDav ( auch nicht lokal vom Browser) ermöglichen. Dann habe ich das virtuelle Verzeichnis gelöscht und eine ganz neue Webseite erstellt und den Pysikalischen Pfad auf den im WebDav freizugebenden lokalen Ordner gelegt. Zunächst alles ohne https und Verschlüsselung. Folgende Schritte habe ich gemacht und es funktionierte damit ohne Probleme:

1) Anlegen einer Benutzergruppe "WebDav"
2) Anlegen einer Freigabe des entsprechenden Ordners mit Berechtigung für "WebDav"-Gruppe
3) Lese-und Schreibrechte der "WebDav"-Gruppe in Sicherheit des entsprechenden Ordners einfügen.
4) Installieren des Internetinformations-Dienstes
5) "Webseite hinzufügen" unter Server - Ort ist der entsprechende Ordner
6) Bindungen für https: 443 mit einem gültigen Zertifikat für die Seite machen
7) Für die Seite (nicht die Unterordner) folgende Einstellungen machen:

Authentifizierung: Standartauthentifizierung (Standard-Domain = Computername oder AD)
Protokollierung : je nach Anforderung
SSL-Einstellung: SSL-Erforderlich; Clientzertifikate ablehnen
Web-DAV-Erstellung: WebDav aktivieren; Erstellungsregel (Gesamter Inhalt, Bestimmte Gruppe "WebDav", Berechtigung "Lesen, Quelle, Schreiben"
Verzeichnis Suche: Erlauben

8) Lokal im Browser testen - es sollte die Datei-Liste kommen.
9) Router/Firewall von außen öffnen und Ports weiterleiten
10)Von Außen im Browser test
11) Von Außen Windows / Netdrive testen.

Vielleicht hilft es jemand weiter.
Beste Grüße
Oliver
Bitte warten ..
Mitglied: keine-ahnung
14.01.2014 um 13:11 Uhr
Schick, das es geklappt hat.

Nochmal zur Ergänzung - deswegen hatte ich nachgefragt: weder ist :81 ein alternativer http-Port noch ist :444 ein SSL-Port.

LG, Thomas
Bitte warten ..
Mitglied: Pressmar
14.01.2014 um 13:25 Uhr
Hallo Thomas,

das Problem war ja das der Port 80 und 443 schon an die Standard-Seiten (SBS-Server) gebunden waren. Deshalb habe ich zum Test im lokalen Netz ohne Firewall diese Ports zum testen benutzt. Der Port den ich jetzt von außen für die SSL gesicherte Verbindung nutze ist auch ein anderer

LG Oliver
Bitte warten ..
Mitglied: keine-ahnung
14.01.2014 um 13:27 Uhr
Kein Thema. Es gibt definierte Alternativports für viele Protokolle, wenn die nicht reichen, denkt man sich welche weit oberhalb von 10000 aus. 81 und 444 sind bereits standardisiert ... nur eben nicht für http/https

LG, Thomas
Bitte warten ..
Ähnliche Inhalte
Exchange Server

SBS 2011 Migration auf SBS 2011 - Zertifikatsprobleme

Frage von aschinnerlExchange Server3 Kommentare

Hi zusammen, Ich habe von einem SBS 2011 (physisch) auf einen SBS 2011 virtuell migriert. Alles hat ohne Probleme ...

Windows Server

SBS 2011 - Domäne

gelöst Frage von MiStWindows Server7 Kommentare

Hallo, ich habe hier einen SBS 2011. Bei dem ist mir aufgefallen, dass die Gesamtstrukturfunktionsebene auf "Windows Server 2003" ...

Exchange Server

SBS 2011 - Kalenderfreigabe

Frage von MiStExchange Server10 Kommentare

Guten Morgen zusammen, wir nutzen einen SBS2011 und die Office-Version 2010 und seit kurzem ein paar 2016er. Wenn ich ...

Windows Server

SBS 2011 Alternative

gelöst Frage von MiStWindows Server17 Kommentare

Hallo, ich nutze hier im Betrieb einen SBS2011, den ich mit seinem Umfang ganz OK finde. Er macht, was ...

Neue Wissensbeiträge
Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 20 StundenBackup

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 2 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 steht in Englisch bereit mit Unterstützung für Windows 10 1903 (May Update)

Information von VGem-e vor 2 TagenSicherheits-Tools1 Kommentar

Moin Kollegen, Dann kommt wohl demnächst auch die deutschsprachige/europäische Version zur Auslieferung. Gruß VGem-e

Batch & Shell
PowerShell Konferenz - Videos online
Information von NetzwerkDude vor 3 TagenBatch & Shell

Abend, die Tage werden Videos der Talks von der diesjährigen EU Powershell Konferenz hochgeladen, sind einige Interessante dabei: MFG ...

Heiß diskutierte Inhalte
Google Android
Anbieter für Diensthandys
Frage von Pat.batGoogle Android24 Kommentare

Hallo zusammen, ich bin seit einiger Zeit zuständig für die Diensthandys bei uns in der Behörde. Eine Management Software ...

Windows Server
Windows Server 2016 einrichten
Frage von borjiaWindows Server20 Kommentare

Ich würde gerne einen Server einrichten, erstmal nur mit DNS und AD. Habe mich die letzten Wochen durch diverse ...

Exchange Server
Vorgehen um von Tobit auf Exchange zu wechseln
Frage von Martin1987Exchange Server17 Kommentare

Guten Abend Ich habe den Auftrag erhalten, unser Mail von David zu Outlook zu wechseln. Wie muss ich da ...

Microsoft Office
Office 365 eMail via Website verschicken
Frage von BiBeSoMicrosoft Office16 Kommentare

Hallo, kann man im Office 365 eMails anlegen welche zum versenden (smtp) für die Website funktionieren ? Muss man ...