Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wenn-Funktion für Text anwenden

Mitglied: -betty-

-betty- (Level 1) - Jetzt verbinden

17.12.2005, aktualisiert 23.12.2005, 6436 Aufrufe, 3 Kommentare

Hallo,

mit Zahlen funktioniert die Wenn-funktion ja immer wunderbar. Jetzt möchte ich Sie aber mit Text anwenden und das funktioniert überhaupt nicht.
(also wenn in Zelle XY3 misc 1 steht, soll in der anderen ein bestimmter Produktname erscheinen, wenn misc 2 drin steht ein anderer Produktname usw...)
Geht das, entweder mit der Wenn- oder einer anderen Funktion?

Vielen Dank für Eure Hilfe,

Betty
Mitglied: Biber
21.12.2005 um 22:38 Uhr
Moin -betty-,

falls Dein Problem noch bestehen sollte:
Ein Formelwert
=WENN(x3="misc 1";"Product 1";"anderes")
funktioniert tadellos bei mir.
Und Du kannst es relativ beliebig schachteln:
=WENN(E7="misc 1";"Product 1";WENN(E7="misc 2";"Product 2";"anderes")) ........usw.

Bei mehreren Wahlmöglichkeiten würde man/frau allerdings eher irgendwelche LookUp-Funktionen nehmen, aber das war ja nicht Deine Frage.

HTH Biber
Bitte warten ..
Mitglied: -betty-
23.12.2005 um 17:23 Uhr
Vielen Dank, jetzt funktioniert es.

Ich hatte es wohl vorher irgendwie falsch eingegeben.

Leider steht in der Zelle, wenn ich die Formel eingebe jetzt immer FALSCH.

Das ist auch ungünstig, da ich manchmal weniger und manchmal mehr Produkte eingeben möchte und in den Leeren Zeilen darf dann natürlich nicht "Falsch" stehen.

Kann man das noch irgendwie formatieren?
Bitte warten ..
Mitglied: Biber
23.12.2005 um 17:46 Uhr
Moin -betty-,

..wenn dort jetzt "FALSCH" steht, dann ist das ein logischer Rückgabewert.. dann fehlt vielleicht ein "=" am Anfang der Formel.
Aber das pure Spekukation - wenn es wichtig ist, schick mir die Excel-Datei (falls das keine 14 GigaByte sind).
Geht schneller als dieses Stochern im Nebel.
Ich schick Dir mal eine Mail-Adresse per pn.

Gruß Biber
Bitte warten ..
Ähnliche Inhalte
Microsoft Office

Excel 2010 - Funktion TEXT - variable Anzahl an Nachkommastellen

gelöst Frage von JuckieMicrosoft Office5 Kommentare

Hallo an alle, es geht um die Verkettung von Werten in Zellen in Excel 2010: Wert in Zelle A1 ...

Microsoft Office

Excel: Text in Zellbereich prüfen mit Vergleichstext ggf. mit Exact-Funktion

gelöst Frage von Michi1Microsoft Office5 Kommentare

Hallo, Ich möchte in Excel 2013 in einer sxls-Datei einen Berich, der Text enthält durchsuchen. Der Text jeder Zelle ...

Microsoft Office

Ungleich Text

gelöst Frage von grasihuepferMicrosoft Office1 Kommentar

Hi Leute, Wie kann man eigentlich ungleich in eine Formel setzen? Bei Zahlen kann ich das ja mit "ungleich". ...

Windows 7

Tablett Funktion aktivieren

Frage von Adnan88Windows 71 Kommentar

Hallo, habe ein Win 7 - Pro 32 bit Edition, nun wollte ich einen TouchScreen Monitor nutzen allerdings ist ...

Neue Wissensbeiträge
Windows 7
Updategängelung auf Windows 10, die zweite
Information von Penny.Cilin vor 2 TagenWindows 7

Hallo, da Windows 7 im kommenden Jahr nicht mehr supportet wird, werden Nutzer von Window 7 home premium wieder ...

Internet
EU-Urheberrechtsreform: Zusammenfassung
Information von Frank vor 4 TagenInternet1 Kommentar

Auf golem.de gibt es eine Analyse von Friedhelm Greis, der das Thema EU-Urheberrechtsreform gut und strukturiert zusammenfasst. Zwar haben ...

Microsoft Office

Office365 Schwachstellen bei Sicherheit und Datenschutz

Information von Penny.Cilin vor 5 TagenMicrosoft Office7 Kommentare

Auf Heise+ gibt es einen Artikel bzgl. Office365 Schwachstellen. Das ist noch ein Grund mehr seine Daten nicht in ...

Sicherheit
Schwachstellen in VPN Clients
Tipp von transocean vor 7 TagenSicherheit2 Kommentare

Moin, es gibt Sicherheitslücken bei VPN Clients namhafter Hersteller, wie man hier lesen kann. Gruß Uwe

Heiß diskutierte Inhalte
Utilities
Teamviewer 9.x "out of date" ??
gelöst Frage von keine-ahnungUtilities12 Kommentare

Moin at all, mein topaktueller teamviewer (alles 9.x - releases) verweigert seit heute die Arbeit und bemeckert: "the remote ...

Windows Installation
Windows10 Home Neuinstallation - Raketentechnik
Frage von spacyfreakWindows Installation12 Kommentare

"Kannst du den Rechner von der Tante von WindowsXP auf Windows10 Home upgraden" haben sie gefragt? "Sicher, was kann ...

Windows 10
Windows 10 verwendet FritzBox per IPv6 als DNS-Server an Stelle des per DHCP vergebenen DNS-Servers
Frage von Datax87Windows 1010 Kommentare

Hallo, ich habe ein kleines Problem mit der Namensauflösung (DNS) unter Windows 10. Mir ist heute aufgefallen, dass ich ...

Peripheriegeräte
Empfehlung für Home-USV (ca. 450VA 270W) Irgendwelche Osterpreisaktionen bekannt?
Frage von Server-NutzerPeripheriegeräte9 Kommentare

Hallo und schöne Ostern. Meine private Heim-USV Yunto Q450 (ca. 450VA 270W) hat sich nach vielen Jahren ohne Probleme ...