Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Windows2003-Server zeigt immer

Mitglied: AdrianMonk

AdrianMonk (Level 1) - Jetzt verbinden

18.08.2006, aktualisiert 22:27 Uhr, 3622 Aufrufe, 8 Kommentare

Moin Moin,
Ich habe folgendes Problem mit meinem WIndows2003-Server:
Ich habe ein Script was einen FTP-Server durchkämmt und seine Ergebnisse in eine Mysql-Datenbank schreibt. Wenn der FTP-Server gut angebunden ist und mein Server auch nicht gerade zu busy ist geht das alles in Ordnung (ca. 5000 Einträge). Aber wenn eines davon nicht der Fall ist kann es schon mal länger dauern... Ist auch nicht das Problem... nur wenn es länger dauert und ich das script per web aufgerufen habe kommt nach einer gewissen Zeit "Bad Gateway (halt einfach diese Fehlerseite)" und das script hört auf zu suchen. Ich hab es nun schon direkt mit der php.exe versucht nur da gerät das script nach einer gewissen Zeit in ein Timeout obwohl ich die max_execution_time in der Php.ini schon auf etwa 12000 oder so hochgedreht habe.
Ich wäre sehr dankbar für jede mögliche Art Hilfe.
Gruß
Jan
Mitglied: Dani
18.08.2006 um 20:40 Uhr
Hi,
binde einfach folgende Funktion in in dein PHP-Script ein. Am besten Ganz am Anfang nach <?php.
01.
set_time_limit(SEKUNDEN);
Gruß
Dani
Bitte warten ..
Mitglied: AdrianMonk
18.08.2006 um 21:01 Uhr
Hy Dani,
Vielen Dank für deine Antwort, es funktioniert ;) , leider nur nicht ganz....
Ich hab bis vor kurzem noch keine Probleme damit gehabt, aber wenn ich das script ausführe sagt der rechner mir call to undefined function curl_init()... in der php.ini ist die extension schon auskommentiert... esging vorher eigentlich auch und in der phpinfo() steht es auch als enabled drinne:

CURL support enabled
CURL Information libcurl/7.11.2 OpenSSL/0.9.7d zlib/1.1.4

Ich habe PHP 4.3.11
Hoffentlich kannst du oder jemand anderes mir weiterhelfen....
Gruß
Jan
Bitte warten ..
Mitglied: Dani
18.08.2006 um 21:08 Uhr
Hi,
ist das Problem durch meine Funktion gekommen?!
Ist eigentlich auch egal. Naja...ich nehme mal an du hast dann im PHP-Script die entsprechenden Funktionen auch auskommentiert, die zur dei Bibo gehören?!


Gruß
Dani
Bitte warten ..
Mitglied: AdrianMonk
18.08.2006 um 21:19 Uhr
Im Php-script kann ich doch nichts auskommentieren... ich hab über die php.exe das script gestartet und das zeigte mir dass die Funktion nicht definiert sei, obwohl eigentlich alles dafür spricht, dass sie das ist....
Nein nein, das Problem ist nicht durch deine Funktion gekommen... das mit dem Bad Gateway war ja per aufruf via web aber nun via php.exe sagt er mir, dass die funktion curl_init() nicht definiert sei... das badway-problem ist aber immer noch da...
Viele Grüße
Jan
Bitte warten ..
Mitglied: Dani
18.08.2006 um 21:25 Uhr
Hi,
schreib mal error_reporting(0); am den Anfang!!!


Gruß
Dani
Bitte warten ..
Mitglied: AdrianMonk
18.08.2006 um 21:41 Uhr
Also via web kommt da nach wie vir Bad Gateway und via php.exe kommt keine Fehlermeldung mehr aber dafür ist das script nach einer Sekunde zuende obwohl es sonst immer etwa eine Minute dauert. Es würde mir auch genügen wenn ich es per php.exe starten könnte, aber jetzt kommt garnichts mehr. kann das mit dem fehle von curl_init damit zusammenhängen, dass ich vorhin bei dem IIS das Verbindungstimeout von 120 sek. auf 1800 gesetzt hab?
Grüße
Jan
Bitte warten ..
Mitglied: Dani
18.08.2006 um 21:49 Uhr
Hi,
setz es doch alles, was du geändert hast, auf die Werte als es noch funktioniert hat. Und danach kannst du ja Schritt für Schritt analysieren!


Gruß
Dani
Bitte warten ..
Mitglied: AdrianMonk
18.08.2006 um 22:27 Uhr
Nein, geht immer noch nicht... vielleicht fällt dir an der php-ini was auf....
http://www.lix.in/80ff8c
Als Sercer steht ganz oben windows nt dabei habe ich 2003?
Grüße
Jan
Bitte warten ..
Ähnliche Inhalte
Festplatten, SSD, Raid
SSD zeigt falsche Werte
gelöst Frage von karl2014Festplatten, SSD, Raid30 Kommentare

Ich habe ein Problem mit der SSD in meinem Laptop mit Windows 10. Es ist eine 1Tb Platte die ...

CPU, RAM, Mainboards
PC zeigt kein BIld
Frage von Ghost108CPU, RAM, Mainboards13 Kommentare

Hallo zusammen, habe heute meine Bestellung von CPU,Mainbard und RAM erhalten: Allerdings bekomm ich kein Bild (verwende die onBoard ...

Windows 7
Windows zeigt Speicherplatz falsch an
gelöst Frage von honeybeeWindows 73 Kommentare

Hallo, ich löse gerade ein seltenes Phänomen: Vor kurzem wurde eine SSD gegen eine größere ausgetauscht (von 250 GB ...

Monitoring

Nagios Website zeigt "Not running"

gelöst Frage von TuffliMonitoring13 Kommentare

Hallo Leute, ich habe einen XenServer 6.2 in Betrieb und darunter eine VM mit Ubuntu 14.04.1 worauf ein Nagios ...

Neue Wissensbeiträge
Router & Routing

Zyxel VMG 1312 B30A - Firmwareupdate nur im "privaten" Firefox Modus möglich

Tipp von the-buccaneer vor 13 StundenRouter & Routing2 Kommentare

Hatte hier ein Zyxel 1312 das ums verrecken kein Firmwareupdate durchführen wollte. Datei ist auswählbar, dann kommt der Fortschrittskreisel ...

Windows 7

Windows 7 u. Server 2008 (R2) SHA-2-Update kommt am 12. März 2019

Information von kgborn vor 2 TagenWindows 75 Kommentare

Kleine Info für die Admins der oben genannten Maschinen. Ab Juli 2019 werden Updates von Microsoft nur noch mit ...

Firewall
PfSense 2.5.0 benötigt doch kein AES-NI
Information von ChriBo vor 3 TagenFirewall2 Kommentare

Hallo, Wie sich einige hier erinnern werden hat Jim Thompson in diesem Aritkel beschrieben, daß ab Version 2.5.0 ein ...

Internet
Copyright-Reform: Upload-Filter
Information von Frank vor 5 TagenInternet4 Kommentare

Hallo, viele Menschen reden aktuell von Upload-Filtern. Sie reden darüber, als wären es eine Selbstverständlichkeit, das Upload-Filter den Seitenbetreibern ...

Heiß diskutierte Inhalte
Hardware
IT-Werkzeugkoffer bis 50,- EUR
gelöst Frage von departure69Hardware48 Kommentare

Hallo. Ich bin als IT-Systembetreuer einer Gemeinde zusätzlich auch der IT-Systembetreuer einer Grund- und Hauptschule. Dort muß ich jedoch ...

Netzwerke
Verteilung von Programmdaten außerhalb des internen Netzwerkes
Frage von mertaufmbergNetzwerke27 Kommentare

Guten Morgen liebe Administratoren, ich versuche zurzeit eine möglichst sichere und einfache Lösung zu suchen, um ein Programmverzeichnis über ...

Netzwerkmanagement
Richtfunknetzwerk mit vielen Hops stabiler gestalten
Frage von turti83Netzwerkmanagement22 Kommentare

Hallo, in meinem Dorf habe ich vor ca. einem Jahr ein Backbone aufgebaut um die Nachbarschaft mit Internet zu ...

Hyper-V
Intel MSC Raid 5 Rebuild
Frage von DannysHyper-V19 Kommentare

Hallo Community, Ich habe einen Modul Server von Intel in Betrieb. Dort ist eine Festplatte aus dem Raid 5 ...