Zwei Netze über VPN verbinden, Ping geht, sehe Computer und Freigaben aber nicht

Mitglied: Quark

Quark (Level 1) - Jetzt verbinden

17.07.2006, aktualisiert 18.07.2006, 17989 Aufrufe, 8 Kommentare

Hallo, habe ein Problem mit einer funktionierenden VPN Verbindung, ich kann zwar die Rechner im entfernten LAN anpingen, aber nicht auf die Windowsnamen zugreifen.

Folgende Konfiguration:

Router Netgear DG834B als VPN Endpunkt mit DynDNS, IP Bereich 192.168.0.0/24
Entfernter PC: Netgear VPN ProSafe Client im Netzwer 192.168.1.0/24

Ich kann die PC's im 192.168.0.0 Netz anpingen, aber sehe nicht die Computer in der Arbeitsgruppe (überall gleiche Arbeitsgruppe).
Die XP Firewall habe ich schon auf beiden PC's um das jeweilig andere Netz bei Datei und Druckerfreigabe erweitert.
Über \\192.168.0.X kann ich auch nicht zugreifen, immer wieder die Meldung:
Die DATEI \\192.168.0.X kann nicht gefunden werden...

Die Firewall an den Routern kanns ja eigentlich nicht sein, da ja ein Tunnel dazwischen aufgebaut ist oder?

Muss ich Windows noch irgendwie sagen, dass es über das eigene Subnet raus gucken soll?

DANKE!

Philipp
Mitglied: 27119
27119 (Level 2)
17.07.2006 um 23:30 Uhr
net use \\192.168.0.X\freigabename

Gleiche Arbeitsgruppe? (Rechtsklick Arbeitsplatz, Computername)
Berechtigungen?
Ports 135-139 frei=?
Datei- u. Druckerfreigabe u. Client für Microsaft Netzwerke läuft?
Serverdienst läuft? (Services.msc).

Netbios over TCPIP müsste in den Netzwerkeigenschaften autom. aktiv sein.
Probiers auch mal über Start...Suchen...Computer oder über Netzlaufwerk verbinden.
Kann manchmal auch einfach ne Weile dauern bis es läuft. Diese Masterbrowser Election ist schon ein Schrott. Das SMB Protokoll ist eins der meistbenutzten - und meistbeschissenen ehrlichgesagt.
Bitte warten ..
Mitglied: fugu
18.07.2006 um 00:24 Uhr
Wenn du in beide Richtungen pingen kannst, dann hast du das Netz zumindest schon mal "sauber stehen".

Aber wer soll denn in deiner Konfiguration die Namen auflösen? Ping IP geht... geht auch ping <rechnername>? Oder willst du alle Zugriffe über IP machen?

Die XP-Firewall würde ich zum Testen mal ganz abschalten!
Die Router-Firewall kommt hier nicht zum tragen, weil alle notwendigen Ports durch den Tunnel geschleust werden.

Mal angenommen, du würdest die beiden PCs über ein Crossover-Kabel verbinden... oder über einen normalen Switch... würden die Zugriffe dann funktionieren? Öhm, also - ich meine - die Benutzerdaten (User//Password) hast du doch überprüft, oder?

Als (vorerst) letzte Idee würde ich - sofern du das benutzt hast - die VPN auf eine unverschlüsselte Verbindung zurücksetzen
PPTP, PAP, MPPE-Verschlüsselungsmodus off

Und als allerletzten Vorschlag (so hab ich mir selbst mal vor einiger Zeit geholfen - wenn man den Wald vor lauter Bäumen nicht mehr sieht):
Router-Konfig zurücksetzen (Factory Reset) und die VPN neu einrichten.

Greetz Fugu
Bitte warten ..
Mitglied: filippg
18.07.2006 um 00:54 Uhr
Muss ich Windows noch irgendwie sagen, dass
es über das eigene Subnet raus gucken
soll?
Hallo,

wenn du unterschiedliche Subnetze hast ist es wohl eher nicht verwunderlich, dass die Namensauflösung und das Browsen der Arbeitsgruppe nicht funktioniert. Die Auflösung wird (afaik) nur über Broadcasts im eigenen Netz gemacht.
Die Dateifreigabe sollte eigentlich schon funktionieren. Woran das liegt? Hm... Warum bekommt denn eigentlich der entfernte Rechner beim Aufbauen des VPN keine IP aus dem Routernetz? Das VPN erscheint doch bei ihm als virtuelle Netzwerkkarte, oder?

Filipp
Bitte warten ..
Mitglied: Quark
18.07.2006 um 08:18 Uhr
Leider nicht, sobald ich eine virtuelle Netzwerkarkte verlange verweigert mir der Router den Zugang, daher muß ich umbedingt zwei verschiedene Subnetze verwenden, sonst geht gar nix mehr...
Ich bau keine Verbindung mit dem XP VPN Verbindung auf sondern mit dem Netgear ProSafe Client.

Habe mich gestern noch "ausgesperrt", muß erst warten bis wieder jemand vor Ort ist, der mir den Zugnag wieder ermöglicht :-( face-sad. Dann werd ich weiter probieren.

Danke schon mal!
Bitte warten ..
Mitglied: 27119
27119 (Level 2)
18.07.2006 um 09:24 Uhr

wenn du unterschiedliche Subnetze hast ist
es wohl eher nicht verwunderlich, dass die
Namensauflösung und das Browsen der
Arbeitsgruppe nicht funktioniert. Die
Auflösung wird (afaik) nur über
Broadcasts im eigenen Netz gemacht.


http://techrepublic.com.com/i/tr/cms/contentPics/r00320021105boy01_01.g ...

Netbios over TCP/IP wurde genau aus dem Grunde erfunden.
Bitte warten ..
Mitglied: 27119
27119 (Level 2)
18.07.2006 um 09:26 Uhr
Jo - wenn du erstmal über Crossoverkabel zwei PCs direkt verbindest, und es funktioniert, dann kannst du das Problem vielleicht besser eingrenzen.
Bitte warten ..
Mitglied: 27119
27119 (Level 2)
18.07.2006 um 19:28 Uhr
Manchmal hilft auch (wenn man ansonsten alles richtig gemacht hat u. es trotzdem nicht geht) folgende Befehl kombination

net use /DELETE \\<ip-entfernter-rechner\freigabename

net use \\<ip-entfernter-rechner\freigabename
Bitte warten ..
Mitglied: Quark
18.07.2006 um 21:19 Uhr
Super, danke euch allen!

Jetzt kann ich über \\IP\Freigabe zugreifen.

Ich hab einfach in der Windows Firewall nur af Bereich ändern geklickt, und hab zuerst nicht gecheckt, dass das dann nur für den gerade makierten Port gilt (selber schuld, steht ja sogar da...). Hab zwar testweise mal beide Firewalls ausgeschaltet gehabt, hab aber da dann wohl irgendwas anderes verdreht...

Der Name ist mir nicht wichtig, da kommen eigentlich keine neuen PC's hinzu auf die zugegriffen werden muß

Super! Danke noch mal!

Philipp
Bitte warten ..
Heiß diskutierte Inhalte
Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 18 StundenFrageOff Topic17 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 1 TagFrageWindows 1036 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 20 StundenTippHumor (lol)10 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 1 TagFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...

SAN, NAS, DAS
Synology DS213j - Volume nach HDD Austausch vergrößern
gelöst JasperBeardleyVor 1 TagFrageSAN, NAS, DAS4 Kommentare

Moin, ich hab meinem NAS zwei neue 8TB spendiert, da die 3TB Platten jetzt 6 Jahre alt sind. Da die beiden Platten im JBOD ...