Cluster mit heartbeat und drbd

franzmann
Goto Top
Hallo,
ich habe in Anlehnung an den Beitrag (https://www.administrator.de/forum/linux-hochverf%c3%bcgbarkeitssystem-m ..) mal die problematik aufgegriffen und versucht es nachzubilden.
Heartbeat Installation ist kein Problem, aber die DRBD Installation ist schon ne etwas härtere Nuss.
Habe die drbd.conf editiert und bekomme jetzt beim Versuch den Dienst zu starten, folgende Meldung:
Starting DRBD resources: /etc/drbd.conf:2: one of 'protocol|incon-degr-cmd|startup|disk|net|syncer|on <HOSTNAME>' expected, 'not protocol=C'
Hier meine drbd.conf:

01 #
02 # drbd.conf
03 #
04 # Parameter die anzupassen sind:
05 # - resource name, hier drbd0
06 # - hostname
07 # - device
08 # - disk,
09 # - IP-Adresse
10 # - port in der "on <hostname> {}" section
11 # - disk-size.
12 #
13 resource drbd0 {
14 protocol = C
15 fsck-cmd = fsck.ext2 -p -y
16 disk {
17 # Wenn der lower level device einen io-error meldet, haben wir ein Problem
18 # und der andere Knoten soll uebernehmen
19 do-panic
20 # maximale Devicegroesse in KByte runtergerundet auf 4
21 disk-size = 1194300k
22 }
23 net {
24 sync-min = 500k # syncer versucht ueber dieser Rate zu bleiben
25 sync-max = 100M # maximale durchschnittliche syncer Bandbreite
26 tl-size = 5000 # transfer log Groesse
27 timeout = 60 # 0.1 Sekunden
28 connect-int = 10 # Sekunden
29 ping-int = 10 # Sekunden
30 }
31 on knoten1 {
32 device = /dev/nb0 # virtueller Block-Device, steht auch in /etc/fstab
33 disk = /dev/sda2 # logische Partition, wird von YAST oder manuell angelegt
34 address = 192.168.1.1 # IP-Adresse fuer die DRBD-Daten
35 port = 7788 # Port fuer die DRBD-Daten
36 }
37 on knoten2 {
38 device = /dev/nb0
39 disk = /dev/sda2
40 address = 192.168.1.2
41 port = 7788
42 }
43 }

Weiß jemand warum der Fehler auftritt ?

~ edit ~
Wenn ich cat /proc/drbd eingebe, kommt folgende Meldung:
0: cs: unconfigured
1: cs: unconfigured

Content-Key: 66256

Url: https://administrator.de/contentid/66256

Ausgedruckt am: 16.05.2022 um 10:05 Uhr

Mitglied: Franzmann
Franzmann 16.08.2007 um 08:08:55 Uhr
Goto Top
So habe die nochmal drübergeschaut und ein Paar Dinge geändert
Die Konfig File schaut nu wie folgt aus:

Code:
resource drbd0 {
protocol C;

on m3 {
device /dev/drbd0;
disk /dev/sda2;
address 192.168.1.1:7788;
meta-disk internal;
}

on m4 {
device /dev/drbd0;
disk /dev/sda2;
address 192.168.1.2:7788;
meta-disk internal;
}
}


Jetzt bekomm ich als Fehler diese Meldung:
Code:

Starting DRBD resources: [d0 ioct1(,SET_DISK_CONFIG,) failed: Invalid argument Lower Device is already mounted cmd /sbin/drbdsetup /dev/drbd0 disk /dev/sda internal -1 failed!


Zum ersten Fehler glaube ich das dort noch Parameter fehlen, nur welche ?
Beim zweiten liegts wohl an dem Parameter "meta-disk internal" ?!
Was muss hier anders aussehen ?
Mitglied: Franzmann
Franzmann 20.08.2007 um 16:21:03 Uhr
Goto Top
Es läuft. Nachdem ich die Ursprungsdatei ha.cf neugeladen habe und Schritt für Schritt nur die wichtigen Parameter editiert habe, hab ichs zum laufen bekommen.

Nun noch eine Verständnisfrage zum Schluss:
Welche IP- Adressen nimmt man für die Heartbeatleitung ?
Man sollte ja schließlich auch im Notfall ein anderes Subnetz gewählt haben oder ?!
Sollte man das wie folgt machen oder anders ?!
Maschine1: eth0: 10.120.10.2 eth1 192.168.1.2 (Heartbeatleitung da anderes Subnetz)
Maschine2: eth0: 10.120.10.3 eth1 192.168.1.3 (Heartbeatleitung da anderes Subnetz)
Dann müsste ich eth1 mit einem Cross-Over-Kabel verbinden !
Aber wie mache ich das wenn beide Maschinen räumlich von einander getrennt stehen ?
Für Hilfe wäre ich dankbar...
Mitglied: oberfranke
oberfranke 11.10.2007 um 09:20:33 Uhr
Goto Top
Hi,
ich vermute mal über ein normales cat5 (nicht crossover) Kabel auf den selbigen Router mit anderem Subnetz. Geht ja dann gar nicht anders.

lg