Debian 3.1r2 Sarge: Reihenfolge der Netzwerkkarten/Netzwerkports eth0, eth1, eth2 ändern

Mitglied: LightScape66

LightScape66 (Level 1) - Jetzt verbinden

14.06.2006, aktualisiert 08:38 Uhr, 7303 Aufrufe, 1 Kommentar

Auf eth0 liegt die ieee1394 Firewire-Schnittstelle, eth1 und eth2 sind Ethernet-Ports. Wie ändere ich die Reihenfolge?

Hallo,

auf einem Eigenbau-Rechner (MSI Speedster-FA4) habe ich einen onboard ieee1394-Controller und eine Dual-Port Marvell Yukon 88E8053. Zur Installation mit dem NetInst-Image der Debian-Sarge 3.1r2 habe ich temporär eine 3COM 3C905C-TX einbauen müssen, da diese Release des Yukon-Chipsatzes von dem Installations-Kernel (2.6.-irgendwas) nicht erkannt wurde. Also so installiert, vorkompilierten 2.6.8.3-8686-smp drauf, dann Module mit den gut dokumentierten Marvell-Tools gebaut und schon kann sk98lin geladen werden.
Zum Installationszeitpunkt hatte die3COM-Karte eth0, die Firewire war eth1, eth2 und eth3 wurde dann für die Yukon belegt. Nach dem Entfernen der 3COM sind dann die Karten aufgerückt. Beim Booten versucht der dhclient-Job dann über die Firewire-Schnittstelle Verbindung zum DHCP-Server zu bekommen, aber da hängt ja nix dran.... zumindest noch nicht. Deaktivieren will ich den Port aber auch nicht, weil ich ihn später noch gebrauchen werde. (wird ein FreeVO MultiMedia-Rechner)
Wie bekomme ich die eth-Interfaces nun ohne Frickelscripte in die richtige Reihenfolge? Früher gab es mal irgendeine etc-Datei, in der den Ethernet-Interfaces Module zugewiesen werden konnten. Das scheint aber nicht mehr zu klappen oder ich mache das nicht richtig. Hat da jemand ein Patentrezept?
okay, ich bekomme das wohl hin, dass der dhclient sich via eth1 die IP-Adresse holt, aber ich möchte gerne die Netzwerk-Ports auf eth0 und eth1 haben. damit habe ich dann auf jeder Linux-Büchse das Hausnetzwerk auf eth0 liegen, so dass man nicht versehentlich falsche Ports umkonfiguriert oder sich anderweitig mal vertut..... ;-) face-wink

Ciao,
Thomas
Mitglied: LightScape66
14.06.2006 um 08:38 Uhr
Hallo,

wird die Namensvergabe nicht mit udev gemacht? Ich habe inzwischen die Datei /etc/udev/rules.d/udev.rules editiert und folgende Werte eingefügt:

Bei BUS und ID habe ich es allerdings auch mit 2 Gleichzeichen probiert.
Das Kommando lspci ergibt folgende Ausgabe:

Was läuft da falsch?

Ciao,
Thomas
Bitte warten ..
Heiß diskutierte Inhalte
Zusammenarbeit
Klimaschutz
NebellichtVor 1 TagTippZusammenarbeit52 Kommentare

Hallo friends, (friends in Anlehnung an die vielen Fs in dem englischen von FFF: fridays for future. Übrigens am 19.03.2021 gibts wieder einen globalen ...

Notebook & Zubehör
Tipp für festgefressene Scharniere bei Lenovo V120 Notebook?
gelöst LochkartenstanzerVor 1 TagFrageNotebook & Zubehör20 Kommentare

Moin Kollegen, Ich habe hier ein Lenovo V120 mit einem laut Internet üblichen Problem von "festgefressenen" Scharnieren. Ich könnte jetzt aufwendig das Notebook zerlegen ...

Microsoft Office
Microsoft365 und Outlook verbinden
ratzekahl1Vor 1 TagFrageMicrosoft Office31 Kommentare

Guten Morgen zusammen, ich habe einige Probleme / Fragen. Ich habe Office 365 auf den ersten Rechnern installiert. Admin angelegt, Benutzer usw. Da ich ...

Viren und Trojaner
Ryuk Ransomware Warnzeichen
SchlemihlVor 1 TagFrageViren und Trojaner8 Kommentare

Guten Abend, nachdem ich hier und hier erfahren habe, wie sich die Ransomware Ryuk verhält, musste ich feststellen, dass unser kleines Netzwerk für eine ...

Internet
Sichere Verbindung von zu Hause zu einem Firmenpc
haiflosseVor 1 TagFrageInternet6 Kommentare

Hallo! Ich suche eine Lösung mit der ich eine sichere Verbindung (ohne das ein Virus, Trojaner oder Ransom Virus den Computer bzw. Netzwerk zerstört) ...

Hyper-V
ESXi free oder Windows Hyper-V Server 2019
lukas0209Vor 15 StundenAllgemeinHyper-V12 Kommentare

Hallo, ich brauche ca. 2 oder 3 Windows 10 virtualisiert um Dinge zu testen. Ist es dafür sinnvoller ein Windows Hyper-V Server 2019 (kostenlos) ...

Firewall
Firewall Regeln Ping
gelöst Jannik2018Vor 1 TagFrageFirewall9 Kommentare

Hallo zusammen, ich habe folgende firewallregel erstellt aber irgendwie kann ich aus dem Roten Netz keine Pings ins Grüne Netz schicken ist dort etwas ...

Off Topic
Nach 700 Tagen adwcleaner
altmetallerVor 16 StundenAllgemeinOff Topic6 Kommentare

Hallo, ich habe in meinem Netzwerk diverse Maßnahmen, um nicht nur Angriffe, sondern auch - sagen wir mal - unerwünschte Datenabflüsse und Tracking zu ...