Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Debian auf Server mit Hardware-Raid im UEFI-Modus installieren

Mitglied: daniel4

daniel4 (Level 1) - Jetzt verbinden

13.06.2019 um 20:29 Uhr, 752 Aufrufe, 10 Kommentare

Hallo,

für virtuelle Maschinen habe ich bereits öfters ein Debian/Linux-Betriebssystem installiert und ebenfalls ein Software-RAID aufgesetzt. Nun aber habe ich einen physischen Server bekommen, welcher mit 2 SSDs ein Hardware Raid-1 Verbund besitzt. Ich habe als erstes auf einen USB-Stick das aktuelle Debian 9.9, die CD-Variante mit xfce, drauf gebracht und boote diesen im UEFI-Modus.

Dann habe ich bereits nachgelesen unter https://wiki.debian.org/DebianInstaller/SataRaid und mit den Schritten 1-4 das System installiert. Zugriff auf das Raid hatte ich auch und es wurde mir richtig als nur eine Partition angezeigt. Darauf wurde nun manuell das folgende Partitionsschema angelegt: 500MB Efi Partition mit Bootflag, 120GB root Partition ext4 und 4GB Swap. Grub Bootloader war erfolgreich hat zumindest während der Installation keine Fehler gebracht.

Wenn ich nun das installierte System starte, kommt richtig der blau Bildschirm an dem ich zwischen Debian oder Erweiterten Einstellungen wählen kann. Wenn ich hier Debian starte erscheint 30s lang nichts, danach startet initramfs und es erscheint die Fehlermeldung: "ALERT! /dev/mapper/isw_dasjdjda_Volume0p2 does not exist. Dropping to a shell!"

Habe bereits heraus gefunden über den Befehl "blkid", dass das Volumen richtig "/dev/mapper/isw_dasjdjda_Volume0" heißt. Also zurück in den blauen Auswahl Bildschirm, "e"-Drücken und den Pfad anpassen. Danach erscheint beim Boot wieder initramfs und der Fehler: "mount: mounting /dev/mapper/isw_dasjdjda_Volume0 on /root failed: No such file or directory".

Was kann ich tun? Liegt der Fehler an der Partitionierung oder am UEFI? Bin dankbar für jede Hilfe!
Mitglied: daniel4
14.06.2019 um 11:37 Uhr
Im Artikel steht "Nach der Installation wird Ihre Linux-Distribution standardmäßig über die ESP booten, die auf /boot/efi/ hängt" - dies ist leider bei mir nicht der Fall wie ab Absatz 3 bei mir oben zu lesen. Hatte gerade schon Hoffnung, aber trotzdem danke.
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 14.06.2019, aktualisiert um 14:04 Uhr
Moin,

https://askubuntu.com/questions/509423/which-commands-to-convert-a-ubunt ...

Das sollte auch mit debian funktionieren.

lks
Bitte warten ..
Mitglied: daniel4
14.06.2019 um 13:51 Uhr
Dann probiere ich es so, erst Legacy Installation und danach zu UEFI. Aber eigentlich müsste die Installation doch auch so klappen, aber schade
Bitte warten ..
Mitglied: Lochkartenstanzer
14.06.2019 um 14:06 Uhr
Zitat von daniel4:

Dann probiere ich es so, erst Legacy Installation und danach zu UEFI. Aber eigentlich müsste die Installation doch auch so klappen, aber schade

Ich meint enciht, daß Du erst legacy installieren sollst, sondern Dir aus der Anleitung den Teil heraussuchst, der dafür sorgt, daß man mit UEFI booten kann. Dazu muß man nicht neu installieren.

lks
Bitte warten ..
Mitglied: daniel4
16.06.2019 um 20:19 Uhr
Ja naja mach die UEFI-Installation so oder so nochmal neu. Muss dann morgen gleich mal die Lösungsvariante ausprobieren, hoffe das bringt Abhilfe. Ein was vorweg, unter der Legacy Installation gab es den gleichen Fehler
Bitte warten ..
Mitglied: daniel4
17.06.2019 um 13:35 Uhr
Und Schade, der Lösungsweg von oben brachte es nicht. Ich habe jetzt das Hardware-Raid einmal aufgelöst und einer Platte das System installiert mit UEFI, hat wunderbar funktioniert. Also liegt es an der Erkennung des Hardware Raid 1 nach der Installation.
Bitte warten ..
Mitglied: aqui
17.06.2019, aktualisiert um 14:55 Uhr
Komisch, denn mit der im o.a. ct' Artikel beschrieben Vorgehensweise klappt es wunderbar. Und das auch noch Ausfall sicher.

Aber wenns das denn nun war dann bitte
https://administrator.de/faq/32
nicht vergessen.
Bitte warten ..
Mitglied: Lochkartenstanzer
17.06.2019 um 14:59 Uhr
Zitat von daniel4:

Und Schade, der Lösungsweg von oben brachte es nicht. Ich habe jetzt das Hardware-Raid einmal aufgelöst und einer Platte das System installiert mit UEFI, hat wunderbar funktioniert. Also liegt es an der Erkennung des Hardware Raid 1 nach der Installation.

vermutlich sind dann die Treiber nicht in dem initramfs. ggf. das einfach updaten lasen und dabei auf die korrekte modules.conf achten.

lks
Bitte warten ..
Mitglied: daniel4
18.06.2019 um 15:31 Uhr
Treiber müsste ich mal noch suchen. Habe nun aber rausgefunden, dass es sich um ein Fake-Raid handelt.. Habe mich dazu entschieden, dieses im BIOS komplett abzuschalten und auf ein Software-Raid zu setzen - und es funktioniert endlich.
Bitte warten ..
Ähnliche Inhalte
Linux

Debian Software Raid - Ersatzplatte für 2 Raids ?

gelöst Frage von TastuserLinux2 Kommentare

Guten Tag, ich habe 2 Raids und eine Ersatzplatte. Wie füge ich diese in beide Raids hinzu ? Sodass ...

SAN, NAS, DAS

Raid 5 Volume im inaktiven Modus nach HDD-Tausch

Frage von JackoeSAN, NAS, DAS11 Kommentare

Servus zusammen, ich habe eine Frage zu einem QNAP NAS-Server. Typ: TS-439+ 4 x 1TB Seagate HDDs einfach als ...

Debian

Debian 8.5 mit FAKE Raid - rsync und cp verursachen Systemabsturtz

Frage von backaraDebian13 Kommentare

Hallo die Damen und Herren, nach langer Zeit hab ich mal wieder ein Problemchen wo pure Ratlosigkeit zum Vorschein ...

Debian

BIOS-RAID mit 4 TB platten werden im System als nur 1802GB RAID-Verbund angezeigt - Debian

gelöst Frage von Gansterjo2Debian4 Kommentare

Liebe Forumsmitglieder Mein Ziel: Aus einem herrkömlichen Computer soll ein NAS werden. Dabei werden die Platten über das BIOS-RAID ...

Neue Wissensbeiträge
Verschlüsselung & Zertifikate

Extended Validation Certificates are (Really, Really) Dead

Information von Dani vor 11 StundenVerschlüsselung & Zertifikate

Moin all, sehr interessanter Artikel zu EV SSL/TLS- Zertifikate von Troy Hunt: Gruß, Dani

Humor (lol)
Das IoT wird schlimmer
Erfahrungsbericht von Henere vor 3 TagenHumor (lol)8 Kommentare

Nun auch schon über den WSUS:

Sicherheit

Win10 1809 und höher erlauben nun das Sperren und Whitelisten von bestimmten Geräten

Tipp von DerWoWusste vor 3 TagenSicherheit1 Kommentar

Vor 1809 konnten nur Geräteklassen gesperrt werden, nun können endlich einzelne Device instance IDs gewhitelistet werden (oder andersherum: gesperrt ...

Windows 10

Hands-On: What is new in the Windows 10 November 2019 Update?

Information von DerWoWusste vor 3 TagenWindows 10

Die wenigen (aber zum Teil interessanten) Neuheiten werden in diesem Video sehr schnell erklärt und vorgeführt.

Heiß diskutierte Inhalte
Mac OS X
Mac Startfehler: Too many corpses created
Frage von winlinMac OS X23 Kommentare

Seit meinem letzten update komme ich nach der Anmeldung nixht mehr weiter. Der Fortschrittsbalken nach der Anmeldung geht bis ...

Netzwerke
Subnetzmaske mit Hilfe der IP-Adresse berechnen
gelöst Frage von Jennifer21Netzwerke22 Kommentare

Hi zusammen, kann mir bitte jemand helfen bei dieser Aufgabe. Ich muss die die Subnetzsmaske berechnen von den IP-Adressen: ...

Exchange Server
Exchange 2016 550 5.7.60 SMTP Client does not have permissions to send
Frage von kermit-elmoExchange Server17 Kommentare

Hallo, ich möchte für bestimmte Mitarbeiter einen IMAP Zugang zum Firmen internen Exchange 2016 bereitstellen. Ein paar verwenden Linux ...

Windows 10
3D PDF bei WIN 10 mit Adobe Acrobat DC öffnen
Frage von DysfunktionWindows 1016 Kommentare

Hallo zusammen, Aus einem Konstruktionsprogramm ( Catia ) kann man Zeichnungen als 3 d PDF exportieren. Diese werden lokal ...