arano
Goto Top

Firefox zeigt Homeverzeichnis anstelle der Startseite

Trotz einer definierten Startseite zigt mir mein Firefox beim starten mein Homeverzeichnis (file:///home/arano/) an !?

Guten Morgen.

Seit der Installation von Firefox (v3.5.5) zeigt mir dieser beim starten mein Homeverzeichnis (file:///home/arano/) anstelle der eingestellten Startseite (Google) an.
Beim Klick auf den Startseiten-Button wird die Startseite dan doch noch geöffnet, allerdings nervt das doch irgendwie auf dauer.

In den Einstellungen habe ich gewählt:
Bearbeiten -> Einstellungen -> Allgemein -> Wenn Firefox gestartet wird = Startseite anzeigen
Bearbeiten -> Einstellungen -> Allgemein -> Startseite = http://www.google.de
So steht es auch in der "about:config":
browser.startup.homepage = http://www.google.de
browser.startup.page = 1
Beim System handelt es sich um ein Debian Lenny Kernel 2.6.26-2-686 und Xfce4 als Desktopumgebung

Den Firefox habe ich direkt von der Mozilla Seite runtergeladen (firefox-3.5.5.tar.bz2) und als root entpackt sowie nach /opt/firefox verschoben.
Und folgende symbolische Links erstellt:
lamp:~$ ls -l /usr/bin | grep firefox
lrwxrwxrwx 1 root root  20 30. Nov 11:20 firefox -> /opt/firefox/firefox
lamp:~$ ls -l /etc/alternatives | grep firefox
lrwxrwxrwx 1 root root  16 30. Nov 11:22 x-www-browser -> /usr/bin/firefox
lamp:~$ 
Auch ein löschen meines Mozilla-Ordners (/home/arano/.mozilla) brachte keine Änderung.
Eben habe ich auch noch einmal den Firefox neu heruntergeladen und erneut installiert (nach /opt kopiert) aber das war es auch nicht.

Habt ihr noch Ideen woran das liegen könnte und wie ich den "listigen Fuch" doch noch überreden kann die eingestellte Startseite anzuzeigen ?


~Arano

Content-Key: 130492

Url: https://administrator.de/contentid/130492

Printed on: June 22, 2024 at 18:06 o'clock

Member: Snowman25
Snowman25 Nov 30, 2009 at 11:21:58 (UTC)
Goto Top
about:config in die Adresszeile eintippen und dort als filter start eintragen. überprüfen, ob browser.startup.homepage auf google gestellt ist, ausserdem sollte browser.startup.page auf 1 stehen. der Eintrag browser.startup.homepage_override.mstone sollte (sofern vorhanden) keine URL beinhalten, sondern eine Revisionsnummer wie z.B. rv:1.9.1.5
Member: Arano
Arano Nov 30, 2009 at 11:34:14 (UTC)
Goto Top
Hallo Snowman25

browser.startup.homepage = http://www.google.de 
browser.startup.page = 1
browser.startup.homepage_override.mstone = rv:1.9.1.5
Genau so habe ich es ja...

Aber Danke für den Versuch face-smile


~Arano
Member: Snowman25
Snowman25 Nov 30, 2009 at 11:37:33 (UTC)
Goto Top
möglicherweise ist deine Verknüpfung auf den Browser mit einem entsprechendem Parameter versehen?
Member: Arano
Arano Nov 30, 2009 at 11:59:12 (UTC)
Goto Top
Oh nein, das kann ja wohl nicht wahr sein...

...du hast recht !
Ich bin immer davon ausgegangen das Browsersymbol im Startpanel auf /usr/bin/firefox (o.ä.) zeigt.
Aber dieses zeigte auf "exo-open --launch WebBrowser"
Bei einem direktem Aufruf von "/usr/bin/firefox" wird dann auch wieder die Startseite angezeigt face-smile
(DAS hätte ich ja auch mal testen können...)

Jetzt freu ich mich zwar das es endlich so funktioniert wie es soll,
ärgere mich aber auf der anderen Seite weil es mal wieder so simpel war...

Naja, in jedem Fall danke ich dir für deine Hilfe.
Dankeschön !


~Arano