gelöst Installer meldet sich bei Aufruf eines Programmes

Mitglied: Stoertebecker

Stoertebecker (Level 1) - Jetzt verbinden

09.01.2009, aktualisiert 08:58 Uhr, 9689 Aufrufe, 11 Kommentare

Hallo,

habe ein Problem mit einem PC. Hier wurde der "XP-Cleaner 5.8" installiert und danach wieder deinstalliert. Die Deinstallation ist wohl nicht sauber gelaufen. Es waren noch viele Reste in der Registry, etc.
Wir haben jetzt das Problem, dass sich der Installer bei einem ganz anderen Programm meldet. Wird dieses Programm gestartet, kommt der Installer und will noch etwas von "XP-Cleaner" installieren. Das gestartete Programm ist eine Individualsoftware für eine Tischlerei, hat also nichts mit XP-Clean zu tun.

Wollte den XP-Cleaner daraufhin nochmal installieren, um ihn dann nochmal sauber zu deinstallieren. Die Installation scheitert....

Habe mir dann die registry vorgenommen und alle Reste von XP-Cleaner gesucht und gelöscht. Leider ohne Erfolg.

Was kann ich noch machen?

Viele Grüße

Klaus
Mitglied: Hannes-Schurig
09.01.2009 um 09:49 Uhr
Kommt die Installation bei einem eingeschränktem Nutzer oder auch bei einem Administrator?
Was passiert in der Installation? Kommt nur ein Fortschrittsbalken der irgendwann abbricht und eine Fehlermeldung zeigt oder kommt ein richtiges Installationsfenster mit Weiter-Buttons und son Kram?

Ich kenne Verhalten dieser Art auch allerdings läuft diese Restinstallation bei mir im Administratorkonto durch und kommt dann auch nie wieder.
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 09:50 Uhr
Hallo Klaus,
schau doch mal ob du Logfiles von der fehlgeschlagenen Installation des XP Cleaners findest.
Einfach so in der Registry rumzuhandwerken reicht oft nicht / bringt mehr durcheinander.
Installationsreste gibt es oft als Verzeichnisse/Dateien an Stellen im os wo man gar nicht so schnell dran denkt.
Gruß
Michael
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 12:50 Uhr
Hallo,

es handelt sich um einen XP-Rechner. Benutzer ist auch Computeradministrator.

Rufe ich die Installation auf, erscheint folgende Fehlermeldung:
"Der Systemadministrator hat die Roichtlinien erlassen, um diese Installation zu verhindern..."
Benutzer ist aber Admin!

Log-Files? Wo werden welche erstellt? Kann keine finden....

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 12:55 Uhr
Hi Klaus,
ist der Rechner in einer Domäne ?
Was ist das für ein Installationspaket (msi)?
Gruß
Michael
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 13:01 Uhr
Hallo,

danke für die schnelle Reaktion!!!!!

der Rechner ist ein Einzelplatzrechner. Keine Domäne.

Die Installationsdatei ist eine MSI (XPClean58.msi)

Wenn ich das Tischlerprogramm starte erscheint der Windows Installer: "Bitte warten Sie, während Windows XP-Clean konfiguriert". Dann erscheint das zweite Fenster "Fehler 1606. Zugriff auf die Netzwerkadresse war nicht möglich"Muss ein paar mal auf Abbrechen oder "X" klicken und dann startet die Anwendung un man kann normal arbeiten.

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 13:15 Uhr
Zitat der Winfaq " ...Lösung:

HKEY_LOCAL_MACHINE\ SOFTWARE\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ Shell Folders
HKEY_CURRENT_USER\ Software\ Microsoft\ Windows\ CurrentVersion\ Explorer\ User Shell Folders

den Wert der Einträge "RECENT" (Datentyp REG_SZ) auf ein vorhandenes Verzeichnis abändern oder den Eintrag einfach löschen, nachdem man den entsprechenden Registryzweig exportiert (gesichert) hat.

Weiterhin muss der Eintrag "Eigene Dateien" auf ein gültiges Verzeichnis verweisen.

Wenn Sie eingestellt haben, dass die Historie der zuletzt genutzten Dateien bei jedem Neustart gelöscht wird (Tweak UI), werden alle Einträge in diesem Verzeichnis gelöscht. Sie sollten also entweder das Recent-Verzeichnis oder ein leeres Verzeichnis angeben.

Windows neu starten.
Wenn das nicht hilft, dann:

... kann es auch am Windows Installer liegen.

Von diesem Problem ist auch bei Office-Installationen berichtet worden. Die Ursache ist oft ein nicht korrekt deinstalliertes Office. Die Lösung brachte das Entfernen der *.msi Dateien aus dem windows\installer\ Verzeichnis, das Löschen des Temp-Verzeichnisses und aller Einträge von Office und Installer aus der Registry (!!).

Ich persönlich finde diese Lösung ziemlich kritisch, auf jeden Fall sollte man vorher eine Sicherung der Registry durchführen. ...."

Würde das mal so probieren
Bitte warten ..
Mitglied: Hannes-Schurig
09.01.2009 um 13:52 Uhr
Zitat von Stoertebecker:
Wenn ich das Tischlerprogramm starte erscheint der Windows Installer:
"Bitte warten Sie, während Windows XP-Clean
konfiguriert". Dann erscheint das zweite Fenster "Fehler
1606. Zugriff auf die Netzwerkadresse war nicht möglich"Muss
ein paar mal auf Abbrechen oder "X" klicken und dann startet
die Anwendung un man kann normal arbeiten.

SilentBob hat Recht, das Problem kommt u.A. auch bei Installationen von Office und u.U. auch bei Acrobat Installationen vor.
Der Installationsassistent sucht den Pfad ("Zugriff auf Netzwerkadresse" <- von dort wurde es wohl installiert) und findet ihn nicht. Wenn der Pfad mit den richtigen Dateien vorhanden wäre könnte der Assistent vielleicht abschließen und dann könnte man mit einer sauberen Installation das ganze beseitigen.

Wenn wir hier in der Firma Office 2003 Pro über ein Netzlaufwerk installieren und dann das Netzlaufwerk nicht vorhanden ist, wenn Office versucht sich beim ersten Start einzurichten, dann findet der Assistent diesen Pfad ins Netzwerk, von wo es installiert wurde, auch nicht. Durch mehrmaliges Abbrechen startet das Programm aber bei jedem Start versucht der Installer Office einzurichten, bis irgendwann das Verzeichnis vorliegt und er die nötigen Dateien zum konfigurieren erhält. Dann rattert er wenige Sekunden rum und Office startet ohne Fehler, in Zukunft dann auch.

Vielleicht kannst du Ähnliches in deiner Situation machen.
Bitte warten ..
Mitglied: Stoertebecker
09.01.2009 um 14:46 Uhr
Hallo,

habe die drei Punkte in der registry soeben bearbeitet. Auch TweakUI installiert und die Einstellung vorgenommen. Leider ohne Erfolg.

Einen neuen Installer habe ich auch installiert....

Leider habe ich unter Windows kein "Installer" Verzeichniss, wo ich die Datei hätte löschen können.

Die Alternative, die Installationsdatei nochmal an den Ursprungsort zu kopieren geht leider nicht. Ich habe es nicht installiert und weiß auch nicht, wo derjenige damals die Installationsdatei gespeichert hatte. Ich wurde nur gerufen um den Fehler zu beheben ála "Du kennst Dich doch mit Computern aus...." ..... Jetzt sitze ich damit

Viele Grüße

Klaus
Bitte warten ..
Mitglied: SilentBob72
09.01.2009 um 14:52 Uhr
Dumme Frage hast die Ordneroption auf Ansicht für alle Dateien gestellt ? Kein Ausblenden von Systemdateien etc. ?
Gruß
Michael
Bitte warten ..
Mitglied: Hannes-Schurig
09.01.2009 um 15:00 Uhr
Und es lässt sich aus keinen Logeinträgen oder Fehlerberichten oder Fehlermeldungen ein Pfad ergattern? Meist erscheint eigentlich ein Fehler mit dem Format "Installationsdateien unter H:\Programme\XPClean nicht gefunden" oder so.
Bitte warten ..
Mitglied: Stoertebecker
10.01.2009 um 14:17 Uhr
Hallo,

habe es gestern abend hinbekommen! Lösung habe ich auf der Support-Seite von MS gefunden. Im Eventvwr konnte ich den Product-Code herauslesen. Nach diesen habe ich dann in der Regisry gesucht und die vorhandenen gelöscht. Jetzt läuft es wieder.

Danke für die Hilfe

Klaus
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerke
Sicherheitsbetrachtung virtualisierte Umgebung
gelöst Philipp711FrageNetzwerke22 Kommentare

Hallo liebe Community, ich habe eine kleine Frage bzgl. der Netzwerksicherheit in virtualisierten Umgebungen. Beispiel: Ich habe einen Hypervisor ...

Outlook & Mail
Nach Update von Office 2013 auf 2016 funktioniert das Autodiscover nicht mehr
gelöst StefanKittelFrageOutlook & Mail14 Kommentare

Hallo, ich habe hier einen PC mit Win10 Prof (20H2). Darauf installiert war Office 2013 Home and Business. Dieses ...

Notebook & Zubehör
Surface pro 3 oder aktueller
devazubiFrageNotebook & Zubehör11 Kommentare

Moin moin zusammen, ich möchte eine kurze Umfrage/Feedbackrunde starten. Ich habe gerade angefangen Wirtschaftsinformatik berufsbegleitend zu studieren. Ich würde ...

Router & Routing
Mariadb über nginx direkt erreichen?
TastuserFrageRouter & Routing9 Kommentare

Hallo, ich habe eine Dockerumgebung mit einem letsencrypt (neu swag) Container mit nginx und einen mariadb Container. Nun möchte ...

Hardware
Können Netzteile bei dauerhafter Unterbelastung Schaden nehmen?
UweGriFrageHardware9 Kommentare

Guten Abend, mir ist es jetzt 2x vorgekommen, das hochwertige Marken Netzteile die deutlich überdimensioniert sind, Schaden bei dauerhafter ...

Hosting & Housing
Performance mediawiki unter windows10 - (cgi)
jan99FrageHosting & Housing8 Kommentare

Moin! zunächst einmal hoffe ich so einigermassen die richtige Gruppe gewählt zu haben. Ich bin in userem Unternehmen so ...

Ähnliche Inhalte
Windows Tools
OpenVPN 2.4 Silent install
gelöst geocastFrageWindows Tools1 Kommentar

Guten Abend zusammen Da nun OpenVPN nach Jahren endlich mal ohne Adminrechte funktioniert (als die Route hinzufügen). Wollte ich ...

Java
Aufruf der web.xml
gelöst qwertz1FrageJava3 Kommentare

Hallo, ich habe einen Server, der diverse Java-Servlets hat. Habe nur http-Zugriff auf diesen Server. Die Servlets kann man ...

E-Mail
Fortimail meldet DKIM Fehler
Finchen961988FrageE-Mail1 Kommentar

Hallo ich bekomme bei einer Fortimail die folgende Meldung DKIM Check Failed. The body hash is not valid. komischer ...

Server-Hardware
Aufruf Zeichen leuchtet gelb
gelöst jarimlimFrageServer-Hardware22 Kommentare

Auf einem IBM x3850 System auf der vordere seite leuchtet ein AufrufZeichen gelb. was beduetet das ? Vielen Dank

Windows 10
Hyper-V2016 - W10 Install scheitert
gelöst HenereFrageWindows 1013 Kommentare

Servus zusammen, ich versuche gerade eine W10 unter einem Hyper-V zu installieren. Heruntergeladen habe ich die aktuelle 1809. Da ...

Batch & Shell
Parameter für plink-Aufruf
gelöst trobonarfFrageBatch & Shell4 Kommentare

Hallo, ich führe via plink ein lokales Skript auf dem Server aus - das klappt soweit. Beispiel: .\plink.exe -ssh ...

Neue Fragen
Administrator Magazin
11 | 2020 Virtualisierung ist aus der IT nicht mehr wegzudenken. In der November-Ausgabe des IT-Administrator Magazins dreht sich der Schwerpunkt um das Thema "Server- und Storage-Virtualisierung". Darin erfahren Sie, wie sich die Virtualisierungstechnologie entwickelt hat, welche Varianten es im Bereich Server und Speicher gibt und wie ...
Neue Beiträge
Neue Jobangebote
Server- und Storage-VirtualisierungServer- und Storage-VirtualisierungBerechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid Cloud