Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Kixtart Drucker Gruppenbezogen verbinden

Mitglied: Ting

Ting (Level 1) - Jetzt verbinden

23.04.2008, aktualisiert 20.05.2008, 15374 Aufrufe, 14 Kommentare

Mittels Kixtart Drucker Gruppenbezogen verbinden.

Hallo zusammen,

verwende als LogOn Script Kixstat.
In meinem Script bekommen alle user unsere Drucker vom Printserver verbunden.

Nun, werden es aber zu viele Drucker und somit auch zu unübersichtlich.
Hab jetzt im AD Gruppen für die einzelen Drucker eingerichtet.

Nun komme ich aber nicht weiter wie ich die Drucker Gruppenbezogen im LogonScrip verbinden lassen kann.

Bisher mache ich es so.

If ADDPRINTERCONNECTION ("\\"+$PrintServer+"\DRUCKER") = 0
;? "DRUCKER wurde verbunden"

Nun will ich halt das den Drucker nur noch ein bestimmte Gruppe verbunden bekommt!

Vielen Dank im Vorraus.
Gruß
Ting
Mitglied: 60730
23.04.2008 um 14:40 Uhr
Hallo zusammen,

zurück....
01.
IF INGROUP("domain\drucker1")
02.
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\DRUCKER1")
03.
 
04.
endif
Gruß
Bitte warten ..
Mitglied: Ting
23.04.2008 um 16:29 Uhr
Hallo,
hab es so veruscht, nur leider Klappt es nicht.
weiß nicht warum.

wenn ich es so mache,

if @userid="USER"
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\Drucker01")
endif

dann klappt es.
Es will aber nicht über die Gruppe funktionieren.
Netzlaufwerke kann ich auch über die Gruppe mappen.

Gibt es noch eine andere Methode?

Vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: Ting
23.04.2008 um 16:42 Uhr
Hab meinen Fehler gefunden,
hatte meine Server noch nicht Repliziert.

Vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: Ting
30.04.2008 um 09:17 Uhr
Hallo zusammen,
hab zu dem thema noch einmal eine Frage,

wenn ich die Gruppen in einzelne OU´s habe, kann ich die Gruppen dann auch ganz normal über

IF INGROUP("test")
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\Printer") = 0
endif

oder muss ich noch den OU namen mit angeben?

vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: 60730
30.04.2008 um 10:19 Uhr
Servus Ting,

wenn du es noch nicht ausprobiert hast?

Denk mal drüber nach, ob du bei der Freigabeberechtigung von Ordnern auch die OU eintragen mußt.
Wenn da nicht, warum sollte es dann bei Kix anders sein?


muss ich noch den OU namen mit angeben?
NEIN
Gruß
Bitte warten ..
Mitglied: Ting
30.04.2008 um 10:49 Uhr
upps, Stimmt

Vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: Ting
30.04.2008 um 14:23 Uhr
jetzt muss ich leider schon weider nerven ^^

und zwar verbindet er mir bei manchen Rechnern die Drucker nicht!
Hab das Problem jetzt bei drei WinXp Rechnern festgestellt.

selbst wenn ich das LogOn Script im angemeldeten Zustand ausführe, will er mir zwei Drucker nicht verbinden.

Auf nem W2k Terminalserver funktionierts.

Wird das LogOn Script irgendwie im Cache vom Rechner gespeichert oder so?
Ich hab langsam echt keine Ahnung mehr warum es auf manchen Rechner nicht funktionieren will.

ich hoffe es kann mir jemand helfen!

Vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: Ting
05.05.2008 um 09:01 Uhr
Weiß keiner de Idee?

wie gesagt, auf vielen Clients, willer mir die Drucker nicht verbinden!
Manche vom gleichen Server macht er manche nicht.
des muss also ein Problem von Client sein!
Warum auch immer

Vielleicht hatte schon mal jemand das Problem.

Danke
Gruß
Ting
Bitte warten ..
Mitglied: gogoflash
10.05.2008 um 12:19 Uhr
Hallo Ting,

wie wird das Anmeldescript bei dir aufgerufen?
Über Gruppenrichtlinie, CMD Datei oder beim User eingetragen?

Manchmal kann es sein, dass die Gruppenrichtlinien auf den Clients nicht sauber angewendet werden. Scahu mal ob es dafür Indizien im Eventlog gibt.

PS. Könntes ausdieser Frage gleich auch einen neuen Beitrag machen, weil sonst keiner so tief runterblättert....


Gruß Miguel
Bitte warten ..
Mitglied: Ting
13.05.2008 um 08:05 Uhr
Hallo Ting,

wie wird das Anmeldescript bei dir
aufgerufen?
Über Gruppenrichtlinie, CMD Datei oder
beim User eingetragen?

Manchmal kann es sein, dass die
Gruppenrichtlinien auf den Clients nicht
sauber angewendet werden. Scahu mal ob es
dafür Indizien im Eventlog gibt.

PS. Könntes ausdieser Frage gleich auch
einen neuen Beitrag machen, weil sonst keiner
so tief runterblättert....


Gruß Miguel

Hi Miguel,
das Script ist bei den Usern im AD eingetragen.
kann mir das Problem absolut nicht vorstellen, hab schon alles versucht ...

Vielleicht weiß noch jemand eine Idee?

Danke Gruß
Ting
Bitte warten ..
Mitglied: 60730
14.05.2008 um 13:51 Uhr
Servus,

schreib doch mal genau, was nicht klappt.

Das es an einem W2k Server funktioniert und unter XP nicht - könnte an den Treibern liegen.

Sicherstellen kannst du das nur, wenn du es "manuell" ohne Skript probierst.
Da das Skript die Drucker auch nicht verbindet, wenn du es manuell startest, könnte es auch am Skript liegen.

Poste das Skript mit Info, welcher gemappt wird und welcher nicht.
Vielleicht sieht man dann mehr....
Bitte warten ..
Mitglied: Ting
15.05.2008 um 09:21 Uhr
Hallo TimoBeil,

also, die Drucker kann ich manuell Verbinden, es funktioniert nur nicht in Verbindung mit WinXP.
Hab jetzt auch mal geschaut, ob es am Kaspersky liegt, hab aber auch nen XP Rechner ohne Kaspersky versucht, klappt auch nicht.

Hier mal ein auszug aus dem Script:

; Variablen deklarieren
; *
$PrintServer="pi100testscsi" <-- W2K Server
$PrintServerNeu="w2k3s6workra" <-- W2K3 Server
;;
; Drucker verbinden
; *
IF INGROUP("Prnt ALL")
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\Xerox") = 0 <-- Wird Verbunden
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\designjet 4000") = 0 <-- Wird Verbunden
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\HPColorLaserJet 4550N") = 0 <-- Wird Verbunden
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\farbdrucker 2.0 og") = 0 <-- Wird Verbunden
endif
;
IF INGROUP("Prnt 1OG")
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\business inkjet 1.OG") = 0 <-- Wird Verbunden
endif
;
IF INGROUP("Prnt 2BA")
ADDPRINTERCONNECTION ("\\"+$PrintServerNeu+"\HPLJP3005_2.BA") = 0 <-- keine Verbindung
ADDPRINTERCONNECTION ("\\"+$PrintServer+"\InkjetWGB") = 0 <-- keine Verbindung
endif

wie gesagt, die Drucker werden auf nem W2k Server alle Verbunden. MAnuell kann ich sie auch Verbinden. Es muss also irgend ein Lokales Problem sein, denke ich ...

Vielleicht weiß noch einer ne Idee.

Vielen Dank
Gruß
Ting
Bitte warten ..
Mitglied: 60730
15.05.2008 um 12:58 Uhr
Servus,

IF INGROUP("Prnt 2BA")

Dort würde ich mal nach dem Fehler suchen, also ob die Gruppe so existiert, bzw. "Members" hat.

Vielleicht ein
use y: "\\server\freigabe"
nur zum testen, ob das Laufwerk Y dann gemappt wird.
Bitte warten ..
Mitglied: Ting
20.05.2008 um 15:46 Uhr
alles klar, hat sich geklärt.
der Fehler lag tatsächlich am Kaspersky 6.
Warum auch immer.

Zumindest funktionert jetzt alles.

Vielen Dank
Gruß
Ting
Bitte warten ..
Ähnliche Inhalte
Drucker und Scanner
Duplex-Druck
Frage von beamenwaerschoenDrucker und Scanner5 Kommentare

Hallo liebe Admins, wir haben einen Rechner in der Firma nach einem Virus neuinstalliert. Jedoch tritt nach folgendes Problem ...

Windows 10
Druck option
Frage von jensgebkenWindows 108 Kommentare

Hallo Gemeinschaft, folgendes Problem. Ich muss aus einer Anwendung drei Drucke erstellen 2x schwarz weiss 1 x Farbe 1 ...

TK-Netze & Geräte

Verbind 2 Hauser mit Kupfer und einen Netzwerkisolator

Frage von Hampi7273TK-Netze & Geräte3 Kommentare

Ich hab gelesn das in der Medizin Technik oft mit Netzwerkisolator gebaut wird. Netzwerkisolatoren bilden innerhalb einer kupfergeführten Ethernet-Datenleitung ...

Drucker und Scanner

Chipkartendrucker: Druck entfernen?

gelöst Frage von BadgerDrucker und Scanner13 Kommentare

Hallo, ich habe eine Frage zu Chipkartendruckern: kann man einen Druck auch wieder entfernen, wenn man Chipkarten mit einem ...

Neue Wissensbeiträge
iOS
WatchChat für Whatsapp
Tipp von Criemo vor 1 TagiOS3 Kommentare

Ziemlich coole App für WhatsApp User in Verbindung mit der Apple Watch. Gibts für iOS sowohl als auch für ...

iOS
IOS hat nen Cursor !!!
Tipp von Criemo vor 2 TageniOS5 Kommentare

Nette Funktion im iOS. iPhone-Mauszeiger aktivieren „Nichts ist nerviger, als bei einem Tippfehler zu versuchen, den iOS-Cursor an die ...

Off Topic
Avengers 4: Endgame - Erster Trailer
Information von Frank vor 4 TagenOff Topic2 Kommentare

Ich weiß es ist Off Topic, aber ich freue mich auf diesen Film und vielleicht geht es anderen hier ...

Webbrowser
Microsoft bestätigt Edge mit Chromium-Kern
Information von Frank vor 4 TagenWebbrowser5 Kommentare

Microsoft hat nun in seinem Blog bestätigt, dass die nächste Edge Version kein EdgeHTML mehr für die Darstellung benutzen ...

Heiß diskutierte Inhalte
Windows Netzwerk
Kerio. Kann keine Mails empfangen aber senden. Wer ist schuld. Kerio oder Windows domäne?
gelöst Frage von frosch2Windows Netzwerk33 Kommentare

Hallo, es existiert ein Problem bei uns mit dem mailen. Alle bestehenden Nutzer können mailen. Raus wie rein. Neuen ...

LAN, WAN, Wireless
WLAN und Ausmessung - Eine Glaubensfrage?
Frage von ptr2brainLAN, WAN, Wireless23 Kommentare

Liebe Experten, als Sys-Admin habe ich mir schon öfter die Frage gestellt, ob es sich beim Thema WLAN und ...

Hosting & Housing
VMware VM mit über 1TB RAM für S4HANA
Frage von Leo-leHosting & Housing22 Kommentare

Hallo zusammen, wer hat Erfahrng und kann mir einen Tipp zum sizing von S4HANA Systemen geben? Wir möchten, zunächst ...

Virtualisierung
Gebrauchte Server Hardware als Virtualisierungs-"Spielwiese"?
Frage von NixVerstehenVirtualisierung19 Kommentare

Einen wunderschönen guten Morgen zusammen, ich möchte mich gerne etwas tiefer mit dem Thema Virtualisierung beschäftigen und dazu ein ...