MikroTik RouterOS Destination NAT hinter Speedport (interner Zugriff)

Mitglied: 120764

120764

16.02.2016, aktualisiert 13:59 Uhr, 1380 Aufrufe, 8 Kommentare

Hallo zusammen,

ich stecke etwas fest und ich glaube das ihr mir weiterhelfen könnt.

zum Aufbau:

WAN: SpeedPort (192.168.0.1) <-> MikroTik Router (192.168.0.2)

MikroTik Router (192.168.254.1) <-> DMZ (192.168.254.0/24)
MikroTik Router (192.168.2.1) <-> Gäste Netzwerk (192.168.2.0/24)
MikroTik Router (192.168.1.1) <-> Mein Netzwerk (192.168.1.0/24)

Ich hoffe das ist verständlich sonst kann ich gerne noch eine grafische Darstellung hochladen.

zum Problem:

Ich habe einen Webserver (192.168.254.3) in der DMZ stehen. Und diesen würde ich gerne von "außen" erreichen wollen. Port Freigabe auf dem SpeedPort ist eingerichtet und ein Destination NAT auf den MikroTik Router ist auch eingestellt:


Von "außen" ist auch alles wunderbar erreichbar (wenn ich selber nicht in meinem Netz bin z.B. Mobilfunk). Wenn ich allerdings meine Domain intern aufrufen möchte (von z.B. 192.168.1.100) , lande ich immer auf der Konfigurationsseite des SpeedPorts. Im Internet stand etwas bezüglich Hairpin NAT, allerdings denke ich das es nur für den Fall ist, dass sich sowohl der Webserver als auch der Client, der die Anfrage stellt, im selben Netzwerk befinden.

Ich hab irgendwo einen Denkfehler und ich würde mich darüber freuen, wenn mir jemand helfen kann. :) face-smile

Wenn Informationen fehlen sollten einfach bescheid sagen.

Vielen Dank

minefubi
Mitglied: 114757
114757 (Level 4)
16.02.2016, aktualisiert um 15:16 Uhr
Uups was ist jetzt passiert ? Mein Post ist verschwunden ... kurios.
Na egal, dann erneut.

Die Speedport-Gurke ist hier das Problem, die streiken bekanntlich beim Hairpin-NAT ...

Setze intern einfach einen statischen DNS-Eintrag der direkt auf die IP in der DMZ zeigt.

Gruß jodel32
Bitte warten ..
Mitglied: 120764
120764 (Level 1)
16.02.2016 um 15:31 Uhr
Zitat von @114757:
Die Speedport-Gurke ist hier das Problem, die streiken bekanntlich beim Hairpin-NAT ...

Setze intern einfach einen statischen DNS-Eintrag der direkt auf die IP in der DMZ zeigt.

Das hatte ich schon... nur ging es mit meinem (Ex-) EdgeMax Router ja auch... gibt es echt keine möglichkeit?

Und warum ist denn dein Post verschwunden? ;P
Bitte warten ..
Mitglied: 114757
114757 (Level 4)
16.02.2016, aktualisiert um 15:38 Uhr
Zitat von @120764:
Das hatte ich schon... nur ging es mit meinem (Ex-) EdgeMax Router ja auch... gibt es echt keine möglichkeit?
Der Edge-Max ist aber auch keine billige Speedportgurke !! Kannst du hier im Forum diverse Beschwerden nachlesen die den Schina-Schrott immer als Ursache haben.
Am besten du betreibst kein doppeltes NAT und besorgst dir ein Modem was du direkt an den Mikrotik pappst und diesen die PPPoE Verbdindung aufbauen lässt, oder wenn die du eine alte Firmware auf den Speedport flashst welche diesen als Modem benutzen lässt.
Und warum ist denn dein Post verschwunden? ;P
Keine Ahnung.
Bitte warten ..
Mitglied: 120764
120764 (Level 1)
16.02.2016 um 15:48 Uhr
Zitat von @114757:
Der Edge-Max ist aber auch keine billige Speedportgurke !!

Der Edge-Max war auch vorher hinter dem Speedport...

Ich muss mal gucken ... diese gemietete Gurke lässt auch nur dann auf sich zu greifen wenn sie als DNS eingetragen ist (Oder einfach als forward in Bind9 eingetragen wird) ... -.- so ein mist hatte ich echt noch nie...!
Bitte warten ..
Mitglied: Kuemmel
16.02.2016 um 19:31 Uhr
Welches Speerport-Modell hast du denn eigentlich?
Bitte warten ..
Mitglied: 120764
120764 (Level 1)
16.02.2016 um 19:43 Uhr
Ich hab den Speedport W 724V

Und komischer weise hat der Edgemax Router hinter dem Speedport die Anfragen sowohl intern als auch extern korrekt beantwortet
Bitte warten ..
Mitglied: Kuemmel
16.02.2016 um 19:50 Uhr
Dann aber schnell zurück mit der Kiste!
Bitte warten ..
Mitglied: 120764
120764 (Level 1)
16.02.2016, aktualisiert um 20:00 Uhr
Ja hab ich mir fast gedacht...
Will nur keine teure FritzBox holen...
Ich brauch einfach einen VDSL Router mit DECT der alles an meinen Mikrotik Router weiterleitet...
Dann muss ich mal gucken das ich die Mietgurke wieder loswerde...

Und sonst gibt es keine Möglichkeiten?
Bitte warten ..
Heiß diskutierte Inhalte
Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 1 TagFrageOff Topic19 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 1 TagFrageWindows 1045 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 1 TagTippHumor (lol)12 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...

Grafikkarten & Monitore
Monitorhalterung mit 80cm Armlänge
ben1300Vor 1 TagFrageGrafikkarten & Monitore7 Kommentare

Guten Abend ! ich bin auf der Suche nach einer Monitorhalterung, im besten Fall ohne Bohrung für einen 28" Monitor (Vesa Halterung). Nun kommt ...

SAN, NAS, DAS
Synology DS213j - Volume nach HDD Austausch vergrößern
gelöst JasperBeardleyVor 1 TagFrageSAN, NAS, DAS4 Kommentare

Moin, ich hab meinem NAS zwei neue 8TB spendiert, da die 3TB Platten jetzt 6 Jahre alt sind. Da die beiden Platten im JBOD ...