MSI über Gruppenrichtlinien fehlgeschlagen da Netzlaufwerk noch nicht verbunden.

Mitglied: Machete

Machete (Level 1) - Jetzt verbinden

18.07.2011 um 01:08 Uhr, 5619 Aufrufe, 8 Kommentare

Hallo Zusammen,

Bin im Thema Server noch recht neu und hätte da mal eine Frage zur Verteilung von Software über die Gruppenrichtlinien.

Es geht um eine Software, welche ein zentrales Verzeichnis auf dem Server nutzt.
Server: Win 2003 als auch Win 2008.
Clients: XP, Vista und Win 7.

Die Rechner auf welche die Software verteil werden, sind entsprechend die Clients.
Das Zentrale Verzeichnis wird über ein Laufwerks mapping verbunden.

Wenn nun das Setup/MSI verteilt wird, bricht die Installation ab, da vor der Win Useranmeldung das Laufwerk noch nicht verbunden ist.

Die Software hat eine Abfrage drin, ob das gemappte Laufwerk vorhanden ist.

Hat jemand eine Idee wie ich das Ganze hinbekommen könnte?

Vielen Dank schon mal im voraus.

Gruß Machete
Mitglied: breppe
18.07.2011 um 07:08 Uhr
Hallo,

schau dir mal folgende GPO an:
Computerconfg -> Richtlinien -> Admin. Vorlagen -> System -> anmelden -> Bei neustart immer auf Netzwerk warten (so, oder so ähnlich)

Gruß
Bitte warten ..
Mitglied: Xboxer
18.07.2011 um 07:12 Uhr
Hi,

das mit der Abfrage wird immer fehlschlagen, da das Loginscript erst mit der Benutzeranmeldung ausgeführt wird.

Warum nutzt du keine UNC Pfade?

Gruß
Christoph
Bitte warten ..
Mitglied: Machete
18.07.2011 um 07:35 Uhr
Hallo Christoph,

es wird nur ein Verzeichnis gepflegt und dann auf die anderen Server geklont.
In manchen Dateien ist der Pfad hinterlegt, d.h. wenn nun die Clients auf einen anderen Server zugreifen würden
Sie die richtigen Dateien nicht mehr finden da es sich um einen anderen UNC Pfad handelt.

Es kann schon mal vorkommen das bis zu 30 Server im Einsatz sind, diese alle einzeln zu Pflegen wäre zu zeitaufwendig.

@breppe: Werde ich mal nach schauen.

Gruß
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 07:42 Uhr
Moin,

welchen Sinn hat das denn, dass die Software über mehrere Server verteilt werden?

Eigentlich braucht man nur einen und da liegt die Software.

Bei der GPO wird dann die Software aus dem Ordner :

\\Servername\Install

eingetragen und gut ist.
Da braucht man keine Laufwerkmappings - eh sinnlos, weil warum sollen die User auf dieses Verzeichnis direkten Zugriff haben?
Überflüssig und lästig und verwirrend.

VG
Bitte warten ..
Mitglied: tikayevent
18.07.2011 um 09:01 Uhr
Ich lege saemtliche msi-Pakete die per GPO verteilt werden sollen in den SYSVOL-Ordner. Dadrauf haben normale Benuter nur Leserechte, aber die Computer koennen auch vor der Anmeldung darauf zugreifen. Ebenfalls wird das Verzeichnis zwischen allen Domaenencontrollern repliziert. In die GPO haenge ich das msi-Paket dann mit dem DFS-Pfad ein, also \\domaene.local\sysvol\scripts\...
Bitte warten ..
Mitglied: 101238
101238 (Level 1)
18.07.2011 um 19:27 Uhr
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000 war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige Ansatz.

Viel Glück
Bitte warten ..
Mitglied: Xaero1982
18.07.2011 um 19:30 Uhr
Zitat von @101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück

Diese Richtlinie ist nicht relevant, wenn man die Software per UNC Pfad angibt wie ich es oben schrieb.

VG
Bitte warten ..
Mitglied: Machete
18.07.2011 um 22:30 Uhr
Zitat von @101238:
hallo,

ich schließe mich "breppe" an, win xp, win7 und vista verbinden erst das Netzwerk nach der Anmeldung. Bei Win2000
war das noch anders.

Ich habe die Einstellungen für die Clients in den GPO verändert, so das erst Netzwerk verbunden wird und dann die
Benutzeranmeldung kommt. Starten dauert etwas länger aber es funktioniert. Und die Software wird vor der Benutzeranmeldung
installiert. Den genauen Ort für die Einstellungen habe ich im Moment nicht auf der Pfanne, aber das ist der richtige
Ansatz.

Viel Glück



So etwas habe ich bei Herrn Google auch gefunden und es geht nun endlich.

Es werden mehrere Server benötigt, da diese in unterschiedlichen Filialen zum Einsatz kommen.
Die eigentliche Pflege soll aber nur aus einer Filiale heraus stattfinden.

Deshalb keine Installation über UNC Pfad möglich.

Vielen Dank,
Gruß Machete
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
PDF automatisch auf zwei Drucker aufteilen
hannes.pVor 1 TagFrageWindows 109 Kommentare

Hallo zusammen, ich suche verzweifelt nach einer Möglichkeit, ein von einer Web-Anwendung generiertes PDF automatisch auf zwei Drucker drucken zu lassen. Das PDF Dokument ...

Microsoft
Erwerb von M365 Lizenzen, Partner Autorisierung für Azure AD - Globaler Administrator wirklich nötig?
NidavellirVor 1 TagFrageMicrosoft4 Kommentare

Hi zusammen, bitte entschuldigt den etwas sperrigen Titel, aber ein knapperer wollte mir nicht einfallen. :D Wir wollen bei einem Systemhaus M365 Lizenzen (Business ...

Windows 10
Sperrbildschirm nach 5 min
ZeppelinVor 1 TagFrageWindows 1012 Kommentare

Hallo zusammen, ich wende mich mit meinem anliegen an euch weil ich mit meinen Möglichkeiten am Ende bin. Wenn innerhalb von 5 min. keine ...

Speicherkarten
Welchen USB Stick für Bootstick?
gelöst dlnkrgVor 1 TagFrageSpeicherkarten6 Kommentare

Hallo, Ich bin auf der Suche nach USB - Sticks, auf denen ich Linux Ubuntu installieren kann und praktisch als Festplatte für das Betriebssystem ...

Off Topic
BKA und der Bundestrojaner
brammerVor 1 TagInformationOff Topic3 Kommentare

Hallo, habe kurz überlegt ob das unter Off Topic allgemein oder Off Topic LOL gehört brammer

Windows Netzwerk
Sporadisch kein Netz auf mehreren Win10-Maschinen
SolarflareVor 22 StundenFrageWindows Netzwerk6 Kommentare

Hallo, ich habe seit Monaten einen eigenartigen Effekt in unserem Windows-Netz. Windows-Domäne mit ca. 100 Maschinen, alle Clients aktuelles Windows 10. Die Maschinen hängen ...

Sicherheit
Emails als Nur Text
Jessica98Vor 1 TagFrageSicherheit4 Kommentare

Hallo zusammen, macht es Sinn E-Mails als nur Text einzustellen, um sich vor schädlichen HTML-Code zu schützen? Meines Erachtens wird ein Benutzer diese Email ...

Windows 7
Userpfad Problem nach Aenderung des Computernamens
BernerVor 1 TagFrageWindows 78 Kommentare

In einem Netzwerk von 9 PCs sind 9 Ersatz-PCs eingebunden, bei denen im Bedarfsfall vor dem Einsatz nur der Computername und die IP-Adresse angepasst ...