Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme mitdem Zugriff auf Software die auf dem Server installiert ist

Mitglied: KRApollo

KRApollo (Level 1) - Jetzt verbinden

15.05.2019 um 11:59 Uhr, 569 Aufrufe, 22 Kommentare, 3 Danke

Hallo zusammen,

ich bin erst seit kurzem der Admin und habe von meinem Vorgänger ein IT-Chaos vererbt bekommen.

Folgendes Problem bereitet mir am meisten Kopfzerbrechen:

Wir benutzen 2 Programme die jeweils auf dem Server installiert sind.
Diese beiden Programme haben separate Shares auf dem Server auf die die Benutzer per Freigabe Zugriff haben.

Nach dem ich allen PCs einheitliche hostnames verpasst habe und auch die Benutzer alle einheitliche Namen haben, kommt es völlig sporadisch zu dem Problem, dass die Programme die von den Clients aufgerufen werden keine Verbindung zu ihrer Datenbank auf dem Server bekommen oder diese im Laufenden Betrieb verlieren.

Alle Rechner haben feste IPs im Netzwerk, blöd ist nur dass es sich um Windows 10 Home Rechner handelt, aber da bin ich dran das zu ändern.
Ebenfalls "bescheiden" ist, dass drei von 8 PCs über WLAN im Netzwerk sind.

Beim Server handelt es sich um Windows Server 2016. Alle PCs sind als Computer in der Server AD existent, alle Benutzer ebenfalls als User in der AD.
Ich weiß - mit Windows 10 Home funktioniert die Domänengeschichte nicht.

Wenn ich jetzt auf einem Client das genannte Problem hab, deaktiviere ich kurz die Netzwerkverbindung und aktiviere sie wieder, warte ein paar Sekunden und das Problem ist behoben.
Kann mir jemand erklären wo hier der Hase im Pfeffer liegt? Ich vermute entweder Benutzerrechte auf die Freigaben oder irgendein DNS-Problem.

Bevor ich die hostnames und Benutzernamen geändert hab lief alles wohl ohne Probleme
Mitglied: Kraemer
15.05.2019 um 12:09 Uhr
Moin,
Zitat von KRApollo:
blöd ist nur dass es sich um Windows 10 Home Rechner handelt
...
Alle PCs sind als Computer in der Server AD existent,
wie hast'de denn das gemacht?

Gruß
Bitte warten ..
Mitglied: chgorges
15.05.2019 um 12:13 Uhr
Zitat von KRApollo:

Hallo zusammen,
Hi,
ich bin erst seit kurzem der Admin und habe von meinem Vorgänger ein IT-Chaos vererbt bekommen.
Wie immer
Bevor ich die hostnames und Benutzernamen geändert hab lief alles wohl ohne Probleme
Dann war dein Redesign-Konzept schlecht, bzw. nicht bis zum Ende durchdacht (Was passiert wenn...)

Ohne nähere Infos zu haben: Schau dir die Skripte an, mit denen die Shares auf den Clients verbunden werden. Ohne richtige Domänenintegration der Clients, was du ja auf Grund von Windows 10 Home nicht machen kannst, ist DNS nur bedingt einsatzfähig. Dementsprechend empfehl ich, hier nur IP-Adressen einzusetzen.

Dann gehst du turnschuhmäßig hin und schaltest auf allen Windows 10 Geräten den Hiberboot aus (was bei dir per GPO ja nicht möglich ist).

Danach nimmst du dir den (hoffentlich installierten) DHCP-Server auf dem 2016er Knecht vor, konfigurierst den korrekt durch und nimmst allen Clients die statischen IP-Adressen weg.

Das als Anfang.
Bitte warten ..
Mitglied: chgorges
15.05.2019 um 12:14 Uhr
Zitat von Kraemer:

Moin,
Zitat von KRApollo:
blöd ist nur dass es sich um Windows 10 Home Rechner handelt
...
Alle PCs sind als Computer in der Server AD existent,
wie hast'de denn das gemacht?

Gruß

Wahrscheinlich die Computerkonten manuell angelegt, was hier halt fürn Allerwertesten und ohne Funktion ist :D
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 12:19 Uhr
Zitat von Kraemer:

Moin,
Zitat von KRApollo:
blöd ist nur dass es sich um Windows 10 Home Rechner handelt
...
Alle PCs sind als Computer in der Server AD existent,
wie hast'de denn das gemacht?

Gruß

Ich nix, war alles schon da und ich versuch das Chaos zu beherrschen Ich kann leider nicht bei 0 anfangen, weil es hier keine Unterbrechung geben darf.
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 12:23 Uhr
Zitat von chgorges:

Zitat von KRApollo:

Hallo zusammen,
Hi,
ich bin erst seit kurzem der Admin und habe von meinem Vorgänger ein IT-Chaos vererbt bekommen.
Wie immer
Bevor ich die hostnames und Benutzernamen geändert hab lief alles wohl ohne Probleme
Dann war dein Redesign-Konzept schlecht, bzw. nicht bis zum Ende durchdacht (Was passiert wenn...)

Es passiert ja nicht auf allen Clients, das ist ja das was ich nicht verstehe....

Ohne nähere Infos zu haben: Schau dir die Skripte an, mit denen die Shares auf den Clients verbunden werden. Ohne richtige Domänenintegration der Clients, was du ja auf Grund von Windows 10 Home nicht machen kannst, ist DNS nur bedingt einsatzfähig. Dementsprechend empfehl ich, hier nur IP-Adressen einzusetzen.

Dann gehst du turnschuhmäßig hin und schaltest auf allen Windows 10 Geräten den Hiberboot aus (was bei dir per GPO ja nicht möglich ist).

Ok, das sollte dann was bewirken?
Die Option dass die Netzwerkkarte zum Stromsparen abgeschaltet werden darf hab ich schon bei allen deaktiviert.

Danach nimmst du dir den (hoffentlich installierten) DHCP-Server auf dem 2016er Knecht vor, konfigurierst den korrekt durch und nimmst allen Clients die statischen IP-Adressen weg.

DHCP ist installiert Mit automatisch zugewiesenen IPs hab ich es schon probiert, leider keine Veränderung.

Das als Anfang.
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 12:24 Uhr
Zitat von chgorges:

Zitat von Kraemer:

Moin,
Zitat von KRApollo:
blöd ist nur dass es sich um Windows 10 Home Rechner handelt
...
Alle PCs sind als Computer in der Server AD existent,
wie hast'de denn das gemacht?

Gruß

Wahrscheinlich die Computerkonten manuell angelegt, was hier halt fürn Allerwertesten und ohne Funktion ist :D

Wie gesagt, war schon so und in der Freigabe standen alle Benutzer drin.
Bitte warten ..
Mitglied: St-Andreas
15.05.2019, aktualisiert um 12:34 Uhr
Hallo,

was sagen denn die Logfiles der beteiligten Komponenten vor, während und nach der Störung?

Warum sind die Computer und Benutzernamen geändert worden?

Sind die Computernamen und/oder Benutzernamen in irgendeinerweise in den genutzen Programmen/Datenbanken verdrahtet?

Wenn es vorher problemlos lief und jetzt nicht mehr, dann scheint das Chaos ja größer, nicht kleiner geworden zu sein.
Bitte warten ..
Mitglied: Archeon
15.05.2019 um 12:58 Uhr
Mahlzeit,

wie werden denn deine Laufwerke verbunden?
Hast du mal einen generellen Netzwerkstresstest gemacht, nicht das du Ausfälle unter Last hast?
Ist im Moment des "Ausfalls" im Netz alles problemlos erreichbar und nur die Freigaben sind weg?

Gruß
Bitte warten ..
Mitglied: goscho
15.05.2019 um 13:01 Uhr
Mahlzeit,

Zitat von KRApollo:

Beim Server handelt es sich um Windows Server 2016. Alle PCs sind als Computer in der Server AD existent, alle Benutzer ebenfalls als User in der AD.
Ich weiß - mit Windows 10 Home funktioniert die Domänengeschichte nicht.

Wenn ich jetzt auf einem Client das genannte Problem hab, deaktiviere ich kurz die Netzwerkverbindung und aktiviere sie wieder, warte ein paar Sekunden und das Problem ist behoben.
Kann mir jemand erklären wo hier der Hase im Pfeffer liegt? Ich vermute entweder Benutzerrechte auf die Freigaben oder irgendein DNS-Problem.

Bevor ich die hostnames und Benutzernamen geändert hab lief alles wohl ohne Probleme
Ich würde die dann ja glatt mal zurückändern.

Was heißt eigentlich vereinheitlicht?
Haben die PCs jetzt aber nicht alle den selben Namen?

Ansonsten mache folgendes:

Windows 10 Pro Upgrade
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 13:20 Uhr
Die Computer- und Benutzernamen waren alle wild durcheinander, einer hieß Asus, der andere Desktop, usw. genau wie die Benutzernamen völlig ohne Struktur. Nein, natürlich haben die PCs jetzt nicht alle unterschiedliche Namen. Die PCs sind jetzt durchnummeriert "PC-XX-01", usw. und die Benutzernamen "Vorname.Nachname".

Netzt ist völlig stabil, die Freigaben verschwinden auch nicht während der Probleme. Im Explorer sind sie völlig normal sichtbar und der Zugriff klappt auch. Es wird nur scheinbar der Pfad zu den files der Software anscheinend nicht gefunden.

Nach kurzer Trennung der Netzwerkverbindung klappt es wieder. Neustart hilft auch.

Wenn ich die wieder zurück ändere hab ich nichts gewonnen und bekomme niemals eine Struktur rein.

Die Laufwerke sind SMB Freigaben, dafür sind auf dem Server in der AD die Benutzer angelegt mit separatem Passwort (anders als das PW zum Anmelden am PC), was ich eingeben muss wenn ich mich zu den Shares verbinden will vom jeweiligen PC aus. Das funktioniert ja auch wunderbar, nur die Software hat eben ab und zu die Probleme die DB zu finden.
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 13:24 Uhr
Zitat von goscho:

Ansonsten mache folgendes:

Windows 10 Pro Upgrade


Das ist auf jeden Fall der Plan, ich hoffe dann wird alles etwas einfacher
Bitte warten ..
Mitglied: chgorges
15.05.2019 um 14:14 Uhr
Dann gehst du turnschuhmäßig hin und schaltest auf allen Windows 10 Geräten den Hiberboot aus (was bei dir per GPO ja nicht möglich ist).

Ok, das sollte dann was bewirken?
Die Option dass die Netzwerkkarte zum Stromsparen abgeschaltet werden darf hab ich schon bei allen deaktiviert.

Das solltest du als Windows 10 Admin nicht wirklich fragen, sondern wissen, was dahinter steckt und dass es im Corporate nichts zu suchen hat. Und nein, es hat absolut nichts mit der Energiespareinstellungen der Netzwerkkarten zu tun.

Was sind das denn für Programme? S-Firm, Proficash?

Host- und Username-Änderung sollten vorrangig derartige Programme nicht aus der Spur werfen. Nachrangig ist immer einiges möglich, schätze aber, dass in der Infrastruktur mehr im Argen ist.
Bitte warten ..
Mitglied: KRApollo
15.05.2019 um 14:26 Uhr
Zitat von chgorges:

Ok, das sollte dann was bewirken?
Die Option dass die Netzwerkkarte zum Stromsparen abgeschaltet werden darf hab ich schon bei allen deaktiviert.

Das solltest du als Windows 10 Admin nicht wirklich fragen, sondern wissen, was dahinter steckt und dass es im Corporate nichts zu suchen hat. Und nein, es hat absolut nichts mit der Energiespareinstellungen der Netzwerkkarten zu tun.

Ich weiß schon was dahinter steckt, kann mir nur nicht vorstellen dass das mein Problem löst, weil ich die Ursache irgendwo bei mir sehe und eine falsche Einstellung irgendwo gemacht hab.

Was sind das denn für Programme? S-Firm, Proficash?

ADDISON und DATAflor

Host- und Username-Änderung sollten vorrangig derartige Programme nicht aus der Spur werfen. Nachrangig ist immer einiges möglich, schätze aber, dass in der Infrastruktur mehr im Argen ist.

Da geb ich dir völlig Recht und ich versuche mich so gut es geht durchzufinden.
Bitte warten ..
Mitglied: Kraemer
15.05.2019 um 14:32 Uhr
Zitat von chgorges:
Wahrscheinlich die Computerkonten manuell angelegt, was hier halt fürn Allerwertesten und ohne Funktion ist :D
auch ohne Fehlfunktion?
Bitte warten ..
Mitglied: Kraemer
15.05.2019 um 14:33 Uhr
Zitat von KRApollo:
ADDISON und DATAflor
zumindest ersteres hat keine für Windows 10 HOME

Zitat von KRApollo:
Ebenfalls "bescheiden" ist, dass drei von 8 PCs über WLAN im Netzwerk sind.
die Rechner, die Probleme machen sind nicht zufällig die, die per Wlan im Netz hängen?
Bitte warten ..
Mitglied: KRApollo
15.05.2019, aktualisiert um 15:49 Uhr
Zitat von Kraemer:

Zitat von KRApollo:
ADDISON und DATAflor
zumindest ersteres hat keine für Windows 10 HOME

Was meinst du mit "...hat keine für Windows 10 HOME" ?


Zitat von KRApollo:
Ebenfalls "bescheiden" ist, dass drei von 8 PCs über WLAN im Netzwerk sind.
die Rechner, die Probleme machen sind nicht zufällig die, die per Wlan im Netz hängen?

Richtig, die machen die meisten Probleme, aber die anderen auch. Ich versteh halt nicht warum eine kurze Deaktivierung des Netzweradapters das Problem löst...??? Das kann doch nichts mit Zugriffsrechten zu tun haben.
Bitte warten ..
Mitglied: Kraemer
15.05.2019 um 15:55 Uhr
Zitat von KRApollo:

Zitat von Kraemer:

Zitat von KRApollo:
ADDISON und DATAflor
zumindest ersteres hat keine für Windows 10 HOME

Was meinst du mit "...hat keine für Windows 10 HOME" ?
Freigabe


Zitat von KRApollo:
Ebenfalls "bescheiden" ist, dass drei von 8 PCs über WLAN im Netzwerk sind.
die Rechner, die Probleme machen sind nicht zufällig die, die per Wlan im Netz hängen?

Richtig, die machen die meisten Probleme, aber die anderen auch. Ich versteh halt nicht warum eine kurze Deaktivierung des Netzweradapters das Problem löst...??? Das kann doch nichts mit Zugriffsrechten zu tun haben.
Bei den Clients mit Wlan wirst du wahrscheinlich mit den Problemen leben müssen
Wenn aber auch fest verkabelte Rechner machen, stimmt sehr wahrscheinlich was im Netz nicht. DNS, Switch, etc. etc.
Einfach mal alles kontrollieren - Stück für Stück

PS: Beim AD würde ich anfangen
Bitte warten ..
Mitglied: chgorges
15.05.2019 um 16:01 Uhr
Beim Dataflor habe ich Wiki ein paar Aussagen gefunden, dass u.A. der Replikationsmodus mit WLAN-Clients nicht unterstützt wird. Evtl. stehen da auch noch mehr wichtige Sachen drin.
Bitte warten ..
Mitglied: KRApollo
17.05.2019 um 07:13 Uhr
Zitat von Kraemer:

Bei den Clients mit Wlan wirst du wahrscheinlich mit den Problemen leben müssen
Wenn aber auch fest verkabelte Rechner machen, stimmt sehr wahrscheinlich was im Netz nicht. DNS, Switch, etc. etc.
Einfach mal alles kontrollieren - Stück für Stück

PS: Beim AD würde ich anfangen

Das Abschalten des Hyperboot Modus hat jedenfalls nichts gebracht. Jeden Tag wenn ich die Clients einschalte das gleiche Problem wieder. Netzwerkadapter kurz deaktivieren und es funktioniert. In der AD scheint von den Berechtigungen her alles in Ordnung zu sein. Irgendwas stimmt in den DNS-Einstellungen nicht denke ich. Ich werd mal schauen ob ich mir ein altes Backup virtualisieren kann und mal die Einstellungen vergleichen.
Bitte warten ..
Mitglied: Dani
18.05.2019 um 16:40 Uhr
Moin,
Jeden Tag wenn ich die Clients einschalte das gleiche Problem wieder. Netzwerkadapter kurz deaktivieren und es funktioniert.
irgendwie geistert in meinem Kopf etwas wie dopplte IP-Adressen herum. Denn dadurch wird auf dem Switch die MAC-Adresse neu registiert.

Wenn das Problem wieder auftritt, schau mal auf dem Switch bzw. Server ob MAC-Adresse zu IP-Adresse passt. Parallel dazu vom Server einmal die IP-Adresse des Clients versuchen anzupingen. Geht das?


Gruß,
Dani
Bitte warten ..
Mitglied: KRApollo
21.05.2019, aktualisiert um 09:14 Uhr
Zitat von Dani:

Moin,
Jeden Tag wenn ich die Clients einschalte das gleiche Problem wieder. Netzwerkadapter kurz deaktivieren und es funktioniert.
irgendwie geistert in meinem Kopf etwas wie dopplte IP-Adressen herum. Denn dadurch wird auf dem Switch die MAC-Adresse neu registiert.

Wenn das Problem wieder auftritt, schau mal auf dem Switch bzw. Server ob MAC-Adresse zu IP-Adresse passt. Parallel dazu vom Server einmal die IP-Adresse des Clients versuchen anzupingen. Geht das?


Gruß,
Dani

Moin,

welche Adressen meinst du ob MAC zu IP passt? Die vom Server oder die eines Clients?
Bitte warten ..
Mitglied: Dani
21.05.2019 um 10:04 Uhr
Moin,
von den Clients, welche Probleme haben.


Gruß,
Dani
Bitte warten ..
Ähnliche Inhalte
Windows Server
Problem Zugriff Administrative Zugriffe
gelöst Frage von SyncmastaWindows Server3 Kommentare

Hallo zusammen, ich habe folgendes Szenario: Wir betreiben einen Windows 2003 Server in einer Domäne. (Ja, ich weiß ist ...

Windows Server
GPO Problem - Zugriff nicht möglich
gelöst Frage von WeigmannWindows Server4 Kommentare

Hallo, ich habe eine Frage bezüglich GPO's bei der ich schon seit 2 Tagen auf dem Schlauch stehe. Problem: ...

Windows 10

Freigabe Problem direkter Zugriff auf IPadress

Frage von fabio84Windows 103 Kommentare

Hey Jungs sehr stranges Problem Ausgangssituation: keine Domäne, -> nur Workgroup 2 Pcs im Netzwerk (2x win10) Ziel Zugriff ...

Windows Update

Werden gerade Updates installiert?

gelöst Frage von BinisidumWindows Update6 Kommentare

Hallo, gibt es eine zuverlässige Möglichkeit festzustellen, ob auf einem Windows PC gerade Microsoft Updates installiert werden? Einen Registryeintrag, ...

Neue Wissensbeiträge
Off Topic
Europawahl 2019
Information von Frank vor 23 StundenOff Topic23 Kommentare

Vom 23. bis 26. Mai 2019 findet die Europawahl in den Mitgliedstaaten der Europäischen Union statt (ja auch in ...

Humor (lol)

Minister wollen offenbar Ausweispflicht für .de-Domain

Information von Kraemer vor 1 TagHumor (lol)7 Kommentare

Zitat von Golem.de: Die zuständigen Verbraucherschutzminister fordern einem Medienbericht zufolge offenbar eine Ausweispflicht für .de-Domains. Das soll Betrugsfälle mit ...

Off Topic
Was als Noob hier mal gesagt werden musste
Information von th30ther vor 3 TagenOff Topic5 Kommentare

Moinsen wertes Forum, ich möchte mich an dieser Stelle mal beim Forum generell und bei aqui speziell bedanken! Ich ...

Windows 10
Windows 10 Mai 2019 Update (Version 1903) ist da
Information von kgborn vor 3 TagenWindows 109 Kommentare

Nur ein kurzer Infosplitter: Microsoft hat die Nacht (21. Mai 2019) das Funktionsupdate auf Windows 10 Version 1903 freigegeben. ...

Heiß diskutierte Inhalte
Ausbildung
Wie sind eure Erfahrungen als oder mit Ü30 Azubis für Fachinformatik Systemintegration?
Frage von CaptainProcessorAusbildung26 Kommentare

Tagchen allerseits :) Mir steht in wenigen Monaten eine Veränderung bevor, da mein AG seine IT auslagert und ich ...

Off Topic
Europawahl 2019
Information von FrankOff Topic23 Kommentare

Vom 23. bis 26. Mai 2019 findet die Europawahl in den Mitgliedstaaten der Europäischen Union statt (ja auch in ...

Router & Routing
ZyXEL ZyWALL USG 20 Routing
Frage von Oggy01Router & Routing12 Kommentare

Hallo, und wieder habe ich ein Problem mit dem Routing. Bis vor ein paar Tagen habe ich das mit ...

Virtualisierung
VServer (Linux): Absichern, verschlüsseln usw
Frage von mrserious73Virtualisierung11 Kommentare

Hallo zusammen, ich möchte einen Linux-Vserver mieten und diesen absichern. Darunter verstehe ich in diesem Falle hauptsächlich: Dafür sorgen, ...