Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Raspberry Pi 3 mit Raspbian Netzwerk Startup Problem

Mitglied: Avaatar

Avaatar (Level 1) - Jetzt verbinden

25.04.2018 um 11:24 Uhr, 1871 Aufrufe, 15 Kommentare

Hallo zusammen,

ich habe seit Montag (da habe ich es entdeckt) mit einem meiner Raspberry Pi 3 ein seltsames Phänomen wo ich nicht weiterkomme und hoffe dass jemand Rat weiß.
Am Montag habe ich meinen Internetzugang mit der Connectbox bei Unitymedia erhalten. Daraufhin fiel mir auf dass ich einen meiner Raspberry Pis mit SSH etc. nicht
mehr erreiche. Als ich an das Gerät einen Monitor anschloss und es neu startete fiel mir auf dass beim Startup steht "My Ip Address: ipv6-Zeichenfolge". Er zeige dort
also eine IPV6 an. Gleichzeitig fielen auch Mount per fstab auf Netzwerklaufwerke und der Start des SSH Servers auf die Nase.
Das Gerät hat eine statische IP (dhcpcd.conf, 192.168.0.27) zugewiesen. Bisher lief alles ohne Probleme also verdächtigte ich spontan UM mit dem DS-Lite Zeug.
Bei näherer Untersuchung fiel mir auf dass die eth0 beim Hochfahren des Geräts keine IPV4 Adresse bekam, daher zeigte das Gerät auch die IPV6 an.
Die dhcpcd.conf wurde von mir nicht geändert. Wenn ich dann auf der Konsole das Netzwerk einmal per service networking restart neu starte hat eth0 auf einmal die
korrekte IPV4 Adresse. Ich kann dann SSH per Hand starten und auch das Netzlaufwerk mounten.
Beim Starten von Raspbian (aktueller Patchstand) wird also beim Hochfahren die IPV4 Adresse nicht zugewiesen. Ich habe testweise mal IPV6 deaktiviert, keine
Verbesserung. Starte ich das Netzwerk dann einmal einfach neu klappt es.
In den Logfiles finde ich auch nichts ungewöhnliches (vielleicht habe ich auch in die falschen geguckt).
Hat jemand von euch dieses Problem mal gesehen und weiß Rat?

Viele Grüße.
Mitglied: Pjordorf
25.04.2018, aktualisiert um 11:33 Uhr
Hallo,

Zitat von Avaatar:
Das Gerät hat eine statische IP (dhcpcd.conf, 192.168.0.27) zugewiesen.
Also so z.B. https://www.raspberrypi.org/learning/networking-lessons/rpi-static-ip-ad ...

Beim Starten von Raspbian (aktueller Patchstand) wird also beim Hochfahren die IPV4 Adresse nicht zugewiesen.
Auch keine IPv6?
SwitchPort und/oder Einstellungen defekt?
LANPort am Raspi defekt?
Anstelle direkt an der ConnectBox einen Switch nutzen?

Gruß,
Peter
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 11:40 Uhr
Hallo Pjorsdorf,

vielen Dank für die schnelle Antwort.
Die dhcpcd.conf passt, auch lt. Deinem Link.
Beim Hochfahren kriegt eth0 eine IPV6 Adresse zugewiesen, das ist das Skurrile dabei.
Wenn ich das LAN Kabel getrennt lasse kriegt eth0 gar nichts, ich habe es mal als Gegentest geprüft
ob vielleicht die IPV6 Adresse von UM irgendwie stört.
Es klappt also nur ipv4 beim Hochfahren nicht, wenn man dann wie gesagt auf der Konsole Networking neu startet klappt alles.


Viele Grüße.
Bitte warten ..
Mitglied: Pjordorf
25.04.2018, aktualisiert um 11:51 Uhr
Hallo,

Zitat von Avaatar:
Beim Hochfahren kriegt eth0 eine IPV6 Adresse zugewiesen, das ist das Skurrile dabei.
Nö, hängt alles von deiner Konfiguration(en) und Hardware ab.

Wenn ich das LAN Kabel getrennt lasse kriegt eth0 gar nichts, ich habe es mal als Gegentest geprüft
Was das zu erwartende Verhalten ist.

ob vielleicht die IPV6 Adresse von UM irgendwie stört.
Ist es denn eine FE80::/10? Das wäre eine Link-Local.

Es klappt also nur ipv4 beim Hochfahren nicht
Einstellungen am LANPort passen?
Einstellungen an SwitchPort passen?
Einen Switch anstelle deiner ConnectBox mal genommen und dazwischen gehangen?

https://en.wikipedia.org/wiki/Link-local_address
https://www.cisco.com/c/en/us/support/docs/ip/ip-version-6-ipv6/113328-i ...

Gruß,
Peter
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 11:56 Uhr
Hi Peter,

es werden sogar 2 IPV6 Adressen zugewiesen, eine fe80 wie von Dir vermutet und eine von Unitymedia, 2a02:908:d20...........
Der Raspberry hängt an einem kleinen TP-Link Switch, nicht an der Connectbox direkt. Der Switch ist nicht konfiguriert.
eth0 ist auch definitiv up, es hat eben nur keine ipv4 Konfig. Wenn eth0 wenigstens komplett down wäre, das wäre einfacher.

Viele Grüße.
Bitte warten ..
Mitglied: ashnod
25.04.2018 um 12:12 Uhr
Moin ...

Zitat von Avaatar:
> Das Gerät hat eine statische IP (dhcpcd.conf, 192.168.0.27) zugewiesen. Bisher lief alles ohne Probleme also verdächtigte ich spontan UM mit dem DS-Lite Zeug.


In welchem Netz befindest du dich denn mit deiner Connext Box (192.168.0.0 ?) und von wo/wem wird die "statische dhcp" Adresse für den PI zugewiesen?.

Happy Day
Bitte warten ..
Mitglied: Pjordorf
LÖSUNG 25.04.2018 um 12:16 Uhr
Hallo,

Zitat von Avaatar:
es werden sogar 2 IPV6 Adressen zugewiesen
Klar.

Wenn es seit dem du deine neue ConnectBox hast, dann schalte doch IPv6 am Raspi ab, sofern du kein IPv6 nutzt. Vermutlich hat dein vorheriger Router mit IPv6 nichts am Hut gehabt. Oder du beschäftigst dich mit IPv6 und seine Spielarten und lernst das es NAT bei IPv6 nicht gibt. Jedes Gerät ist per IPv6 immer erreichbar, auch von ausserhalb deines LANS, ausser du verhinderst es.

https://www.leowkahman.com/2016/03/19/disable-ipv6-raspberry-raspbian/
https://www.raspberrypi.org/forums/viewtopic.php?t=138899
https://raspberrypi.stackexchange.com/questions/23884/force-ipv4-address
http://no-sheds.blogspot.de/2017/05/disabling-ipv6-on-raspberry-pi.html

https://community.spiceworks.com/topic/1986162-prefer-ipv4-over-ipv6
http://forevercached.syphzero.net/2012/09/preferring-ipv4-over-ipv6.htm ...
https://askubuntu.com/questions/32298/prefer-a-ipv4-dns-lookups-before-a ...

Gruß,
Peter
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 12:21 Uhr
Hallo Ashnod,

die Connectbox steht im Netz 192.168.0.0 und hat die IP 192.168.0.1. Das lässt sich auch nicht umbauen, das ist meine nächste Baustelle
da ich meine OPNSense nicht nutzen kann aktuell, aber ist ein anderes Thema. Werde sie wohl in den Transparent Bridging Mode setzen
müssen aber wie gesagt anderes Thema.
Die statische IP ist direkt in der dhcpcd.conf eingetragen, wird also nicht von extern zugewiesen.

Viele Grüße.
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 12:27 Uhr
Hi Peter,

ich habe IPV6 auch jetzt erst mal abgeschaltet. Mit IPV6 werde ich mich auf jeden Fall beschäftigen müssen, ich glaube auf IPV4 zurückzufallen
ist nur eine Lösung für den Moment für mich.
Sehr spannend:
Nachdem ich IPV6 komplett deaktiviert habe klappt die IPV4 Zuweisung anscheinend auch wieder.
Ich hatte als Mogellösung schon in der rc.local ein service networking restart eingetragen, das funktionierte auch, ist aber nicht wirklich elegant um es mal so zu sagen.
Also die Lösung ist: IPV6 komplett zu deaktivieren. Mein Test mit abgezogenem LAN Kabel hat mich nur in die Irre geführt da ich dachte dass wenn keine IPV6 Adresse zugewiesen wird auch kein Konflikt enstehen kann.

Vielen Dank für eure Hilfe und einen schönen Tag noch.
Bitte warten ..
Mitglied: Pjordorf
25.04.2018 um 12:30 Uhr
Hallo,

Zitat von Avaatar:
die Connectbox steht im Netz 192.168.0.0 und hat die IP 192.168.0.1. Das lässt sich auch nicht umbauen, das ist meine nächste Baustelle
Warum lässt sich die nicht ändern?

Die statische IP ist direkt in der dhcpcd.conf eingetragen, wird also nicht von extern zugewiesen.
https://www.elektronik-kompendium.de/sites/raspberry-pi/1912151.htm
https://jankarres.de/2013/09/raspberry-pi-statischefeste-ip-adresse-verg ...
http://www.netzmafia.de/skripten/hardware/RasPi/RasPi_Network.html

Schalte an deiner ConnectBox internes IPv6 ab.

Gruß,
Peter
Bitte warten ..
Mitglied: aqui
25.04.2018, aktualisiert um 13:06 Uhr
Noch besser die gruselige Connect Box durch einen richtigen Router ersetzten statt sich so ein billiges Zwangsteil aufs Auge drücken zu lassen was man nicht muss...
Vermutlich wird man dann damit auch noch mit TR096 ausgeschnüffelt. Da wäre sogar ne Router Kaskade noch besser...
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 13:45 Uhr
Hi Peter,

weil UM das beschnitten hat. Man kann an der Box fast nichts mehr einstellen. Auch in den Modem Modus schalten wurde deaktiviert

Viele Grüße.
Bitte warten ..
Mitglied: Avaatar
25.04.2018 um 13:49 Uhr
Ich wünschte das ginge Aqui, aber die Situation ist kompliziert.
Die ConnectBox in den Modem Modus (Bridge) setzen geht nicht mehr da UM das per Firmware unterbindet.
Setzt man das Gerät auf Werkseinstellungen zurück ist die Option da. Hängt man die CB ans Netz kommt die UM
Firmware und bügelt das alles weg.
Ich habe schon eine Weile gesucht aber es gibt in Deutschland kein frei erhältliches alternatives Modem das auch die
24 Downkanäle wie von UM gefordert bietet. Man kann aus dem Ausland importieren aber ob das dann alles läuft...
Die Fritzbox 6490 kann angeblich in den Bridge Modus, bei den freien wurde das allerdings von AVM rausgepatcht.
Man kann es mit Tricks immer noch aktivieren aber naja.... was bei den von UM gestellten 6490 ist weiß ich nicht, die
Aussagen sind zwiespältig.
Fakt ist, bei UM ist die freie Routerwahl aktuell nicht möglich. Ich habe mich auch bei der Bundesnetzagentur beschwert,
das Ganze ist aber ein anderes Thema.

Viele Grüße.
Bitte warten ..
Mitglied: aqui
26.04.2018 um 16:36 Uhr
Dann belässt du die Connect Box halt und machst eine Router Kaskade also kaskadierst einen "richtigen" Router oder eine Firewall dahinter. Das ist zwar das kleinere Übel klappt ja aber auch und ist allemal besser als mit dieser Gruselbox only arbeiten zu müssen.

Und....was meinst du genau mit "..kommt die UM Firmware und bügelt das alles weg. ?"
Die ist doch sowieso im Flash und wenn du TR069 Autoconfig ausschaltest (was man so oder so IMMER zwingend machen sollte !) macht die Box auch nicht mehr was sie will !

Sich an solchen Provider zu binden der einen so gängelt und entmündigt was seine Datenhoheit anbetrifft ist ja dein Ding und hast du selber zu verantworten.
Mindestens solltest du dich dann aber mit einem System dahinter schützen damit der Provider da nicht auch noch fummeln kann.
Bitte warten ..
Mitglied: Avaatar
29.04.2018 um 18:15 Uhr
Hi Aqui,

auf eine Routerkaskade etc. wird es hinauslaufen.
Ich glaube Du musst Dir mal so eine Connect Box ansehen, das wäre sehr spannend für Dich. TR069 ist gar nicht aktiviert bzw. die Option (auch anderslautend) ist gar nicht vorhanden.
Es läuft so: Die Connectbox geht online und wird anhand ihrer MAC Adresse identifiziert (Zugang). Danach spielt UM die aktuelle Firmware automatisch auf. Das kannst Du nicht blocken oder verhindern oder ähnliches machen.
UM ist nicht mein Wunschprovider, ganz klar. Aber besser als weiter auf 16 Mbit rumzukriechen, da es hier ländlich ist habe ich keine andere Option.
Guck Dir mal eine Connectbox an, ich war auch recht sprachlos wie sehr UM hier einschränkt.

Viele Grüße.
Bitte warten ..
Mitglied: aqui
29.04.2018 um 18:25 Uhr
welches Programm nutzt du für die Veranschaulichung von Netzwerken.
Nee, besser nicht. Bei so einem Provider Schrott kommen einem immer die Tränen. Aber für 98% der Otto Normaluser reicht das ja allemal. Die wissen eh nicht was in so einer Box vor sich geht
TR069 ist gar nicht aktiviert bzw. die Option (auch anderslautend) ist gar nicht vorhanden.
Da täuschst du dich gewaltig ! Die "siehst" es nur nicht. Nur bessere Systeme haben das überhaupt konfigurierbar.
Die anderen haben das alle fest eingebaut ohne das du es merkst, weisst oder ein Chance hast das abzustellen.
Sowie sich Router wie "von Geisterhand" die Anschlusskonfigst inkl. Passowrt ziehen ist TR069 ganz sicher im Spiel.
Was der Provider noch damit macht willst du besser gar nicht wissen !
ich war auch recht sprachlos wie sehr UM hier einschränkt.
Darf ja für den Provider nix kosten. Menschnefreunde sind das nicht die wollen nur dein Bestes...dein Geld und eine langfristige Bindung
Bitte warten ..
Ähnliche Inhalte
CPU, RAM, Mainboards
Raspberry Pi Netzwerk
Frage von noahharCPU, RAM, Mainboards11 Kommentare

Hallo zusammen, mein Raspberry Pi kann sich seit heute nicht mehr mit meinem Netzwerk verbinden. Die LED an der ...

Debian
Nginx + Raspberry Pi 3
gelöst Frage von leasuredevelopingDebian2 Kommentare

Hallo Entwicklerfreunde! Brauche eure Hilfe bei einer Sache. Folgendes: Ich verwende nginx zum ersten Mal. Ich bekomme es soweit ...

Apache Server
Raspberry Pi 3 Owncloud installieren
gelöst Frage von bestelittApache Server4 Kommentare

Hallo zusammen! Ich habe vor mir einen Dropboxersatz zusammenzustellen, also habe ich mir ein RPi3 und eine WD PiDrive ...

Debian
LDAP + Raspberry Pi 3 + MediaWiki
gelöst Frage von leasuredevelopingDebian8 Kommentare

Habe folgendes Problem: Nutze als Server einen Raspberry Pi 3. Die Implementierung von MediaWiki war erfolgreich. Für die Verwaltung ...

Neue Wissensbeiträge
Firewall
Übernahme von SOPHOS durch Thoma Bravo
Information von Dilbert-MD vor 14 StundenFirewall1 Kommentar

Kam die Tage per Newsletter: Zitat: " Das Sophos Board of Directors hat gestern bekanntgegeben, dass die Private-Equity-Investment-Firma Thoma ...

Windows Netzwerk

Ereignis-ID 20226 RasClient Ursachencode 829 VPN Verbindung wird abgebrochen

Anleitung von Hardstyles vor 6 TagenWindows Netzwerk

Hallo zusammen, nach Stundenlanger Analysen und test konnten wir den Fehler Lösen. es geht um folgende Fehler Meldung in ...

Windows 10

Windows 10 Version 1903: Update KB4522015 blockt VMware Workstation

Information von kgborn vor 10 TagenWindows 10

Nur eine kurze Information für Leute, die schon Windows 10 Version 1903 in Betrieb haben und dort VMware Workstation ...

VB for Applications

Fritzbox Telefonbuch - XML-Importdatei aus Excel erstellen

Tipp von PeterleB vor 10 TagenVB for Applications1 Kommentar

Das Thema geistert schon seit Jahren durch verschiedene Foren. Habe mich jetzt mal damit etwas intensiver befasst und hoffe, ...

Heiß diskutierte Inhalte
Switche und Hubs
24 Rasperry PI vernetzen, was nimmt man da?
gelöst Frage von clkdivSwitche und Hubs25 Kommentare

Hallo, ich möchte 24 Raspberries vernetzen. Bis jetzt waren es 4 Stück, ich habe dafür einen cheap-o-cheap Edimax-Hub benutzt, ...

LAN, WAN, Wireless
Hausnetzwerk mit Routern
Frage von perhaps-labs.comLAN, WAN, Wireless22 Kommentare

Hallo an Alle, ich habe ein Riesenhaus erworben und möchte nun überall ein Netzwerk dafür installieren. Das Haus hat ...

E-Mail
Optionen des Mails-Empfangs
Frage von SchauerE-Mail19 Kommentare

Hallo an Alle. ich habe die Aufgabe bekommen zu recherchieren, welche Optionen sich anbieten Mails zu empfangen. Klingt banal, ...

Firewall
Welche Anbieter, Geräte und Programme gelten als sicher?
Frage von NordicMikeFirewall16 Kommentare

Moin zusammen, wenn man sich die vielen Sicherheitslösungungen ansieht, erkenn man nicht, auf was man sich einlassen würde. Man ...