Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Software RAID1 - Ubuntu startet nur von der default hdd

Mitglied: Pixelschubser

Pixelschubser (Level 1) - Jetzt verbinden

01.10.2013 um 22:43 Uhr, 1676 Aufrufe, 4 Kommentare

Ich habe zum Testen meiner zukünftigen RAID-Konfiguration folgendes System in der VM erstellt.

Ubuntu Server 12.04
2x HDD

/
/boot
swap

Die Partitionen laufen dementsprechend in einem RAID1 (keine Spare-Platte). Grub habe ich mit folgenden Befehlen auf beiden Platten installiert:

grub-install /dev/sda
grub-install /dev/sdb

Im laufenden Betrieb kann ich vom System Platten entfernen und hinzufügen. Auch der anschließende Sync funktioniert. Entferne ich jedoch die erste Platte (bei der zweiten habe ich keine Probleme) und starte anschließend mit nur der zweiten Platte im RAID neu, kommt das System nicht mehr hoch. Nach dem BIOS Symbol startet er sofort neu, keine Meldung, nichts. Ich habe die Vermutung, dass grub noch konfiguriert werden muss, hierzu fande ich jedoch nichts.

Was jedoch wieder überhaupt nicht passt. Entferne im im Betrieb die erste Platte und lasse eine neue gleich live syncen, startet das System.

Denkt bitte primitiv =) , ich hatte bis auf die letzten beiden Tagen nichts mit Software-RAIDs am Hut und bin daher total unerfahren.

Grüße
Mitglied: ahuser
02.10.2013 um 00:16 Uhr
Hi,

Eventuell stimmen die Einträge in der grub.cfg nicht, (bsp. /boot/grub2/grub.cfg)
Prüfe mal ob sda oder die UUID der sda in den Menüeinträgen hinterlegt ist, ich glaube alleine mit einem grub-install ist es nicht getan.

Schau mal hier...
http://www.howtoforge.com/software-raid1-grub-boot-debian-etch-p2
http://wiki.ubuntuusers.de/Software-RAID

oder einfach mal googeln, gibt genügend gute Anleitungen die diesesThema behandeln.
https://www.google.de/#q=mdadm+raid1+grub+u

VG und viel Erfolg!
Andreas
Bitte warten ..
Mitglied: Pixelschubser
02.10.2013 um 10:01 Uhr
Die Seiten bin ich schon durchgegangen. Durch die neuere Ubuntu-Version werden einige Konfigurationspunkte bereits bei der Installation abgearbeitet.
Bitte warten ..
Mitglied: Pixelschubser
02.10.2013, aktualisiert um 12:41 Uhr
Also... das scheint kein Konfigurationsfehler sondern eher ein Bug zu sein.

http://forum.ubuntuusers.de/topic/raid-bootet-nicht-einzeln/

Auch andere (wenige) Leute haben dieses Problem. Scheinbar testet vorher keiner seine RAID-Konfiguration (ich habe jetzt drei Tage damit verbracht).

Es wird empfohlen nach einem Crash von einer Live-CD zu starten, die Platten zu syncen und anschließend das ursprüngliche System zu booten. Das soll funktionieren auch wenn mein erster Test fehlgeschlagen ist - hab wahrscheinlich das System vorher totkonfiguriert.

Ich teste das nochmal ausführlich und melde mich noch einmal.
Bitte warten ..
Mitglied: Pixelschubser
02.10.2013 um 15:11 Uhr
Nein läuft nicht. Boote ich von einer Live-Cd ist es endgültig vorbei. Findet kein Boot-Device
Bitte warten ..
Ähnliche Inhalte
Ubuntu
Ubuntu startet nicht mehr
gelöst Frage von CoreknabeUbuntu16 Kommentare

Moin, ich habe in einer HyperV-Umgebung ein Ubuntu 16.04.3 laufen. Plötzlich fährt die VM nicht mehr hoch: Jetzt hocke ...

Ubuntu

Ubuntu 16.04 mit Raid1 - boot und home Partition zusammenführen

gelöst Frage von chris-ynaUbuntu4 Kommentare

Hallo liebe Administratoren Ich habe einen Ubuntu server mit einem Raid1 aus 2 Platten. Es gibt 4 Partitionen: Fdisk ...

Virtualisierung

Virtualbox startet nicht auf Ubuntu 18.04 - Deinstallation

gelöst Frage von wusa88Virtualisierung7 Kommentare

Hallo Zusammen, ich wollte auf einem Ubuntu 18.04, Virtualbox installieren. Habe mich vorerst an diese Anleitung gehalten.: Allerdings war ...

Festplatten, SSD, Raid

Festplatte defekt? Vorübergehend nur eine HDD in RAID1 auf Synology NAS möglich?

gelöst Frage von FlachpfeifeFestplatten, SSD, Raid7 Kommentare

Guten Tag allerseits, heute morgen habe ich festgestellt, das unsere Synology DS216j ein Problem meldet. Eine der beiden Festplatten, ...

Neue Wissensbeiträge
Datenschutz

SiSyPHuS Win10: Analyse der Telemetriekomponenten in Windows 10

Tipp von freesolo vor 2 TagenDatenschutz1 Kommentar

Alle die sich detailliert für die Datensammlung interessieren die unter Windows 10 stattfindet, sollten sich folgende Analyse des BSI ...

Sicherheit
Adminrechte dank Intel-Grafikkarte
Information von DerWoWusste vor 2 TagenSicherheit1 Kommentar

ist das Advisory, welches beschreibt, welche Intel HD Graphics Modelle Sicherheitslücken haben, mit denen sich schwache Nutzer zu Admins ...

Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 3 TagenInternet1 Kommentar

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 3 TagenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Heiß diskutierte Inhalte
Router & Routing
Lancom-VPN-Client
Frage von FM28880Router & Routing15 Kommentare

Hallo zusammen, ich habe heute zwei Rechner mit einem Lancom VPN-Client eingerichtet. Die VPN-Verbindung wird aufgebaut und steht. Jedoch ...

Hyper-V
Hyper-V Manager startet, jedoch keine VM
Frage von NaleorHyper-V13 Kommentare

Hallo zusammen, auf meinem Windows 10 (Build 1703) Notebook von der Arbeit scheint Hyper-V plötzliche nicht mehr zu funktionieren. ...

Windows Server
Sonntagsfrage: Welchen Sinn seht Ihr noch im Server 2019 Essentials
Frage von ashnodWindows Server12 Kommentare

Guten Morgen, ich habe gestern den Windows Server 2019 Essentials als Trial in einer VM installiert um mir das ...

TK-Netze & Geräte
Telefonanlage Alcatel OXE R11.0.1, CPU c7s2, CPU 7 abgekündigt
Frage von magicteddyTK-Netze & Geräte10 Kommentare

Moin, letzten Monat rief mich ein Mitarbeiter unseres Service Partners an und erzählte mir das wir mit unserer Anlage ...