Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Sophos Firewall - OpenVPN Verbindung langsam oder limitiert ?!

Mitglied: LordXearo

LordXearo (Level 2) - Jetzt verbinden

06.03.2019 um 19:39 Uhr, 330 Aufrufe, 6 Kommentare, 1 Danke

Hallo Zusammen,


wir haben Probleme mit unserer SSL bzw. OpenVPN Anbindung. Und zwar scheinen alle unserer Clients nur einen maximalen durchsatz von maximal ~2MB/s (~10Mbit/s) zu bekommen. Ich konnte das auf mindestens zwei Clients verifizieren. Zu dem Problem konnte ich zwar 3-4 Threads finden, in dem sich auch andere Leute mit dem gleichen Problem geäußert haben, nur leider ist mir bisher nie eine Lösung untergekommen.

Wir haben zwei SG230 im Einsatz und eine 100Mbit/100Mbit anbindung.

Version: 9.601-5

OpenVPN ist mit Port 443, Compression aktiviert, AES-256-CBC, SHA2 256, 2048bit und Port TCP eingerichtet. Ein ändern der Verschlüsselung oder des Protokolls ist leider kaum möglich, da wir viele Mitarbeiter extern haben und diese dann die neue Konfiguration erstmal benötigen würden.

Die Clients die ich getestet habe waren einmal mit VDSL (~40Mbit/s Download) und Kabel (~60Mbit/s Down) angebunden. An dem Client mit VDSL habe ich eine andere OpenVPN verbindungen getestet an einer pfsense und hatte dort einen durchsatz von ca. 4MB/s.

Die Datenraten habe ich sowohl mit smb als auch mit https erhalten.

An der Sophos habe ich bereits alles zu testzwecken deaktiviert (IPS /Advanced Threa Protection).

QoS Regel sind keine aktiviert.

In den Logs konnte ich nichts verdächtiges finden.

Clientseitig hatte ich noch mit der MTU in der OpenVPN Config gespielt, hat aber nichts gebracht.



Es würde mich freuen wenn mich jemand unterstützen könnte oder sogar eine Lösung für das Problem parat hat.


Gruß

Ps. Die Frage habe ich auch im Sophos Forum gestellt:
https://community.sophos.com/products/unified-threat-management/f/german ...
Mitglied: Pjordorf
06.03.2019 um 19:51 Uhr
Hallo,

Zitat von LordXearo:
Es würde mich freuen wenn mich jemand unterstützen könnte oder sogar eine Lösung für das Problem parat hat.
Mal mit einen Wirshark geschaut ob es auffälligkeiten gibt? Und warum sollte eine Sophos Hardware deine Leitungen verlangsamen? Mal mit ein NetIO geschaut was über deine Leitungen gehen kann?

Gruß,
Peter
Bitte warten ..
Mitglied: LordXearo
06.03.2019 um 20:13 Uhr
Hallo Peter,

mit Wireshark hab ich noch nicht geschaut, werde ich morgen mal als erstes machen.
Mit NetIO habe ich auch noch nicht gemessen. Denke aber bei zwei unterschiedlichen rechnern, zwei unterschiedlichern internetzugängen und zwei verschiedene Protokollen ist das wohl nicht nötig.

Es ist eine Sophos Appliance (SG230) mit integriertem OpenVPN Server. Warum der Zugriff solangsam ist wüsste ich ja gerne. Für mich sieht es aber so aus, als ob mir pro User nur 10Mbit zur Verfügung stehen.

Gruß
Bitte warten ..
Mitglied: St-Andreas
LÖSUNG 06.03.2019 um 20:57 Uhr
Moin!

Biste mal die Rulz durchgegangen?
Bitte warten ..
Mitglied: ipzipzap
07.03.2019, aktualisiert um 00:03 Uhr
Hallo,

Zitat von LordXearo:
OpenVPN ist mit Port 443, Compression aktiviert, AES-256-CBC, SHA2 256, 2048bit und Port TCP eingerichtet.

Als allererstes stellt man das bei Sophos immer auf UDP um, das bringt normalerweise schon einen sehr großen Performancesprung; wird auch so überall in den Sophos-Foren empfohlen. Auf TCP steht das ab Werk wohl aus Kompatibilitätsgründen.

Ein ändern der Verschlüsselung oder des Protokolls ist leider kaum möglich, da wir viele Mitarbeiter extern haben und diese dann die neue Konfiguration erstmal benötigen würden.

Das ist natürlich blöd

Wie IT-affin sind diese Mitarbeiter? Weil im Grunde mußt Du nur unter

C:\Program Files (x86)\Sophos\Sophos SSL VPN Client\config

die entsprechende .ovpn Datei bearbeiten und die Zeile "proto" von TCP auf UCP ändern.

Kurze Rundmail an alle, das ab Datum X das umgestellt wird und jeder seine Datei anpassen muß.


cu,
ipzipzap
Bitte warten ..
Mitglied: LordXearo
07.03.2019 um 08:05 Uhr
Zitat von ipzipzap:

Wie IT-affin sind diese Mitarbeiter? Weil im Grunde mußt Du nur unter

C:\Program Files (x86)\Sophos\Sophos SSL VPN Client\config

die entsprechende .ovpn Datei bearbeiten und die Zeile "proto" von TCP auf UCP ändern.

Kurze Rundmail an alle, das ab Datum X das umgestellt wird und jeder seine Datei anpassen muß.



Die Mitarbeiter sind teilweise nicht sehr "IT-affin". Dann wäre aber auch noch das Problem dass die Mitarbeiter im config Ordner nur Lesen können. Das ließe sich natürlich auch noch beheben. Bei einer kurzen umstellung zu udp hatte ich meine 4MB/s am 40Mbit VDSL anschluss.
Bitte warten ..
Mitglied: LordXearo
07.03.2019 um 08:07 Uhr
Zitat von St-Andreas:

Moin!

Biste mal die Rulz durchgegangen?


Moin,

das Problem könnte behoben sein. Die Funktion "Enable TCP Window scaling" war bei uns noch nicht aktiviert. Jetzt bekam ich über meinen Testrechner auch über Protokoll TCP ca. 4MB/s bei einer 40Mbit/Vdsl Leitung. Wenn ich das bei den Kollegen auch noch verifizieren kann markiere ich den Beitrag als gelöst.

Vielen dank schonmal.
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Sophos Firewall "externe" VPN Verbindung durchlassen

gelöst Frage von floodministratorRouter & Routing8 Kommentare

Hallo Administratoren und Netzwerk-Profis, ich habe für einen Projektaufbau das Szenario des beigefügten Bildes aufgebaut. Bei den beiden Seiten ...

Netzwerkmanagement

Sophos UTM 9 - Openvpn

gelöst Frage von TuberPlaysNetzwerkmanagement5 Kommentare

Hallo, ich habe gestern eine neue Sophos Firewall als Router installiert. Nun stellt sich allerdings die Frage zum Thema ...

Firewall

Sophos UTM: Firewall Regeln

gelöst Frage von 130854Firewall7 Kommentare

Hallo, ich habe eine Sophos UTM daheim stehen, die soweit den ganzen Datenverkehr regelt. Ich habe auch keine ANY-ANY-ANY ...

Firewall

Sophos Firewall korrekt einstellen

Frage von dreckigersockenFirewall3 Kommentare

Mahlzeit Leute, ich habe mir zu Hause eine Sophos UTM eingerichtet auf aktuellem Softwarestand. Hier zuerst der Aufbau: Zur ...

Neue Wissensbeiträge
Datenschutz

SiSyPHuS Win10: Analyse der Telemetriekomponenten in Windows 10

Tipp von freesolo vor 23 StundenDatenschutz1 Kommentar

Alle die sich detailliert für die Datensammlung interessieren die unter Windows 10 stattfindet, sollten sich folgende Analyse des BSI ...

Sicherheit
Adminrechte dank Intel-Grafikkarte
Information von DerWoWusste vor 1 TagSicherheit1 Kommentar

ist das Advisory, welches beschreibt, welche Intel HD Graphics Modelle Sicherheitslücken haben, mit denen sich schwache Nutzer zu Admins ...

Internet

EU Urheberrechtsreform: Eingriff in die Internetkultur

Information von Frank vor 1 TagInternet1 Kommentar

Liebe Besucherin, lieber Besucher, warum erscheint das obere Banner in allen Beiträgen? Aus Protest gegen Teile der geplanten EU-Urheberrechtsreform ...

Windows Server
Windows Backup - FilterManager Event 3
Tipp von NixVerstehen vor 2 TagenWindows Server

Hallo zusammen, ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Glasfaserkabel verlegen und Anschlüsse setzen
Frage von LLL0rdLAN, WAN, Wireless21 Kommentare

Hallo Leute, ich muss demnächst ein Netzwerkkabel auf einer Länge von ca. 70 Metern verlegen. Das Netzwerkkabel soll dabei ...

Windows Server
Mac Rechner im Windows Netzwerk - was jetzt?
gelöst Frage von Kopfg3ldWindows Server18 Kommentare

Hallo zusammen, ich habe folgende Herausforderungen. Aber erst mal was kurz zum Netzwerk - Windows Server (ältester ist ein ...

Microsoft Office
Sharepoint 2016 mag keine Umlaute in .docx-Titeln
gelöst Frage von DerWoWussteMicrosoft Office14 Kommentare

Moin Kollegen. Nutzt hier jemand Sharepoint? Könnt Ihr, unabhängig von der Sharepointversion, bitte einen Test machen? Ladet ein .docx ...

Basic
VBS soll alle Ordner auswählen, die im Startmenu angezeigt werden
Frage von Senseless-CreatureBasic12 Kommentare

Guten Morgen - gibt es eine Möglichkeit, per VBS das Startmenu in Win10 zu modifizieren? Ich beherrsche VBS mittlerweile ...