Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst "Standard" Netzwerkverbindung auf Windows Server mit mehreren Netzwerkadressen

Mitglied: tobalf

tobalf (Level 1) - Jetzt verbinden

27.03.2006, aktualisiert 28.03.2006, 9466 Aufrufe, 14 Kommentare

LAN und BACKUP-LAN trennen

Hallo!

Habe mehrere Windows-Server mit einer zweiten Netzwerkkarte (1 Gb) und der Adresse (192.1.1.X) für ein Backup-LAN ausgestattet.
Die Server befinden sich ebenfalls im LAN (190.1.1.X). Die Kommunikation der Server untereinander soll weiterhin im LAN erfolgen. Verbinde ich jetzt allerdings die Server mit dem 192.-Netz, läuft anscheinend jeglich Kommunikation der Server untereinander nur noch über das BACKUP-LAN.
Im DNS habe ich eine Untergruppe eingerichtet (backup.xxxx.local). Diese habe ich auch bei den entsprechenden Netzwerkkarten als DNS-Suffix hinterlegt. Ebenfalls habe ich in der DNS-Untergruppe backup die entsprechenden Server mit der 192.er-Adresse eingetragen.

Was kann ich noch tun bzw. wie setze ich die 190.er-Netzwerkkarte als Standard-Verbindung ein?

Vielen Dank.

tobalf
Mitglied: RaRi2003
27.03.2006 um 11:41 Uhr
Wow,

das ist mal ne Aufgabe.
Es gibt in den Settings der Server im Bereich der DNS eine Möglichkeit festzulegen auf welcher Netzwerkkarte (Adresse) er hören soll.

Grundsätzlich nehmen die Maschinen glaub ich die Schnellste Verbindung her.

Darf ich Fragen was daran stört das die Server das Backup Lan verwenden und wie Sie darauf kommen das es so sein könnte? Der Beweis hierfür fehlt mir noch...

Eventuell mal mit Ethereal anschauen das ganze..

MFG RARI
Bitte warten ..
Mitglied: ITwissen
27.03.2006 um 11:55 Uhr
Rein theoretisch werden die Datenpakete immer ueber das Netzwerk geroutet, welches am wenigsten "kostet". Die "Kosten" haengen von ein paar Faktoren (z.B. Netzwerkgeschwindigkeit, etc.) ab. Im Wesentlichen laesst sich aber nur eines im Windows einstellen, das nennt sich Metric.

Abfragen kann man die Metrik Einstellungen mit netstat -r. In der letzten Spalte steht die Metrik als Zahl. Je kleiner, desto niedriger die Kosten.

Einstellen kann man die im der TCP/IP Netzwerkkonfiguration unter Advanced.
Bitte warten ..
Mitglied: Atti58
27.03.2006 um 12:42 Uhr
... wenn Du zwei Netzwerkkarten im gleichen Netz in Deinem Server hast, kann die zweite Karte gar nicht mehr angesprochen werden, es wird also immer die erste Karte der Routingtabelle ("route print") verwendet.

Wenn Du nur das Backup über die anderen Karten fahren willst, musst Du diese in eine eigenes Netz legen,

Gruß

Atti.

PS: Das kann man hier nachlesen:

http://www.pl-berichte.de/t_netzwerk/routing.html
Bitte warten ..
Mitglied: tobalf
27.03.2006 um 14:23 Uhr
Habe mal nach der metric geschaut. Das scheint es nicht zu sein.
Ich tippe mittlerweile auf ein DNS-Problem.

Nochmal zur Info:
die Server sind mit zwei Netzwerkkarten ausgestattet:
- LAN: IP Bereich: 190.1.1.X (Switch1)
- Backup-LAN: 192.1.1.X (Switch2)

Im Backup-LAN sind alle Server angebunden, im LAN zus. noch alle Clients.
Am DNS-Server (Win2003, auch Domänencontroller, Domäne: xxxx.local) habe ich einen Subdomänenbereich backup.xxxx.local eingerichtet für alle Server im Backup-LAN (192.1.1.x). An den einzelnen Netzwerkkarten habe ich unter Erweitert das DNS-Suffix backup.xxxx.local eingetragen.
So sollte dann eigentlich die Kommunikation bei einem Ping auf server.xxxx.local auf den IP-Bereich 190.1.1.x laufen und bei einem Ping auf server.backup.xxxx.local auf den Bereich 192.1.1.X. So lange, wie ich das Netzwerkkabel des Backup-LANs (192.1.1.x) nicht anschließe, funktioniert das auch einwandfrei. Schließe ich das Kabel nun an, wird der ping nur auf die 192.1.1.x - Adresse abgegeben (auch wenn ich server.xxxx.local anpinge).

Vielleicht muss ich noch etwas in den erweiterten Netzwerkkarteneinstellungen ändern?


Vielen Dank für Eure Hilfe!!!!!

tobalf
Bitte warten ..
Mitglied: Atti58
27.03.2006 um 14:33 Uhr
Sorry, die Zwei da vorne hatte ich überlesen ...

Hast Du denn ein "Standardgateway" eingestellt und wenn ja, welches? Vielleicht solltest Du allen Servern noch per "statischem Routingeintrag" sagen, dass sie für das Backup-LAN die 192. ... nehmen sollen:

route add -p 192.1.1.0 maske 255.255.255.0 [eigene 192'er IP]

Gruß

Atti
Bitte warten ..
Mitglied: tobalf
27.03.2006 um 15:11 Uhr
Einen Standardgateway habe ich in der LAN-Verbindung hinterlegt. In den BACKUP-LAN Einstellungen habe ich keinen gesetzt (sollte man glaube ich auch so machen!?).
Der ping auf eine IP-Adresse funktioniert auch richtig, also ping auf 190.1.1.x geht auf die 190-er Adresse und bei 192.1.1.x ebenso. Nur der ping auf den DNS-Namen also bspw. server1 läuft sobald ich das BACKUP-LAN aktiviere, nicht mehr über das LAN sondern autom. über das BACKUP-LAN, obwohl im DNS-Server explizit für das BACKUP-LAN ein Subdomäne angelegt wurde.

Danke!

tobalf
Bitte warten ..
Mitglied: Atti58
27.03.2006 um 15:33 Uhr
Hast Du denn auch in den DNS-Serveeinstellungen festgelegt, dass der DNS auf beiden Interfaces arbeiten soll?

Gruß

Atti
Bitte warten ..
Mitglied: tobalf
27.03.2006 um 15:51 Uhr
Jawohl

Habe bei beiden Netzwerkkarten die gleichen DNS-Server eingetragen (190.1.1.1 + 190.1.1.2).

Gruß
tobalf
Bitte warten ..
Mitglied: RaRi2003
27.03.2006 um 15:51 Uhr
Okay, also wenn ein Ping auf 190.xxx.xxx.2 von einer Maschine im 190' Bereich gemacht wird ist alles gut, selbes gilt für den 192.xxx.xxx.xxx Bereich?

Aber wenn der name der Maschine genutzt wird dann landet der Ping auf der ersten IP Adresse der Maschine.

Ist doch okay so, denn im DNS Server steht ein Eintrag mit dem Namen der zu einer IP Adresse gehört.
Bitte warten ..
Mitglied: RaRi2003
27.03.2006 um 15:54 Uhr
Jawohl

Habe bei beiden Netzwerkkarten die gleichen
DNS-Server eingetragen (190.1.1.1 +
190.1.1.2).

Gruß
tobalf

Sorry aber die Angabe passt net so ganz zum Scenario? Eine Karte müsste demnach nämlich 190.1.1.1 und die andere doch 192.1.1.1 ? Sorry für die Rückfrage...
Bitte warten ..
Mitglied: Atti58
27.03.2006 um 16:33 Uhr
... danach hatte ich eigentlich nicht gefragt, ich wollte wissen, ob Du in der DNS-Verwaltungskonsole beide IP's verwendest ...

Vielleicht liegt Dein Problem ja auch nur einfach daran, dass die "falsche" Karte hier:

"Eigenschaften von Netzwerkverbindungen" -> "Erweitert" -> "Erweiterte Einstellungen"

an erster Stelle steht, verschiebe sie einfach mit dem grünen Pfeil nach unten ...

Gruß

Atti
Bitte warten ..
Mitglied: tobalf
27.03.2006 um 17:08 Uhr
> Jawohl
>
> Habe bei beiden Netzwerkkarten die
gleichen
> DNS-Server eingetragen (190.1.1.1 +
> 190.1.1.2).
>
> Gruß
> tobalf

Sorry aber die Angabe passt net so ganz zum
Scenario? Eine Karte müsste demnach
nämlich 190.1.1.1 und die andere doch
192.1.1.1 ? Sorry für die
Rückfrage...

Hier waren die DNS-Server gemeint und die liegen beide im 190er Adressbereich. Die Karten sind mit 190.1.1.X und 192.1.1.X Adressen konfiguriert.
Bitte warten ..
Mitglied: tobalf
27.03.2006 um 17:14 Uhr
... danach hatte ich eigentlich nicht
gefragt, ich wollte wissen, ob Du in der
DNS-Verwaltungskonsole beide IP's verwendest
...

Vielleicht liegt Dein Problem ja auch nur
einfach daran, dass die "falsche"
Karte hier:

"Eigenschaften von
Netzwerkverbindungen
" ->
"Erweitert"
-> "Erweiterte
Einstellungen
"

an erster Stelle steht, verschiebe sie
einfach mit dem grünen Pfeil nach unten
...

Gruß

Atti


DAS WARS!!!!

Vielen DANK an ALLE!!!!

Gruß
tobalf
Bitte warten ..
Mitglied: Atti58
28.03.2006 um 09:23 Uhr
Super, danke für die Rückmeldung, wenn Du nun noch so gut sein würdest und Deinen Thread als "Gelöst" zu markieren und die helfenden Beiträge bewerten würdest, hätten andere User es leichter,

Gruß

Atti.
Bitte warten ..
Ähnliche Inhalte
Windows 7

Keine Netzwerkverbindung mehr unter 2 Windows 7 Rechner

gelöst Frage von MarkowitschWindows 720 Kommentare

Hallo zusammen, natürlich habe ich schon gegoogled, aber keine Lösung gefunden. Ich habe 2 Windows 7 Rechner, wo der ...

Windows Server

Windows SBS 2011 Standard-Konsole funktioniert nicht mehr

Frage von TitusFlaviusWindows Server1 Kommentar

Moin, die Windows SBS 2011 Standard-Konsole hängt sich auf, wenn ich "Datensicherung und Serverspeicher" ausgewählt habe, den Server markiert ...

Windows 10

Standard App in Windows 10 starten nicht mehr

Frage von zeroblue2005Windows 107 Kommentare

Hallo Zusammen, ich habe es einfach mal gewagt, bei meinem alten Rechner die alte SSD auszubauen und in meinem ...

Windows Server

Windows 2012 standard

gelöst Frage von fisch56Windows Server10 Kommentare

Hallo, kurze Frage: Wir haben einen Windows 2012 Standanrd gekauft, mit raid 5 auf einem dell. wir haben nur ...

Neue Wissensbeiträge
Internet

Kommentar: Bundesregierung erwägt Ausschluss von Huawei im 5G-Netz - Unsere Presse wird immer sensationsgieriger

Information von Frank vor 1 TagInternet5 Kommentare

Hier mal wieder ein schönes Beispiel für fehlgeleiteten Journalismus und Politik zugleich. Da werden aus Gerüchten plötzlich Fakten, da ...

Windows 10

Netzwerk-Bug in allen Windows 10-Versionen durch Januar 2019-Updates

Information von kgborn vor 1 TagWindows 101 Kommentar

Nur ein kurzer Hinweis für Admins, die Windows 10-Clients im Portfolio haben. Mit den Updates vom 8. Januar 2019 ...

Windows 10

Windows 10 V1809: Rollout ist gestartet - kommt per Windows Update

Information von kgborn vor 2 TagenWindows 102 Kommentare

Eine kurze Information für die Admins, die Windows 10 im Programm haben. Microsoft hat die letzte Baustelle (die Inkompatibilität ...

Sicherheit

Heise Beitrag Passwort-Sammlung mit 773 Millionen Online-Konten im Netz aufgetaucht

Information von Penny.Cilin vor 2 TagenSicherheit6 Kommentare

Auf Heise Online ist folgender Beitrag veröffentlicht worden: Heise Beitrag passwörter geleakt Ich bin mir jetzt nicht ganz sicher, ...

Heiß diskutierte Inhalte
TK-Netze & Geräte
TAPI auf einem Win2016Server installieren und einrichten
Frage von wstabelTK-Netze & Geräte30 Kommentare

Hallo liebe Admins, ich habe folgende Situation: 1 Windows Server 2016 Standard als DC 1 SNOM 710 IP-Telefon 1 ...

Batch & Shell
Mit findstr batch doppelte zeilen einer txt löschen
Frage von Burningx2Batch & Shell25 Kommentare

Hi Vor einer weile habe ich im netzt einen windows shell befehl gefunden mit welchem man über die konsole ...

Verschlüsselung & Zertifikate
Netzwerkfreigabe Verschlüsselung
Frage von grill-itVerschlüsselung & Zertifikate20 Kommentare

Moin zusammen, sicher nutzen hier die ein oder anderen ein Produkt zur Verschlüsselung von Netzwerkfreigaben/-laufwerken auf denen hochsensible Daten ...

Microsoft
Übertragung von MS Volumenlizenzen
Frage von SherlockineMicrosoft20 Kommentare

Ich bin Angestellte in einer kleinen 10-köpfigen IT-Firma, die Netzwerklösungen, Telefonielösungen und Ähnliches anbietet. Im Sommer hatten wir einen ...