Virtuelle Maschine kann nicht mehr gestartet werden

madmax1972
Goto Top
Hallo allerseits,

ich habe folgendes Problem:

eine virtuelle Maschine auf der ein Windows 10 Pro (2004) läuft lässt sich nicht mehr starten:
sie hängt in einer Bootschleife fest. Man kann über den Hyper-V Manager nur kurz das Windows Logo sehen und dann die Meldung

"Am Computer vorgenommene Änderungen werden rückgängig gemacht" - das für ca. 3 Minuten und dann erneut Bootlogo.

Ich habe die VM in einer Datensicherung (Veeam): aber leider sind alle 10 vergangen Sicherungen mit dem gleichen Phänomen.
An das Dateisystem der VM komme ich heran.
Diese Maschine wird nicht allzu oft benutzt bei uns: daher ist es erst gestern aufgefallen das sie nicht mehr läuft.

Ich habe schon versucht mit einem WIn10 Bootimage die Starthilfe und die Reparaturoptionen auszuprobieren.
Aber leider alles bisher ohne Erfolg. Ob man einen abgesicherten Modus bei einer VM unter Hyper-V erzwingen kann, habe ich leider nicht rausbekommen.
Die VM bleibt in dem o.g. Zustand.

Hat hier jemand vielleicht noch eine Idee was ich probieren könnte?
Ich würde (natürlich) eine Neuinstallation vermeiden wollen ;-) face-wink

Vielen Dank im Voraus für Tipps.

MfG Markus

Content-Key: 667243

Url: https://administrator.de/contentid/667243

Ausgedruckt am: 29.05.2022 um 13:05 Uhr

Mitglied: Mad-Eye
Mad-Eye 01.06.2021 um 21:03:10 Uhr
Goto Top
Hi MadMax,

ich denk mal den Host wirst du schon mal neu gestartet haben oder? Ansonsten würde ich an deiner stelle Mal versuchen die VHDX einfach an eine neue VM anhängen. Evtl. noch sicheren Start versuchen zu deaktivieren oder Netzwerk mal auf Nicht verbunden setzen.

Grüße,
Mad-Eye
Mitglied: Franz-Josef-II
Franz-Josef-II 02.06.2021 um 09:16:22 Uhr
Goto Top
Guten Morgen


Zitat von @MadMax1972:
An das Dateisystem der VM komme ich heran.


Die Eigenschaften der VM wirst ja schon durchgeschaut haben. Ich würde auf die Schnelle eine neue VM erstellen, die VHD(X) als Laufwerk einbinden und schauen ob's geht.
Mitglied: MadMax1972
MadMax1972 02.06.2021 um 09:35:59 Uhr
Goto Top
Guten Morgen,

ja, das anhängen habe ich auch schon probiert. Den Tipp hatte ich schon gefunden.
Und das deatkvieren des Netzwerkes hatte auch keinen Erfolg gebracht.

Wie meinst Du das mit dem "sicheren Start"?

MfG
Markus
Mitglied: MadMax1972
MadMax1972 02.06.2021 um 09:37:23 Uhr
Goto Top
Guten Morgen,

das will ich gerne noch mal probieren. Danke für den Tipp.

MfG
Markus
Mitglied: MadMax1972
MadMax1972 02.06.2021 um 10:37:13 Uhr
Goto Top
Das hat leider auch nicht geklappt - seufz.......
Langsam habe ich auch keine Ideen mehr.
Danke aber für den Tipp.
Mitglied: D8gg3r
D8gg3r 02.06.2021 aktualisiert um 12:12:49 Uhr
Goto Top
Hallo MadMax1972,

ich hatte schon ähnliche Phänomene, jedoch noch in Win7-Zeiten.
An dem Verhalten sollte sich aber nichts geändert haben.

Versuche es mal so:
  • von Windows 10 ISO booten
  • Computerreparatur
  • Eingabeaufforderung
  • regedit starten
  • System Registrierung einbinden (Pfad: C:\Windows\System32\config\SYSTEM)
  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\TrustedInstaller -> Wert vom DWORD "Start" auf 4 ändern
  • Computer\HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\wuauserv -> Wert vom DWORD "Start" auf 4 ändern
  • Eingebundene Registry-Struktur entfernen
  • PC neu starten -> *daumendrück*

Damit werden die Dienste Windows Installer und Windows Update beim Start deaktiviert und somit sollte Windows keine Änderungen mehr verarbeiten wollen.
Wenn das soweit funktioniert, dann kannst du dich an die Reparatur machen (Bereinigung SoftwareDistribution oder InPlace-Upgrade z.B.)

Hoffe es hilft dir weiter.

Grüße
Thomas
Mitglied: MadMax1972
MadMax1972 02.06.2021 um 12:50:51 Uhr
Goto Top
Hallo Thomas,

probiere ich aus. Danke.
Nur der Punkt: "Systemregistrierung einbinden" ist mir nicht ganz klar, was gemeint ist?
Mitglied: D8gg3r
D8gg3r 02.06.2021 aktualisiert um 13:04:36 Uhr
Goto Top
Hallo Markus,

du musst auf HKEY_LOCAL_MACHINE klicken, dann Datei->Struktur laden.
Anschließend einen temporären Namen für die eingebundene Struktur festlegen. (z.B. System1)
Danach kannst du auf die eingebundene Struktur zugreifen.
Mitglied: MadMax1972
MadMax1972 02.06.2021 um 14:15:16 Uhr
Goto Top
Hallo Thomas,

danke für die Erläuterung.
Aber auch das funktioniert leider nicht.
Deine Änderungen sind aber auf jeden Fall in der Registry des defekten Windows "angekommen".
Nur leider bewirken sie immer noch keine Veränderung im Bootverhalten.

Hat jemand eventuell noch einen Plan B parat?
Mitglied: Franz-Josef-II
Franz-Josef-II 03.06.2021 aktualisiert um 12:28:46 Uhr
Goto Top
Zitat von @MadMax1972:
Hat jemand eventuell noch einen Plan B parat?

Neuinstallation?
😊

Ernsthaft: Wenn die ganzen "alten Indianertricks" nicht funktionieren, geht das am Schnellsten ..... ausgenommen es ist eine extrem spezielle Maschine. Aber sogar da würde ich parallel eine neue machen. Dann ist man um einiges weiter, wenn auch die nächsten Versuche danebengehen.
Mitglied: MadMax1972
MadMax1972 03.06.2021 um 09:38:52 Uhr
Goto Top
Guten Morgen,

ich habe schon begonnen mit dem Neuaufsetzen der Maschine.
Es sind zwar alle Dateien in der Sicherung vorhanden: bis die aber alle wieder an "der richtigen Stelle" sind, dauert halt.
War eine Maschine zur Ansteuerung von Industriedruckern. Mal schauen wie weit ich hier mit der Konfiguration komme.