Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

W2K3-Userscript kopiert Starmenüeintrage ins falsche Profil (trotz %username%)

Mitglied: Labamba0704

Labamba0704 (Level 1) - Jetzt verbinden

25.07.2006, aktualisiert 27.07.2006, 4031 Aufrufe, 8 Kommentare

Hallo.

Ich weise den Benutzern auf meinem windwos 2003 Server per GPO Scripte zu. Im folgenden sieht das script so aus:

xcopy "\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk" "C:\Dokumente und Einstellungen\%username%\Startmen\GFUB\INFO\" /y /i


trotzdem haben die Benutzer keinen Eintrag im Startmenü. ein gpresult auf den Clients zeigt an das die GPO angewendet wird.
An einem Clientcomputer findet man auch unter dokumente und Einstellungen und dann im entsprechenden Profil den startmenüeintrag.

anscheinend ist das startmenü nicht dasselbe was der user eigentlich benutzt.

Als Zusatzinfo: Es ist eine Domäne, wir haben servergespeicherte Profile und die Benutzer können manuell Einträge im Startmenü ändern,löschen,etc.

Einzig bei meinem Rechner klappen die Startmenüscripteinträge

Jemand eine Idee???
Mitglied: Dani
25.07.2006 um 14:30 Uhr
Hi,
könnte an diesem UNC Pfad liegen (\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk").
Hast du das xcopy mal per Hand eingeben bzw. probiert?!


Gruß
Dani
Bitte warten ..
Mitglied: Labamba0704
25.07.2006 um 15:34 Uhr
Führe ich das Script manuell aus (Doppelklick) dann macht er das was ich will.

Was genau meinst du mit dem UNC-Pfad?Was könnte den da nicht stimmen?

Groß/Kleinschreibung beachten oder sowas? Gebe ich den Pfad im Browser ein, komme ich auch zu der Verknüpfung
Bitte warten ..
Mitglied: rc-computer
25.07.2006 um 15:49 Uhr
Koennte es sein das bis zum ausfuehren deiner xcopy sache noch keines der Laufwerke gemappt ist!?

Mit freundlichen Gruessen
- Johannes Matjeschk
Bitte warten ..
Mitglied: Biber
25.07.2006 um 19:18 Uhr
Moin Labamba074,

dumme Frage zu "anscheinend ist das startmenü nicht dasselbe was der user eigentlich benutzt."..
Wieso lässt Du Windows das nicht selbst herausfinden, was das richtige Verzeichnis ist?
Kopiere doch nach "%userprofile%\Startmenü".

Zweitens... wenn das per Doppelklick klappt, aber nicht als Batch, deutet es darauf hin, dass Windows (mit Codepage 1252) und CMD.exe (mit Codepage 850) mit dem "ü" in "Startmenü" eventuell untergehen.
Setz doch mal vor deinen "XCOPY"-Einzeiler mal ein "CHCP 1252" aus Spass.

Drittens ... leite die Ausgabe von XCOPY doch um in eine Logdatei auf dem Server.. im Erfolgs- und im Misserfolgsfall.

Beispiel:
...
chcp 1252
xcopy ....quell-Link.. "%userprofile%\Startmenü\Bla\" >>serverxy\logs\myclients.log
echo %date% %computername% %username% xCopy-Ergebnis: [%errorlevel%]>>serverxy\logs\myclients.log
....

Gruß
Biber
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 09:25 Uhr
Hallo,

ich habe das Script jetzt mit %userprofile% abgeändert. Gab keinerlei Veränderungen zu vorher mit %username% (ausser das der pfad im script logischerweise etwas kürzer ist)

CHCP 1252 habe ich nun auch vorran gestellt, sowie die ausgabe von xcopy umgeleitet in eine log datei.

Es ist weiterhin alles wie zuvor. in der logdatei gibt es keine fehlermeldung.

Melde ich mich an (Userkennung gfub1012) steht in der logdatei:

27.07.2006 CFBK0032 gfub1012 xCopy-Ergebnis: [0]
\\Sfbk0001\Daten\DATEN\Info\Geburtstagskalender.lnk
1 Datei(en) kopiert

Melde ich mich als ein User an für den ebenfalls die Gruppenrichtlinie mit den script gilt (mit gpresult überprüft) bekommt er dieselbe meldung nur mit seiner kennung halt (statt gfub1012 kommt gfub1002).


Das kuriose ist das der 1002 Benutzer unter dokumente und einstellungen usw den gewünschten ordner im startmenü hat, also wird korrekt kopiert von dem script. der ordnername lautet:

c:\dokument.....usw\gfub1002\Startmenü\GFUB

Trtozdem ist dieser Eintrag nicht in seinem Startmenü drin. ein Echo %userprofile% sagt c:\doku...usw\gfub1002, also passt das eigentlich. Trotzdem ist nichts im Startmenü (wenn man auf start klickt) zu sehen.


melde ich mich an (gfub1012) habe ich unter c:\dokumen...usw ebenfalls die korrekten einträge (nur mit gfub1012 halt). bei mir hingegen steht der Eintrag GFUB in meinem startmenü, wenn ich auf start klicke.


ich weis nicht mehr weiter. normalerweise gehe ich davon aus das wenn ich als benutzer xyz angemeldet bin, die einträge unter c:\doku..usw\xyz\startmenü für den user xyz gelten.


INTERESSANTER NACHTRAG!!!

ich habe gerade das script mal kurz abgeändert, also den eintrag startmenü gegen desktop getauscht und siehe da, bei allen von der gpo betroffenen usern wird der ordner auf den desktop kopiert. also kann man schonmal sagen das es am startmenü liegt, oder?

ich freue mich auf eure meinungen
Bitte warten ..
Mitglied: Biber
27.07.2006 um 09:37 Uhr
..dann ist es ein Zeichensatz-Problem wie vermutet. (das "ü" in Startmenü")

Ändere bitte mal den Zilepfad um in:
"%userprofile%\Startm~1\bla"

[sieht zwar krank aus, könnte aber helfen.]

Wenn das hilft, dann solltest Du mal in der Mittagspause am CMD-Prompt testen, wie denn dort der Ordner "Startmenü" angezeigt wird. Also ein "DIR %userprofile%\*" eingeben.
Und dann mit CHCP 850/ CHCP1252/ probieren, mit welchem Zeichensatz ein "ü" statt einer hochgestellten Drei angezeigt wird.

Gruß
Biber
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 10:10 Uhr
ich weis nicht was du mit cmd-prompt meinst. aber ich habe auf dem server per konsole (cmd) mir die schreibweise von startmenü angeschaut. wurde überall mit korrekten ü angezeigt.

ebenso habe ich das per cmd an einem client getestet, dasselbe ergebnis, alles korrekt mit ü.

ich bin aber auf ein interessantes detail gestoßen.

alle user wo das script nicht zu klappen scheint haben in ihrem profil ordner neben dem ordner startmenü noch einen ordner start menu.

ich hingegen (bei dem das script korrekt ausgeführt wird) habe nur einen startmenü ordner.

habe bereits versucht den star menu ordner zu löschen, der kommt aber immer wieder.

gibt es eine saubere lösung windows davon zu überzeugen nur noch ein startmenü zu nehmen?
Bitte warten ..
Mitglied: Labamba0704
27.07.2006 um 17:11 Uhr
alles gelöst.

mann muss unter HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\User Shell Folders

den eintrag Start Menu entsprechend abändern.

danke an alle, nun klappts
Bitte warten ..
Ähnliche Inhalte
Microsoft Office
Excel kopiert Zeilen selbständig
Frage von FreaksterMicrosoft Office2 Kommentare

Hallo, ich habe ein etwas seltsames Problem, ich verwende eine Exceldatei (xlsx) mit mehreren Tabellenblättern. In letzter Zeit ist ...

Windows 10
Festplattenplatz falsch angezeigt
Frage von DasistdasEndeWindows 103 Kommentare

Hallo. Ich habe eben meiner 256 Platte Platz geschaffen, in dem ich unter AppData IOS Backups gelöscht habe. Ich ...

DNS
DNS Antworten falsch
Frage von MasterSchlumpfDNS12 Kommentare

Hallo Community, ich habe ein schwieriges DNS-Problem. Wenn ich einen PC mit Namen PC-Meyer anpinge erhalte ich eine Antwort ...

Webbrowser
Hyperlink arbeitet falsch
Frage von 129914Webbrowser16 Kommentare

Hallo, Mein Betr.system ist Win.7 Ich habe eine PPT mit PowerPoint mit Office 2003 erstellt und als PPS abgespeichert. ...

Neue Wissensbeiträge
Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 23 StundenHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 1 TagServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 2 TagenHumor (lol)8 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Linux

"Warum Linux in einer vernetzten Welt einfach keinen Komfort bietet!"

Tipp von Snowbird vor 3 TagenLinux13 Kommentare

Ein interessanter Einblick warum Linux nichts für Geräteübergreifende Arbeit ist :)

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Windows Server über Außen-IP nicht ansprechbar
Frage von uups81Netzwerkgrundlagen25 Kommentare

Hallo! Es gibt mehrere Windows Server (2016, 2019), die über einen zweiten Netzwerkadapter in einem lokalen Netzwerk miteinander verbunden ...

Microsoft
Windows 10 - Kombination von lokalen Benutzerkonten und Benutzern aus einer Domäne
Frage von PappnaseVxVVMicrosoft21 Kommentare

Hi, würde gerne folgendes realisieren, von dem ich gern wüsste, ob es geht. Ich habe einen Raum mit 3 ...

Grafikkarten & Monitore
Grafikkarten Angebot auf Amazon
gelöst Frage von NudellordGrafikkarten & Monitore21 Kommentare

Hallo Community, ich suche eine neue Grafikkarte und bin auf die Nvidea Gforce GTX 1080 ti gestoßen. Und dabei ...

Hyper-V
Keine Netzwerkverbindung W2016 VM
gelöst Frage von keine-ahnungHyper-V19 Kommentare

Moin, ich verliere gleich meine contenance ;-). Ich versuche gerade, auf einem Hyper-V 2016 GUI eine W2016-VM (Generation 2 ...