Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst XP - 2 Netzwerkkarten - nutzt richtige NIC aber falsche Source IP

Mitglied: sebaaaat

sebaaaat (Level 1) - Jetzt verbinden

18.09.2007, aktualisiert 18.10.2012, 6892 Aufrufe, 11 Kommentare

XP Rechner mit 2 Netzwerkkarten in 2 getrennten Netzen schickt Pakete in Netz B mit der Source IP von Netz A

Ich habe einen XP Prof Rechner, der aus 2 physikalisch getrennten Netzen (172.20.10.0 und 10.226.182.0) erreichbar sein soll. Über das 172er Netz wird er gesteuert und über das 10er Netz soll er SIP-Calls durchführen. Hier zur Übersicht der Aufbau:

A(172.20.10.0)-----[[NIC1:172.20.10.24] XP-Rechner [NIC2:10.226.182.86]]------(10.226.182.0)B

In einem Wireshark-Sniff des Rechners seh ich, dass er SIP-Pakete mit der Source-MAC-Adresse von NIC2 und der Source IP von NIC1 ins Netz B schickt. Diese Pakete werden natürlich weder geroutet, noch beantwortet. Irgendwie scheint mir das ein Windows-Fehler zu sein. Die default-Route zeigt ins Netz B. Ein Kollege meinte, das könnte ein Fehler der Priorität der Netzwerkkarten sein. Dazu habe ich jedoch bisher nichts gefunden.

Irgendwelche Ideen?
Mitglied: Egbert
18.09.2007 um 12:50 Uhr
Hallo,

probier doch mal unter Netzwerkverbindungen --> Erweitert --> Erweiterte Optionen mal die Bindungsreihenfolge zu ändern.

Gruß

Egbert
Bitte warten ..
Mitglied: cat
18.09.2007 um 13:20 Uhr
Ich habe einen XP Prof Rechner, der aus 2
physikalisch getrennten Netzen (172.20.10.0
und 10.226.182.0) erreichbar sein soll.
Über das 172er Netz wird er gesteuert
und über das 10er Netz soll er SIP-Calls
durchführen. Hier zur Übersicht der
Aufbau:

A(172.20.10.0)-----[[NIC1:172.20.10.24]
XP-Rechner
[NIC2:10.226.182.86]]------(10.226.182.0)B


Bei XP ist standardmäßig das Routing deaktiviert
http://support.microsoft.com/?scid=kb%3Bde%3B315236&x=7&y=14
Bitte warten ..
Mitglied: sebaaaat
18.09.2007 um 13:42 Uhr
Das hat leider auch nicht geholfen. Ich hab beide Reihenfolgen versucht - ohne Erfolg. Gibt's sonst noch Ideen?

Ist es möglich, dass die Anwendung bei der Installation an ein bestimmtes Interface gebunden wurde?
Bitte warten ..
Mitglied: sebaaaat
18.09.2007 um 13:44 Uhr
Der Rechner soll auch nicht routen. Netz A und B sollen weiterhin getrennt bleiben. Es geht nur darum, dass der Rechner selbst erzeugte Pakete, die für das Netz B bestimmt sind, auch in das Netz B schicken soll, und zwar mit richtiger IP.
Bitte warten ..
Mitglied: cat
18.09.2007 um 15:37 Uhr
was sagt denn ein
01.
ipconfig /all
und ein
01.
route print
Bitte warten ..
Mitglied: cat
18.09.2007 um 16:12 Uhr
Ich hoffe ich habs jetzt verstanden:

NIC 1: 172.20.10.24
NIC 2: 10.226.182.86

NIC 1 sollte keine DHCP IP bekommen, kann sonst ärger bei der Reihenfolgenverteilung von Microsoft geben.
NIC 1 hat wahrscheinlich auch ein Gateway eingetragen, da hier ja im Netz gerabeitet werden soll.

NIC 2 soll lediglich an den Rechner mit der IP 10.226.182.0 Daten schicken
NIC 2 darf kein Gateway eingetragen haben, soll ja nich in die anderen Netze

Wichtig ist dann die Reihenfolge
Platz 1 hat dann NIC 2
Paltz 2 hat dann NIC 1

Aber warum sollte das gehen?
NIC 2 kann nicht ins andere Netz mangels Gateway, wird aber immer als erstes benutzt dort laufen jetzt alle Lokalen Netztwerkaktivitäten in 10er Netz, denn diese gehen auch ohne Gateway.
Bitte warten ..
Mitglied: sebaaaat
18.09.2007 um 16:16 Uhr
route print:

Interface List
0x1 ........................... MS TCP Loopback interface
0x2 ...00 a b0 a1 7b d0 ...... TE100-PCBUSR 32-Bit Cardbus PC Card - Packet Scheduler Miniport
0x3 ...00 03 2d da 00 c7 ...... Intel(R) PRO/100 M Desktop Adapter - Packet Scheduler Miniport
Active Routes:
Network Destination Netmask Gateway Interface Metric
0.0.0.0 0.0.0.0 10.226.182.1 10.226.182.86 20
10.226.182.0 255.255.255.0 10.226.182.86 10.226.182.86 20
10.226.182.86 255.255.255.255 127.0.0.1 127.0.0.1 20
10.255.255.255 255.255.255.255 10.226.182.86 10.226.182.86 20
127.0.0.0 255.0.0.0 127.0.0.1 127.0.0.1 1
172.20.10.0 255.255.255.0 172.20.10.24 172.20.10.24 20
172.20.10.20 255.255.255.255 172.20.10.24 172.20.10.24 1
172.20.10.24 255.255.255.255 127.0.0.1 127.0.0.1 20
172.20.255.255 255.255.255.255 172.20.10.24 172.20.10.24 20
192.168.1.0 255.255.255.0 172.20.10.1 172.20.10.24 1
224.0.0.0 240.0.0.0 10.226.182.86 10.226.182.86 20
224.0.0.0 240.0.0.0 172.20.10.24 172.20.10.24 20
255.255.255.255 255.255.255.255 10.226.182.86 10.226.182.86 1
255.255.255.255 255.255.255.255 172.20.10.24 172.20.10.24 1
Default Gateway: 10.226.182.1
Persistent Routes:
Network Address Netmask Gateway Address Metric
172.20.10.20 255.255.255.255 172.20.10.24 1
192.168.1.0 255.255.255.0 172.20.10.1 1



ipconfig /all:



Windows IP Configuration

Host Name . . . . . . . . . . . . : KNMSIP113
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : Yes
WINS Proxy Enabled. . . . . . . . : Yes

Ethernet adapter LAN Connection 2:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Realtek RTL8139/810X Family Fast Ethernet NIC
Physical Address. . . . . . . . . : 00-A1-B0-A1-7B-D0
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 10.226.182.86
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 10.226.182.1
DHCP Server . . . . . . . . . . . : 10.226.182.20
Lease Obtained. . . . . . . . . . : Tuesday, September 18, 2007 4:00:44 PM
Lease Expires . . . . . . . . . . : Wednesday, September 19, 2007 4:00:44 AM

Ethernet adapter Onboard LAN:

Connection-specific DNS Suffix . : TESTNET.de
Description . . . . . . . . . . . : Intel(R) PRO/100 M Desktop Adapter
Physical Address. . . . . . . . . : 00-03-2D-DA-00-C7
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IP Address. . . . . . . . . . . . : 172.20.10.24
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . :
DHCP Server . . . . . . . . . . . : 172.20.10.1
Lease Obtained. . . . . . . . . . : Tuesday, September 18, 2007 4:00:46 PM
Lease Expires . . . . . . . . . . : Wednesday, September 19, 2007 4:00:46 PM
Bitte warten ..
Mitglied: sebaaaat
18.09.2007 um 16:54 Uhr
So. Ich hab jetzt beide Adressen statisch vergeben und kein Default Gatway angegeben, sondern alle Routen, die ich brauche händisch eingegeben.

Die NIC2 (10.226.182.86) hab ich unter "Netzwerkverbindungen-->Erweitert-->Erweiterte Einstellungen-->Netzwerkkarten und Bindungen" in der Liste ganz nach oben gesetzt.

Alles gespeichert, rebootet, aber es tut's immer noch nicht.

Sonst noch Vorschläge?
Bitte warten ..
Mitglied: Dani
18.09.2007, aktualisiert 18.10.2012
Moin sebaaaat,
schau dir mal das wunderschöne Tutorial von aqui an. Hat bisher nie versagt. *g*


Grüße
Dani
Bitte warten ..
Mitglied: sebaaaat
19.09.2007 um 09:09 Uhr
Danke für den Tip. Das Tutorial hatte ich schon überflogen. Nur habe ich nicht vor, die Netze zu koppeln. Der PC soll in keinster Weise als Router fungieren. Er soll lediglich aus beiden Netzen erreichbar sein, bzw. besser gesagt: Er soll beide Netze erreichen können.
Bitte warten ..
Mitglied: sebaaaat
19.09.2007 um 09:13 Uhr
Ich habe das Problem jetzt (mehr oder weniger) gelöst, indem ich einfach die NICs vertauscht habe. Sprich, ich habe die Karten umkonfiguriert und die Kabel so getauscht, dass Netz B jetzt an NIC 1 verkabelt ist. Jetzt läufts. Und das sogar, trotzdem die NIC2 immer noch oben in der Bindungsliste ist. Totaler Schwachsinn, aber was solls.

Wer dennoch eine Lösung für das eigentliche Problem hat, kann es mich gerne wissen lassen...

Besten Dank soweit!
Bitte warten ..
Ähnliche Inhalte
Google Android

MIT AppInventor - WebApp nutzt Proxy nicht oder falsch

Frage von Winfried-HHGoogle Android2 Kommentare

Hallo in die Runde! wir haben mit dem Google/MIT AppInventor eine App erstellt, die die WebSite antolin.westermann.de aufrufen soll: ...

Windows Server

IP-Einstellungen werden falsch angezeigt

Frage von schlumpf90Windows Server5 Kommentare

Hallo zusammen, ich habe bei einem Win 2012 R2 Server ein sehr merkwürdiges Verhalten: Wenn man sich die IPv4-Netzwerkeinstellungen ...

LAN, WAN, Wireless

Prio 2 - NIC Teaming Multi-Vendor

gelöst Frage von ProvidedLanLAN, WAN, Wireless10 Kommentare

Hallo zusammen, wir veranstalten nächste Woche mal wieder eine FirmenLan (IT-Firma). Natürlich werden da legal erworbene Filme, Spiele und ...

Windows 10

Win 10 Domain Passwort falsch, ist aber richtig

gelöst Frage von tomi93Windows 1017 Kommentare

Guten Morgen, ich habe gestern an einem Rechner Win 10 Pro installiert und in die Domäne eingefügt. Anschließend auf ...

Neue Wissensbeiträge
Windows 10

Windows 10 - Programme laufen schneller, wenn Sie mit Administratorrechten ausgeführt werden !

Erfahrungsbericht von 1Werner1 vor 5 StundenWindows 106 Kommentare

Moin, das wollte ich erst nicht glauben, aber es ist so. Wenn Ihr ein Programm mit Administratorrechten unter Windows ...

Sicherheits-Tools
Putty hat heftige Bugs korrigiert!
Information von Lochkartenstanzer vor 1 TagSicherheits-Tools5 Kommentare

Moin, Wie man aus herauslesen kann, sind in den Versionen vor 0.71 gravierende Bugs, die es angeraten erscheinen lassen, ...

Off Topic
Sachen die die Welt nicht braucht - Platz 1
Tipp von brammer vor 4 TagenOff Topic21 Kommentare

Hallo, ich habs als Tipp angelegt als Erfahrungsbericht nein Danke brammer

Humor (lol)
Spirit of Health-Kongress in Berlin
Information von AnkhMorpork vor 4 TagenHumor (lol)6 Kommentare

tgif! Beim dritten Spirit of Health-Kongress trafen sich am Wochenende Alternativmediziner und Naturheilkundler im Maritim Hotel Berlin, um sich ...

Heiß diskutierte Inhalte
Windows Server
Eingeschränkte Gruppen - Spezielle Benutzergruppe hinzufügen
Frage von killtecWindows Server17 Kommentare

Hallo, ich möchte gerne folgendes Realisieren: Ich habe bei mir Eingeschränkte Gruppen via GPO aktiv und möchte nun der ...

Microsoft Office
Videodateien auf Windows Server 2008 R2 öffnen schlägt fehl
Frage von SchroediMicrosoft Office13 Kommentare

Hallo zusammen, wir haben das Problem das embedded Videos in PowerPoint (O365) auf unserer Citrix Farm (6.5) nicht abgespielt ...

DNS
Größere DNS Probleme nach zweitem DC. Eigentlich sollte es auch dadurch besser werden
Frage von TeWutzDNS13 Kommentare

Hallo zusammen, nachdem ich letzte Woche erfolgreich einen zweiten DC ) an den Start gebracht habe melden sich weiterhin ...

LAN, WAN, Wireless
Switch als Verbindung von 2 Netzwerken
gelöst Frage von Lutz-ReLAN, WAN, Wireless12 Kommentare

Guten Tag Ich hab folgendes Problem 2 Rechner und 2 IP Kameras sind ohne dhcp in einen IP4 Netzwerk ...