Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Fritz!Boxen per VPN gekoppelt, danach kann sich Asterisk nicht mehr zum VoIP Anbieter verbinden. Gründe?

Mitglied: JTRipperZ

JTRipperZ (Level 1) - Jetzt verbinden

01.02.2010 um 09:34 Uhr, 8053 Aufrufe, 7 Kommentare, 1 Danke

Da dieses mein erster Post ist bedanke ich mich schon mal im Vorraus für alle Antwortenden, diese Plattform hat mir schon sehr oft weitergeholfen und ich hoffe, dass es hier diesmal auch klappt.

Wir haben bei uns in der Firma folgende Situation:
Büros:
Fritz!Box1 (7270) mit IP: 192.168.253.1 / Subnet : 255.255.0.0
TK-Server (Asterisk mit IPTAM Oberfläche) IP: 192.168.1.101 / 255.255.0.0

Lager:
Fritz!Box2 (7270) mit IP: 10.0.0.1 / Subnet: 255.255.255.0

Verbunden sind beide per VPN über das Integrierte Tool. Das klappt auch perfekt.
Aber nach ca. 5 - 50 Minuten ist es dem TK-Server nicht mehr möglich zu unserem VoIP Anbieter zu verbinden. (Status: Request, da TimeOut der Verbindung)
Verbunden wird nach "gw1.extrasip.de". Ein Ping und oder tracert an diese Adresse ist nicht möglich, da das Netz keine Pings zuläßt. Auch ein ändern der Domain in die IP ergab keine Besserung.
Der AVM Support verweist auf die Einstellungen der Asterisk, nur ohne aktiven VPN der zwei Boxen funktioniert das ganze prächtig.

Habe ich da einen Denkfehler im System oder müssen wir uns der "einfachheit" halber einfach einen zweiten DSL Anschluss zulegen, mit dem sich die Box dann zum Provider verbindet.

Auch stehe ich mit dem Entwickler der IPTAM im engen Kontakt, der mir aber auch keinen Fehler aufzeigen konnte,

Über jedweilige Hilfe bin ich sehr dankbar und poste auch gerne alle Logs die evtl. gebraucht werden könnten.
Mitglied: Arch-Stanton
01.02.2010 um 10:08 Uhr
eine ziemlich wirre Konstruktion ist das. Warum sind denn nicht alle Geräte in einem Netz? Verbindest Du das Lager über das Internet, also über DSL?

Gruß, Arch Stanton
Bitte warten ..
Mitglied: JTRipperZ
01.02.2010 um 11:16 Uhr
Das Netz im Büro ist der einfacheren administrierung so eingerichtet.
Die Workstation liegen im 192.168.10.0 Bereich und die Drucker im 192.168.200.0 etc.
Im Lager ist das nicht notwendig, da dort nur ca. 5 Geräte stehen, die im Netzwerk sind.
Das Netz im Lager musste auf das 10er Netz gehen, da lt. Anleitung zur VPN-kopplung von zwei Fritz!Boxen von AVM, die Boxen in verschiedenen IP-Netzen sein müssen.

Beide FritzBoxen sind per DSL verbunden.
Büro: KabelDeutschlandDSL (30.000) und Lager: "normales" DSL (16.000)
Bitte warten ..
Mitglied: Phalanx82
01.02.2010 um 13:23 Uhr
Zitat von JTRipperZ:
Das Netz im Büro ist der einfacheren administrierung so eingerichtet.
Die Workstation liegen im 192.168.10.0 Bereich und die Drucker im 192.168.200.0 etc.
Im Lager ist das nicht notwendig, da dort nur ca. 5 Geräte stehen, die im Netzwerk sind.
Das Netz im Lager musste auf das 10er Netz gehen, da lt. Anleitung zur VPN-kopplung von zwei Fritz!Boxen von AVM, die Boxen in
verschiedenen IP-Netzen sein müssen.

Beide FritzBoxen sind per DSL verbunden.
Büro: KabelDeutschlandDSL (30.000) und Lager: "normales" DSL (16.000)

Hi,

wenn ich das richtig sehe verbindet ihr die beiden Fritz-Boxen über die DSL Anbindung miteinander?
Wenn dem so ist, überbrückst du imho beide Boxen miteinander übers Internet, lässt aber keinen
Traffic an sich mehr in selbriges abfließen, da nur noch Traffic über den VPN von Box zu Box fließt.

Kannst du noch im Internet surfen oder was runter laden?

Teste das mal und geb hier Bescheid.

Mfg.
Bitte warten ..
Mitglied: aqui
01.02.2010 um 13:59 Uhr
@Phalanx82
Nein, das ist technischer Unsinn ! Er macht ja eine normale VPN Verbindung und jede FB routet sehr wohl lokalen Internet Traffic ins Internet. Es werden lediglich die VPN Netze 192.168.0.0 /26 und 10.0.0.0 /24 über den IPsec VPN Tunnel verbunden. Eine stinknormale VPN Konstruktion soweit.

Ungewöhnlich ist die Verwendung von einer 16 Bit CIDR Maske im Class C 192.168er Netz das sonst 24 Bit Masken vorschreibt. Das könnte eine Gefahrenquelle sein, da längst nicht alle IP Stacks mit CIDR Adressen umgehen können. Vermutlich ist das ein Grund dazu müsste man AVM mal befragen ob die das implementiert haben bzw. damit umgehen können bei VPNs.
Andernfalls ist es auch möglich das du in der VPN Konfig fälschierweise bei den 192.168er IP Adressen eine 24 Bit Maske angegeben hast satt der 16er und damit inkonsistente Subnetzmasken in deinem 192.168.0.0 /16 Netz verwendest.
Unverständlich ist aber auch die Verzögerung mit der der Ausfall passiert. Hättest du ein Routing Problem oder generell ein Problem mit den FBs müsste sofort bei VPN Aufbau der Asterisk die Internet Verbindung verlieren.
Der Asterisk word ja vermutlich über die lokale FB den SIP Provider erreichen. Wenn das wegbricht, was geschieht dann mit anderen Internet Verbindungen bzw. mit einem Ping auf das SIP Gateway gw1.extrasip.de ??? Wird das auch interbrochen ??
Bitte warten ..
Mitglied: JTRipperZ
02.02.2010 um 08:18 Uhr
So. Weitere Beobachtungen und die "Hilfe" des AVM Supports.

Zitat Support Mail von AVM:

"Bei dem neuen genannten Problem kann ich aber beim besten Willen keinen
Zusammenhang entdecken. Der Aufbau einer VPN-Verbindung ändert von sich aus
ja nichts an der Konfiguration eines Asterisk-Servers. Ich kann Ihnen in
diesem Fall nur empfehlen, die Konfiguration des Asterisk-Servers zu
überprüfen, wann und unter welchen Umständen dieser den Verbindungsaufbau
nicht zulässt.

Freundliche Grüße aus Berlin"

Also kann AVM auch nicht helfen bei dem Problem.

Aber ich hab es weiter eingrenzen können.
In der FritzBox im Büro ist nun der TK-Server testweise als "Exposed Host" am Netz. Und siehe da. Es funktioniert. Jetzt ist nur noch die Frage welche Ports ich genau freischalten muss, damit die Verbindung zum SIP-Provider auch weiter aufgebaut bleibt. Das Problem ist nur, dass der Port 5060 in der FritzBox selber "gebraucht" wird und damit kein Routing auf ein anderes Gerät zuläßt. Aber die IPTAM intern einen Proxy hat, welcher den Port 5060 nicht verwendet, da die Entwickler der IPTAM genau das Problem sahen. Daher wird von der IPTAM der Port 25060 genuzt.

Ich versuche heute noch nen bischen was an den Ports und halte euch auf dem Laufenden.

Für weitere / andere Lösungsansätze bin ich sehr dankbar...

PS: Ein Ping auf gw1.extrasip.de ist generell nicht möglich, da kein aktiver Ping zurückkommt. Und ich muss gestehen, dass ich gestern ein traceroute vom falschen Server ausgeführt habe (putty 3 mal offen) und mich gefreut hatte, dass ein traceroute die ganze Zeit ging. Danach hab ich gleich den "Exposed Host" eingestellt
Bitte warten ..
Mitglied: aqui
02.02.2010 um 10:04 Uhr
Das ist in so fern sehr verwunderlich da so gut wie alle SIP Provider heutzutage STUN nutzen ! (Session Traversal Utilities for NAT)
http://de.wikipedia.org/wiki/STUN
Ohne STUN ist es sehr schwer für SIP eine NAT Firewall zu überwinden, da SIP revers dynmaische Ports nutzt die den gesamten freien Port Bereich überstreichen. Siehe hier: http://de.wikipedia.org/wiki/Session_Initiation_Protocol
Ggf. ist das STUN bei Asterisk aber einfach nur nicht aktiviert bei dir, was auch möglich ist. Ansonsten solltest du mal das Asterisk HowTo checken ob die SIP Portrange ggf. eingeschränkt ist damit du prüfen kannst auf welchen Bereich du dein Port Forwarding beschränken kannst.
Wie gesagt. Mit aktivem STUN muss es auch ganz ohne Forwarding klappen....
Bitte warten ..
Mitglied: JTRipperZ
18.02.2010 um 09:51 Uhr
So gelöst.
Danke mit dem STUN Server. Der war eigentlich eingerichtet. Naja die FritzBox scheint das nicht so verknust zu haben.
FritzBox komplett zurückgesetzt und dann komplett neu eingerichtet. Seit dem funktioniert es perfekt.
Soviel dazu, dass es ja nicht die Box sein könnte.
Danke euch!
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VPN aus Fritz!box Netzwerk
gelöst Frage von PharITRouter & Routing8 Kommentare

Hallo allerseits, auf dem Weg zum VPN Profi ;-) bin ich mal wieder an den Grundlagen hängen geblieben Hat ...

Router & Routing
Fritz Box VPN ohne Client Software
Frage von HeinrichMRouter & Routing28 Kommentare

Hallo zusammen! Gibt es eine Möglichkeit, einen VPN Tunnel mit einer FritzBox herzustellen, ohne dass ich eine Client Software ...

Voice over IP

Elastix VoIP (bzw. Asterisk) redundant auslegen

gelöst Frage von PharITVoice over IP2 Kommentare

Hallo allerseits, für mehrere Standorte über den Globus verteilt wollen wir gerne als Startup-Lösung Elastix einsetzen. Wie geht Ihr ...

Router & Routing

Routing Fritz!Box

Frage von frunkyRouter & Routing8 Kommentare

Hallo Zusammen, ich möchte mich über VPN mit einer Fritz!Box 7490 verbinden. Dies funktioniert auch über den Shrew VPN-Client ...

Neue Wissensbeiträge
LAN, WAN, Wireless
OPNsense Captive Portal mit vordefnierten Voucher
Tipp von Crusher79 vor 5 StundenLAN, WAN, Wireless

Hallo, Ziel war es vorhandene Klienten-Daten (Nummer im System) und Kennwörter anzulegen. Voucher werden durch externes Programm in Papierform ...

Administrator.de Feedback
Entwicklertagebuch: Die nächste Version
Information von admtech vor 1 TagAdministrator.de Feedback6 Kommentare

Hallo Administrator User, vielleicht haben es einige User schon mitbekommen: Wir arbeiten aktuell an einer komplett neuen Version von ...

Windows Server

Active Directory ESE Version Store Changes in Server 2019

Information von Dani vor 4 TagenWindows Server

Moin, Last month at Microsoft Ignite, many exciting new features rolling out in Server 2019 were talked about. But ...

Exchange Server

Microsoft Extending End of Support for Exchange Server 2010

Information von Dani vor 4 TagenExchange Server5 Kommentare

Moin, After investigating and analyzing the deployment state of an extensive number of Exchange customers we have decided to ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Zukunftsicheres Heimnetzwerk aufbauen
Frage von CRO-WarriorNetzwerkgrundlagen16 Kommentare

Hallo Leute. Ich bin dabei das Haus in Kroatien zu renovieren. Da hab ich jetzt die Möglichkeit alles so ...

Windows Server
Windows Domäne, SBS 2011, Anmeldung als Admin nicht mehr möglich
Frage von big-dummyWindows Server14 Kommentare

Hallo, vorab: ich habe nun leider keine Grundruhe mehr - die Folgen wären katastrophal. Was ist das Problem: Ich ...

Router & Routing
Anmeldung am Router von einer ext. IP?
Frage von BigSnakeyeRouter & Routing13 Kommentare

Hallo, ich habe gerade seltsames in meiner Fritzbox entdeckt. Plötzlich war die Verbindung unterbrochen - kein Internet. Also habe ...

KVM
Performance Verlust durch Virtualisierung
Frage von RalleoniusKVM11 Kommentare

Hallo zusammen, ich überlege meinen Server mit Debian, der als Webserver dient zu virtualisieren um eine 2te Maschine auf ...