Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Registry-Script Probleme - Einträge werden nicht erstellt

Mitglied: DownhillDom

DownhillDom (Level 1) - Jetzt verbinden

17.10.2007, aktualisiert 18.10.2007, 4960 Aufrufe, 4 Kommentare

Hallo zusammen,

habe mir vor kurzem eine eigene Reg-Eintrag-Zusammenstellung geschrieben, aber habe folgendes Problem:
Einträge, die noch nicht existieren, werden trotz Eintrag nicht erstellt.
Änderungen und Löschungen von Einträgen funktionieren problemlos.

Als Anhaltspunkt ein Teil des Scripts...
01.
;Automatisches Suchen nach Netzwerkordnern deaktivieren
02.
[HKEY_CURRENT_USER\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
03.
"NoNetCrawling"=dword:00000001
04.

05.
;MFT-Größe anpassen 25 Prozent des Datenträgers
06.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\FileSystem]
07.
"NtfsMftZoneReservation"=dword:00000002
08.

09.
;Alle Dateien anzeigen lassen
10.
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
11.
"Hidden"=dword:00000001
Hier soll der 2. Eintrag erstellt werden, da er noch nicht existiert.
Ist das von mir ein Syntax-Fehler, oder ein Phänomen? :-P


Zudem kann man ja per Reg-Eintrag die Größe der Auslagerungsdatei bestimmen.
Das klappt leider auch nicht so ganz. Der Scriptteil sieht so aus:
01.
;Auslagerungsdatei für 2GB RAM einstellen
02.
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
03.
"PagingFiles"= "C:\pagefile.sys 3072 3072"
Durch die letzte Zeile wird ja ein REG_SZ-Wert geändert. Der Werttyp ist hier allerdings REG_MULTI_SZ.
Muss ich deswegen etwas spezielles beachten?
Denn diese Vorgaben werden trotz Neustart nicht übernommen.


Hoffe, ihr könnt mir helfen.

Gruß, Dominik
Mitglied: rubberbear
17.10.2007 um 12:24 Uhr
Hi
wie startest du den reg eintrag? (wenn du es remote machst hat der remote nutzer die einstellungen nicht der aktuell angemeldete)
und als wer startest du es?
HKEY_LOCAL_MACHINE kannst du nur als Admin ändern/einfügen (Global für Maschiene)
HKEY_CURRENT_USER ist für jedern Nutzer neu zu setzen (Benutzer Profil)
vieleich hilft das etwas weiter.
Bitte warten ..
Mitglied: DownhillDom
17.10.2007 um 13:57 Uhr
Ich starte es auf dem Rechner als Admin selber.
Was die Schlüssel besagen, weiß ich, aber ich verstehe nicht, wieso die Einträge nicht hinzugefügt werden, sofern sie noch nicht existieren.
Bitte warten ..
Mitglied: Dani
17.10.2007 um 19:07 Uhr
Hi Dominik,
schau dir mal den Befehl "reg add /?" an. Einfach eine Eingabeaufforderung öffnen und eingeben. Damit sollte es dann auf jeden Fall gehen.


Grüße
Dani
Bitte warten ..
Mitglied: DownhillDom
18.10.2007 um 08:28 Uhr
Hallo

Problem hat sich gelöst. Habe in den Tiefen der Google-Ergebnisse einen Hinweis gefunden, dass am Ende einer Reg-Datei mindestens eine Leerzeile sein muss, da es sonst angeblich nicht funktioniert.
Mit einer einzigen hats bei mir nicht geklappt, also hab ich noch 2 dazugemacht und siehe da... es läuft

Trotzdem danke für die Hinweise.
Bitte warten ..
Ähnliche Inhalte
Samba
Registry-Eintrag per Netlogon - Rechte?
Frage von n0varinoSamba4 Kommentare

Hallo, ich habe die Obhut für ein kleines Netzwerk übernommen, welches aktuell noch mit Samba als Domänencontroller läuft. Aus ...

Windows Userverwaltung
Registry Eintrag per GPO ändern
gelöst Frage von ArberBerWindows Userverwaltung10 Kommentare

Hallo, Um im Thema GPOs fit zu werden, hab ich angefangen mich ein wenig damit zu befassen. Ich würde ...

Windows 10

Registry-Eintrag wird bei Neustart verworfen

Frage von bayreuthWindows 107 Kommentare

Hallo miteinander, mein neu geklonter Schul-Computerraum zeigt folgenden Fehler: Nach dem Neustart (über eine pädagogische Oberfläche) wird ein manuell ...

Microsoft

Registry Eintrag für "Zeitlimit für Konsolensperre"

gelöst Frage von Michael.AMicrosoft4 Kommentare

Hallo, Ich möchte das Zeitlimit der Konsolensperre auf 0 setzten, damit dies deaktiviert wird. Dieser Registry Eintrag soll per ...

Neue Wissensbeiträge
Sicherheits-Tools

TrendMicro Worry-Free Business Security 10.0 SP1 - Jetzt in Deutsch verfügbar! (Windows 10 1903 Support)

Tipp von TrinXx vor 10 StundenSicherheits-Tools1 Kommentar

Moin! Nach wochenlangem Warten wird Trend Micro das SP1 für WFBS 10 voraussichtlich am 26.08.19 veröffentlichen. Ich habe das ...

Hyper-V
Setup VM W2016 startet nicht in Hyper-V 2016
Erfahrungsbericht von keine-ahnung vor 1 TagHyper-V4 Kommentare

Moin, sitze gerade über meinem neuen Server und versuche, die VM auf den Host zu prügeln. Jetzt wollte ich ...

Server-Hardware

HPE Proliant ML350P Gen8 Probleme mit Zugriff auf Raid-Volumes

Erfahrungsbericht von goscho vor 1 TagServer-Hardware1 Kommentar

Hallo Leute, das Problemgerät: HPE ML350P G8 Windows Server 2012R2 HyperV-Host 8 x 300 GB 10K SAS HDD (1 ...

Humor (lol)

"Linux und 5 Gründe Warum man kein Windows verwenden sollte sondern Ubuntu Linux"

Information von Snowbird vor 3 TagenHumor (lol)9 Kommentare

Gerade gefunden. Ja, ist etwas älter, aber irgendwie lustig?

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Grafikkarten Angebot auf Amazon
gelöst Frage von NudellordGrafikkarten & Monitore22 Kommentare

Hallo Community, ich suche eine neue Grafikkarte und bin auf die Nvidea Gforce GTX 1080 ti gestoßen. Und dabei ...

Hyper-V
Keine Netzwerkverbindung W2016 VM
gelöst Frage von keine-ahnungHyper-V19 Kommentare

Moin, ich verliere gleich meine contenance ;-). Ich versuche gerade, auf einem Hyper-V 2016 GUI eine W2016-VM (Generation 2 ...

Batch & Shell
Powershell - Webseite auslesen und Abspeichern ein paar Probleme
gelöst Frage von kime203Batch & Shell18 Kommentare

Hallo alle miteinander, ich hab die Aufgabe eine Webseite auszulesen um Einsatzdaten der Feuerwehr daraus zu gewinnen. Das habe ...

Windows 7
Systemwiederherstellung mittel Console und Schattenkopie?
Frage von Kerbel3rdWindows 717 Kommentare

Moin, leider hat mir das Update auf Framework 4.8 meinen Rechner bzw mein Framework zerschossen. Nach tagelangen Reparaturversuchen mittels ...