michi.wtr
Goto Top

Angular Projekt funktioniert nicht mehr

Hey zusammen,

neulich habe ich von einem Kollegen empfohlen bekommen, meine Website mit Angular zu programmieren. Leider habe ich dazu nun absolut keine Erfahrung. Bisher hat alles ganz nett geklappt. Nach der Installation von Node.js konnte ich meine Projekte auf verschiedenen Rechnern auschecken und bearbeiten. Dafür musste ich jedoch jedes mal den Befehl eingeben:
npm install
, da glaube ich in der .gitignore Datei der node_module Ordner nicht mit gespeichert wurde. Hat auch einwandfrei funktioniert, nur geht das ganze nun nicht mehr:
£> npm install
npm ERR! code ERESOLVE
npm ERR! ERESOLVE could not resolve
npm ERR!
npm ERR! While resolving: @angular-devkit/build-angular@16.2.10
npm ERR! Found: @angular/compiler-cli@17.0.6
npm ERR! node_modules/@angular/compiler-cli
npm ERR!   dev @angular/compiler-cli@"^17.0.0" from the root project  
npm ERR!
npm ERR! Could not resolve dependency:
npm ERR! peer @angular/compiler-cli@"^16.0.0" from @angular-devkit/build-angular@16.2.10  
npm ERR! node_modules/@angular-devkit/build-angular
npm ERR!   dev @angular-devkit/build-angular@"^16.2.10" from the root project  
npm ERR!
npm ERR! Conflicting peer dependency: @angular/compiler-cli@16.2.12
npm ERR! node_modules/@angular/compiler-cli
npm ERR!   peer @angular/compiler-cli@"^16.0.0" from @angular-devkit/build-angular@16.2.10  
npm ERR!   node_modules/@angular-devkit/build-angular
npm ERR!     dev @angular-devkit/build-angular@"^16.2.10" from the root project  
npm ERR!
npm ERR! Fix the upstream dependency conflict, or retry
npm ERR! this command with --force or --legacy-peer-deps
npm ERR! to accept an incorrect (and potentially broken) dependency resolution.
npm ERR!
npm ERR!
npm ERR! For a full report see:

Im Log steht dazu:
verbose Windows_NT 10.0.22631
63 verbose node v20.10.0
64 verbose npm  v10.2.3
65 error code ERESOLVE
66 error ERESOLVE could not resolve
67 error
68 error While resolving: @angular-devkit/build-angular@16.2.10
68 error Found: @angular/compiler-cli@17.0.6
68 error node_modules/@angular/compiler-cli
68 error   dev @angular/compiler-cli@"^17.0.0" from the root project  
68 error
68 error Could not resolve dependency:
68 error peer @angular/compiler-cli@"^16.0.0" from @angular-devkit/build-angular@16.2.10  
68 error node_modules/@angular-devkit/build-angular
68 error   dev @angular-devkit/build-angular@"^16.2.10" from the root project  
68 error
68 error Conflicting peer dependency: @angular/compiler-cli@16.2.12
68 error node_modules/@angular/compiler-cli
68 error   peer @angular/compiler-cli@"^16.0.0" from @angular-devkit/build-angular@16.2.10  
68 error   node_modules/@angular-devkit/build-angular
68 error     dev @angular-devkit/build-angular@"^16.2.10" from the root project  
68 error
68 error Fix the upstream dependency conflict, or retry
68 error this command with --force or --legacy-peer-deps
68 error to accept an incorrect (and potentially broken) dependency resolution.
69 error
69 error
69 error For a full report see:
69 error ...\npm-cache\_logs\2023-12-18T17_17_14_266Z-eresolve-report.txt
70 verbose exit 1


Ich bin mit einem Gigacube verbunden, d.h. keine Firewall (außer natürlich meiner Windows Defender Firewall), hat aber zuvor sowieso eigentlich keine Probleme gemacht. Was genau ist mein Problem hier?

Content-Key: 33430144764

Url: https://administrator.de/contentid/33430144764

Printed on: July 24, 2024 at 14:07 o'clock

Member: michi1983
michi1983 Dec 18, 2023 updated at 22:25:49 (UTC)
Goto Top
Hallo,

scheint bekannt zu sein.

Im Prinzip hast du ein Paket installiert welches eine Abhängigkeit auf ein anderes Paket hat dessen Version nicht kompatibel ist mit dem was du nutzt.

Könnte sein, dass es npm ist und du es downgraden musst oder ein anderes Paket in den Abhängigkeiten.

Oder du ignorierst und riskiert es, in dem du die im Link erklärten Parameter mitgibst.

npm install --legacy-peer-deps

Gruß
Member: mbehrens
mbehrens Dec 18, 2023 at 23:12:36 (UTC)
Goto Top
Zitat von @michi.wtr:

Was genau ist mein Problem hier?

Das deutet auf einen Versionkonflikt hin:

Actively supported versions
Member: godlie
godlie Dec 18, 2023 at 23:37:02 (UTC)
Goto Top
Hallo,

die Lösung deines Problemes findest du

error For a full report see:
69 error ...\npm-cache\_logs\2023-12-18T17_17_14_266Z-eresolve-report.txt
70 verbose exit 1

Als Tipp, dass sind gerne alte Dependencies........

grüße
Member: michi.wtr
Solution michi.wtr Dec 19, 2023 at 09:57:35 (UTC)
Goto Top
Quote from @michi1983:

Oder du ignorierst und riskiert es, in dem du die im Link erklärten Parameter mitgibst.

npm install --legacy-peer-deps

Habe ich versucht, stand ja auch in der Hilfe, genau wie
npm install --force

Hat nur leider tausend Warnungen gebracht und am Ende nichts geholfen.

Tatsächlich hat aber ein Kollege herausgefunden was es war. Wir haben in der package.json Datei die Version auf mind. 17.0.0 angehoben und die package-lock.json Datei gelöscht. Nun scheint wieder alles zu funktionieren...

Danke euch face-smile