2 Cisco AIR-LAP1142N-E-K9 als Bridge verbinden

schluetel
Goto Top
Hallo, mein Name ist Mark und habe mich hier gerade angemeldet.

Ich habe mehrere APs Cisco AIR-LAP1142N-E-K9 erhalte, die wurden bei uns in der Firma ausgemustert.
Dank Eurer Seite habe ich rausgefunden, dass ich diese APs mit Hilfe der Standalone-Firmware (c1140-k9w7-tar.152-4.JB4.tar) als Standalone-AP konfigurieren kann.
Das hat auch wunderbar funktioniert, ich habe 2APs bei mir im Haus als W-LAN-Versorgung laufen.

Jetzt möchte ich gerne eine ca. 100m entfernte Werkstatt mit Netztwerk über W-LAN versorgen.
Ein Kabel kann ich leider nicht legen.

Jetzt möchte ich gerne 2 AIR-LAP1142N-E-K9 als Bridge verbinden. Also: LAN-Kabel - W-LAN-Verbindung mit 2APs - LAN-Kabel.

In der Konfiguration kann ich ja alles mögliche einstellen:

screenshot 2022-05-29 151213

Ich habe es aber nicht hinbekommen, dass die beiden APs sich finden.

Kann mir da jemand weiterhelfen?

Meine Erfahrungen mit Cisco sind gleich Null. Ich habe zwar mal eine Umschulung zum IT-Systemelektroniker gemacht, aber nie in dem Beruf gearbeitet.
In meinem Beruf betreue ich MSR-Steuerungen von Lüftungs- und Klimaanlagen.
Grundkenntnisse in der Netzwerktechnik sind vorhanden.

Vielen Dank im voraus!

Mark

Content-Key: 2929626981

Url: https://administrator.de/contentid/2929626981

Ausgedruckt am: 07.08.2022 um 17:08 Uhr

Mitglied: aqui
aqui 30.05.2022 aktualisiert um 11:08:46 Uhr
Goto Top
Hilfreich wäre zu wissen WAS du denn schon gemacht hast um dein Ziel zu erreichen??
Die APs wie im Screenshot als APs zu betreiben und NICHT als Bridge wie sie eigentlich arbeiten sollen bei dir ist ja falsch und damit klar das du dann scheitern musst.
https://www.cisco.com/c/de_de/support/docs/wireless/aironet-1200-series/ ...
https://www.cisco.com/c/en/us/td/docs/wireless/access_point/15-3-3/confi ...
Mitglied: schluetel
schluetel 30.05.2022 um 20:50:51 Uhr
Goto Top
Ja, das ist der Zustand nachdem die APs auf Werkszustand zurückgesetzt habe, weil gar nichts mehr ging.

Ich werde die APs als Universal Workgroup Bridge konfigurieren.
Als Client MAC verwende ich die LAN-MAC des jeweiligen Partners?

Ich denke mit Hilfe der Anleitungen werde ich das hinkriegen.

Danke erst mal!

Mark
Mitglied: aqui
aqui 30.05.2022 um 21:11:55 Uhr
Goto Top
Client Mac brauchst du nicht bei einer Bridge.
Ich denke mit Hilfe der Anleitungen werde ich das hinkriegen.
👍 Ansonsten einfach fragen...
Mitglied: schluetel
schluetel 31.05.2022 um 17:54:35 Uhr
Goto Top
Ich habe versucht der Anleitung zu folgen.
Hier die Konfiguration eines APs, den anderen habe ich genauso konfiguriert.

Kann jemand da einen grundlegenden Fehler entdecken?

1
2
3
4
5
6
7
8
9

Vielen Dank an Euch!

Mark
Mitglied: aqui
aqui 01.06.2022 aktualisiert um 10:11:53 Uhr
Goto Top
Konfig sieht soweit gut aus. Was aber oben fehlt ist die Definition der SSID des bestehenden APs bzw. WLAN Netzes auf das der Workgroup Bridge AP connecten soll. face-sad
Ein show logg des Connect im WGB AP wäre noch hilfreich.

Im Grunde ist es kinderleicht...
  • Du definierst global die SSID des bestehenden Root APs auf den du connecten willst
  • Ggf. Passwort und WPA2 sofern der bestehende Root AP verschlüsselt, was ja üblich ist
  • Auf dem Radio Interface dann einfach nur die Role "workgroup bridge" aktivieren und gut iss.
Das wird dir alles nochmal ganz genau in dem Video hier erklärt:
https://www.youtube.com/watch?v=yoP8SkMaUIc
(AAP = Autonomous AP)
Mitglied: aqui
aqui 27.06.2022 um 14:59:47 Uhr
Goto Top
Wenn es das denn nun war bitte dann auch deinen Thread hier als erledigt schliessen!
Mitglied: schluetel
schluetel 27.06.2022 um 16:10:10 Uhr
Goto Top
Bis jetzt kann ich noch keinen Erfolg vermelden, leider.
Mir fehlt im Moment allerdings die Zeit.

Mark
Mitglied: aqui
aqui 27.06.2022 um 18:53:39 Uhr
Goto Top
Hast du bedacht das die Cisco Bridge Funktion ausschliesslich nur zwischen 2 Cisco APs funktioniert?!
Sie funktioniert nicht mit einem Bridging auf einen Hersteller fremden AP also z.B. direkt auf einen FritzBox AP usw.
Mitglied: schluetel
schluetel 27.06.2022 um 19:09:48 Uhr
Goto Top
Ja, ich will 2 Cisco AIR-LAP1142N-E-K9 verbinden.
Mittlerweile glaube ich dass ich eine Punkt zu Punkt Verbindung brauche um zwei LAN-Netze zu verbinden.
Ich habe diese Anleitung gefunden: Link
Allerdings sind dort andere APs beschrieben, die scheinbar etwas anders konfiguriert werden.
Daran verzweifel ich etwas.

Mark
Mitglied: aqui
aqui 28.06.2022 um 09:18:18 Uhr
Goto Top
Die reine Bridge Option ginge auch. Beide Optionen Work Groupe Bridge oder Bridge lösen dein Problem und führen zum Erfolg.
Die Workgroup Bridge hätte aber den Vorteil das ein AP weiter aktiv als Accesspoint genutzt werden kann z.B. zur Erweiterung des WLANs an den die WGB dann ankoppelt. Bei der reinen Bridge geht das nicht, da sind beide APs dedizierte Bridges.
Es wäre sehr hilfreich gewesen deine Konfigs hier einmal mit show run zu posten. So hätte man sofort sehen können wo du deinen Konfig Fehler begangen hast.
Mitglied: schluetel
schluetel 28.06.2022 um 11:39:02 Uhr
Goto Top
Es wäre sehr hilfreich gewesen deine Konfigs hier einmal mit show run zu poste n

Wie mache ich einen show run ?

Die Workgroup Bridge hätte aber den Vorteil das ein AP weiter aktiv als Accesspoint genutzt werden kann z.B. zur Erweiterung des WLANs an den die WGB dann ankoppelt.


Das wäre nicht so wichtig, von den Dingern habe ich genug! Ich wollte es so einfach wie möglich halten.

Mark
Mitglied: aqui
aqui 28.06.2022 aktualisiert um 14:23:23 Uhr
Goto Top
Wie mache ich einen show run ?
Oha...solltest du als Cisco Profi aber eigentlich wissen... face-wink
Entweder die Konsole des APs über ein USB-Seriell Adapter anschliessen.
Oder du machst via PuTTY Terminal eine Telnet oder SSH Verbindung via Netzwerk auf die IP des APs auf. Analog wie du es mit dem GUI und Browser schon kennst.

Dort dann mit enable in den Admin privileged Mode wechseln ("#" im Eingabeprompt) und dann einfach show run eingeben.
Das gibt dir dann deine AP Konfig als einfache Textdatei aus.
Siehe auch HIER.

Schnellübersicht der Cisco Terminal Kommandos findest du u.a. hier:
https://www.coufal.info/cisco_ios/

Nebenbei:
Richtig zitieren machst du mit einem "> " direkt am Zeilenanfang VOR dem Text den du zitieren willst!! FAQs lesen hilft. face-wink
Mitglied: schluetel
schluetel 28.06.2022 um 14:50:43 Uhr
Goto Top
>Es wäre sehr hilfreich gewesen deine Konfigs hier einmal mit show run zu posten. So hätte man sofort sehen können wo du deinen Konfig Fehler begangen hast.
Das kriege ich jetzt hin, hoffe ich.face-wink face-wink

ap#show run
Building configuration...

Current configuration : 1780 bytes
!
! Last configuration change at 00:25:00 UTC Fri Mar 1 2002
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret 5 $1$Lko4$JEHdfTSIvRmvl5b7QdyVE.
!
no aaa new-model
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid Cisco
authentication network-eap eap_methods
!
!
dot11 guest
!
!
!
username Cisco password 7 13261E010803
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
shutdown
!
ssid Cisco
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
shutdown
!
ssid Cisco
!
antenna gain 0
peakdetect
no dfs band block
speed 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address 192.168.178.60 255.255.255.0
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip default-gateway 192.168.178.1
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
transport input all
!
end


Das ist der eine.
Hier kommt der andere:

ap#show run
Building configuration...

Current configuration : 2691 bytes
!
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname ap
!
!
logging rate-limit console 9
enable secret 5 $1$cCDo$tWSgr1S9o7m0jWihBiiUK/
!
aaa new-model
!
!
aaa group server radius rad_eap
server name 192.168.178.59
!
aaa group server radius rad_mac
!
aaa group server radius rad_acct
!
aaa group server radius rad_admin
!
aaa group server tacacs+ tac_admin
!
aaa group server radius rad_pmip
!
aaa group server radius dummy
!
aaa authentication login eap_methods group rad_eap
aaa authentication login mac_methods local
aaa authorization exec default local
aaa accounting network acct_methods start-stop group rad_acct
!
!
!
!
!
aaa session-id common
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid Cisco
authentication network-eap eap_methods
guest-mode
mbssid guest-mode
infrastructure-ssid
!
!
dot11 guest
!
!
!
username Cisco password 7 096F471A1A0A
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
shutdown
!
encryption key 1 size 128bit 7 0B4859701297F1AFFB1439656A93 transmit-key
encryption mode wep mandatory
!
ssid Cisco
!
antenna gain 0
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
!
encryption key 1 size 128bit 7 5FD518A21653D183FB3B0AA56FCA transmit-key
encryption mode wep mandatory
!
ssid Cisco
!
antenna gain 0
peakdetect
no dfs band block
speed basic-6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15.
channel dfs
station-role root bridge
bridge-group 1
bridge-group 1 spanning-disabled
!
interface GigabitEthernet0
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.178.59 255.255.255.0
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip default-gateway 192.168.178.1
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
!
radius-server local
nas 192.168.178.59 key 7 0625062243
user NonRoot nthash 7 112F4B20404A5C28577D7D070A156306452332505706090900062B5A3B44080D73
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
radius server 192.168.178.59
address ipv4 192.168.178.59 auth-port 1812 acct-port 1813
key 7 112A1016141D
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
transport input all
!
end


Ich habe wieder was gelernt. face-wink face-wink

Mark
Mitglied: aqui
Lösung aqui 28.06.2022, aktualisiert am 30.06.2022 um 11:02:56 Uhr
Goto Top
Damit das Drama hier nun endlich einmal ein Ende hat...
Vorab:
Bitte benutze unbedingt Code Tags für das Posten von Konfig Code!! Das erhöht die Lesbarkeit und hilft allen.
Hier eine sauber funktionierende Lösung. Hat gerade mal 10 Minuten gekostet die Konfig auf die beiden APs zu bringen.

back-to-topTest Setup

wgb

back-to-topKonfig AP1: Accesspoint

(Die Default Kommandos der Übersicht halber weggelassen!)
!
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime localtime
service timestamps log datetime localtime show-timezone year
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 ssid Bitschleuder
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii test1234567
!
interface Dot11Radio0
description 2,4 GHz Radio
speed only-ofdm
encryption mode ciphers aes-ccm
ssid Bitschleuder
!
sntp server ntp0.fau.de


back-to-topKonfig AP2: Workgroupe Bridge

!
dot11 ssid Bitschleuder
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii test1234567
!
interface Dot11Radio0
description 2,4 GHz Radio
speed only-ofdm
encryption mode ciphers aes-ccm
ssid Bitschleuder
station-role workgroup-bridge
!
sntp server ntp0.fau.de


back-to-topStatus Messages und Bridge Checks

Wichtig ist hier die "Associated To AP ap2702 286f.7f32.7ca0 [None WPAv2 PSK]" Logmessage. Diese zeigt das sich die WGB Bridge erfolgreich mit dem AP verbunden hat.

Mac Adressen und Bridging Access Point:
Mac Adressen und Bridging Workgroup Bridge AP:

back-to-topFinaler Ping Check vom Test PC zum Router via Cisco Bridge

pcheck

back-to-topDeine Fehler

Weiss man gar nicht wo man anfangen soll. face-sad
Deine beiden APs oben sind vollkommen unsinnig und wirr konfiguriert was du ja auch sicher selber siehst, wenn du deine Konfig oben mit der funktionierenden vergleichst. Der eine mit externer Radius EAP Authentisierung aber mit völlig fehlerhafter SSID. Der andere auch mit Radius und einer völlig unsinnigen Konfig die NICHT zu deinem Vorhaben passt. Vergiss den Unsinn also.
Wie sinnfrei deine Konfigs sind kannst du ja selber im Vergleich mit den Cisco AP Beispielkonfigs sehen.
Oben wurdest du schon mehrfach darauf hingewiesen hast das aber wohl völlig ignoriert. face-sad
Logisch natürlich das das völlig in die Hose gehen MUSS wenn man so unstrukturiert und ignorant vorgeht!! Da hilft dann auch das beste Forum nix.

back-to-topDeine ToDos

  • Lösche mit erase startup-config oder write erase erstmal deine unsinnigen Konfigs auf beiden APs. (Reset auf die Factory Defaults!)
  • Achtung!! Der AP legt immer auch eine Backup Konfig im Flash ab. Ein show flash: zeigt dir den Inhalt des Konfig Flashspeichers. Die beiden Dateien config.txt und config.txt.bak müssen beide gelöscht sein VOR dem Reboot. Das geht mit del flash:config* Die Abfrage ob er löschen soll quittierst du mit der Eingabetaste. Wenn die .bak Datei nicht gelöscht wird scheitert der Reset.
  • Danach die APs rebooten. (Stromlos machen oder Kommando "reload") Sie kommen dann mit einer jungfräulichen Konfig wieder hoch. (Factory Defaults)
  • Den einen AP im Accesspoint Mode (Router Seite) mit der o.a. Konfig konfigurieren. Kommandos kannst du per cut and paste nach Eingabe von conf t einfach eingeben. Ggf. die SSID nach deinem Wunsch anpassen. Am besten immer identisch zu einer ggf. schon bestehenden Heimnetz SSID wenn dort schon ein WLAN Router oder AP rennt!
  • Auf dem 2,4 GHz Interface unbedingt speed only-ofdm konfigurieren
  • Auf dem 5 GHz Interface unbedingt speed throughput konfigurieren und die Bandbreite mit channel width 40-above erhöhen.
  • Dann den AP der die Workgroup Bridge ist konfigurieren. Tip: Du solltest die Bridge wenn immer möglich unbedingt im störungsarmen und deutlich performanteren 5 GHz WLAN Band betreiben!! (Hier im Beispiel ist der Einfachheit halber 2,4 GHz genutzt, was eher kontraproduktiv ist wegen der Überfüllung und geringeren Bandbreite!) Also unbedingt das 2,4GHz Radio (Interface dot11 0) dann ausschalten (Shutdown) mit dem Kommando shut !! Nur wenn die 2,4er Feldstärke partout nicht reichen sollte machst du es genau andersrum. (5er auf shut und nur 2,4er betreiben. 2,4 ist aber die schlechtere Wahl!) Auf der WGB sollten NICHT beide WLAN Radios aktiv sein sondern immer nur eins!
  • Wichtig: Das Kommando station-role workgroup-bridge auf dem Radio Interface des WGB Bridge APs nicht vergessen! Der Rest der Konfig ist sonst bei beiden APs gleich.

Ist auch alles, wie am Anfang schon gesagt, in einem YouTube Video nochmal erklärt:
https://www.youtube.com/watch?v=yoP8SkMaUIc
Mitglied: schluetel
schluetel 29.06.2022 um 15:14:43 Uhr
Goto Top
Hallo,
danke für Deinen unmissverständlichen Ansagen! (Das meine ich wirklich ernst!)
Mir fehlt einfach die Erfahrung.

Ich habe die beiden APs jetzt genau nach Deinen Angaben konfiguriert über Putty mit Konsolen-Kabel.
Die beiden APs verbinden sich, und ich kann mich auf dem Werkstatt-AP per W-Lan einloggen und habe eine Internet-Verbindung.
Alles Super!
Auch eine LAN-Verbindung mit einem PC funktioniert!

Vielen Dank an Dich, aqui!

Kann ich mich irgendwie bei Dir oder Euch bedanken? Habt Ihr eine Spendenmöglichkeit per PayPal für Euer Forum?

Mark
Mitglied: aqui
aqui 30.06.2022 aktualisiert um 11:30:38 Uhr
Goto Top
Glückwunsch! 👏👍
So sollte es sein und dafür ist ein Forum ja auch da. Spenden muss man da nix. Dafür lädst du dann die Trautholdeste zum Eis essen ein!!! Oder...zeigst ihr mal die Werkstatt im Dunkeln! 😉
Mitglied: schluetel
schluetel 30.06.2022 um 11:26:20 Uhr
Goto Top
Das mache ich gerne!

Falls jemand von Euch aus der Nähe von Kiel kommt, den würde ich auf ein frisch gezapftes selbst gebrautes Bier einladen!

Vielen Dank für Eure bzw. Deine Hilfe.

Mark