Confluence SSO funktioniert nach Domainänderung nicht mehr

josephusflavius
Goto Top
Hallo,

unser Confluence-Domain hat sich geändert.

Der SAML-Plugin ist soweit eingerichtet und mit dem ADFS-Server verbunden. Trotzdem kommt eine Fehlermeldung bei Anmeldung.

Wenn ich mir die Einstellungen des Plugins unter "Service Provider" anschaue, stimmen Entity ID und die Zertifikat-Details unter "Service Provider Certificate" nicht überein.

Entity ID hat schon die neue Domain. Das Zertifikat ist aber noch fürs alte Domain ausgestellt worden.
Dasselbe Zertifikat habe ich auch auf dem ADFS für diese Vertrauensstellung gefunden.

Frage:

1. kann ich das Zertifikat getrennt erneuern oder muss ich die komplette Vertrauensstellung neu einrichten?
2. Wie auf dem Screenshot zu sehen ist, ist dieses Zert explizit für SSO ausgestellt worden. Es ist also richtig, dass es keinen Sinn ergibt hier das neu generierte SSL Zertifikat für HTTPS reinzukopieren? Falls nein, wo kann ich ein neues Zertifikat generieren? Direkt auf ADFS?

conf

oder generiere ich dieses Zert direkt in dem Plugin ("generate new private key and certifikate)?

Vielen Dank für eure Meinungen.

JoFla

Content-Key: 2945628206

Url: https://administrator.de/contentid/2945628206

Ausgedruckt am: 19.08.2022 um 08:08 Uhr

Mitglied: Dani
Dani 31.05.2022 um 20:20:39 Uhr
Goto Top
Moin,
Trotzdem kommt eine Fehlermeldung bei Anmeldung.
Wie lautet die Fehlermeldung?

Dasselbe Zertifikat habe ich auch auf dem ADFS für diese Vertrauensstellung gefunden.
Das ist so auch korrekt. Sowohl im AD FS als auch Confluence. DAs muss identisch sein!

Ist das Zertifikat evtl. abgelaufen? Wäre ein sehr unglücklicher Zufall.


Gruß,
Dani