Drucker per Batch installieren unter Windows 7 - Treiber wird nicht gefunden

Mitglied: Aurora15

Aurora15 (Level 1) - Jetzt verbinden

25.07.2011 um 12:46 Uhr, 19137 Aufrufe, 6 Kommentare

Hallo,

Ich suche nun schon länger nach einer Lösung für mein Problem, da ich bis jetzt aber nichts dergleichen gefunden habe wende ich mich nun an Euch:
Ich versuche mit folgendem Befehl:
einen Drucker zu installieren. Unter XP (32bit) klappt dies ohne Probleme, aber unter Windows 7 (64bit) kommt immer die Fehlermeldung "Es wurde kein Treiber gefunden" (nachdem kurz über Windows Updates nach Treiber gesucht wird)
Die entsprechenden Treiber sollten allerdings auf dem Druckerserver bereitliegen und unter Windows 7 funktionieren, eine manuelle Installation eines Druckers funktioniert nämlich tadellos, sobald man dasselbe mit printui.dll lösen möchte geht es aber aus oben genanntem Grund nicht.
Ich dachte, dass es evtl. ein Fehler der dll sein könnte und habe kurz getestet, ob es mit anderer Software möglicherweise gehen würde, aber "con2prt" hat das genau das gleiche Problem.

Ist das Problem tatsächlich der Treiber? Und wenn ja, wieso funktioniert dann die manuelle Installation, die müsste doch theoretisch ebenfalls wegen fehlenden Treiber scheitern?

Danke für Eure Hilfe
Gruss
Aurora
Mitglied: SHuesken
25.07.2011 um 12:58 Uhr
Wir hatten ein ähnliches Problem:

Wir binden per Loginscript die Netzwerkdrucker unserer Domaine an die WinXP Pro Geräte. Dort gibt es kein Problem. Als Server dient ein 32 Bit Win 2003 RC 2 Server.

Beim Login mit einer Win7 64bit Maschine hatten wir dann auch das Problem, dass er die Treiber nicht automatisch einlesen wollte.

Wir haben das Problem dann umgangen, indem wir die Treiber für 64bit Systeme auf dem 2003 Server hinterlegt haben.
ABER: Wir mussten die inf-Dateien der Treiber so anpassen, dass die Drucker in den Dateien genau so benannt waren wie in den 32 Bit treibern.

Beispiel:
32 Bit: HP LJ4200 PCL5e
64 Bit: Hewlett Packard LJ4200 PCL5 -> geändert auf HP LJ4200 PCL5e

Nach der Änderung und einem neuen durchlauf des Login-Scriptes wurde an der Win7 Maschine dann nur noch die Adminzustimmung abgefragt und dann ging alles.

Gruss
SHuesken
Bitte warten ..
Mitglied: GuentherH
25.07.2011 um 13:54 Uhr
Hallo.

Dürfte wahrscheinlich dein Problem sein - http://www.faq-o-matic.net/2009/10/08/drucken-unter-windows-7-in-der-do ...

LG Günther
Bitte warten ..
Mitglied: Aurora15
25.07.2011 um 14:56 Uhr
Danke vielmals für die schnelle Antwort an Euch beide.
In dem Fall geht es per Batch tatsächlich nur mit 64bit Treiber- wie befürchtet, aber wenn es so ist, dann ist es eben so.
Trotzdem ist es sehr seltsam, dass die manuelle Einrichtung damit anscheinend keine Probleme hat, dies sollte doch eigentlich einfach eine grafische Lösung von printui.dll sein? (also auch in etwa gleich funktionieren)

Danke auch dir Günther, dies war zwar nicht direkt mein Problem, aber das würde schon mal erklären wie man die Adminabfrage wegbekommen würde, was sehr wahrscheinlich meine nächste Frage gewesen wäre. Wobei diese Lösung wahrscheinlich nicht funktionieren wird, da unser Druckerserver noch mit Windows 2003 läuft..

Was mir noch aufgefallen ist: Die manuelle Installation mit Treiberinstallation funktioniert nur mit Adminrechten und per Hostname, bzw. TCP/IP-Adresse.. Versucht man ihn über den "\\Druckerserver\Druckernamen" zu installieren kommt wieder die Fehlermeldung, dass der Treiber nicht gefunden werden kann.

Gruss
Aurora
Bitte warten ..
Mitglied: SHuesken
25.07.2011 um 15:37 Uhr
Vergleich bitte einmal die "alten" WinXP Treiber und die "neuen" Win7 Treiber. Speziell die inf.Dateien und wie die Drucker dort heißen. :) face-smile Wie bereits oben geschrieben war das bei uns das Problem, da die "neuen" Treiber auf den alten Namen umgeschrieben werden mussten.

mfg
SHuesken
Bitte warten ..
Mitglied: Aurora15
26.07.2011 um 15:54 Uhr
Leider habe ich persönlich keinen Zugriff auf den Druckerserver- ich bin nur für die Entwicklung eines kleineren Programmes zuständig, aber ich werde auf alle Fälle das mal an die zuständigen Leute weiterleiten. Danke für die Tipps, falls es nicht funktionieren sollte, melde ich mich mal zurück :) face-smile

Gruss
Aurora
Bitte warten ..
Mitglied: mayho33
20.06.2012 um 22:07 Uhr
Hi!

Also als erstes mittels pnputil den Treiber manuell installieren, so ist er sicher einmal im richtigen Repository vorhanden und auch bereits installiert. Danach kannst du den Drucker wie gewohnt bereitstellen: Hier ein Beispiel:

rundll32 printui.dll,PrintUIEntry /if /q /b "TestPrinter" /r "USB:" /m "HP Color LaserJet 2800 Series PS" /z /f "%systemroot%\inf\ntprint.inf"
Bitte warten ..
Heiß diskutierte Inhalte
MikroTik RouterOS
Simples VLAN bringt mich zur Verzweiflung
gelöst Daniel26Vor 1 TagFrageMikroTik RouterOS30 Kommentare

Moin, ich bin sehr neu im Mikrotik-Bereich, aber schon dabei, aufzuegeben. Wir verbauen in unserer Hardware Switche von Mikrotik. Bisher waren da Netgear-Teile drin, ...

LAN, WAN, Wireless
Switch läuft, ist aber nicht erreichbar
gelöst AndiPeeVor 1 TagFrageLAN, WAN, Wireless19 Kommentare

Hallo zusammen, mein Problemfall einleitend kurz umrissen: Privates Netzwerk Es funktioniert grundsätzlich, allerdings habe ich immer mal ein paar Ausfälle im WLAN-Netzwerk und bin ...

Microsoft
STRG + ALT + ENTF
TezzlaVor 22 StundenAllgemeinMicrosoft12 Kommentare

Mahlzeit zusammen, wir haben gerade im Kollegenkreis über Sinn und Unsinn der Sperrbildschirmentriegelung STRG + ALT + ENTF unter Win10 diskutiert. Mich würde hierzu ...

Windows 10
SMB Performance VPN
Guhl22Vor 1 TagFrageWindows 104 Kommentare

Hallo zusammen, wir stellen bei uns in der Firma ein sehr merkwürdiges Phänomen fest. Zugriffe über VPN auf gemappte Netzlaufwerke (über vbs Logon Skript ...

Video & Streaming
Streamingplattform mit eigenen Servern
gelöst icegetVor 23 StundenFrageVideo & Streaming5 Kommentare

Hallo liebe Community, ich würde gerne via Amazaon AWS (oder andere Cloudanbietern) mehrere Serverinstanzen (Streaming) starten, um z.B. 2000 Personen den selben Stream den ...

E-Mail
Alternative zu horde webmail
fisch56Vor 1 TagFrageE-Mail6 Kommentare

Hallo, ich habe das horde webmail auf meinem Server, macht allerdings Probleme. Suche daher eine Alternative. Das Postfach hat viele Unterordner, die z.B. bei ...

Windows Server
Nutzer als lokaler Admin in Windows Server 2019
hanheikVor 1 TagFrageWindows Server6 Kommentare

Hallo, in SBS 2011 konnte ich ganz einfach einen Nutzer als lokalen Admin einstellen. Windows fragte dann, für welchen Rechner; Rechner auswählen; fertig! In ...

Switche und Hubs
Zwei Lancom GS-315XP Switche VLAN verbinden
wieoderwasVor 1 TagFrageSwitche und Hubs14 Kommentare

Hallo zusammen, wir haben zwei neue Lancom GS-315XP Switche bekommen. An einem dieser Switche sind Lancom Accesspoints angeschlossen. Ich verzweifel gerade an der Verbindung ...