Eintrag Vista in boot.ini des XP Betriebssystem

xaverdunn
Goto Top
Hallo,

ich habe XP und Vista installiert, allerdings so das kein Bootmanager erscheint.
Die Installationen sind auf einer Festplatte, die in 2 primäre und eine erweiterte Partition eingeteilt worden ist. Nach dem hochfahren von XP kann ich den nächsten Start in der Datenträgerverwaltung für Vista einleiten. Dann setze ich Partition E:\ als aktiv. Umgedreht kann ich das dann unter Vista auch um beim nächsten Start XP hochzufahren.
4f32e80816da4569c8290d2b78e3173c-os
Vorteil der Sache ist, man kann Vista sehr leicht wieder vom Rechner entfernen ohne Probleme, da der MBR von Vista in der eigenen und nicht in der XP Partition liegt. Weiterhin habe ich über
XP Drive Image 7 installiert und ein Image von Vista gemacht. Neuinstallation des Vista innerhalb 20 min möglich.
Nun möchte ich Vista mal in die boot.ini von XP eintragen, so das man gleich beim Hochfahren auswählen kann.
Hier die ursprüngliche boot.ini von XP:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect

Ja nun fehlt noch der Eintrag von Vista.
Kann mir da jemand behilflich sein?

MfG Xaverdunn

Content-Key: 67361

Url: https://administrator.de/contentid/67361

Ausgedruckt am: 19.05.2022 um 04:05 Uhr

Mitglied: lebeART
lebeART 18.12.2008 um 22:45:19 Uhr
Goto Top
Hallo, hatte das Problem das ich Vista auf die 2te Partition einer Platte installiert habe, auf der 1ten Partition lag XP...

Lief auch ewig Super, aber als ich Probleme mit XP hatte und ein Update gefahren habe waren die Vista Boot Einträge der boot.ini verschwunden.... (logisch)

Konnt Vista nicht mehr Booten.

Habe die Boot.Ini der XP Version geändert:

[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Windows VISTA

danach kommt zumindest wieder ein Starteintrag, aber Vista bootet immer noch nicht, es zeigt sich nur ein weisser blinkender Cursor...

Jetzt mit der Vista CD Booten und "Computerreperaturoptionen" wählen. Bei mir hat er Autmatisch die Vista Partition gefunden und den Fehler behoben...

Jetzt Bootet Vista wieder normal wenn es in den Startoptionen wähle...

LG