carlehmann
Goto Top

ERP Software (SQL DB) lädt beim Start am Client im Netzwerk langsam ?

Moin ins Forum,

wir haben in der Firma eine ERP Software M-Soft Business 5 im Einsatz u. suchen Verbesserungsmöglichkeiten mit der Geschwindigkeit beim Laden der einzelnen Module. Die Firma haben wir natürlich schon kontaktiert u. die haben so auch keine Ideen mehr.

Die SQL-Datenbank wird auf einer Windows Server VM gehostet. Da das ERP modular aufgebaut ist, lädt das System pro Modulstart (Startmodul, Modul Bestellwesen, Modul Statistik, Modul Kalkulation usw.) von einer Windows Freigabe auf dem Application Server (auch Windows Server VM) die Exe Dateien also bei Bedarf auf den Client. Diese Dateien sind alle ca. 70 MB groß, ein Start pro Modul dauert aber einige Sekunden (20-40).

Wir haben schon den Pfad in der Sicherheitssoftware (With-Secure, vorher F-Secure) mit aufgenommen, erzielen damit aber kaum messbare Verbesserung.

Hat jemand hier noch Ideen / Vorschläge? Der SQL Server hat aktuell 32 GB RAM, Hardware ist auch nicht mehr die neueste. Aber daran möchten wir aktuell aus mehreren Gründen nicht schrauben.

Gruß
Carsten Lehmann

Content-Key: 34169334844

Url: https://administrator.de/contentid/34169334844

Printed on: May 20, 2024 at 12:05 o'clock

Member: flo72it
flo72it Apr 17, 2024 at 17:38:20 (UTC)
Goto Top
Moinmoin,

kurzfristig würde ich ein Monitoring-System aufsetzen um herauszufinden wo genau die Zeit verlorengeht (SQL-VM, Fileserver, Appserver-VM, Hypervisor(s), client).

Mittelfristig würde ich eine derart altertümliche Software-Architektur loswerden wollen und durch was halbwegs modernes ersetzen. exe-Dateien über Freigabe kopieren klingt stark nach letztem Jahrtausend. Und da der Hersteller ja offenbar nicht einmal Ideen hat wie man herausfindet wo die Zeit verlorengeht ist eine Abkehr von ihm sicherlich nicht verkehrt.

Viele Grüße, Flo
Member: wiesi200
wiesi200 Apr 17, 2024 at 17:55:43 (UTC)
Goto Top
Hallo,

das Verhalten Module beim starten auf Server share fund ich auch etwas "merkwürdig" bzw. Veraltete. Aber gut muss nichts bedeuten.

Wie verhält sich der Start am Server? Dann könnte man mal einen Server ohne Virtualisierung laufen lassen. Welche SQL Datenbank ist am Start? Der freie von MS nutz sehr wenig Ressourcen.
Eftl. mal den SQL Query Analyzer mitlaufen lassen, vielleicht liegt es nicht am SQL. Klassisches Debugging/ Fehlersuche eben
Member: mbehrens
mbehrens Apr 17, 2024 at 18:33:47 (UTC)
Goto Top
Zitat von @Carlehmann:

wir haben in der Firma eine ERP Software M-Soft Business 5 im Einsatz u. suchen Verbesserungsmöglichkeiten mit der Geschwindigkeit beim Laden der einzelnen Module. Die Firma haben wir natürlich schon kontaktiert u. die haben so auch keine Ideen mehr.

Einfach mal das Monitoring anwerfen (Hypervisior, Hardware, DB, Software, Netzwerk, ...) um das ganze mal quantifizierbar zu machen. Gefühlte Geschwindigkeit ist ein schlechtes Merkmal.

Die VM des unbekannten Datenbankservers wird wohl für die 60 Mitarbeiter unterdemensioniert zu sein. Drehende Platten sind hier auf jedem Fall auch nicht zielführend. Der eine zugewiesene Kern wird wohl auch nicht reichen face-wink
Member: Carlehmann
Carlehmann Apr 18, 2024 at 04:45:08 (UTC)
Goto Top
Hallo Flo,

da ich IT-Allrounder bin (also breit aber nicht tief aufgestellt), bräuchte ich hier etwas Input.

Der Hersteller hatte schon mal versucht mittels Wireshark den Netzwerkverkehr (alles 1 GBit) zu analysieren -> und meinte das Netzwerk wäre der Flaschenhals aber ohne das konkret zu begründen. Für so eine Analyse reichen aber meine Kenntnisse nicht aus -> in solchen Fällen hätte ich aber einen Dienstleister, auf den ich zugreifen kann.

Ja, die Software soll aktuell noch ein paar Jahre laufen, damit müssen wir im Moment leider leben.

Gruß
Carsten
Member: kpunkt
kpunkt Apr 18, 2024 at 04:59:03 (UTC)
Goto Top
Die Aussage vom Hersteller kann man da gerne anzweifeln. Weil im Zweifel deuten die auch nur dahin, wohin sie nicht Schuld sind.
Generell wäre es aber keine schlechte Idee, das mal zu überprüfen. Kann ja doch immer sein, dass da im LAN was quersteckt oder was dazwischenfunkt. Wireshark ist ja nicht schlecht, aber dnn ohne Begründung und das konkrete Benennen des Flaschenhalses ist das eher meh.
Ich würd da an einen Dienstleister rantreten und dem das überprüfen lassen. Und wenn der nix findet ist ja dann wieder der Hersteller dran.
Hilft halt den MA jetzt so kein bisschen, ist aber der erste Weg. Und dann auch die Ressourcen von denen überprüfen lassen, muss ja nicht das LAN der Schuldige sein.
Member: MysticFoxDE
MysticFoxDE Apr 18, 2024 updated at 05:26:34 (UTC)
Goto Top
Moin @Carlehmann,

Hat jemand hier noch Ideen / Vorschläge? Der SQL Server hat aktuell 32 GB RAM, Hardware ist auch nicht mehr die neueste. Aber daran möchten wir aktuell aus mehreren Gründen nicht schrauben.

Wie man das Windows 10 und 11 TCP-Handling wieder desuboptimieren kann

und das ist nur ein kleiner Auszug an dem was man alles optimieren kann/muss. 😔

Verwendet ihr zufällig Hyper-V als Hypervisor?

Gruss Alex

P.S.

Auch das könnte das Problem sein, zumindest eines davon.

Defender lässt sich bei Windows 11 22H2 nicht mehr deaktivieren. :-(
Member: Carlehmann
Carlehmann Apr 18, 2024 at 05:25:42 (UTC)
Goto Top
Also, vielleicht hilft das noch ein wenig:

Hardware Blech:
Xeon E5-2420 1,90 Ghz (2xProzessoren)
128 GB RAM, HP Logical SCSI Disk 2 TB
VMs laufen auf einer Fusion mit 3 TB (SSD über so eine ioMemory Steckkarte von HP)
Hyper-V Generation 2.

Application VM:
Hier ist das ERP installiert; 12 GB RAM, 4 x virtuelle Proz.,
Netzwerk 10 Gbit über SFP

Datenbank VM:
SQL Server, 42 GB RAM, 6 x virtuelle Proz.
Netzwerk 10 Gbit über SFP


Gerade mal die Sekunden gestoppt:

ERP Start Modulstart bis Login Modul1
Application VM: 28 sec 45 sec
Datenbank VM: 1:17 min 58 sec

Client1 über WLAN: 32 sec 10 sec
Client2 über LAN: 23 sec 21 sec
Client3 über LAN: 12 sec 20 sec
Member: ReissT
ReissT Apr 18, 2024 at 05:29:23 (UTC)
Goto Top
Ein paar allgemeine Ideen:

- Sind die Virtualisierungshost mit 10GB angebunden und auch aktiv?
- Ist in den BIOS Einstellungen vom Virtualisierungshost die Energiespareinstellung auf "Höchstleistung" o.ä.
(Da hatte ich schon die tollsten Erkenntnisse sammeln dürfen).
- Hast du mit iperf2 die reine TCP Netzwerkbandbreite zwischen Server und Client gemessen ob das überhaupt der Bottleneck ist?

- Kannst du testweise den Virenscanner deaktivieren?
- Stimmt die DNS Auflösung von Client und Servern?
- Kannst du u.U. die Anwendung am Applikationsserver direkt starten und den Startvorgang damit vergleichen?

Aber ich befürchte das wird alles nicht besser.
Hatte auch mal ein vergleichbares System zu betreuen, dass wird vermutlich nicht besser.

Gruß
Thomas
Member: MysticFoxDE
MysticFoxDE Apr 18, 2024 updated at 05:32:37 (UTC)
Goto Top
Moin @Carlehmann,

Hyper-V Generation 2.

Get-VMSwitch | Set-VMSwitch -EnableSoftwareRsc $false 
😉

Rest später, muss jetzt weiterflitzen.

Hier noch eine kleine Lektüre für dazwischen.
https://community.spiceworks.com/t/server-2019-network-performance/72496 ...
Beim Server 2022 ist es übrigens, leider +- dasselbe. 😔

Gruss Alex
Member: flo72it
flo72it Apr 18, 2024 at 07:52:28 (UTC)
Goto Top
Moin,

1 GBit/sec = ca. 125 MB/sec. -> Wenn das Netzwerk der Flaschenhals sein soll, dann müsste da eine riesen-Menge an Daten durch bei jedem Start; das ist unwahrscheinlich. Erreicht ihr denn annähernd 1 GBit/sec. beim Start der Anwendung?

Da das System noch eine Weile laufen soll würde ich da ein Monitoring-System draufaufsetzen und hinten purzelt ein Dashboard (Grafana o.ä.) raus, was die Analysen dann auch in die richtige Richtung schiebt.

Die unterschiedlichen Laufzeiten zeigen ja deutlich, dass da nicht nur ein Punkt im System irgendwie krumm läuft.

Viele Grüße, Flo
Member: ukulele-7
ukulele-7 Apr 18, 2024 at 08:02:14 (UTC)
Goto Top
Zitat von @Carlehmann:

Gerade mal die Sekunden gestoppt:

ERP Start Modulstart bis Login Modul1
Application VM: 28 sec 45 sec
Datenbank VM: 1:17 min 58 sec

Client1 über WLAN: 32 sec 10 sec
Client2 über LAN: 23 sec 21 sec
Client3 über LAN: 12 sec 20 sec
Wie genau ist das zu verstehen, schwankt das jeweils zwischen den niedrigen und dem hohen Wert? Dann würde ich sagen da ist irgendwo ganz viel Auslastung im Spiel. Sonst wären die Ergebnisse ja reproduzierbar schnell oder langsam.

Hast du zwischen Clients und Servern eine Netzwerksegmentierung, läuft das irgendwo durch eine Firewall?
Member: MysticFoxDE
MysticFoxDE Apr 18, 2024 at 11:56:04 (UTC)
Goto Top
Moin @flo72it,

1 GBit/sec = ca. 125 MB/sec.

die 125 MB/sec sind brutto, netto sind bei 1 GBit/sec und über TCP, nur ~113 MB/s möglich.

Gruss Alex
Member: mbehrens
mbehrens Apr 18, 2024 at 15:53:37 (UTC)
Goto Top
Zitat von @Carlehmann:

Application VM:
Hier ist das ERP installiert; 12 GB RAM, 4 x virtuelle Proz.,
Netzwerk 10 Gbit über SFP

Datenbank VM:
SQL Server, 42 GB RAM, 6 x virtuelle Proz.
Netzwerk 10 Gbit über SFP

Kann der unbekannte SQL Server überhaupt mit der Menge/Prozessoren an RAM umgehen? Ist dieser passend konfiguriert?

SFP und 10G passend irgendwie nicht zusammen.
Haben beide Maschinen dedizierte Netzwerkkarten oder einen gemeinsamen vSwitch oder sind diese z. B. per SR-IOV direkt angebunden?
Ist die Netzwerkhardware passend konfiguriert (VMQ/Offloading/...)?
Member: Carlehmann
Carlehmann Apr 18, 2024 at 16:12:28 (UTC)
Goto Top
Wie genau ist das zu verstehen, schwankt das jeweils zwischen den niedrigen und dem hohen Wert? Dann würde ich sagen da ist irgendwo ganz viel Auslastung im Spiel. Sonst wären die Ergebnisse ja reproduzierbar schnell oder langsam.

Nein, das ist die gestoppte Zeit von Iconklick bis ich kann mich am ERP anmelden (=Modulstart bis Login).
Das anmelden selbst dauert 2-3 sec, dann kann ich die Module im ERP starten. Modul1 ist das tägliche Modul was alle Kollegen nutzen.

Witzig ist, das mein Client im WLAN schneller lädt als über LAN. Client1 u. Client2 sind mein Laptop sorry einmal im WLAN einmal LAN. WLAN ist 10sec schneller.

Es kommt auch nicht auf die Hardware an, ich habe vorhin 2 x fast identische CAD Maschinen mit guter Power getestet:
Einer braucht 4,5 sec für Modulstart u. 18 sec für Modul1.
Der zweite 11 sec für Modulstart u. 38 sec für Modul1. Beide im LAN.

Hast du zwischen Clients und Servern eine Netzwerksegmentierung, läuft das irgendwo durch eine Firewall?
Das war auch mein Ansatz: beide CAD Maschinen liegen auf unterschiedlichen Switchen.

Wir haben eine Sophos Firewall; HP Switche u. einen Cisco. Es laufen auf den Switchen nur einige VLANs für Maschinen, diese PCs haben aber nur unser internes Netz.

Aber vielleicht:
Ich habe in unserer Security Suite nochmal genauer geschaut -> Der Pfad für den Echtzeit-Scan (Ausnahme) könnte das Problem sein -> wir haben Anfang 2023 vom ERP zwei weitere Instanzen installiert. Die zweite = aktuelle = haben wir als Ausnahme wohl vergessen. Das habe ich gerade mal nachgetragen bei wenigen Rechnern um ggf. ein geändertes Verhalten zu prüfen.

Gruß
Carsten
Member: Carlehmann
Carlehmann Apr 18, 2024 updated at 17:03:31 (UTC)
Goto Top
Wie muss so ein Pfad dort eingegeben werden:

ist das so korrekt?
\\Server\FreigabeOrdner\

oder so:
\\Server\FreigabeOrdner


-> Ich habe in der Doku geschaut, die schreiben dort C:\Test -> ohne \
Ordnerpfad: C:\test (Der gesamte Ordner C:\test wird nicht gescannt.)

Es können auch einzelne Anwendungen (Exe) vom Scan ausgeschlossen werden, vielleicht macht das auch Sinn, das mal auf 2-3 Clients zu testen?

Aus dem Handbuch:
Geben Sie unter Ausgeschlossene Prozesse jeden auszuschließenden Prozess in einer eigenen
Zeile ein.
Geben Sie den vollständigen Pfadnamen für den Prozess an, zum Beispiel
C:\Programme\Anwendung\app1.exe. Sie können auch systemeigene Umgebungsvariablen in
dem Pfad verwenden, zum Beispiel %ProgramFiles%\Anwendung\app1.exe.
Anmerkung: Dateien, auf die die ausgeschlossenen Prozesse zugreifen, sind ebenfalls vom
Scan ausgeschlossen.


Für unser DMS (ELO) haben wir damals die Pfade mit \ am Ende lt. Doku eintragen müssen.
Member: Carlehmann
Carlehmann Apr 18, 2024 at 16:31:42 (UTC)
Goto Top
Kann der unbekannte SQL Server überhaupt mit der Menge/Prozessoren an RAM umgehen? Ist dieser passend konfiguriert?

MS SQL Server 2016 ist installiert.
Habe ich leider nicht eingerichtet u. auch nicht wirklich Ahnung von, mir wurde bisher immer nur gesagt, gebe dem mehr RAM -> allerdings zieht der auch alles in den RAM, was er zur Verfügung hat.


Eine andere befreundete Firma hat das gleiche ERP, die haben ihren Server vor einen Jahr aufgerüstet: DB-Server: 12 Proz. mit 128 GB RAM, Application-Server: 8 Prozessoren mit 64 GB RAM. Das Hauptblech Xeon Silver 4114 CPU u. 512 GB RAM.


SFP und 10G passend irgendwie nicht zusammen.
Im Hyper-V Manager für Switche steht:
10Gbit - SFP P1, Mellanox ConnectX-2 Ethernet-Adapter.
Das hatte mein externer ITler vor einiger Zeit mal aufgeräumt.


Haben beide Maschinen dedizierte Netzwerkkarten oder einen gemeinsamen vSwitch oder sind diese z. B. per SR-IOV direkt angebunden?
Ist die Netzwerkhardware passend konfiguriert (VMQ/Offloading/...)?
Auch hier fehlen mir tiefere Kenntnisse, auch das hat unserer externer aufgeräumt.
Da stehen:
ETH1 Intel(R) I350 Gigabit Network Connection #2
Ethernet Intel(R) I350 Gigabit Network Connection
Ethernet 5 Intel(R) I350 Gigabit Network Connection #3
Ethernet 6 Intel(R) I350 Gigabit Network Connection #4
SFP P1 Mellanox ConnectX-2 Ethernet Adapter
SFP P2 Mellanox ConnectX-2 Ethernet Adapter #2

Und dann noch: Netzwerk MS Network Adapter Multiplexor Driver

;)
Member: ReissT
ReissT Apr 18, 2024 at 19:49:44 (UTC)
Goto Top
Aber vielleicht:
Ich habe in unserer Security Suite nochmal genauer geschaut -> Der Pfad für den Echtzeit-Scan (Ausnahme) könnte das Problem sein -> wir haben Anfang 2023 vom ERP zwei weitere Instanzen installiert. Die zweite = aktuelle = haben wir als Ausnahme wohl vergessen. Das habe ich gerade mal nachgetragen bei wenigen Rechnern um ggf. ein geändertes Verhalten zu prüfen.

Gruß
Carsten

Deaktiviere testweise diese Suite am Client (und ggf. am Server) komplett (Dienste stoppen o. drgl.). und versuch es nochmal.
Member: ReissT
ReissT Apr 18, 2024 at 20:02:19 (UTC)
Goto Top
Und das versteht ich jetzt nicht.
Der 1. sec Wert ist der Programmaufruf bis zum Login und der 2. sec Wert nach dem Login bis Modul 1 läuft?

Client1 über WLAN: 32 sec 10 sec
Client2 über LAN: 23 sec 21 sec
Client3 über LAN: 12 sec 20 sec


und du schreibst auch

Witzig ist, das mein Client im WLAN schneller lädt als über LAN. Client1 u. Client2 sind mein Laptop sorry einmal im WLAN einmal LAN. WLAN ist 10sec schneller.

Da würde ich sagen im WLAN ist der Download trotzdem langsamer (32 sec) im Vergleich von WLAN zu LAN.
Das der Modulaufruf (10 sec) schneller ist ist bemerkenswert.

Und da auch deine 2 CAD Maschinen in unterschiedlichen LAN liegen, teste doch deinen Client mal mit den unterschiedlichen LAN Segmenten.
Ziehen die Probleme mit, dann stimmt was mit dem entsprechenden LAN Segment (Switch?) nicht.
Wo hängen deine WLAN AP dran?
Am Switch mit dem LAN Segment in dem auch die "schnelle" CAD Workstation liegt?

Gruß
Thomas
Member: MysticFoxDE
MysticFoxDE Apr 19, 2024 at 05:34:29 (UTC)
Goto Top
Moin @Carlehmann,

Und dann noch: Netzwerk MS Network Adapter Multiplexor Driver

das heisst, dass auf dem entsprechende Hyper-V noch ein LBFO-Teaming aktiviert ist und wenn du nicht gerade noch einen Hyper-V 2012 R2 betreibst, dann ist schon das nicht ganz richtig.

https://community.spiceworks.com/t/the-windows-horror-story-season-001-n ...

Aber das muss nicht unbedingt dein Problem auch auslösen.

Kannst du mal auf einem der Rechner der am meisten Probleme hat, bitte mal den folgenden Befehl per Powershell (als Administrator) ausführen ...

Get-MpComputerStatus

... und seine Ausgabe hier zurückposten.

Gruss Alex
Member: ukulele-7
ukulele-7 Apr 19, 2024 at 07:25:27 (UTC)
Goto Top
> Hast du zwischen Clients und Servern eine Netzwerksegmentierung, läuft das irgendwo durch eine Firewall?
Das war auch mein Ansatz: beide CAD Maschinen liegen auf unterschiedlichen Switchen.

Wir haben eine Sophos Firewall; HP Switche u. einen Cisco. Es laufen auf den Switchen nur einige VLANs für Maschinen, diese PCs haben aber nur unser internes Netz.
Dann geht vermutlich alles zwischen Server und Client über die Sophos ins jeweils andere VLAN. Das ist nicht zwangsläufig schlecht, mache ich auch so. Aber hast du mal geguckt ob in der Client Server Kommunikation irgendwas geblockt wird in der Firewall Log?

Steht die SQL DB auf einem fixen Port (i.d.R. 1433) oder dynamisch? Hier mal die entsprechende Stelle in der Config an der MSSQL VM:
Start \ SQL Server 2022-Konfigurations-Manager
SQL Server-Netzwerkkonfiguration \ Protokolle für 'MSSQLSERVER'
TCP/IP aktivieren (default)
Doppelklick \ IP-Adressen \ IPAll
TCP-Port 1433 (default)
http://msdn.microsoft.com/en-us/library/ms345327.aspx

Wie muss so ein Pfad dort eingegeben werden:

ist das so korrekt?
\\Server\FreigabeOrdner\

oder so:
\\Server\FreigabeOrdner
Das kann dir die Doku der Software sagen. Ich gehe davon aus das beides geht, aber der Pfad \\Server\FreigabeOrdner eventuell auch \\Server\FreigabeOrdnernamelang mit einschließen würde, also etwas weiter gefasst ist.

Vom Verhalten her würde ich stark auf deine Security Lösung als Ursache tippen. Du musst die unbedingt für die ersten Tests komplett ausschließen, am besten an einem Client deinstallieren oder einen Test-Client aufsetzen und am Server auch deaktivieren. Eine Pfad-Ausnahme kann die Performance verbessern aber mit der Software aktiv kannst du nie bestimmen wie schnell es wohl ohne diese Software läuft.
Member: Carlehmann
Carlehmann Apr 19, 2024 at 12:51:27 (UTC)
Goto Top
PS C:\Windows\system32> Get-MpComputerStatus


AMEngineVersion : 0.0.0.0
AMProductVersion : 4.18.24030.9
AMRunningMode : Not running
AMServiceEnabled : False
AMServiceVersion : 0.0.0.0
AntispywareEnabled : False
AntispywareSignatureAge : 0
AntispywareSignatureLastUpdated :
AntispywareSignatureVersion :
AntivirusEnabled : False
AntivirusSignatureAge : 65535
AntivirusSignatureLastUpdated :
AntivirusSignatureVersion :
BehaviorMonitorEnabled : False
ComputerID : 7F776C57-xxxx-x-xxxxAC7E-xxxxxxxxxxxxxx
ComputerState : 0
DefenderSignaturesOutOfDate : False
DeviceControlDefaultEnforcement : Unknown
DeviceControlPoliciesLastUpdated : 01.01.1601 01:00:00
DeviceControlState : Unknown
FullScanAge : 4294967295
FullScanEndTime :
FullScanOverdue : False
FullScanRequired : False
FullScanSignatureVersion :
FullScanStartTime :
InitializationProgress : ServiceStartedSuccessfully
IoavProtectionEnabled : False
IsTamperProtected : False
IsVirtualMachine : False
LastFullScanSource : 0
LastQuickScanSource : 0
NISEnabled : False
NISEngineVersion : 0.0.0.0
NISSignatureAge : 65535
NISSignatureLastUpdated :
NISSignatureVersion :
OnAccessProtectionEnabled : False
ProductStatus : 1
QuickScanAge : 4294967295
QuickScanEndTime :
QuickScanOverdue : False
QuickScanSignatureVersion :
QuickScanStartTime :
RealTimeProtectionEnabled : False
RealTimeScanDirection : 0
RebootRequired : False
SmartAppControlExpiration :
SmartAppControlState :
TamperProtectionSource : Signatures
TDTCapable : N/A
TDTMode : N/A
TDTSiloType : N/A
TDTStatus : N/A
TDTTelemetry : N/A
TroubleShootingDailyMaxQuota :
TroubleShootingDailyQuotaLeft :
TroubleShootingEndTime :
TroubleShootingExpirationLeft :
TroubleShootingMode :
TroubleShootingModeSource :
TroubleShootingQuotaResetTime :
TroubleShootingStartTime :
PSComputerName :

Das kommt bei raus ;) Das ist mein Laptop, allerdings aktuell im HomeOffice u. VPN. Im Büro bin ich erst kommenden Dienstag.
Member: Dani
Dani Apr 19, 2024 at 15:33:19 (UTC)
Goto Top
Moin,
Die SQL-Datenbank wird auf einer Windows Server VM gehostet. Da das ERP modular aufgebaut ist, lädt das System pro Modulstart (Startmodul, Modul Bestellwesen, Modul Statistik, Modul Kalkulation usw.) von einer Windows Freigabe auf dem Application Server (auch Windows Server VM) die Exe Dateien also bei Bedarf auf den Client.
wenn du die Daten lokal, ohne Share, bereitstellst, tritt das Problem nicht auf?!


Gruß,
Dani
Member: MysticFoxDE
MysticFoxDE Apr 21, 2024 at 06:08:03 (UTC)
Goto Top
Moin @Carlehmann,

AMRunningMode : Not running

Das kommt bei raus ;) Das ist mein Laptop, allerdings aktuell im HomeOffice u. VPN. Im Büro bin ich erst kommenden Dienstag.

das sieht schon mal gar nicht so schlecht aus, sprich bei diesem Rechner kann der Defender schon mal nicht dazwischen spucken.

Schau aber zur Sicherheit bitte nach, ob das bei den anderen Rechnern auch so der Fall ist.

Könntest du ausserdem, bei den entsprechenden Rechner mal den ERP-Start über den Ressourcenmonitor beobachten und schauen, wie sich die Latenz der TCP-Verbindungen verhält, die zum ERP gehören.

ressourcenmonitor netzwerk latenz

Siehst du hier irgendwelche Unterschiede bei der Verbindungslatenz zwischen den schnelleren und den langsameren Clients?

Gruss Alex
Member: Carlehmann
Carlehmann Apr 23, 2024 at 17:22:32 (UTC)
Goto Top
Moin Alex,

sorry der Tag war zu voll: okay, das ist schon mal ein Ansatz. Ich habe die Suche bemüht, da die Prozesse hier ja ständig hin- u. herspringen.

Perfmon für bestimmte Anwendung

Ich habe mit dieser Leistungsüberwachung noch nichts gemacht, kann man das damit überwachen, ich möchte ja eigentlich nur eine gefilterte Ansicht haben mit den 2-5 exe Dateien, die mich am ERP interessieren? Ich habe mir hiermit 3 x Exc Dateien ausgewählt, aber der Protokolliert ja sooo viel mit.

Gruß
Carsten
Member: flo72it
flo72it Apr 26, 2024 at 12:23:50 (UTC)
Goto Top
Moin,

gönne dir und euch doch ein Monitoring-System - prometheus/Grafana, Zabbix, o.ä. ist doch schnell aufgesetzt (ansonsten: Dienstleister deiner Wahl) und bringt dann alles mit, damit du schnell Flaschenhälse siehst.

Viele Grüße, Flo
Member: Carlehmann
Carlehmann Apr 26, 2024 at 13:15:21 (UTC)
Goto Top
Wo liegt so etwas preislich?
Wir haben ca. 40 PC, ca 40 mobile Endgeräte aber die haben schon ein MDM von Cisco - Meraki.
Member: flo72it
flo72it Apr 26, 2024 at 13:29:07 (UTC)
Goto Top
Die PCs+mobilen Endgeräte sind weniger spannend, eher die Server+Rest der Infrastruktur. Die von mir genannten Systeme sind open source und damit kostenfrei.

Viele Grüße, Flo
Member: MysticFoxDE
MysticFoxDE Apr 26, 2024 at 17:27:28 (UTC)
Goto Top
Moin @Carlehmann,

Ich habe mit dieser Leistungsüberwachung noch nichts gemacht, kann man das damit überwachen, ich möchte ja eigentlich nur eine gefilterte Ansicht haben mit den 2-5 exe Dateien, die mich am ERP interessieren? Ich habe mir hiermit 3 x Exc Dateien ausgewählt, aber der Protokolliert ja sooo viel mit.

du kannst mit dem Ressourcenmonitor nur eine Echtzeitüberwachung machen, sprich, die Analyse muss sofort geschehen, da die Daten nicht Aufgezeichnet werden. Mit etwas Übung, bekommt man damit auf die Schnelle und vor allem mit Bordmitteln, schon eine ganz gute Übersicht.

Mit der Leistungsüberwachung, kann man mit Bordmitteln noch filigraner Monitoren, ist aber auch um einiges fisseliger, bis man die gewünschten Leistungsindikatoren eingerichtet hat.

Und wenn du es mit der Analyse auf die Spitze treiben möchte, dann nimmt man den WPR (Windows Performance Recorder) + WPA (Windows Performance Analyzer).

https://learn.microsoft.com/de-de/windows-hardware/test/wpt/windows-perf ...
https://learn.microsoft.com/de-de/windows-hardware/test/wpt/windows-perf ...

Darüber zu analysieren, erfordert jedoch einiges an Wissen.

Gruss Alex
Member: Carlehmann
Carlehmann Apr 30, 2024 at 17:09:37 (UTC)
Goto Top
Die PCs+mobilen Endgeräte sind weniger spannend, eher die Server+Rest der Infrastruktur. Die von mir genannten Systeme sind open source und damit kostenfrei.

Danke schön, das werde ich mir bei Zeiten wohl mal anschauen müssen, um hier Lösungen zu finden.

Gruß
Carsten