clschak
Goto Top

IPv6 Routing ohne Funktion

Hiho

wir haben seit Anfang der Woche das Problem, das der gesamte IPv6 Traffic nicht mehr geroutet wird. Die VE's sind aus den einzelnen VLANs erreichbar, der Router selbst kann auch fröhlch alle Geräte in den unterschiedlichen VLANs anpingen, wenn man aber von einem Endpunkt (Client, Server usw.) versucht ein IPv6 Adresse in einem anderen VLAN zu erreichen kommt das ganz bis zum Router und läuft dann ins Nirvana.

Wir arbeiten aktuell und zu Testzwecken ausschließlich mit statischen IP Adressen, aus dem Grund Advertised der Router auch seine Settings nicht, funktionierte auch alles anstandslos bis Anfang dieser Woche :< , es wurde am Routing nichts umgestellt, auch eine doppelte Adressvergabe kann ausgeschlossen werden. In den Logs steht auch nichts was darauf hinweist, dass das Routing "aus" ist, die Router hatten auch keinen Reboot oder vergleichbares. Ich kann mir da aktuell keinen Reim drauf machen face-sad

Gerät ist ein 4er Stack ICX7750 mit dem L3 RouterImage

Anbei die Auszüge aus der Config:

Basis Config:
errdisable recovery cause all
errdisable recovery interval 10
aaa authentication login default local
jumbo
default-vlan-id 777
enable skip-page-display
enable super-user-password .....
enable aaa console
hostname GeräteName
ip dns server-address ServerIP ServerIP
ip forward-protocol udp 4
ip forward-protocol udp echo
ip route 0.0.0.0/0 NextHopIP
!
ipv6 dns server-address (IPv6Präfix):1::2 (IPv6Präfix):1::50
ipv6 unicast-routing
ipv6 route ::/0 (IPv6Präfix):1::12
ipv6 route (IPv6Präfix):200::/64 (IPv6Präfix):1::58
!
qos-tos map dscp-priority 46 to 6
logging host ServerIP  udp-port 10514
logging facility syslog
logging buffered 1000
username admin password .....
snmp-server community ..... ro
snmp-server community ..... rw
!
!
clock timezone gmt GMT+01
!
!
ntp
 server ServerIP
 server ServerIP
!
!
hitless-failover enable
!
router ospf
 area 0.0.0.0
 auto-cost reference-bandwidth 4294967
!
!
!
!
!
!
!
ipv6 router ospf
 area 0.0.0.0
 auto-cost reference-bandwidth 4294967
!

Router Interfaces
interface ve 1
 ip address IP-Adresse 255.255.255.0
 ip address IP-Adresse 255.255.252.0
 ip directed-broadcast
 ip helper-address 1 IP-Adresse
 ip ospf area 0.0.0.0
 ipv6 address (IPv6Präfix):1::30/64
 ipv6 enable
 ipv6 ospf area 0.0.0.0
 ipv6 ospf active
 ipv6 nd suppress-ra
!
interface ve 12
 ip address IP-Adresse 255.255.255.0

 ip ospf area 0.0.0.0
!
interface ve 15
 ip address IP-Adresse 255.255.255.0
!
interface ve 50
 ip address IP-Adresse 255.255.255.0
 ip ospf area 0.0.0.0
 ipv6 address (IPv6Präfix):50::30/64
 ipv6 enable
 ipv6 ospf area 0.0.0.0
 ipv6 ospf active
 ipv6 nd suppress-ra
!

Vielleicht hat ja noch wer ein Idee woran es liegen kann

FW Version: 08.0.30gT203

Add: Lustig ist allerdings, das ich aus jedem VLAN die RouterInterfaces anpingen von jedem anderen VLAN ...


Gruß
@clSchak

Content-Key: 505361

Url: https://administrator.de/contentid/505361

Printed on: May 22, 2024 at 13:05 o'clock

Member: aqui
Solution aqui Oct 16, 2019 updated at 20:48:31 (UTC)
Goto Top
Deine Firmware ist recht alt und auch schon lange nicht mehr die recommended Version.
Du solltest als Allererstes den Stack auf die recommended Version 8.0.7f (aktuell latest) updaten und das Verhalten nochmal checken.
Ein kurzer Check mit der 8.0.7f auf einem 7250 zeigte hier absolut fehlerloses Verhalten im v6 Routing mit statischen IPs auf den Endgeräten. Innerhalb des Switches. Test aktuell nur mit einem Switch. Ein OSPFv3 Test Umfeld dauert etwas kann ich aber testen.
<OT> Hat das einen Grund warum du der OSPF Reference Bandwith so einen komischen Wert gibst und nicht schlicht und einfach 100000 ?? Dann hätte ein 100Gig Interface die Cost 1 und bis 100G kann der OSPF Prozess dann alles fehlerlos identifizieren ?! </OT>
Member: clSchak
clSchak Oct 16, 2019 updated at 21:28:03 (UTC)
Goto Top
ssh@NAME(config-ospf6-router)#auto-cost reference-bandwidth
  DECIMAL   <1-4294967>  in Mbits per second

darum, ist der maximale Wert der lt. CLI gesetzt werden kann.

Updaten wird da schon komplizierter, das Gerät ist der Primäre Router :> ich kann den nicht mal eben rebooten ohne vorher einige andere Dienst neuzustarten, außerdem _suckt_ die neue PVID Funktion ... face-smile.

Btw. wir haben ohnehin nur eine Area und vor Uhrzeiten OSPF als Protokoll gewählt und sind dann dabei geblieben. Ich habe auch schon das ganze IPv6 Routing auf RIP umgestellt, der gleich Effekt, wir haben keine ACL's oder vergleichbares auf dem Router laufen was evtl. einen Sideeffekt haben könnte. Das IPv4 Routing funktioniert auf den Interfaces anstandslos, nur das IPv6 eben nicht :|.

Evtl. morgen mal einen Call bei Ruckus aufmachen.

PS: 8.0.9d ist die aktuellste Version bzw. 8.0.80d
Member: aqui
aqui Oct 17, 2019 updated at 08:15:55 (UTC)
Goto Top
Btw. wir haben ohnehin nur eine Area und vor Uhrzeiten OSPF als Protokoll gewählt und sind dann dabei geblieben.
Was ja per se nicht falsch ist und man generell so machen kann !
auf RIP umgestellt, der gleich Effekt
Igitt...RIP, nee lieber OSPF. Aber das das nichts ändert ist mehr oder weniger nachvollziehbar, denn die Routing Protokolle distribuieren ja einzig nur die Routen. Vermutlich liegt dein Kinken im IPv6 Forwarding selber. Deine Routing Tabelle (sh ip rou) zeigt dir sicher alles sauber an, oder ?
8.0.9d ist die aktuellste Version bzw. 8.0.80d
Ja, aber nicht die "Recommended" !! Ich habe teils böse Erfahrungen gemacht mit den brandneuen Images. OK nur in Nischenkonfigs (NAC Umfeld) aber das hat Tage gekostet rauszubekommen wo der Fehler lag. Letztlich ein Bug der im Recommended nicht drin war. Seitdem bleibe ich dabei, gehe aber immer auf den höchsten Minor Patch Level in dem Release Train. Wenn man zwingend brandneu nehmen muss wegen irgendwelcher Features, sollte hinten mindestens ein "c" sein. face-wink
Ich flash die 8.3er mal ins Secondary und teste das damit nochmal... Mal sehen ob man das reproduzieren kann auf anderen Modellen. Ggf. ist das nur ein Hänger und verschwindet nach einem Reboot. Wenn du aber rebootest kannst du auch gleich auf die aktuelle Recommended gehen !
Vielleicht mal ein kleines Warungsfenster heute nach Feierabend einschieben ?! Ins Secondary Flash kannst du sie ja schon mal vorab kopieren. Reboot dauert ja nur 2-3 Minuten... face-wink
Member: clSchak
clSchak Oct 17, 2019 updated at 08:41:46 (UTC)
Goto Top
Hi aqui

ja die Routen werden korrekt im OSPF auf den VE Interfaces angezeigt

Lustiges Verhalten:

InterVLAN Routing -> geht nicht, also ich kann z.B. keine Adresse von VLAN1 in VLAN50 pingen

Routing ins Internet: ping -6 auf die Google: funktioniert von allen VLANs ôÔ

das zum Verhalten, ich habe testweise auch das RouterAdvertisment wieder eingeschaltet allerdings ohne Erfolg.

Was ich jetzt gemacht habe auf den VE's: IPv6 Adresse gelöscht und direkt neu gesetzt -> alles funktioniert wieder :| - das habe ich gestern Abend nicht probiert, da ja aktuell die gesamte IPv6 Geschichte static ist.

Aber ich kann das Verhalten nicht nachvollziehen warum das nicht funktioniert hat, sieht mir doch sehr nach einen Bug aus face-sad - werde wohl updaten müssen.

Mal sehen wann sich ein Zeitfenster findet, da wir 24/7 Betrieb habe und das halt "Core" ist, ist da ein wenig Abstimmung notwendig aber nicht unmöglich.
Member: aqui
aqui Oct 17, 2019 at 11:09:35 (UTC)
Goto Top
werde wohl updaten müssen.
Besser ist das in jedem Falle. Wenn du das verlässlich laufen haben willst ist das ein Muss...weisst du selber.
Wie gesagt Reboot dauert ja nur 2-3 Minuten.
Beim nächsten TAC Case hauen die dir das so oder so um die Ohren, denn die 3er ist vermutlich nicht mehr supportet auf der Plattform.
Übrigens...
Auch mit der 8.0.3 latest liess sich das hier auf dem 7250 nicht reproduzieren. Ist wie bei dir, wenn man es neu konfiguriert rennt es.
Vermutlich ist das irgendwie ein temporärer Hänger in der FIB oder CAM Table oder Buffer Overflow oder was auch immer in der Firmware.