Keine Verbindung zu Server mit remote Desktop über ssh-Tunnel möglich

37103
Goto Top
Ich hab keine Idee mehr. Vielleicht fällt Euch noch etwas ein.

Ich möchte auf einen Windows 2000 Server per remote Desktop zugreifen. Die Verbindung geht über einen ssh-Tunnel. (Portforwarding von DSL-Router über Proxy zum Win-Server mit freeSSHd) Der Tunnel lässt sich ohne Probleme herstellen. Auf dem Client läuft WinXP, der Tunneleingang liegt auf einem lokalen Port (10000). Eine Verbindungsaufbau beim remote-Desktop mit localhost:10000 scheitert jedoch. Im lokalen Netz funktionierts jedoch (auch mit ssh-Tunnel). Auch mit Linux-Clients via krdc oder rdesktop scheitert die Verbindung. Der Server besitzt eine Dyndns-Adresse.

Content-Key: 42624

Url: https://administrator.de/contentid/42624

Ausgedruckt am: 04.07.2022 um 10:07 Uhr

Mitglied: The-Warlord
The-Warlord 20.10.2006 um 13:28:54 Uhr
Goto Top
Denk dran das die Paket ja auch wieder zurückkommen müssen also müsste man ja auch ihr Ziel wieder erreichen. Ich kanns dir nicht genau sagen, müsste aber was damit zu tun haben. Ich hatte bei meinem IPCop so ein Problem, da lag es an den Routen (allerdings war das mit extra Subnetz von OpenVPN und gedöns). Naja vieleicht bringt dir der Ansatz ja wasface-wink

Good Luck
The-Warlord
Mitglied: 37103
37103 20.10.2006 um 15:50:20 Uhr
Goto Top
Ohne ssh-tunnel mit weiterleitung von Port 3389 funktioniert der remote-Desktop Zugang. War mir jedoch zu unsicher, deswegen wollte ich das über ssh tunneln. Der Tunnel funktioniert ja auch, sprich ich komme vom Client über ssh auf den Server. Blos vom Eingang des Tunnels, dem lokalen Port 10000, kommen die Pakete anscheinend nicht am Port 3389 des Servers an. Ich verstehe nicht was da noch schieflaufen kann. Routing und Firewall scheiden als mögliche Fehlerquelle aus. Gibts bei Windows 2000 Server noch irgendwas, was die Verbindung verhindern könnte?
Mitglied: The-Warlord
The-Warlord 24.10.2006 um 11:42:29 Uhr
Goto Top
Also ich wüsste nichts, kenne mich das betreffend aber auch nicht so gut aus;-/
MfG
The-Warlord
Mitglied: 37103
37103 26.10.2006 um 10:25:56 Uhr
Goto Top
Hi,

ich konnte das Problem lösen. Es lag am freesshd Server, der scheint etwas zickig zu sein, welches auch Beiträge aus anderen Foren bestätigen. (Er friert z.B. ein beim Versuch sich über rdp anzumelden.) Mit winsshd klappt es prima. Zusätzlich zur Standardeinstellung muss nur noch eine IP-Regel unter Connect rules gesetzt werden, die das C2S Port-Forwarding erlaubt (Target: localhost, port: 3389).