gelöst Linux: einige Minuten nach Gruppeneintritt funktioniert Multicast nicht mehr

Mitglied: Waldwuffel

Waldwuffel (Level 1) - Jetzt verbinden

20.07.2020, aktualisiert 15:01 Uhr, 389 Aufrufe, 7 Kommentare

Hallo alle miteinander,

vor einer Weile hatte ich einige Fragen in Bezug auf UPnP und das Routing/die Firewall-Konfiguration in dem Zusammenhang. Zuhause habe ich zwei (drei) Subnetze eingerichtet, um die Server- von den Client-Hosts zu trennen, wobei ein APU2E4-Board mit Debian als Router/Firewall fungiert. Darauf läuft unter anderem SMCRoute, um die UPnP/SSDP-Anfragen von Medien-Playern im "User-Netz" zum Medien-Server (minidlna) im zweiten Subnetz möglich zu machen.

Insgesamt funktioniert das nun alles einwandfrei (inkl. Firewall mit iptables) - bis es vor ein paar Tagen dann damit, aus für mich nicht nachvollziehbaren Gründen, vorbei war. Von einem Moment auf den nächsten, und ohne, dass ich etwas an der Konfiguration geändert hätte, wurde der Medien-Server im anderen Subnetz nicht mehr gefunden (das gleiche Problem trat bereits früher zwei oder dreimal auf, konnte aber durch einen Neustart der Firewall "behoben" werden). Also habe ich angefangen, mir die Situation genauer anzuschauen und bin auf Folgendes gestoßen:

Nachdem SMCRoute gestartet wurde, dauert es einige wenige Minuten, bis die beschriebene Situation auftritt. Wird SMCRoute neu gestartet oder verlasse ich manuell die MC-Gruppe (239.255.255.250) und rejoine (smcroutectl leave/join enp1s0 239.255.255.250), funktioniert es wieder für einige Minuten, bis sich die Situation wiederholt.
Mit tcpdump konnte ich feststellen, dass dann gar keine Pakete an 239.255.255.250 mehr auf der Schnittstelle registriert werden (auf der zweiten hingegen schon). ip maddress listet das Interface nach wie vor als Mitglied der MC-Gruppe.

Darüber hinaus habe ich einen Test mit iperf gemacht:
auf der Server- und
auf der Client-Seite. Das führt zum gleichen Problem. Zuerst registriert der iperf-Server die Anfragen vom Client – doch ein paar Minuten später ist es damit vorbei. Da SMCRoute zu der Zeit nicht lief (und auch sonst keine MC-Routen etabliert worden waren), scheint es sich also eher allgemein um ein Problem mit Multicast zu handeln und nicht speziell um ein MC-Routing-Problem. Zusammengefasst würde ich es damit so beschreiben:

Ein paar Minuten, nachdem ein Interface einer MC-Gruppe beigetreten ist, kommen keine Pakete an die entsprechende MC-Adresse auf diesem Interface mehr an (bis man die Gruppe verlassen und neu betreten hat).

Ich war die letzten Tage auf der Suche nach Erklärungen und Lösungen, konnte aber rein gar nichts in der Richtung finden. Hat vielleicht hier jemand eine Idee, worum es sich dabei handeln könnte? Oder zumindest, in welche Richtung ich suchen sollte, um der Ursache auf die Spur zu kommen?

Vielen Dank und bis später.
Mitglied: aqui
LÖSUNG 20.07.2020, aktualisiert um 14:49 Uhr
Zuhause habe ich zwei (drei) Netzwerke eingerichtet,
Was denn nun 2 oder 3 ??
Noch eine Frage vorab:
Die Netzwerk Switches die deine 2 oder 3 Netze bedienen sind das ungemanagte Dummswitches oder können die IGMP Snooping ? Wenn ja...
  • Ist das aktiviert ?
  • Welche IGMP Version ?
  • Wer ist der Querier im Netz bzw. ist die Querier Funktion aktiviert im Switch ?
Es gibt eine sehr einfache Möglichkeit das Multicast Verhalten über Routergrenzen sauber zu testen:
https://www.administrator.de/content/detail.php?id=362413&token=462# ...
MC Hammer und/oder VLC sind also wie immer deine besten Freunde dabei !
Bitte warten ..
Mitglied: Waldwuffel
20.07.2020, aktualisiert um 19:55 Uhr
Es sind insgesamt drei Netze, eins davon ist allerdings für das MC-Routing nicht relevant (es gibt auch keinen entsprechenden Eintrag in der smcroute.conf).

Einen Switch gibt es in dem Zusammenhang gar nicht (auch keine Bridge-Schnittstellen beim Router). Es existiert nur das APU2E4-Board als Router, wobei auf der einen Seite (über 2 NICs mit je eigenem Subnetz) ein Server (Proxmox VE) und auf der anderen eine FritzBox als Internet-Gateway und WLAN-AP angeschlossen ist. Die Clients/Medien-Player befinden sich im WLAN und sollen auf den Medien-Server (Container) in einem der beiden Server-Netze zugreifen können.

(Korrektur: ) Der Router kann auf allen Interfaces IGMP v3 verwenden. Starte ich minidlna, wird v3 registriert, beim VLC jedoch v2.

Danke schon mal für den Link.

Ergänzung: ansonsten ist mir noch aufgefallen, dass ein IGMP-Report zu 239.255.255.250 vom Router-Interface zum User-Netz (enp1s0) verschickt wird, wenn SMCRoute gestartet wurde - danach aber nicht mehr.
Bitte warten ..
Mitglied: GrueneSosseMitSpeck
21.07.2020, aktualisiert um 09:21 Uhr
tja wenn das join group "vergessen" wird dann ist da halt doch irgendeine Art von Spoofing aktiv bzw eine Fehlfunktion.

Normalerweise hast du beim Starten ein "join group" an 224.0.0.1 bzw. 224.0.0.22, das sind virtuelle IPs die der Router / Switch / ddein APU2E4 emulieren muß da alle Management-Aktiviten (hier join / leave group) an genau diesese beiden Addressen gehen, und nur der "normale" Multicast Traffic geht dann an die regulär registrierte IP (bei dir wohl 239.255.255.250)

Tausch das Ding mal gegen einen Hub oder Switch der für Multicast transparent ist.
Bitte warten ..
Mitglied: Waldwuffel
21.07.2020 um 10:20 Uhr
Ich konnte das Problem in der Zwischenzeit beheben. Es war einfach die Firewall, die die einkommenden IGMP-Reports blockiert hat... Nun kann ich zwar nicht verstehen, warum das vorher anstandslos funktioniert hat (dass die Firewall die ganze Zeit nicht aktiv war, ist mehr als unwahrscheinlich...), aber immerhin läuft es jetzt (wieder).
Bitte warten ..
Mitglied: aqui
21.07.2020 um 11:14 Uhr
ie die einkommenden IGMP-Reports blockiert hat...
Kleine Ursache...große Wirkung.
Fazit: Bei Firewalls besser 2mal ins Regelwerk sehen.
Im Grunde kann man dort immer eine Regel ALLOW 224.0.0.0 /4 eingeben um sicher zu gehen.
Bitte warten ..
Mitglied: Waldwuffel
21.07.2020 um 16:06 Uhr
Ja, in der Tat... Immerhin war das eine Gelegenheit, etwas über Multicast zu lernen

Das heißt, hier gleich den ganzen Adressbereich zuzulassen, ist keine "bad practice"?

Ich habe nun erstmal folgende Regel hinzugefügt:

War aber am Überlegen, ob ich das nicht einschränken sollte, wenn ich weiß, dass nur bestimmte Adressen verwendet werden, etwa:

Bitte warten ..
Mitglied: aqui
22.07.2020 um 09:59 Uhr
wenn ich weiß, dass nur bestimmte Adressen verwendet werden, etwa:
Ist natürlich etwas wasserdichter. Nur da MC ja nicht im öffentlichen Internet übertragen wird ist das vernachlässigbar.
Bitte warten ..
Heiß diskutierte Inhalte
Switche und Hubs
Kaufberatung (10G) Switche für Unternehmensnetzwerk
ipzipzapFrageSwitche und Hubs27 Kommentare

Moin, unsere Firma zieht um und am neu renovierten Standort muss/soll alles neu. Auf drei Etagen stehen Racks, in ...

Drucker und Scanner
Vorlage Endlospapier Nadeldrucker
Hanspeter82FrageDrucker und Scanner17 Kommentare

Hallo, hab die Aufagbe bekommen, eine Vorlage zuerstellen bzgl. Druck auf Endlos Papier über einen Nadeldrucker. Habe allerdings kein ...

Exchange Server
Primäre Mailadresse auf Kleinbuchstaben anpassen
JoergDdorfFrageExchange Server16 Kommentare

Hallo Alle, wir betreiben ein Exchange Hybrid (2016/365). Ich stehe vor dem Problem, dass ich die bestehenden primären Mailadresse ...

LAN, WAN, Wireless
2 Lan Dosen (Unterputz) miteinander Verbinden
gelöst RickHHFrageLAN, WAN, Wireless12 Kommentare

Moin zusammen, ich würde mir gerne auf dem Dachboden 2 Landosen in einen Raum Bauen. Ein Netzwerkkabel geht hoch, ...

Windows Userverwaltung
Active Directory Gruppen auslesen
gelöst MMaiwaldFrageWindows Userverwaltung12 Kommentare

Guten Abend, ich habe mir das Codeschnipsel geschnappt und möchte dieses noch erweitern. Dazu möchte ich noch die Beschreibung ...

Windows Netzwerk
Tool zum prüfen ob Gerät noch online ist
Ringi1970FrageWindows Netzwerk10 Kommentare

Hallo zusammen, ich suche nach einer Freeware, die mir bestimmte Geräte / Workstations (Windows Geräte, feste IP Adressen) prüft ...

Ähnliche Inhalte
Router & Routing
Vlan Multicast
gelöst JuliAugustFrageRouter & Routing7 Kommentare

Hallo Forum, ich arbeite mich aktuell in das Thema "Heimnetz in VLANs unterteilen" ein und habe mir hierzu einen ...

LAN, WAN, Wireless
Multicast Bonjour Airlino WLAN
AmateurverkablerFrageLAN, WAN, Wireless2 Kommentare

Hallo Administratoren, ich habe mir ein Airlino Plus WLan Musikempfänger gekauft um per Handy meine Musikanlage zu speisen. Problem: ...

LAN, WAN, Wireless
Mikrotik cAP Multicast Probleme
gelöst SpartacusFrageLAN, WAN, Wireless56 Kommentare

Hallo, aufgrund eines OS-Wechsels bei meinen Sonos Geräten werden einigen ältere Komponenten deaktiviert. So auch meine Sonos Bridge, die ...

Netzwerkprotokolle
Multicast IGMP Problem
gelöst UnbekannterNR1FrageNetzwerkprotokolle7 Kommentare

Hallo zusammen, Ich gerade ein Profi Problem und komme so nicht weiter. Es geht um Zwei arten von Switches, ...

LAN, WAN, Wireless
Kali Linux WLAN funktioniert nicht
Angelo131095FrageLAN, WAN, Wireless6 Kommentare

Hallo Leute, bei meinem Kali Linux (2018.4) geht das WLAN nicht, Netze werden zwar angezeigt aber mein PC verbindet ...

Netzwerkmanagement
Multicast Videostreaming in Peplink VPN
istike2FrageNetzwerkmanagement2 Kommentare

Hallo, ich habe hier ein Filmproduktionsprojekt, wo 3-4 Standorte via gebündeltes Peplink-VPN vernetzt werden sollen. Das gebündelte VPN-Netz soll ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT