Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux Server mit 2 NIC´s in zwei Netzen, antwortet nur auf einem Netz

Mitglied: mike-berlin

mike-berlin (Level 1) - Jetzt verbinden

07.10.2004, aktualisiert 08.10.2004, 6646 Aufrufe, 17 Kommentare

Hallo "Kollegen",

folgendes Problem.
Wir haben einen Server konfiguriert (Linux) welcher mit zwei NIC's in zwei verschiedenen Subnetzen hängt (192.168.1.x sowie 192.168.200.x).
Versucht jemand aus dem Netz 192.168.1.x den Server auf der Ip 192.168.1.168) zu erreichen kommt eine Antwort. Ein Ping auf die Server IP 192.168.200.168 (zweitze NIC im zweiten Subnetz 192.168.200.x) aus dem Netz 192.168.1.x geht nicht., obwohl sonst sämtliche Geräte im Netz 192.168.200.x erreicht werden können.
Genaus umgekehrt. Ein Zugriff aus dem Netz 192.168.200.x auf die Server IP 192.168.200.168 klappt. Ein Zugriff aus dem Net 192.168.1.x auf die Server IP 192.168.200.168 klappt nicht, obwohl sonst auch alle Gerät vom Netz 192.168.200.x in dem Netz 192.168.1.x erreichbar sind.

Ganz offenbar ist dem Server nicht ganz klar auf welcher der beiden karten er Antworten soll.
Wie kann ich ihm klar machen das Anfragen aus dem Netz 192.169.1.x auf die Server IP 192.168.1.168 auch über diese Karte und bei Anfragen aus dem Netz 192.168.1.x auf die Server NIC 192.168.200.168 Antworten über diese Karte (IP) erfolgen sollen ?

Danke im voraus für jede Unterstützung !

Grüße aus Berlin,
Mike
Mitglied: Atti58
08.10.2004 um 09:32 Uhr
Nur so nebenbei, Deine Netze sind keine Subnetze sondern eigenständige Netze mit der Maske 255.255.255.0.

Zu Deinem Problem: Ich nehme an, Du musst auf Deinem Server statische Rouene eintragen, damit er weiß, dass er bei Anfragen an das 192.168.200.0 Netz das Interface 192.168.1.16 benutzen und bei Anfragen an 192.168.1.0 das Interface 192.168.200.1 verwenden soll. Dazu musst Du mit "route add" arbeiten, sieh Dir am besten die man-Pages an,

Gruß

Atti
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:38 Uhr
Hi!

Habe ich das jetzt richtig verstanden. Der Server steht in beiden Teinetzen mit jeweils einer Karte. Dann müsste er auch normalerweise in beiden Netzen antworten können ohne dass du Routen eintragen musst weil er kennt ja beide Teilnetze schon. Kontrolliere mal genau die Einstellungen für die eine Netzwerkkarte. Da sie aus ihren eignen Teilnetz keinen Pong sendet könnte dort irgend was falsch konfiguriert sein. Liegt vieleicht ein Filter oder einer Firewall auf der KArte?


Tschau

Das Omen
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 09:45 Uhr
@ Omen

... es sind keine Teilnetze! Und somit sollte das jeweilige Standardgateway auch nicht auf die andere Karte zeigen sondern auf die eigene.

@ Mike

Was gibt denn der Befehl "route" aus, vielleicht kabnnst Du das mal posten.

Gruß

Atti.
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:53 Uhr
Hi!

@ atti

Sondern was für Netze? Der Server steht in beiden Netzen physisch mit einer Karte drin also sollte er beide Netze kennen. Wenn er keinen Pong auf der Karte zurücksenden die im Teilnetz steht dann hat es nichts mit Routen zu tun.


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 09:54 Uhr
Hallo "Kollegen",

erstmal danke für die prompte Unterstützung.

die Routingtabelle sieht wie folgt aus:


linux1:~# route
Kernel IP Routentabelle
Ziel Router Genmask Flags Metric Ref Use Iface
localnet 192.168.1.251 255.255.255.0 UG 0 0 0 eth0
localnet * 255.255.255.0 U 0 0 0 eth0
192.168.200.0 * 255.255.255.0 U 0 0 0 eth1
default 192.168.1.251 0.0.0.0 UG 0 0 0 eth0


eth0 hängt am Netz 192.168.1.x
eth1 am Netz 192.168.200.x
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 09:56 Uhr
Hi!

Sorry verlesen! Hast du überhaut routing aktiviert?


Tschau

Das Omen
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 09:58 Uhr
Worin besteht denn eigentlich Dein Problem, es kann doch nicht sein, dass es "nur" die fehlende Antwort der "entfernten" Netzwerkkarte des Servers ist? Sollen denn die User aus Netz A die PC's in Netz B nicht sehen (und umgekehrt)?

Gruß

Atti
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:04 Uhr
Vielleicht noch eine Info dazu.

Für alle Geräte welche im Netz 192.168.1.x hängen ist das Standardtgateway die 192.168.1.251 (Layer3 Switch). Dieser arbeitet auch als Standardgateway für alle Geräte im Netz 192.168.200.x unter der Adresse 192.168.200.1.
Generell laufen also alle Netze auf diesem Switch auf. Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth0 (192.168.1.168) läuft über die 192.168.1.251 an die eth0 (an dieser Karte ist ja auch das Standardgateway 192.168.1.251 eingetragen).
Eine Anfrage aus dem Netz 192.168.1.x an den Server und die karte eth1 (192.168.200. 168) läuft auch über 192.168.1.251 und dann an die 192.168.200.168

Grüße,
Mike
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 10:08 Uhr
Hi!

Hast du auf dem Server routing aktiviert?


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:11 Uhr
also das routing erfolgt direkt über den Layer3 switch an dem die beiden netze hängen.
sehen darf auch jeder alles. das klappt auch. alle geräte in allen netzen können alles anpingen
das problem ist eben nur das der server mit den zwei nic's nicht so antwortet wie er antworten sollte. anfagen aus dem netz 192.168.1.x auf server nix 192.168.1.168 klappen. anfragen aus dem netz 192.168.1.x auf server nic 192.168.200.168 klappen nicht.


grüße,
mike
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 10:13 Uhr
auf dem server selber ist kein routing aktiviert. ist das denn erforderlich ? er soll ja eigentlich selber gar nicht routen. nur antworten. auf der richtigen karte.
wenn anfragen kommen an die 192.168.1.168 dann auch auf dieser karte. anfragen an die 192.168.200.168 dann auf dieser karte
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 10:14 Uhr
Hi!

Ja sicher habe ich auch so verstanden. Versuche doch mal auf dem Server das Routing zu aktivieren.

Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 11:00 Uhr
also Routing (unter Linux IP forwarding) hatten wir schon eingestellt und getestet. Leider auch ohne den gewünschten Erfolg
Bitte warten ..
Mitglied: das-omen
08.10.2004 um 11:02 Uhr
Hi!

hmm muss mal anders Fragen warum ist es so wichtig das die andere Karte antwortet?


Tschau

Das Omen
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 11:10 Uhr
Wir hatten vorher zwei getrennte Machinen. Eine im Netz 192.168.1.x und eine im Netz 192.168.200.x
Die Anwendungen der zweiten Maschine sollen auf die erste Kiste migriert werden (bessere Auslastung).
Da wir einen haufen Anwender/ Entwickler haben die mit der festen IP arbeiten bzw. die Anwendungen auf der Kiste auf die IP festgelegt sind, war es aus unserer Sicht einfacher die bisherige Adresse beizubehalten. Eine Änderung / Anspassung der IP's bei den Anwendungen und bei den Usern ist mit einem irren Aufwand verbunden und defakto nciht machbar / vertretbar.
daher eine kiste mit zwei NIC's unter beibehaltung der IP Konfig. So zumindest die Idee
Haben auch schon versucht beide Adressen / Netze an nur eine Karte zu binden. aber das war leider auch nicht so richtig von erfolg gekrönt.


Grüße,
Mike
Bitte warten ..
Mitglied: Atti58
08.10.2004 um 13:02 Uhr
Wenn ich mir die Routingtabelle so ansehe, sehe ich nur ein Standardgateway für beide Karten. Meiner Meinung nach müsstest Du ein zweites Standardgateway in das 192.168.200.0 Netz der Karte eth1 zuweisen.

Gruß

Atti
Bitte warten ..
Mitglied: mike-berlin
08.10.2004 um 13:49 Uhr
also mit zwei standardgateways haben wir es zar auch schon versucht, aber das hat nicht geklappt. macht auch eigentlich keinen sinn da das standardgateway nur dann zum einsatz kommt wenn eine adresse nicht aufgelöst werden kann. generell gibt es meines wissens nur ein standardgateway auf jedem rechner.
noch n paar ideen ?


Grüße,
Mike
Bitte warten ..
Ähnliche Inhalte
DSL, VDSL

Zwei Wohnhäuser via WAN im gleichen Netz?!!

gelöst Frage von VivaBavariaDSL, VDSL21 Kommentare

Liebe Community, folgende Situation: Zwei Einfamilienhäuser, ca. 500m voneinander entfernt, befinden sich plötzlich im gleichen Netz?? D.h. beide Parteien ...

Netzwerkmanagement

Verbundenes Netz-Laufwerk

gelöst Frage von Juan56Netzwerkmanagement12 Kommentare

Hallo, ein Netzlaufwerk kann ich verbinden über Netzwerk - rechte Maustaste - Laufwerk verbinden - LW Buchstabe auswählen. Dieses ...

Router & Routing

Kaskadiertes Netz UPnP

Frage von Morpheus112Router & Routing4 Kommentare

Hallo Leute, ein Bekannter von mir besitzt ein kaskadiertes Netz und hat Avast installiert. An beiden Router ist UPnP ...

Vmware

VMware Workstation zwei Virtuelle Betriebssysteme im eigenen Netz verbinden

gelöst Frage von matze2090Vmware5 Kommentare

Hallo, ich möchte zwei Virtuelle Betriebssysteme so einrichten das sie miteinander Kommunizieren können. Auf der einen läuft Linux und ...

Neue Wissensbeiträge
Microsoft
SMB Compression: Deflate your IO
Ticker von Dani vor 1 TagMicrosoft

Hi folks, Ned Pyle guest-posting today about SMB Compression, a long-awaited option coming to Windows, Windows Server, and Azure. ...

Virtualisierung

Citrix end of availability (EOA) of perpetual licenses for the on-prem Workspace products

Ticker von Dani vor 1 TagVirtualisierung

Moin, der nächste Marktführer steigt von Kaufen auf Mietzwang um :-( What did Citrix announce on July 1, 2020? ...

Festplatten, SSD, Raid
Stop Error 0x0000007B (INACCESSIBLE BOOT DEVICE)
Anleitung von evinben vor 1 TagFestplatten, SSD, Raid

Systemstand Windows 7, 64-Bit, einschließlich allen Updates bis 10.09.2020 DELL Latitude E6330 PCI-Bus IRQ-Kanal 19: Standard AHCI 1.0 Serieller-ATA-Controller IRQ-Kanal ...

Sicherheit
NSA: UEFI und Secure Boot einsetzen
Ticker von sabines vor 2 TagenSicherheit3 Kommentare

Hilfreicher Heise Artikel zu UEFI und Secure Boot Tipps der NSA Näheres hier: NSA Bericht

Heiß diskutierte Inhalte
Sicherheits-Tools
Passwortmanager Vorschläge
Frage von BelmontSicherheits-Tools20 Kommentare

Servus, Ich bin aktuell auf der Suche nach einem cloudbasiertem Passwortmanager mit bestimmten Features: 1. LDAP-Anbindung bzw. Azure AD ...

Windows Server
Server zum üben
Frage von m.sunguralpWindows Server13 Kommentare

Guten Tag, ich würde mir gerne einen Server einrichten, in dem ich einfach rumtesten kann und Wissensstand erweitern kann. ...

Monitoring
2 Nutzer gleichzeitig auf einem Server mit gleichem Screen-Programm arbeiten
Frage von FreelinerMonitoring12 Kommentare

Hallo in die Runde. Frage: Ist es möglich, dass 2 Nutzer gleichzeitig auf einem Server am gleichen Desktop angemeldet ...

Windows Server
RDP zeigt nur blauer Bildschirm nach der Anmeldung!?
Frage von babyloniaWindows Server10 Kommentare

Hi, seit gestern, kommt nur die Start-Seite nach der Anmeldung an Windows 2012 Terminal Server per RDP!! Hat jemand ...

Administrator Magazin
09 | 2020 Ein Internetauftritt ist für Firmen heute eine Selbstverständlichkeit, doch gilt es beim Betrieb der entsprechenden Server einiges zu beachten. Im September beleuchtet das IT-Administrator Magazin deshalb das Schwerpunktthema "Webdienste und -server". Darin lesen Sie unter anderem, wie Sie Webapplikationen sinnvoll überwachen und welche Open-Source-Managementtools ...
Best VPN