mahutti
Goto Top

Magenta TV hinter pfSense und Cisco c3560cx

Hallo zusammen,

da dies mein erster Beitrag hier bei Euch ist, möchte ich mich gerne zuerst vorstellen.
Mein Name ist Martin und ich komme aus der Nähe von München im schönen Bayern.

Ich bin schon seit einiger Zeit stiller Mitleser in diesem Forum. Dadurch habe ich vor einiger Zeit auch bei mir im Heimnetzwerk den Sprung von der Fritzbox als All-in-One Device zu einer etwas ausgeklügelteren Netzwerkkonfiguration geschafft. Nach einem kurzen Umweg über ein UniFi Security Gateway bin ich recht schnell bei pfSense gelandet und damit super zufrieden. Vielen Dank schon mal face-smile

Kurz zu meiner bisherigen Konfiguration: Ich betreibe die PFsense auf einem APU4D4 hinter einem Vigor165 als Modem. Auf der pfSense habe ich drei VLANs erstellt. Heimnetz, IoT und Gastnetz. Als Switch kommt ein Netgear GS116E zum Einsatz. Wlan für das Heimnetz macht ein UniFi nanoHD und für das IoT-Netz eine Fritzbox 7530. Wahrscheinlich macht es wenig Sinn das auf zwei APs aufzuteilen, schaden tut es aber (hoffentlich) auch nicht. Die Fritzbox arbeitet hier nur als AccessPoint, nicht als Router.

In dieser Konfiguration funktioniert ein MR 401 von der Telekom im IoT-Netz (per Wifi über die FritzBox) einwandfrei und MagentaTV rennt wie es soll. In pfSense hab ich dafür den IGMP-Proxy eingerichtet, mit Upstream Adressen 193.158.0.0/15, 224.0.0.0/4, 87.140.0.0/15. Als Downstream ist mein IoT-Netz angegeben. Dazu WAN seitig noch den Adressbereich 224.0.0.0/4 freigegeben und IP-Options erlaubt.

Durch glückliche Umstände ist mir ein Cisco c3560cx in die Hände gefallen. Brauchen tu ich den freilich nicht, dafür befriedigt er allerdings meinen Spieltrieb, ich hoffe das ist ein angemessener Grund ihn anstelle des Netgear Switchs verwenden zu wollen face-smile Gerne hätte ich nun natürlich auch das Inter-Vlan Routing auf dem Switch.

Also habe ich, auch Dank Hilfe des Forums hier, auf der pfSense meine Vlans gelöscht und nur ein Transfernetz aufgesetzt, das ich mit dem c3560cx verbunden habe. Meine zwei Vlans habe ich nun auf dem Cisco eingerichtet (Gast erst mal weggelassen). Statische Routen auf der pfSense sind erstellt, ebenso die Default Route auf dem Cisco Switch, alles läuft soweit problemlos. Bitte schaut Euch auch hierzu meine Zeichnung an.

unbenannt 1

Die Lösung mit dem Repeater als Wlan Möglichkeit für den MR401 ist sicherlich nicht schön, allerdings läuft der nur wenn auch der MR läuft, und das ist selten. Und dass es auch in der Praxis funktioniert hab ich ja schon gesehen.

Wenn ich das richtig verstanden habe, hat so die PFsense mit meinem Inter-Vlan Verkehr nichts mehr zu tun, sie bekommt diesen Traffic gar nicht mit. So weit so gut, wie gesagt läuft alles so wie es sein soll. Bis auf IPTV. Genau dasselbe Verhalten, als wenn vorher auf der pfSense der IGMP-Proxy nicht aktiv war. Das Bild läuft für ein paar Sekunden und bleibt dann stehen. Das ist dann wohl die Umschaltung auf Multicast? Bibel-TV läuft problemlos.

Und genau hier komme ich leider nicht mehr weiter. Im Folgenden seht ihr meine Switch Konfiguration.

version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Cisco_C3560CX
!
boot-start-marker
boot-end-marker
!
enable secret 5 ...
enable password ...
!
username ...
username ...
no aaa new-model
system mtu routing 1500
!
!
ip routing
ip dhcp excluded-address 192.168.188.1
ip dhcp excluded-address 192.168.20.1
ip dhcp excluded-address 192.168.188.1 192.168.188.99
ip dhcp excluded-address 192.168.20.1 192.168.20.99
!
ip dhcp pool Heimnetz
 network 192.168.188.0 255.255.255.0
 default-router 192.168.188.1
 dns-server 10.0.0.1
!
ip dhcp pool IoT
 network 192.168.20.0 255.255.255.0
 default-router 192.168.20.1
 dns-server 10.0.0.1
!
!
ip domain-name cisco.switch
ip igmp snooping vlan 1 immediate-leave
ip igmp snooping vlan 10 mrouter interface Gi0/1
ip igmp snooping vlan 10 immediate-leave
ip igmp snooping vlan 20 immediate-leave
ip igmp snooping vlan 50 immediate-leave
!
!
spanning-tree mode rapid-pvst
spanning-tree extend system-id
service-list mdns-sd mdns-query permit 10
 match message-type query
!
service-list mdns-sd mdns-query deny 20
!
service-list mdns-sd mdns-answer permit 10
 match message-type query
!
service-list mdns-sd mdns-answer permit 20
 match message-type announcement
 match service-type _hap._tcp.local
!
service-list mdns-sd mdns-answer permit 30
 match message-type announcement
 match service-type _homekit._tcp.local
!
service-list mdns-sd mdns-answer permit 40
 match message-type announcement
 match service-type _airplay._tcp.local
!
service-list mdns-sd mdns-answer permit 50
 match message-type announcement
 match service-type _ipp._tcp.local
!
service-list mdns-sd permit-all permit 10
!
service-list mdns-sd mdns-lists query
 service-type _hap._tcp.local
 service-type _homekit._tcp.local
 service-type _airplay._tcp.local
 service-type _ipp._tcp.local
 service-type _smb._tcp.local
!
service-routing mdns-sd
 service-policy-query mdns-lists 100
!
!
vlan configuration 1,10,20,50
vlan internal allocation policy ascending
!
!
interface GigabitEthernet0/1			HIER KOMMT DAS TRANSFER-NETZ DER PFSENSE AN
 switchport mode access
!
interface GigabitEthernet0/2			HIER GEHT'S ZUM UNIFI AP  
 switchport access vlan 10
 switchport mode access
!
interface GigabitEthernet0/3
 switchport trunk allowed vlan 10,20
 switchport mode trunk
 switchport nonegotiate
!
interface GigabitEthernet0/4
 switchport trunk allowed vlan 10,20
 switchport trunk native vlan 10
 switchport mode trunk
!
interface GigabitEthernet0/5
 switchport access vlan 20
 switchport trunk allowed vlan 10,20
 switchport trunk native vlan 10
 switchport mode access
 spanning-tree portfast edge
!
interface GigabitEthernet0/6
 switchport trunk allowed vlan 50
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast edge
!
interface GigabitEthernet0/7			DAS IST DER PORT ZUR FRITZBOX
 switchport access vlan 20
 switchport mode access
!
interface GigabitEthernet0/8
 switchport trunk allowed vlan 10,50
 switchport trunk native vlan 10
 switchport mode trunk
 switchport nonegotiate
 spanning-tree portfast edge
!
interface GigabitEthernet0/9
 shutdown
!
interface GigabitEthernet0/10
 shutdown
!
interface GigabitEthernet0/11
 shutdown
!
interface GigabitEthernet0/12
 shutdown
!
interface GigabitEthernet0/13
 shutdown
!
interface GigabitEthernet0/14
 shutdown
!
interface GigabitEthernet0/15
 shutdown
!
interface GigabitEthernet0/16
 shutdown
!
interface Vlan1
 ip address 10.0.0.2 255.255.255.0
 ip igmp version 3
!
interface Vlan10
 ip address 192.168.188.1 255.255.255.0
 ip pim sparse-dense-mode
 ip igmp version 3
 service-routing mdns-sd
  service-policy mdns-answer IN
  service-policy permit-all OUT
!
interface Vlan20
 ip address 192.168.20.1 255.255.255.0
 ip access-group IoT in
 ip pim sparse-dense-mode
 ip igmp version 3
 service-routing mdns-sd
  service-policy mdns-answer IN
  service-policy permit-all OUT
!
interface Vlan29
 no ip address
!
ip forward-protocol nd
!
ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 10.0.0.1
ip ssh version 2
!
ip access-list extended IoT
 permit tcp 192.168.20.0 0.0.0.255 192.168.188.0 0.0.0.255 established
 deny   ip 192.168.20.0 0.0.0.255 192.168.188.0 0.0.0.255
 deny   ip 192.168.20.0 0.0.0.255 192.168.50.0 0.0.0.255
 permit ip any any
!
!
line con 0
line vty 0 4
 password ...
 login local
 transport input ssh
line vty 5 15
 password ...
 login local
 transport input ssh
!
!
end

Ich habe in den letzten Tagen viel probiert, wenig verstanden und im Endeffekt hat nichts davon funktioniert. Daher habe ich alle für MagentaTV gedachten Einstellungen wieder rückgängig gemacht.
Leider hapert es schon am Verständnis, wie der Multicast-Traffic meinen MR im IoT Netz erreichen soll. Benötige ich jetzt noch den IGMP-Proxy auf der PFsense oder darf ich den nicht mehr verwenden? Welche Einstellungen sind auf dem Cisco Switch notwendig? Zum Testen habe ich kurzzeitig das Routing von Vlan20 auf dem Switch deaktiviert und die pfSense wieder routen lassen. Funktioniert einwandfrei, ist aber nicht Sinn der Sache, da hätte ich auch gleich den Netgear behalten können.
Zur MagentaTV Konfiguration auf Cisco Routern hab ich schon Informationen gefunden, leider aber nie zur Konfiguration mit einem Switch in Verbindung mit pfSense.

Ich hoffe Ihr habt bis zum Ende durchgehalten und wärt so nett mir den einen oder anderen Tipp zu geben.
Gerne Lesestoff der mir hilft die Sache zu verstehen, über konkrete Tipps zur Umsetzung würde ich mich aber genauso freuen face-smile
Bitte habt Geduld mit mir, ich bin noch ein ziemlicher Anfänger.

Vielen Dank im Voraus!

Viele Grüße

Martin

Content-Key: 595937

Url: https://administrator.de/contentid/595937

Printed on: April 24, 2024 at 13:04 o'clock

Member: Uschade
Uschade Aug 14, 2020 at 07:17:33 (UTC)
Goto Top
Moin...

Dein Problem ist, dass dein IP-Tv dein WLAN flutet.
Hatte ich, hab ich mit der WLAN-Bridge von der Telekom gelöst. Kostet glaub ich ein paar 60 Euro oder so, funktioniert aber wirklich tadellos.

Hier mal ein Link zu Ebay, da wird so ein Ding angeboten...keine Sorge, ist nicht meins..^^

WLAN-Bridge IP-TV Telekom

So long
Uwe
Member: aqui
Solution aqui Aug 14, 2020 updated at 14:22:05 (UTC)
Goto Top
Du hast alles soweit perfekt richtig gemacht mit deinen Komponenten und dem Setup. Glückwunsch. Die hiesigen Tutorials können so schlecht also nicht sein.. face-smile
Zurück zum Thema...
Bei der Konfig des Catalysten hast du ein paar kleine kosmetische Fehler gemacht was das Multicast Routing mit PIM anbetrifft und vermutlich bedingen diese den Fehler.
  • Sparse Dense Mode solltest du nicht mehr konfigurieren. In Kombination proprietäre und heutzutage macht man ausschließlich Sparse Mode. Das solltest du korrigieren.
  • Es fehlt das globale Kommando ip Multicast Routing !
  • Es fehlt die Angabe eines Rendezvous Points ! Ohne das kein funktionales Multicast.
  • In den VLANs wo PIM Routing aktiviert ist brauchst du nicht zwingend IGMP Snooping aktivieren, das ist mit der Aktivierung von PIM dann Default. Schadet aber auch nicht.
  • Telekom erzwingt IGMPv3 was du aber richtig gemacht hast.
Grundlegende Konfig die auch für den L3 Switch gilt findest du hier:
Cisco 880, 890 und ISR Router Konfiguration mit xDSL, Kabel oder FTTH Anschluss plus VPN und IP-TV
Die IOS Kommandos sind mehr oder minder identisch.
Das Thema Multicast und WLAN beschreibt dieser Heise Artikel recht gut.
https://www.heise.de/ct/ausgabe/2014-14-Probleme-bei-Multicast-im-W-LAN- ...
Hier benötigt man APs die eine intelligente Multicast zu Unicast Konvertierung beherrschen was aber mittlerweile fast alle APs beherrschen. Sinnvoll ist in jedem Falle diese Funktion immer zu aktivieren.
Member: mahutti
mahutti Aug 14, 2020 updated at 14:54:01 (UTC)
Goto Top
Ich glaub ich spinn, jetzt läuft alles!

Global:
ip multicast-routing distributed
ip pim rp-address 10.0.0.1

Und im Vlan20:
ip igmp helper-address 10.0.0.1
ip igmp explicit-tracking

Das hat gefehlt. Und den pim mode hab ich ebenso, wie von aqui vorgeschlagen, von sparse-dense auf sparse umgestellt.

Jetzt läuft alles wie es soll.
Vielen lieben Dank!

Jetzt lass ich es für heute gut sein. Freitag Nachmittag und noch schönes Wetter schreien förmlich nach Biergarten face-smile

Nochmals vielen Dank, Ihr habt mir sehr geholfen!
Member: mahutti
mahutti Aug 15, 2020, updated at Feb 13, 2021 at 21:53:47 (UTC)
Goto Top
Eine kleines Problem ist mir jetzt doch noch aufgefallen, ich hoffe es ist ok wenn ich das noch zur eigentlich gelösten Frage dazuschreibe?

Wie ich gestern geschrieben habe, läuft Magenta TV grundsätzlich. Leider bleibt das Bild manchmal alle paar Minuten, manchmal alle paar Sekunden stehen. Nach einigen Sekunden Standbild geht es dann allerdings weiter, wieder für einige Sekunden.

Testweise hab ich die Tipps von aqui auch für mein Heimnetz umgesetzt, also im Vlan10.
Im pfSense IGMP-Proxy habe ich dementsprechend auch das 192.168.188.0/24 Netz als Downstream angegeben.

Folgende Befehle sind im Vlan10 gesetzt.
ip pim sparse-mode
ip igmp helper-address 10.0.0.1
ip igmp version 3
ip igmp explicit-tracking

Damit startet der Stream im VLC auf meinem PC. Das bedeutet doch, dass der Multicast Empfang grundsätzlich schon funktioniert, oder?
Mit meiner ursprünglich fehlerhaften Konfiguration hat dies nie funktioniert.

Leider komme ich hier wieder nicht weiter. Cisco bietet hier einen Troubleshooting Guide an, richtig schlau werde ich daraus aber leider nicht.

Ein paar Sachen die mir relevant erschienen hab ich noch zusammengefasst.
Cisco_C3560CX#show ip mroute 232.0.10.234
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       G - Received BGP C-Mroute, g - Sent BGP C-Mroute,
       N - Received BGP Shared-Tree Prune, n - BGP C-Mroute suppressed,
       Q - Received BGP S-A Route, q - Sent BGP S-A Route,
       V - RD & Vector, v - Vector, p - PIM Joins on route,
       x - VxLAN group
Outgoing interface flags: H - Hardware switched, A - Assert winner, p - PIM Join
 Timers: Uptime/Expires
 Interface state: Interface, Next-Hop or VCD, State/Mode

(87.141.215.251, 232.0.10.234), 01:07:10/00:02:19, flags: sTI
  Incoming interface: Vlan1, RPF nbr 10.0.0.1
  Outgoing interface list:
    Vlan10, Forward/Sparse, 01:07:10/00:02:03

Cisco_C3560CX#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable,
      L - DR Load-balancing Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode

Und hier ein kurzer Mitschnitt während der Stream läuft und hin und wieder abbricht
Aug 15 14:04:37.463: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:37.463: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:04:40.644: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:40.644: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:04:40.693: MRT(0): Update (*,232.0.10.234), RPF (unknown, 0.0.0.0, 0/0)
Aug 15 14:04:40.693: MRT(0): Update (87.141.215.251,232.0.10.234), RPF (Vlan1, 10.0.0.1, 1/0)
Aug 15 14:04:40.693: MRT(0): Update Vlan10/232.0.10.234 in the olist of (87.141.215.251, 232.0.10.234), Forward state - MAC not built
Aug 15 14:04:40.693: MRT(0): Update (*,232.0.10.35), RPF (unknown, 0.0.0.0, 0/0)
Aug 15 14:04:40.693: MRT(0): Update (87.141.215.251,232.0.10.35), RPF (Vlan1, 10.0.0.1, 1/0)
Aug 15 14:04:40.696: MRT(0): Update Vlan10/232.0.10.35 in the olist of (87.141.215.251, 232.0.10.35), Forward state - MAC not built
Aug 15 14:04:40.783: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:40.783: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:04:42.853: MRT(0): Update (*,239.254.127.63), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:42.853: MRT(0): Update Vlan10/239.254.127.63 in the olist of (*, 239.254.127.63), Forward state - MAC not built
Aug 15 14:04:42.853: MRT(0): Update (*,233.89.188.1), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:42.853: MRT(0): Update Vlan10/233.89.188.1 in the olist of (*, 233.89.188.1), Forward state - MAC not built
Aug 15 14:04:43.653: MRT(0): Reset the z-flag for (192.168.188.60, 239.255.255.250)
Aug 15 14:04:43.653: MRT(0): (192.168.188.60,239.255.255.250), RPF install from  /0.0.0.0 to Vlan10/0.0.0.0
Aug 15 14:04:43.653: MRT(0): Set the F-flag for (192.168.188.60, 239.255.255.250)
Aug 15 14:04:43.653: MRT(0): Create (192.168.188.60,239.255.255.250), RPF (Vlan10, 0.0.0.0, 0/0)
Aug 15 14:04:43.653: MRT(0): WAVL Insert interface: Vlan20 in (192.168.188.60,239.255.255.250) Successful
Aug 15 14:04:43.653: MRT(0): set min mtu for (192.168.188.60, 239.255.255.250) 18010->1500
Aug 15 14:04:43.653: MRT(0): Add Vlan20/239.255.255.250 to the olist of (192.168.188.60, 239.255.255.250), Forward state - MAC not built
Aug 15 14:04:43.653: MRT(0): Set the T-flag for (192.168.188.60, 239.255.255.250)
Aug 15 14:04:44.342: MRT(0): Update (*,224.0.1.40), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:44.342: MRT(0): Update Vlan20/224.0.1.40 in the olist of (*, 224.0.1.40), Forward state - MAC not built
Aug 15 14:04:46.194: MRT(0): Update (*,233.89.188.1), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:04:46.194: MRT(0): Update Vlan10/233.89.188.1 in the olist of (*, 233.89.188.1), Forward state - MAC not built
Aug 15 14:05:43.181: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:05:43.181: MRT(0): Update Vlan20/239.255.255.250 in the olist of (192.168.188.60, 239.255.255.250), Forward state - MAC not built
Aug 15 14:05:44.261: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:05:44.261: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:05:44.261: MRT(0): Update Vlan20/239.255.255.250 in the olist of (192.168.188.60, 239.255.255.250), Forward state - MAC not built
Aug 15 14:05:44.879: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:05:44.879: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:05:44.879: MRT(0): Update Vlan20/239.255.255.250 in the olist of (192.168.188.60, 239.255.255.250), Forward state - MAC not built
Aug 15 14:06:45.690: MRT(0): Reset the z-flag for (192.168.20.60, 239.255.255.250)
Aug 15 14:06:45.690: MRT(0): (192.168.20.60,239.255.255.250), RPF install from  /0.0.0.0 to Vlan20/0.0.0.0
Aug 15 14:06:45.690: MRT(0): Set the F-flag for (192.168.20.60, 239.255.255.250)debug ip mpacket 232.0.10.234 detail
Aug 15 14:06:45.690: MRT(0): Create (192.168.20.60,239.255.255.250), RPF (Vlan20, 0.0.0.0, 0/0)
Aug 15 14:06:45.690: MRT(0): Set the T-flag for (192.168.20.60, 239.255.255.250)
Aug 15 14:06:45.959: MRT(0): Update (*,239.255.255.250), RPF (Vlan1, 10.0.0.1, 0/0)
Aug 15 14:06:45.959: MRT(0): Update Vlan20/239.255.255.250 in the olist of (*, 239.255.255.250), Forward state - MAC not built
Aug 15 14:06:45.959: MRT(0): Update Vlan20/239.255.255.250 in the olist of (192.168.188.60, 239.255.255no debug ip mpacket 232.0.10.234 detail
IP multicast packets debugging is off (detailed)

Leider werde ich gerade aus dem debugging log nicht schlau.

Könntet Ihr mir vielleicht nochmal behilflich sein? Der PC hängt per Kabel am Switch, damit man das WLAN zumindest als Fehlerquelle ausschließen kann.

Danke und viele Grüße
Martin
Member: aqui
aqui Aug 16, 2020 at 15:54:42 (UTC)
Goto Top
Die Helper Adresse kann eigentlich keine RFC1918 IP sein sondern muss eine aus dem Telekom Magenta Netz sein sprich eine öffentliche IP.
Das Cisco Tutorial beschreibt wie du diese ermittelst mit show ppp
Member: mahutti
mahutti Aug 17, 2020 at 00:32:45 (UTC)
Goto Top
Das show ppp kennt mein Switch nicht. Dafür braucht es wahrscheinlich einen Router?

Allerdings hab ich die igmp helper-address sowie die rp-address auf 62.155.243.102 gestellt.
Es ändert sich aber leider gar nichts.

Mit dem VLC kann ich die Multicast Streams alle öffnen, sie laufen auch aber immer nur unterschiedlich lang. Dann bleiben sie für einige Sekunden abrupt stehen und laufen dann plötzlich wieder weiter. Sogar wenn ich gar keine rp-Adresse angebe. Das gleiche Spektakel auf meinem MediaReceiver

Ein show ip pim rp zeigt mir für alle Multicast Gruppen einen Rendezvous Point an. Nämlich den, den ich mit dem rp-address Kommando setze. Bei meiner Multicast Gruppe von MagentaTV steht allerdings gar nichts dahinter. Kannst Du damit vielleicht was anfangen?

Auf der pfSense hab ich die WAN seitige allow all IGMP Regel mit Ziel 224.0.0.0/4 loggen lassen. Dies zeigt mir eine Source Adresse von 62.155.242.1 an. Ich dachte, dass vielleicht das der korrekte RP ist, aber leider auch nicht, der gleiche Fehler.

Die von dir verlinkte PDF-Datei aus dem Cisco Tutorial kann ich mir leider nicht anschauen, die Datei scheint nicht mehr vorhanden zu sein.

Fällt Dir vielleicht noch was ein?
Muss ich mein Transfer-Vlan zur pfSense vielleicht noch speziell konfigurieren?
Hier ist aktuell nur ip igmp version 3 sowie ip pim sparse-mode gesetzt.

Oder ist vielleicht auf der pfSense, neben dem IGMP-Proxy, noch was einzustellen?

Vielen Dank!
Member: aqui
Solution aqui Aug 17, 2020 at 06:55:11 (UTC)
Goto Top
auf der pfSense, neben dem IGMP-Proxy, noch was einzustellen?
Nein, die pfSense supportet kein PIM Routing, deshalb ist der IGMP Proxy dort deine einzige Option.
Was noch wichtig ist ist der IGMP Querrier. Der sollte niemals doppelt definiert sein. Wenn du also ein Segment mit PIM hast ist das PIM Interface auch gleichzeitig Querrier. Das muss dann auf allen anderen MC Routing Devices deaktiviert sein.
Das gilt besonders bei der pfSense. Wenn die Querrier ist solltest du die Quierrier Funktion auf dem Switch im Koppelnetz deaktivieren.
Ansonsten Wireshark nehmen und checken wo es kneift.
Member: mahutti
mahutti Aug 17, 2020, updated at Feb 13, 2021 at 21:52:39 (UTC)
Goto Top
So, ich glaub ich hab es hinbekommen.
Warum ist mir allerdings nicht so ganz klar.

Wie von aqui beschrieben, hab ich (versucht), den IGMP Snooping Querier auf meinem Koppelnetz zu deaktivieren.
Ob ich erfolgreich war kann ich nicht genau sagen. Das einzige, das mir als Laie auffällt ist, dass die IP Adresse von Vlan1 auf die pfSense zeigt und nicht auf die IP des Switchs.

Cisco_C3560CX#show ip igmp snooping querier
Vlan      IP Address               IGMP Version   Port
-------------------------------------------------------------
1         10.0.0.1                 v2            Gi0/1
10        192.168.188.1            v3            Router
20        192.168.20.1             v3            Router
50        192.168.50.1             v3            Router

Vlan50 ist mein eigens eingerichtetes IPTV-Vlan. Da hab ich dann meinen PC angeschloßen um im Fall der Fälle nicht meine gesamte Heimnetz Konfiguration zu zerschießen. Streams habe ich nach wie vor mit dem VLC geöffnet. Die 192.168.50.2 ist mein PC.

Ebenfalls habe ich mich an den Wireshark rangetraut.
Davor hab ich wahnsinnigen Respekt gehabt aber so schlimm war's gar nicht face-smile
Hätte ich schon früher machen sollen.

Folgendes kam dabei raus:

1	0.000000000	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
2	2.006511452	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
3	2.202590069	Cisco_a7:e3:8a	Cisco_a7:e3:8a	LOOP	60	Reply
4	3.424288405	192.168.50.1	224.0.0.251	MDNS	75	Standard query 0x0000 PTR _hap._tcp.local, "QM" question  
5	3.425442788	192.168.50.1	224.0.0.251	MDNS	79	Standard query 0x0000 PTR _homekit._tcp.local, "QM" question  
6	3.427096759	192.168.50.1	224.0.0.251	MDNS	79	Standard query 0x0000 PTR _airplay._tcp.local, "QM" question  
7	3.428298514	192.168.50.1	224.0.0.251	MDNS	75	Standard query 0x0000 PTR _ipp._tcp.local, "QM" question  
8	3.429436207	192.168.50.1	224.0.0.251	MDNS	75	Standard query 0x0000 PTR _smb._tcp.local, "QM" question  
9	4.009331173	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
10	6.015172807	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
11	8.018950285	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
12	10.022018884	Cisco_a7:e3:8a	Spanning-tree-(for-bridges)_00	STP	60	RST. Root = 32768/50/a4:b2:39:a7:e3:80  Cost = 0  Port = 0x800a
13	10.999706895	192.168.50.2	224.0.0.22	IGMPv3	58	Membership Report / Group 232.0.10.35, new source {87.141.215.251}
14	11.060376482	87.141.215.251	232.0.10.35	UDP	1370	4000 → 10000 Len=1328
15	11.063369855	87.141.215.251	232.0.10.35	UDP	1370	4000 → 10000 Len=1328
16	11.066373329	87.141.215.251	232.0.10.35	UDP	1370	4000 → 10000 Len=1328
17	11.069560859	87.141.215.251	232.0.10.35	UDP	1370	4000 → 10000 Len=1328
18	11.072810161	87.141.215.251	232.0.10.35	UDP	1370	4000 → 10000 Len=1328

Ab Sekunde 10 startet ca. der Stream. Bei Sekunde 41 bricht er ab und ab Sekunde 56 läuft er wieder.

Hierbei ist mir aufgefallen, dass die Membership reports teilweise relativ lange auseinander liegen, oft mehr als 30 Sekunden.
Und da der Stream immer genau dann abgebrochen ist, als dieses Verhalten auftrat, hab ich zwei Dinge auf meinem Vlan50 interface geändert:

ip igmp query-max-response-time 5
ip igmp query-interval 10

Und damit läuft nun alles. Zum Testen gerade mal für eine gute halbe Stunde laufen lassen. Kein Abbruch, kein Ruckler, so soll es sein face-smile
Wärt Ihr vielleicht noch so nett mich aufzuklären, warum diese Einstellungen notwendig waren? Hab ich sonst bei der Konfiguration was grundlegendes vergeigt?

Nochmals vielen Dank an Euch, speziell an aqui.
Ohne Euch hätte ich das nie im Leben zum laufen bekommen.
Member: aqui
aqui Aug 18, 2020 updated at 07:50:01 (UTC)
Goto Top
Glückwunsch, alles richtig gemacht ! 👍
Wärt Ihr vielleicht noch so nett mich aufzuklären, warum diese Einstellungen notwendig waren?
Das ist leider Hersteller bedingt. Jeder Hersteller setzt dort bestimmte Default Werte ein. Konfigtechnisch sollten die natürlich auf allen Komponenten immer absolut identisch sein und alle Hersteller sollten damit gleiche Default Werte nutzen und halten sich auch meist daran. Aber leider eben nicht alle.
Leider ist das wie gesagt in der Praxis oft nicht der Fall und man muss dann manuell korrigieren das diese Werte identisch sind. Ansonsten hätte man Timing Mismatches die dann zu solchen Effekten wie bei dir führen.
Gute Beispiel mal wieder zus ehen das der Wireshark hilft beim Trouble shooting ! face-wink

P.S.: Ggf. kürzt du oben nochmal nachträglich den Wireshark Output sodas nur die wirklich relevanten Zeilen enthalten sind. Es ist sinnfrei so einen Lindwurm mit 98% überflüssiger Info zu posten ! face-wink
Informativ wäre auch nochmal die jetzt aktuell funktionierenden MC Settings des Switches und ggf. der dazu korrespondierenden Magenta IGMP Proxy Konfiguration der pfSense (Screenshots) wenns nicht zuviel Mühe ist für dich. IP TV Doku mit pfSense ist hilfreich hier, da diese Fragen oft kommen.
Member: mahutti
mahutti Aug 18, 2020, updated at Aug 19, 2020 at 16:45:43 (UTC)
Goto Top
Den Wireshark Output von oben kann ich leider nicht mehr kürzen, da kommt dann eine Meldung, dass sich über 98% des Inhalts ändern würden.

Aber sehr gerne poste ich meine funktionierenden Einstellungen!
Wäre toll, wenn das noch anderen Usern helfen kann.

Um die Config möglichst schmal zu halten habe ich nur die relevanten Sachen mit einbezogen.
Es gibt nur zwei Vlans: Vlan1 als Koppelnetz zwischen pfSense und Switch und Vlan50 als IPTV-Netz.

So schaut die Konfiguration des IGMP-Proxy auf der pfSense aus.
Als Downstream Schnittstelle ist das IPTV-Netz angegeben:

grimshot 2020-08-18 19-25-15

Die Firewallregeln WAN seitig schauen folgendermaßen aus. Bei der IPTV IGMP Regel werden Pakete mit gesetzten IP-Options erlaubt:

grimshot 2020-08-19 18-37-20

Und auf Seiten des Transfernetzes müssen dann auch noch die IP-Options aktiviert werden:

grimshot 2020-08-19 18-37-36

Auf dem Cisco c3560cx schaut die Konfiguration dann folgendermaßen aus:

!
ip multicast-routing distributed
ip igmp snooping vlan 1 immediate-leave
ip igmp snooping vlan 50 immediate-leave
!
interface GigabitEthernet0/1
 switchport mode access
!
interface GigabitEthernet0/10
 switchport access vlan 50
 switchport mode access
!
interface Vlan1
 ip address 10.0.0.2 255.255.255.0
 ip pim sparse-mode
 ip igmp version 3
!
interface Vlan50
 ip address 192.168.50.1 255.255.255.0
 ip pim sparse-mode
 ip igmp helper-address 62.155.243.102
 ip igmp query-max-response-time 5
 ip igmp version 3
 ip igmp explicit-tracking
 ip igmp query-interval 10
!
!
ip pim rp-address 62.155.243.102
ip pim ssm default
!
!
end

Vielen Dank und vielleicht hilft es ja dem einen oder anderen face-smile
Member: aqui
aqui Aug 19, 2020 updated at 06:28:30 (UTC)
Goto Top
da kommt dann eine Meldung, dass sich über 98% des Inhalts ändern würden.
Stimmt, das ist etwas nervig hier im Forum...aber egal, dann lassen wir das eben. face-wink
Dank für deine Settings ! 👍

Eine Frage noch zu den Regeln: Die Anleitung HIER sagt (Zitat): "Zusätzlich müssen Sie zwei Firewall-Regeln anlegen, die IGMP und UDP zum Netz 224.0.0.0/4 zulassen, jeweils auf der WAN-Schnittstelle als auch den internen Netzen. "
Hast du die auch eingerichtet oder ging das auch ohne weil die oben fehlten ?
Member: mahutti
mahutti Aug 19, 2020 updated at 17:24:02 (UTC)
Goto Top
Zitat von @aqui:
Eine Frage noch zu den Regeln: Die Anleitung HIER sagt (Zitat): "Zusätzlich müssen Sie zwei Firewall-Regeln anlegen, die IGMP und UDP zum Netz 224.0.0.0/4 zulassen, jeweils auf der WAN-Schnittstelle als auch den internen Netzen. "
Hast du die auch eingerichtet oder ging das auch ohne weil die oben fehlten ?

Nein, geht nicht ohne. Die hab ich nur schon vor so langer Zeit eingerichtet, dass ich die ganz vergessen hab face-smile
Ich hab es oben korrigiert, danke für den Hinweis!
Member: aqui
aqui Aug 20, 2020 at 07:49:04 (UTC)
Goto Top
👍