foto2004
Goto Top

Omada-Controller nach Umzug keine Endgeräte

Hallo Gemeinde,

wieder ein Problem mit dem Omada-Controller.

ich habe den Software Omada-Controller auf eine andere VM umgezogen (in Docker) soweit läuft er ja einwandfrei aber es werden mir keine Endgeräte angezeigt bzw. einige sind noch da aber nicht alle und neue werden auch nicht angezeigt.

Hat einer eventuell da eine Idee woran das liegen könnte? Ich habe den Umzug mittels Sicherung über den Controller und das einspielen der Sicherung gemacht damit eben alle Mine Einstellungen usw erhalten bleiben, sind sie auch eben nur die Endgeräte werde nicht angezeigt. Aber er kennt sie weil als ich einen AP rausgenommen habe het mir der Controller angezeigt dass sich ein bestimmtes Gerät nicht mit dem AP2 verbinden kann weil ich es so eingestellt hatte dass sich dieses Endgerät nur mit dem AP1 verbinden darf.

Controller = Omada Controller_A3691A
Controller-Version 5.9.31

Content-Key: 2462285551

Url: https://administrator.de/contentid/2462285551

Printed on: June 13, 2024 at 18:06 o'clock

Member: Pjordorf
Pjordorf Sep 16, 2023 at 18:22:47 (UTC)
Goto Top
Hallo,

Zitat von @foto2004:
Hat einer eventuell da eine Idee woran das liegen könnte?
Schon den grünen Nippel durch die rote Lasche gezogen? face-smile

Gruß,
Peter
Member: beidermachtvongreyscull
beidermachtvongreyscull Sep 17, 2023 at 04:03:08 (UTC)
Goto Top
Moin,

ohne die Software genau zu kennen, mutmaße ich, dass ein Neuaufsetzen auf einer anderen Maschine und das Einspielen eines Configbackups einfach nicht reicht.

Also, was kann es sein?

  • Hast Du eventuell eine Lizenz auf der neuen Maschine zu aktivieren?
  • Über Omada lese ich vorallem das Wort "Cloud". Ist Dein Controller vielleicht eher ein Tennant, der erstmal korrekt in Deine Omada-Cloud eingebunden werden muss, bevor er funktioniert?
  • Ich kenne von anderen zentral verwalteten APs, dass die via DHCP eine Option bekommen müssen, in der die IP des verwantwortlichen Controllers drin ist. Ist das hier auch so oder hat der neue Controller die gleiche IP, wie der alte?

Gruß
bdmvg
Member: foto2004
foto2004 Sep 17, 2023 at 07:15:32 (UTC)
Goto Top
Da ist keine Lizenz zu aktivieren weil ich die Cloud nicht nutze.

Und Nippel oder Laschen sind da auch keine face-wink

Ich wolle es eben vermeiden dass ich meine ganzen VLANs usw neu aufsetzen muss.
Member: em-pie
em-pie Sep 17, 2023 at 07:47:59 (UTC)
Goto Top
Moin,

Hatte den OMADA selbst mal eine zeitlang (zum Testen @home) als Dock Container laufen. Auch ein „abreißen“ und neu aufsetzen klappte, bei dem ich glaube ich auch die Config vorher ex- und wieder importiert hatte. Ist aber auch schon 3Jahre her.
In einem anderen Projekt hab ich dann den fertigen OMADA OC200 genutzt.

Sind die beiden Docker in der selben Version gewesen?
IPs identisch geblieben (sollten die mit der Config ja eigentlich)
Mal einen AP neugestartet?
Mal (nur zum Test) einen AP komplett zurück gesetzt, sodass der jungfräulich einen Controller suchen kann?

Ich weiß nicht, ob die nach den ControllerJoin Zertifikate austauschen. Müsstest du mal recherchieren. Falls ja: sind die vielleicht nicht mitgekommen?
Member: nunnu728
nunnu728 Sep 17, 2023, updated at Sep 28, 2023 at 18:08:41 (UTC)
Goto Top
sind sie auch eben nur die Endgeräte werde nicht angezeigt. Aber er kennt sie weil als ich einen AP rausgenommen habe het mir der Controller angezeigt dass sich ein bestimmtes www.routerlogin.net
pikashow apk
Member: foto2004
foto2004 Sep 17, 2023 at 14:11:40 (UTC)
Goto Top
ja ich habe auch schon einen AP rausgenommen und wieder eingebunden auch alle Geräte hatte ich schon neu gestartet.
Member: em-pie
em-pie Sep 17, 2023 at 14:20:58 (UTC)
Goto Top
Zitat von @foto2004:

ja ich habe auch schon einen AP rausgenommen und wieder eingebunden auch alle Geräte hatte ich schon neu gestartet.
Und seit dem läuft es?

Ansonsten: Port, an dem der Docker-Server hängt, spiegeln und mit dem Kabelhai prüfen, was an Traffic so eintrudelt…
Member: foto2004
foto2004 Sep 17, 2023 at 15:11:19 (UTC)
Goto Top
Nein es läuft nicht, wie gesagt der Controller muss die Endgeräte irgendwie sehen weil er zB mosert wen ein bestimmtes Gerät dass sich nur auf dem AP1 verbinden darf versucht auf den AP2 zu verbinden aber wen ich zB auf die Meldung klicke bekomme ich einen Fehler und er mach mir nicht auf der Seite wie gewohnt das Endgerät auf. Auch neue Geräte kann ich ins Netzwerk einbinden aber sie werden mir einfach nicht angezeigt.
Member: em-pie
Solution em-pie Sep 17, 2023 at 15:17:16 (UTC)
Goto Top
Dann noch mal die Frage: passt die Version der eingespielten Config zur neuen Docker-Version?

Und für den OMADA-Docker gab es zumindest mal mehrere Anbieter. Ich hab damals den von mbemtley genutzt…
Member: Snagless
Solution Snagless Sep 17, 2023 at 20:38:09 (UTC)
Goto Top
Hallo,

ich hatte schon den Fall APs mit zu alter FW nicht vom Controller erkannt wurden. Ich würde mal drauf tippen dass die Controller Versionen nicht identisch sind. Oder was mit der Netzwerkonfig / VLAN nicht passt. Installier doch mal einen Soft-Controller von TPL, wenn der sie alle erkennt liegt das Prob. Wohl in eher im Docker-Conroller - das Ding ist ja vermutlich nix offizielles von TPL.
Member: foto2004
Solution foto2004 Sep 23, 2023 updated at 06:06:10 (UTC)
Goto Top
Ich habe es hinbekommen.

Lösung war der Hinweiß dass es verschiedene Docker Versionen von dem Omadacontroller gibt.
Ich habe danach den gleichen noch einmal auf der VM Installiert und das Backup eingespielt und das war es. Er hatte zwar nicht alle Namen Aufgelöst aber das ist zu verkraften.

Danke für eure Mühe