horstvogel
Goto Top

Pfsense 2.4.4 Squid SSL Man In the Middle Filtering Zertifikatsfehler nach Update von 2.4.3

Hallo,
ich habe gerade das Update meiner Pfsense von 2.4.3 auf 2.4.4 gemacht, nun funktioniert SSL Man In the Middle Filtering nicht mehr.
Bzw. ich bekomme jetzt immer einen Zertifikatsfehler. Proxy Cache gelöscht, Paket nochmals installiert, Zertifikat gewechselt, leider immer noch der Fehler
Vor dem Update hat alles funktioniert, kann jemand die Probleme bestätigen?
Ich habe Transparent Proxy aktiviert und SSL Man in the Middle und der Man in the Middle macht halt den Zertifikatsfehler. Wie geschrieben, hat es vorher immer wunderbar funktioniert.

danke!!

2

Content-Key: 387530

Url: https://administrator.de/contentid/387530

Printed on: May 21, 2024 at 11:05 o'clock

Member: moJ090
moJ090 Sep 25, 2018 at 07:00:59 (UTC)
Goto Top
Moin,

Wurde vill beim Update das ca Zertifikat neu erzeugt und du musst es bei den Clients neu importieren?

Was sagt denn der Browser wie die zertifikatskette ausschaut und prüfe doch mal nach ob das mit dem Zertifikat in der pfsense übereinstimmt!?

Gruß Mojo
Member: horstvogel
horstvogel Sep 25, 2018 updated at 16:14:59 (UTC)
Goto Top
Hallo Mojo,
ich betreibe den Squid als Transparent Proxy, dann muss man auf dem jeweiligen Client kein Zertifikat installieren.
danke der Horst

https://zefanjas.de/pfsense-webfilter-squidguard-fuer-https-verbindungen ...
Transparenter Proxy für HTTPS-Verbindungen
Bisher ist der transparente Proxy nur für HTTP, d.h. unverschlüsselte Anfragen aktiv. Zu Beginn dieses Artikels habe ich bereits auf die Schwierig.....
Member: horstvogel
horstvogel Sep 25, 2018 at 16:27:48 (UTC)
Goto Top
Könnte das der Bug sein?

https://redmine.pfsense.org/issues/8832


2018-09-25 18_25_31-window
Member: horstvogel
horstvogel Sep 26, 2018 at 18:45:53 (UTC)
Goto Top
Für die Nachwelt, dass Problem ist jetzt bei Pfsense bzw. Squid behoben. Ich musste Squid einmal deinstallieren, dann wieder installieren, nur die Neuinstallation des Paket hat nichts gebracht, dann den Squid Cache löschen und Neustart der Pfsense und dann ging das wieder.


https://redmine.pfsense.org/issues/8832

der Horst
Member: horstvogel
horstvogel Sep 28, 2018 at 15:19:47 (UTC)
Goto Top
Es gab die letzten Tage einige Update für den Squid, jetzt sind die Probleme anscheinend alle behoben, sogar das direkte Update auf meiner weiteren Pfsense hat direkt geklappt, Squid hat gleich funktioniert.