Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Port forwarding funktioniert nicht für Linux Server im WAN, LAN geht

Mitglied: gargoyle

gargoyle (Level 1) - Jetzt verbinden

14.07.2020, aktualisiert 19:51 Uhr, 361 Aufrufe, 7 Kommentare

Hi,

sehr merkwürdiges Problem. Urplötzlich funktioniert der Zugriff von außen auf einen Linux Server (VM) nicht mehr.
Ich habe ein port forwarding auf der Fritzbox eingerichtet. Im LAN funktioniert das auch. Auch für Linux. Findet ja auch kein forwarding statt.
Von außen, über die WAN IP, klappt es für alle Rechner, ausser der Linux VM. Ich kann zB port 80 auf einen Windows Rechner forwarden, das funktioniert. Der Linux Rechner bleibt stumm.
Das einzige was ich in letzter Zeit angepackt habe ist die MAC Adresse, die ich versucht habe im VM Manager umzubiegen. Aber daran kann man es nicht richtig festmachen.
Mir fällt nichts mehr ein... iptables habe ich auch schon probiert. Fritzbox Problem?
Jemand eine Idee?
Mitglied: erikro
14.07.2020 um 19:52 Uhr
Moin,

hast Du die Fritte schonmal neu gestartet?

Zitat von gargoyle:
Das einzige was ich in letzter Zeit angepackt habe ist die MAC Adresse, die ich versucht habe im VM Manager umzubiegen. Aber daran kann man es nicht richtig festmachen.

Vielleicht versucht die Fritte das noch an die alte MAC zu schicken und findet die nicht mehr. Das sollte sich aber mit der Zeit von alleine erledigen.

hth

Erik
Bitte warten ..
Mitglied: Lochkartenstanzer
14.07.2020 um 20:16 Uhr
Zitat von gargoyle:

Von außen, über die WAN IP, klappt es für alle Rechner, ausser der Linux VM. Ich kann zB port 80 auf einen Windows Rechner forwarden, das funktioniert. Der Linux Rechner bleibt stumm.

Was sagt tcpdump/wireshark?

Das einzige was ich in letzter Zeit angepackt habe ist die MAC Adresse, die ich versucht habe im VM Manager umzubiegen. Aber daran kann man es nicht richtig festmachen.

Das kann durchaus die Ursache sein, weil dann ggf die ARP-Tabelle nciht paßt, bzw die Fritzbox die Pakete zwar an die richtige IP-Adresse, aber an die falsche Mac schickt.

Mir fällt nichts mehr ein... iptables habe ich auch schon probiert. Fritzbox Problem?

Einfach mal auf der Fritzbox mitsniffen, wohin die Pakete gehen.

lks
Bitte warten ..
Mitglied: Dr.Bit
14.07.2020 um 21:36 Uhr
Zitat von gargoyle:

. Urplötzlich funktioniert der Zugriff von außen auf einen Linux Server (VM) nicht mehr.
Das einzige was ich in letzter Zeit angepackt habe ist die MAC Adresse,

Dann war das ja wohl doch nicht so urplötzlich. Schon mal die Fritte und den LinuxRechner neu gestartet, damit die Tabellen sich "berappeln"?

🖖
Bitte warten ..
Mitglied: gargoyle
14.07.2020, aktualisiert um 22:03 Uhr
Ich habe alles schon x mal neugestartet, weil ich schon den ganzen Tag daran am rumdoktorn bin.
Ich habe den Eintrag des Rechners unter Heimnetz/Netzwerk gelöscht, habe ihm einecandere IP verpasst, und habe auch nochmals die MAC Adresse geändert. Das Ergebnis bleibt das gleiche.
Änderungen des port forwardings auf andere Zielrechner haben immer spontan geklappt.
Ich bin leider nicht sicher wie ich das mitsniffen machen soll. Habe noch nie mit wireshark gearbeitet.
ARP Tabellen sagt mir auch nichts.
Hat man da eine Chance das auszulesen, editieren, reseten?
Paketmittschnitt im Fritzbox Supportbereich? Welche Schnittstelle?
Bitte warten ..
Mitglied: Dr.Bit
14.07.2020 um 22:11 Uhr
Und wenn Du die Netzwerkkarte unter Linux entfernst, dann neu startest und dann die Netzwerkkarte wieder einbindest? Dann sollte die die echte Mac wieder haben. Wieso ändert man überhaupt eine Mac Adresse?

🖖
Bitte warten ..
Mitglied: gargoyle
14.07.2020, aktualisiert um 22:54 Uhr
Es ist eine VM. Es gibt also nicht wirklich eine 'echte'
Der Grund liegt beim Google Music Manager. Der mag keine VM Macadressen.

Ich habe jetzt im Paketmischnitt der Routing Schnittstelle folgendes gefunden:
"243","8.713254","192.168.0.10","31.17.209.78","TCP","52","[TCP Retransmission] 54478 → 8088 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 WS=256 SACK_PERM=1"
"244","8.713254","31.17.209.78","192.168.0.45","TCP","52","[TCP Retransmission] 54478 → 8088 [SYN] Seq=0 Win=64240 Len=0 MSS=1460 WS=256 SACK_PERM=1"

Ohne zu wissen was es genau bedeutet, scheint doch der Versuch des forwardings unternommen worden zu sein von 192.168.0.10 (lokaler client) -> 31.17.209.78 (wan ip) -> 192.168.0.45 (lokaler server)

Das ganze kommt x mal.

Im Browser gabs allerdings ein timeout.
Bitte warten ..
Mitglied: gargoyle
15.07.2020 um 17:21 Uhr
Ich habe jetzt die Fritzbox resettet und neu konfiguriert.
Danach geht es immer noch nicht.
Es liegt wohl an der Konfiguration des Servers.

Irgendwelche Hinweise wie ich das am besten analysieren kann?
Bitte warten ..
Ähnliche Inhalte
Windows Server

Remote Desktop über LAN funktioniert, über WAN trotz Port Forwarding nicht

Frage von Mario0084Windows Server8 Kommentare

Hallo Experten, ich habe ein Problem mit meinem Windows Server 2012 R2 bzgl. Remote Desktop. Die RDP Verbindung im ...

Virtualisierung

VirtualBox - SSH Port forwarding funktioniert nicht

Frage von thepandapi94Virtualisierung

Hey Zusammen, auf meinem Host Server habe ich einen SSH Dienst laufen, welcher auf einen anderen Port lauscht und ...

Router & Routing

Libvirt Port forwarding

Frage von fundave3Router & Routing1 Kommentar

NAbend zusammen, Eventuell könnt ihr mir helfen. ICh bin dem Tipp von aqui gefolgt und habe meine alte Monitoring ...

LAN, WAN, Wireless

MikroTik Port Forwarding

gelöst Frage von darefilzLAN, WAN, Wireless2 Kommentare

Hallo liebe Gemeinde, bei mir hakelt es noch am Port Forwarding im MikroTik-Router. Ich habe mir diverseste Anleitungen, Videos ...

Neue Wissensbeiträge
Sicherheit

Eine ungepatchte Sicherheitslücke in der Windows Druckerwarteschlange ermöglicht das Ausführen von Malware mit Adminrechten

Information von transocean vor 6 StundenSicherheit

Moin, eigentlich sollte die Sicherheitslücke schon seit Mai 2020 geschlossen sein. Aber lest selbst. Grüße Uwe

Erkennung und -Abwehr

Liste ungeschützter Pulse-VPN-Server veröffentlicht

Information von Visucius vor 2 TagenErkennung und -Abwehr

bzw. Der tiefe Blick in die Profi-Administratoren-Welt ;-)

Windows 10

Windows Defender verhindert Telemetrieblocking via hosts-Datei

Information von BirdyB vor 2 TagenWindows 102 Kommentare

Für diejenigen, die keine Daten an MS senden wollten, war die hosts-Datei manchmal eine Option.

Monitoring

Unabhängiger Ansatz - IoT (frei von Cloud- oder Appzwang) - Hier mit Schaltsteckdosen

Anleitung von beidermachtvongreyscull vor 5 TagenMonitoring2 Kommentare

Tach Kollegen, ich erzähle Euch mal von meiner Ausgangslage und den/m Problem(chen) Ich benutze ein NAS zur Lagerung meiner ...

Heiß diskutierte Inhalte
Server
Verbindung zum Linux Server nicht möglich
gelöst Frage von it-fraggleServer13 Kommentare

Hallo zusammen, habe gerade ein sonderbares Problem auf dessen Lösung ich gerade nicht komme. Wir haben hier seit einigen ...

CPU, RAM, Mainboards
LED Lüfter und LED LEiste dunkel beim einloggen
Frage von uridium69CPU, RAM, Mainboards11 Kommentare

Moin Ich habe einen PC mit einem ASUS RGB tauglichen Board, dort habe ich einerseits einen CPU Lüfter mit ...

Server-Hardware
Shop für Serverteile
Frage von thomas-hnServer-Hardware10 Kommentare

Hallo, als Privatanwender ist es oft nicht ganz so einfach professionelle Server-Hardware bzw. Zubehörteile zu kaufen. Welche seriösen Onlineshops ...

Batch & Shell
PowerShell GUI - ListView nur bestimmten Text einfärben
gelöst Frage von Daniel183Batch & Shell9 Kommentare

Hallo zusammen, heute mal wieder mit einer PowerShell-Frage die mich ein wenig nervt Ich habe eine PowerShell-GUI mit einem ...

Weniger Werbung?
Administrator Magazin
07 | 2020 In der Juli-Ausgabe beleuchtet das IT-Administrator Magazin den Themenschwerpunkt "Monitoring & Support". Darin zeigt die Redaktion unter anderem, wie Sie die Leistung von Terminalservern im Blick behalten und welche Neuerungen das Ticketsystem OTRS 8 mitbringt. Auch die Überwachung von USV-Anlagen darf nicht fehlen. In ...