Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Probleme bei Installation über SCCM

Mitglied: boeckerit

boeckerit (Level 1) - Jetzt verbinden

22.08.2013 um 10:31 Uhr, 2333 Aufrufe, 5 Kommentare

Hallo Zusammen,

ich habe folgendes Problem bei der Verteilung eines msi Paketes unter SCCM 2007.

Wenn ich das Paket unter den normalen Rechten ( also Systemrechten ) installieren lasse und das Programm auf dem Client starte, beginnt bei jedem Start das Programm mit einem self-repair.
Wenn ich über SCCM mit den Rechten den Anwenders installiere, der währen der Installation angemeldet ist funktioniert der Programmstart problemlos. Hat jemand eine Idee, wie man das Problem lösen kann?

Das Problem läßt sich im übrigen auch lokal am Client darstellen. Sobald ich das msi unter einem anderen benutzer istalliere, als der der angemeldet ist, startet das Programm jedesmal mit einem self-repair.
Mitglied: Bitboy
22.08.2013 um 11:39 Uhr
Hi,

um welches Programm handelt es sich denn?

Nach deiner Beschreibung würde ich darauf tippen, dass das Programm in der User Registry bzw. im User Pfad während der Installation Dateien / Einträge anlegt die beim Start mit einem anderen Benutzer natürlich fehlen.

Sowas kann man fixen indem man das Paket selber baut und die Userabhängigen Teile als eigenen Installer in der Registry unter ActiveSetup einträgt oder bei dem von dir benutzten Programm gibt es vllt einen unattend-Switch der das auch von sich aus machen kann.
Bitte warten ..
Mitglied: boeckerit
22.08.2013 um 12:36 Uhr
Hi,

es handelt sich um ein unbekanntes Programm, welches speziell für meinen Kunden entwickelt wurde. Es ist ein Install-Shield Installer mit einer embedded msi. Also repaketieren scheidet damit eigentlich aus. Ich hab in die msi geschaut. Usereinträge werden nicht gesetzt, weder in der Registry als auch im Userverzeichnis.

Ich sehe das Problem eher in den Access-Token, welche bei der Installation mitgegeben werden.

Active Setup hatte ich auch probiert, führt auch zu keinem zufriedenstellenden Ergebnis. Die Installation ist nur dann wirklich erfolgreich, wenn es in dem Kontext installiert wird, in dem man auch am Client angemeldet ist.
Bitte warten ..
Mitglied: departure69
22.08.2013 um 12:58 Uhr
@boeckerit:

Hallo.

Eine Repaketierung von Setups, die Embdedded-MSIs enthalten, ist durchaus möglich, allerdings nicht mit den bekannten, kostenlosen MSI-Erstellern (z.B. "makemsi"), sondern mit deren Professional- bzw. Enterprise-Varianten.

Beispiel:

http://www.scalable.com/smart-packager-pro/ - die kostenlose Variante kann bloß MSIs erstellen aus Setups, die selber keine MSI enthalten, die kostenpflichtige Variante kann auch MSIs repaketieren.

Es geht also durchaus, kostet aber.

Grüße

von

departure
Bitte warten ..
Mitglied: Bitboy
22.08.2013 um 13:25 Uhr
Hi

wie versuchst du denn zu installieren? Aufruf der EXE oder der eingebetteten msi?
Ich würde an deiner Stelle mal beides versuchen und wenn möglich per /log Switch eine Logdatei erstellen lassen (Am besten bei einer installation die funktioniert und einer die nicht funktioniert hat) und mal schauen was die Unterschiede in der Log sind. Dann kommen wir dem Problem vllt auf die Spur.
Bitte warten ..
Mitglied: boeckerit
22.08.2013 um 14:32 Uhr
Hi, danke für eure Antworten.

lassen wir mal die Verteilung über SCCM beiseite.

Wenn ich die Setup.exe lokal ausführe ( Anwender hat Adminrechte) , funktioniert die Installation und der Start des Programms.
Führe ich die Setup.exe unter einem anderen User aus, funktioniert die Installation auch, habe aber das Problem, das jedesmal wenn ich das Programm starte ein self- repair stattfindet.
Bitte warten ..
Ähnliche Inhalte
Windows Server
SCCM PXE Installation bleibt stehen
Frage von LordNicon79Windows Server1 Kommentar

Hallo zusammen, ich habe hier einen aktuellen SCCM kann seit letzte Woche keine PCs per PXE mehr installieren. Davor ...

Windows Server
Problem SCCM Fehler: 0x80004005
Frage von geforce28Windows Server2 Kommentare

Hallo Leute, ich hoffe hier sind ein paar SCCM Experten unterwegs, die mir helfen können ! Ich habe einen ...

Windows Tools

SCCM 1902 bringt Bluescreen bei PXE Installation

Frage von Susie1703Windows Tools10 Kommentare

Hallo Gemeinde, lange ist es her das ich hier etwas gefragt habe und heute ist es mal wieder soweit. ...

Windows Tools

SCCM Drucker nach Installation von Druck SW hinzufügen

Frage von bolle01Windows Tools7 Kommentare

Moin, erstmal einen juten Start ins neue Jahr. Es gibt mal wieder ein Problem wo ich nicht weiter komme. ...

Neue Wissensbeiträge
Microsoft Office

Office 365 Makro Schutz nicht immer per GPO möglich

Information von sabines vor 1 TagMicrosoft Office1 Kommentar

Der zum Schutz gegen Verschlüsselungstrojaner wichtige Makroschutz lässt sich wohl in Office 365 nicht immer per GPO einstellen. Für ...

Netzwerkmanagement
How To Mikrotik Netinstall
Erfahrungsbericht von areanod vor 3 TagenNetzwerkmanagement

Jedes Mal wenn ich Netinstall längere Zeit nicht benutzt habe stolpere ich über die „Besonderheiten“ dieser Software. Das ist ...

Microsoft
Microsoft: LDAPS per Update als Default
Information von em-pie vor 3 TagenMicrosoft2 Kommentare

Hallo, Microsoft wird mit einem der zukünftigen Updates LDAP auf LDAPS per Default umstellen. Admins von angebundenen Systemen die ...

Humor (lol)

Funny: Warum es immer schwieriger wird, die richtigen Produkte online zu finden

Information von Dilbert-MD vor 5 TagenHumor (lol)19 Kommentare

Wir befinden uns in der Rubrik "Off Topic - Humor" und in 15 Minuten ist Freitag. und ja, es ...

Heiß diskutierte Inhalte
Windows Server
Kontakt mit Warenwirtschaft Software Anbieter - Netzwerkstbilität
Frage von PoddeldunktWindows Server18 Kommentare

Hallo zusammen, entschuldigt erstmal den schlechten Titel, aber mir ist nicht eingefallen wie ich das ganze Aussagekräftiger gestalten soll. ...

Windows 10
Reicht eine 64GB SSD für einen Einwahl-PC für die Funktionsupgrade?
gelöst Frage von StefanKittelWindows 1018 Kommentare

Hallo, ich weiß, bei Google steht ganz viel, aber das meiste zu 32GB und irgendwie schreibt jeder was Anderes. ...

Windows Tools
Autologoff Local User Windows 10 bei idle Time von 900 Sekunden
Frage von Hendrik2586Windows Tools16 Kommentare

Hallo ihr lieben. :) Ich hatte das Thema schon mal vor einer Weile, aber nun muss ich es nochmal ...

Windows Server
Problem bei der Installation von .Net Framework 3.5 auf Server 2012R2
Frage von Timo0oWindows Server15 Kommentare

Hallo zusammen, vielleicht kann mir hier wer helfen ich bin nämlich langsam am Verzweifeln. Ich habe hier einen Server ...