Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst VLAN Frage - Netzwerk-Problem?

Mitglied: 1Yves1

1Yves1 (Level 1) - Jetzt verbinden

08.12.2013 um 16:48 Uhr, 4009 Aufrufe, 8 Kommentare

Hallo zusammen,

Ich bin recht neu hier und wollte mal um euren Rat fragen. Ich erläutere schnell mein Problem und dann meine Lösungsidee mit der Frage.

Ich habe einen Router von meinem Provider (Swisscom <-> pendant von Telekom in der Schweiz) erhalten. Wir haben ja inzwischen auch den schönen Router-zwang und unsere Router kann / darf man auch nicht mehr bridgen sonst funktionieren bestimmte Dienste nicht mehr so wie sie sollten (z.B. SwisscomTV - IPTV Dienst der Swisscom). Vor allem bei FTTH ist das ganze super komplex und mühsam geworden. Was noch neu dazu kommt ist das der neue Router nicht mal mehr in ein anderes Netz als das 192.168.x.x gepackt werden kann (was sich aber laut Hotline um einen Software-Bug handelt welcher bis Ende 1. Quartal 2014 gelöst wird).

Also habe ich mich entschieden hinter den Router einen Router zu packen welcher mein Netz bedient und alle Funktionen kann die ich so brauche. Natürlich wusste ich von Anfang an das das SwisscomTV nicht mehr funktioniert wenn es durch den 2. Router hindurch muss, womit ich auch recht hatte. 7 Sek Bild, dann Freeze, Senderwechsel, wieder 7 Sek Bild, wieder Freeze. usw. Liegt angeblich am Multicast der nicht sauber durchgeht. Soweit so gut. Wenn ich nun ein super langes LAN Kabel nehme die SwisscomTV Box direkt auf den LAN2 des Swisscom Routers schliesse läuft das natürlich wieder alles einwandfrei. Jedoch ist das ganze ja nicht gerade schön wenn man ein LAN Kabel durch das ganze Haus hat. Es gibt zwar eine Verbindung vom Stromkasten (wo der Swisscom und der neue Router ist) direkt zur SwisscomTV Box, jedoch sind dort noch 16 andere LAN Geräte welche im gleichen Netz sein sollten wie der 2. Router und nicht wie der 1. Router also kann man diese Verbindung nicht nur für die SwisscomTV Box einsetzten. Nun zu meiner Idee. Ich hab zwei ziemlich gute Switches (ZyXEL GS1910-24 und ZyXEL GS2200-10 beide managed) womit ich VLANs machen kann, also habe ich mir gedacht ich könnte doch den LAN2 von 1. Router (Swisscom) auf den z.B. LAN9 vom GS2200-10 stecken auf den Port ein VLAN erstellen. Der Switch ist ja mit dem anderen Switch im Wohnzimmer via dieses einzelne Kabel verbunden. Dort auf dem 2. Switch dann auch einen Port mit dem gleichen VLAN Taggen wie auf dem 1. Switch und auf diesen Port dann die SwisscomTV Box anschliessen.

Geht das?

Beide Geräte SwisscomTV und der Router der Swisscom können keine VLANs, ist das relevant? Oder wird der Traffic von VLAN1 eh nur an die Ports im VLAN1 weitergeleitet?

Vielen Dank für eure Hilfe

Freundliche Grüsse
Yves
Mitglied: aqui
LÖSUNG 08.12.2013, aktualisiert 09.12.2013
Ja, das geht bzw. funktioniert natürlich so ! Grundlagen dazu erklären dir diese Tutorials:
https://www.administrator.de/wissen/vlan-installation-und-routing-mit-m0 ...
http://www.schulnetz.info/vlan-einstieg-was-ist-ein-vlan/

Dein eigentliches Grundproblem ist aber der 2te Router den du beschafft hast, denn der supportet kein IP Multicast Routing. Das ist das alleinige Übel das TV nicht mehr funktioniert. Hier hast du also schlicht und einfach vermutlich aus Unwissenheit oder weill du dich nicht richtig informiert hast das falsche Produkt gekauft. Schade…denn dann hätte die Frickelei mit den VLANs nicht sein müssen aber mit dem Umweg ist es auch so mit der falschen Router HW lösbar.
Auch ist deine Schlussfolgerung mit dem Zwangsrouter nicht immer richtig. Auf energisches Nachfragen und Androhung der Kündigung oder Providerwechsel rücken so gut wie alle Provider die Zugangsdaten raus und dann kann man auch (fast immer) alle freien Router einsetzen.
Bitte warten ..
Mitglied: AlFalcone
08.12.2013 um 23:13 Uhr
Leider nicht bei der Swisscom mit dem Abo vom TV.....
Bitte warten ..
Mitglied: MrNetman
LÖSUNG 09.12.2013, aktualisiert um 19:05 Uhr
Es geht.

du betreibst deine VLANs wie ein komplett getrenntes Netzwerk, vergleichbar mit dem Ziehen des langen Kabels. Das geht auf jeden Fall auch ohne Unterstützung des Routers.
Du musst nur am TV und am Swisscom Router-TV-Port eine ander VLAN-ID einstellen und schon verteilt der Switch diese Art Pakete nur für die beiden Teilnehmer. Switchübergreifend geht das auch, wenn die uplinks getaggt werden.

Der Rest steht in den Tutorials von aqui.

Gruß
Netman
Bitte warten ..
Mitglied: 1Yves1
09.12.2013 um 17:25 Uhr
Also, ich hab das ganze mal probiert... leider ohne Erfolg.

Ich habe da ich mal einfach starten wollte am Port10 den Swisscom Router angeschlossen und am Port9 auf dem gleichen Switch mit dem langen LAN Kabel die Swisscom TV Box. Beide Ports ins VLAN10 gelegt und getaggt.

Leider ohne Erfolg...

Hier die Bilder der Konfiguration (ich wusste nicht wie man hier direkt Bilder einfügen kann - also hab ich s auf meine Dropbox geladen):

https://www.dropbox.com/sh/jmvkcbdhpqmoq99/Dd7CeHZZbJ

Grüsse
Yves
Bitte warten ..
Mitglied: 1Yves1
09.12.2013 um 18:06 Uhr
Ich musste das TX-Tagging abschalten. Nun klappt es einwandfrei. Jetzt muss ich s nur noch hinkriegen das vom Switch1 zum Switch2 geht.
Bitte warten ..
Mitglied: aqui
LÖSUNG 09.12.2013, aktualisiert um 19:06 Uhr
Das TX Tagging abschalten…WO ?? Diese Aussage ist mehr oder weniger völlig sinnfrei in dem Kontext
Ein Tagging auf Ports wo Endgeräte angeschlossen sind die untagged Pakete erwarten ist gelinge gesagt ja auch Blödsinn oder meinst du eine TV Box "versteht" VLAN Tags ??
Falls es dich technisch interessiert WIE Endgeräte solche Tags verstehen können kannst du ja mal in dieses Tutorial sehen:
https://www.administrator.de/wissen/vlan-routing-über-802-1q-trunk- ...
Das erfordert aber wie du siehst entsprechende NIC Hardware. Das dein billiges Provider Geraffel sowas nicht kann sollte klar sein.

Na ja das "Verbinden" ist ja kinderleicht wenn du beide VLANs auf dem Uplink zwischen den Switches beidseitig taggst, dann ist das damit gelöst !
Also….
(Router)-----Port VLAN 10-untagged----(Switch)-----Port VLAN 10-tagged----(Switch)----Port VLAN 10-untagged----(Endgerät)
Vielleicht liest du erstmal das VLAN Grundlagen Tutorial vom Kollegen Pfisterer oben, dann erübrigen sich auch solche Grundsatzfragen hier…sorry.
Bitte warten ..
Mitglied: 1Yves1
09.12.2013 um 18:57 Uhr
Sorry aqui, das Problem sind nicht VLANs ansich. Ich habe schon diverse kleinere VLANs gebastelt. Jedoch ist das mühsame das die Interfaces für die VLAN Einstellungen immer wieder anders aussehen (je nach dem noch unzählige mehr Funktionen haben - wie z.B. TX-Tagging).

Aber ich versteh das es mühsam ist für dich Basics weiter zu geben zum 1001 ersten mal zu erklären.

Noch zum TX-Tagging, als ich das auf dem 1. Switch auf dem Port10 wo der LAN2 vom Swisscom Router angeschlossen ist abgeschalten habe funktioniert es einwandfrei. Habe nun den Port2 welcher der Uplink ist zum 2. Switch noch mit dem VLAN10 getaggt. Beim 2. Switch habe ich den Port2 welcher der Uplink an den 1. Switch ist auch VLAN10 getaggt. Port1 vom 2. Switch wo das SwisscomTV dran ist VLAN10 untagged.

Resultat: Alles klappt 1a!

Danke tausendmal!
Bitte warten ..
Mitglied: aqui
09.12.2013, aktualisiert um 19:12 Uhr
Na ja kommt so ein bischen auf die Switchhardware an was man da zum VLAN konfigurieren sieht. Das Gros ist da eigentlich recht logisch sowohl im GUI als auch CLI. Unrühmliche Ausnahme ist hier NetGear an deren kryptischer Syntax und VLAN Logik verzweifeln auch mal Profis (sorry D.o.b.b.y )….
Klasse das nun alle rennt wie es soll…
Bitte warten ..
Ähnliche Inhalte
Router & Routing
VLan Netzwerk aufbauen
gelöst Frage von MacLifeRouter & Routing3 Kommentare

Hallo Leute, ich bin dabei unser normales Netzwerk in einzelne VLans aufzuteilen. Jedoch möchte ich bevor ich auf unserem ...

LAN, WAN, Wireless
Einfaches VLAN Netzwerk aufbauen
Frage von momaiLAN, WAN, Wireless9 Kommentare

Hallo, ich habe vor ein Netzwerk mit VLANs aufzubauen. Es soll ein Internes und ein öffentliches geben (VLAN ID ...

Netzwerkgrundlagen
VLAN Netzwerk zu Hause
gelöst Frage von niLuxxNetzwerkgrundlagen10 Kommentare

Liebe Community, Ich bin gerade dabei mein Heimnetzwerk in 2 Subnetzwerke zu trennen (privat und "geschäftlich"). Die Idee war ...

LAN, WAN, Wireless
Netzwerk mit VLAN (Mikrotik Router)
gelöst Frage von wing84LAN, WAN, Wireless19 Kommentare

Ich versuche gerade mein Netzwerk im Büro neu zu organisieren. Folgendes würde ich gerne realisieren: 4 VLAN (Server, Drucker, ...

Neue Wissensbeiträge
Humor (lol)
Preisvertipper
Information von Dilbert-MD vor 1 TagHumor (lol)6 Kommentare

Moin! weil heute Freitag ist, zeige ich Euch den Preisvertipper der Woche: vergesst den Acer Predator 21x, der ist ...

Windows Update
Sicherheitsupdate für SQL Server 2014 SP3
Information von sabines vor 2 TagenWindows Update2 Kommentare

Für den SQL Server 2014 existiert ein Sicherheitsupdate. Laut KB Artikel wird es als CU3 angezeigt: Server 2014 SP3 ...

Backup

Veeam Agent für MS Windows - neue Version verfügbar (bedingt jedoch offenbar .NET Framework 4.6)

Information von VGem-e vor 3 TagenBackup1 Kommentar

Moin Kollegen, einer unserer Server zeigte grad an, dass für o.g. Software ein Update verfügbar ist. Ob ein evtl. ...

Python

Sie meinen es ja nur gut - Microsoft hilft python-Entwicklern auf unnachahmliche Weise

Information von DerWoWusste vor 5 TagenPython2 Kommentare

Stellt Euch vor, Ihr nutzt python unter Windows 10 und skriptet damit regelmäßig Dinge. Nach dem Update auf Windows ...

Heiß diskutierte Inhalte
Windows Update
WSUS - erforderlich Updates
Frage von emeriksWindows Update24 Kommentare

Hi, ein gängiges Verfahren, welche Updates man am WSUS-Server genehmigen soll und welche nicht, beruft sich darauf, dass man ...

Debian
Alle Verbindungen bis auf eine IP Adresse blockieren
Frage von BananenmeisterDebian13 Kommentare

Hallo Zusammen, Ich habe einen Hyper-V Server auf dem ein debian (ohne desktop) läuft. Dort drauf ist ein Webserver ...

Windows 7
Windows 7: Keine Anmeldung mehr möglich
Frage von hreinartWindows 713 Kommentare

hallo, bei meinem win7 rechner (medion laptop) kann ich mich nicht mehr anmelden. er fährt ohne fehlermeldungen hoch, bringt ...

Netzwerke
Dataintegrity Win7
Frage von alexlaza11Netzwerke9 Kommentare

Schönen guten Abend, Ich wollte fragen wie ihr die Datenintigrität gewährleistet bei qualifizierten Systemen (Pharmaunternehmen, Lebensmittelkonzerne ect.) Die meisten ...