sk8er-boi
Goto Top

Zugriff auf SAMBA Server von einem WIN 10 PC nicht mehr möglich, Ping möglich

Hallo Zusammen,
ich habe einen SAMBA Server unter Proxmox virtualisiert.
Bislang hatte ich mit 3 WIN 10 Pro Rechner Zugriff drauf.
Seit neuestem kann ein Rechner nicht mehr drauf zugreifen.
Anpingen ist möglich.
Auf dem SAMBA Server sind keine User angelegt, ich greife per guest drauf zu.

Beim Versuch auf den Server zuzugreifen, kommt folgende Meldung:
Vergewissern sie sich dass der Name richtig geschrieben wurde oder es liegt ein Netzwerkfehler vor.
Richtig geschrieben ist es (gleiche Zeichenkette funktioniert auf anderen Rechnern)

Was für Infos braucht ihr noch?
Ich weiß aktuell noch nicht wo ich ansetzen muss.

Da alle anderen Rechner funktionieren, versuche ich den Fehler an diesem Rechner zu finden.
Per Powershell NET view SAMBA funktioniert auch nicht, da der Dienst NET angeblich nicht gestartet ist.

Grüße Daniel

Content-Key: 665150

Url: https://administrator.de/contentid/665150

Printed on: February 24, 2024 at 03:02 o'clock

Member: Henere
Henere Mar 25, 2021 at 22:19:26 (UTC)
Goto Top
Servus.
Welche SMB-Stände hat das NAS und die Clients ?

Grüße Henere
Member: sk8er-boi
sk8er-boi Mar 25, 2021 at 22:45:07 (UTC)
Goto Top
auf dem NAS:

Version 4.9.5-Debian

@Samba:~# testparm -v | grep protocol
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Registered MSG_REQ_POOL_USAGE
Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
Load smb config files from /etc/samba/smb.conf
rlimit_max: increasing rlimit_max (1024) to minimum Windows limit (16384)
Processing section "[homes]"
Processing section "[Share]"
Loaded services file OK.
Server role: ROLE_STANDALONE

Press enter to see a dump of your service definitions

client ipc max protocol = default
client ipc min protocol = default
client max protocol = default
client min protocol = CORE
server max protocol = SMB3
server min protocol = LANMAN1

WIN 10 Rechner:

sc.exe qc lanmanworkstation
[SC] QueryServiceConfig ERFOLG

SERVICE_NAME: lanmanworkstation
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 1 NORMAL
BINARY_PATH_NAME : C:\WINDOWS\System32\svchost.exe -k NetworkService -p
LOAD_ORDER_GROUP : NetworkProvider
TAG : 0
DISPLAY_NAME : Arbeitsstationsdienst
DEPENDENCIES : Bowser
: MRxSmb20
: NSI
SERVICE_START_NAME : NT AUTHORITY\NetworkService
Member: GarfieldBonn
GarfieldBonn Mar 25, 2021 at 23:00:42 (UTC)
Goto Top
Auf den Clients mal bitte mit administrativer Powershell den Befehl ausführen:

Get-SmbServerConfiguration | Select EnableSMB1Protocol, EnableSMB2Protocol
Member: fredmy
fredmy Mar 26, 2021 updated at 06:47:01 (UTC)
Goto Top
Hallo,
mal treudoof gefragt: aber die nmbd und smbd Dienste laufen ?

ggfs. auf der Debiankiste findsmb Script aufrufen
Danach erst Win-Kiste ansehen... aber hats du ja wohl gemacht.
Win-Firewall blockiert auch nix, und auf dem Win-Client laufen die smb-Dienste
(hatte ähnliches Problem mit Fritz.Nas - irendein Win-Update muss da in den Einstellungen des Clients ""rumgepfuscht" habe..vermute ich hier mal - war zumindest meine Lösung)

Fred
Member: StefanKittel
StefanKittel Mar 26, 2021 at 08:36:47 (UTC)
Goto Top
Moin,

ich hatte gerade bei einem Kunden das Problem, dass ein Client mit Win20H2 und SMB3 nicht auf ein NAS mit dem Gast-Account zugreifen konnte.
Es kam aber eine passende Meldung, dass Gastzugriffe via SMB nicht mehr erlaubt sind.

Stefan
Member: aqui
aqui Mar 26, 2021 at 09:55:14 (UTC)
Goto Top
mal treudoof gefragt: aber die nmbd und smbd Dienste laufen ?
Wenn von 3 Rechnern 2 fehlerfrei zugreifen können und nur einer nicht muss das ja der Fall sein. face-wink
Member: gammelobst
gammelobst Mar 26, 2021 at 21:05:04 (UTC)
Goto Top
Hallo,

und auf dem Server:

server min protocol = SMB2

setzen
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 18:45:19 (UTC)
Goto Top
PS C:\WINDOWS\system32> Get-SmbServerConfiguration | Select EnableSMB1Protocol, EnableSMB2Protocol

EnableSMB1Protocol EnableSMB2Protocol
------------------
True True


Das scheint zu laufen
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 18:55:34 (UTC)
Goto Top
So sieht die Conf jetzt aus. Funktioniert leider immer noch nicht.


GNU nano 3.2 /etc/samba/smb.conf

[global]
map to guest = Bad Password
security = user
workgroup = WORKGROUP
server min protocol = SMB2

[homes]
comment = Home Directories
browsable = yes
read only = no
create mode = 0750

[Share]
path =/data/
public = yes
writable = yes
comment = smb share
printable = no
guest ok = yes
read only = no
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 18:56:12 (UTC)
Goto Top
So sieht bei mir die Fehlermeldung aus.
samba
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:00:34 (UTC)
Goto Top
service smbd status:

  • smbd.service - Samba SMB Daemon
Loaded: loaded (/lib/systemd/system/smbd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2021-03-28 18:48:49 UTC; 9min ago
Docs: man:smbd(8)
man:samba(7)
man:smb.conf(5)
Process: 141 ExecStartPre=/usr/share/samba/update-apparmor-samba-profile (code=exited, status=0/SUCCESS)
Main PID: 145 (smbd)
Status: "smbd: ready to serve connections..."
Tasks: 4 (limit: 38248)
Memory: 16.7M
CGroup: /system.slice/smbd.service
|-145 /usr/sbin/smbd --foreground --no-process-group
|-175 /usr/sbin/smbd --foreground --no-process-group
|-176 /usr/sbin/smbd --foreground --no-process-group
`-192 /usr/sbin/smbd --foreground --no-process-group

Mar 28 18:48:49 Samba systemd[1]: Starting Samba SMB Daemon...
Mar 28 18:48:49 Samba systemd[1]: Started Samba SMB Daemon.
Mar 28 18:48:49 Samba smbd[145]: [2021/03/28 18:48:49.327481, 0] ../lib/util/become_daemon.c:138(daemon_ready)
Mar 28 18:48:49 Samba smbd[145]: daemon_ready: STATUS=daemon 'smbd' finished starting up and ready to serve connections

service nmbd status:

  • nmbd.service - Samba NMB Daemon
Loaded: loaded (/lib/systemd/system/nmbd.service; enabled; vendor preset: enabled)
Active: active (running) since Sun 2021-03-28 18:59:42 UTC; 10s ago
Docs: man:nmbd(8)
man:samba(7)
man:smb.conf(5)
Main PID: 320 (nmbd)
Status: "nmbd: ready to serve connections..."
Tasks: 1 (limit: 38248)
Memory: 2.3M
CGroup: /system.slice/nmbd.service
`-320 /usr/sbin/nmbd --foreground --no-process-group

Mar 28 18:59:42 Samba systemd[1]: Starting Samba NMB Daemon...
Mar 28 18:59:42 Samba systemd[1]: Started Samba NMB Daemon.
Mar 28 18:59:42 Samba nmbd[320]: [2021/03/28 18:59:42.146490, 0] ../lib/util/become_daemon.c:138(daemon_ready)
Mar 28 18:59:42 Samba nmbd[320]: daemon_ready: STATUS=daemon 'nmbd' finished starting up and ready to serve connections
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:07:00 (UTC)
Goto Top
XXX@Samba:~# findsmb

*=DMB
+=LMB
IP ADDR NETBIOS NAME WORKGROUP/OS/VERSION
192.XXX.178.XX SAMBA +[ WORKGROUP ]
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:08:46 (UTC)
Goto Top
XXX@Samba:~# smbtree
smbXcli_negprot_smb1_done: No compatible protocol selected by server.
smbXcli_negprot_smb1_done: No compatible protocol selected by server.

Soll das so ?
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:09:40 (UTC)
Goto Top
XXX@Samba:~# smbstatus

Samba version 4.9.5-Debian
PID Username Group Machine Protocol Version Encryption Signing

Service pid Machine Connected at Encryption Signing

No locked files
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:29:03 (UTC)
Goto Top
Ich habe langsam die Vermutung das es an dem Lanmanworkstation Dienst liegt.
Diesen bekomm ich einfach nicht zum Laufen:
lan
Member: sk8er-boi
sk8er-boi Mar 28, 2021 at 19:51:48 (UTC)
Goto Top
Ich hab das Gefühl ich komm der Sache näher:


C:\WINDOWS\system32>sc config LanmanWorkstation start=auto
[SC] ChangeServiceConfig ERFOLG

C:\WINDOWS\system32>sc start LanmanWorkstation
[SC] StartService FEHLER 1075:

Der Abhängigkeitsdienst ist nicht vorhanden oder wurde zum Löschen markiert.


C:\WINDOWS\system32>sc qc LanmanWorkstation
[SC] QueryServiceConfig ERFOLG

SERVICE_NAME: LanmanWorkstation
TYPE : 20 WIN32_SHARE_PROCESS
START_TYPE : 2 AUTO_START
ERROR_CONTROL : 1 NORMAL
BINARY_PATH_NAME : C:\WINDOWS\System32\svchost.exe -k NetworkService -p
LOAD_ORDER_GROUP : NetworkProvider
TAG : 0
DISPLAY_NAME : Arbeitsstationsdienst
DEPENDENCIES : bowser
: mrxsmb10
: mrxsmb20
: nsi
SERVICE_START_NAME : NT AUTHORITY\NetworkService

C:\WINDOWS\system32>sc query Bowser

SERVICE_NAME: Bowser
TYPE : 2 FILE_SYSTEM_DRIVER
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0

C:\WINDOWS\system32>sc query MRxSmb20

SERVICE_NAME: MRxSmb20
TYPE : 2 FILE_SYSTEM_DRIVER
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0

C:\WINDOWS\system32>sc query NSI

SERVICE_NAME: NSI
TYPE : 30 WIN32
STATE : 4 RUNNING
(STOPPABLE, NOT_PAUSABLE, IGNORES_SHUTDOWN)
WIN32_EXIT_CODE : 0 (0x0)
SERVICE_EXIT_CODE : 0 (0x0)
CHECKPOINT : 0x0
WAIT_HINT : 0x0