WSUS - seit 07.04.2021 kein Sync mehr

Mitglied: jsysde

jsysde (Level 3) - Jetzt verbinden

08.04.2021 um 11:09 Uhr, 1923 Aufrufe, 20 Kommentare, 3 Danke

Moin zusammen,

ich sehe auf mehreren WSUS-Servern seit gestern Abend (07.04.2021, ~21.00h) Sync-Errors. Auch befreundete Admins aus anderen Unternehmen haben das gleiche Problem.
Könnt ihr bitte mal auf eure WSUS-Kisten schauen, wie das bei euch ausschaut?

Witzigerweise funktioniert der Sync auf einem (nicht mehr aktiven) WSUS-Server. Da wurde im Februar die autom. Synchronisation deaktiviert, ein jetzt angetriggerter, manueller Sync läuft aktuell noch.

Danke.

Cheers,
jsysde
Mitglied: Tommy70
08.04.2021 um 11:13 Uhr
Hallo,

kann ich bestätigen. Letzte erfolgreiche Synchronisierung am 07.04.2021 um 1 Uhr.
Danach sind alle fehlerhaft.

Tom
Bitte warten ..
Mitglied: jsysde
08.04.2021 um 11:46 Uhr
Servus.

Danke fürs schauen - beruhigt mich einerseits, andererseits wirft es (einmal mehr) ein paar Fragen auf, die ich eigentlich gar nicht stellen will...

Cheers,
jsysde
Bitte warten ..
Mitglied: psannz
08.04.2021, aktualisiert um 12:32 Uhr
Sers,

bei mir gab es heute morgen um 6:11 Uhr einen erfolgreichen Sync mit ein paar Updates. WSUS ist ein 2012R2.
Manueller Sync um 12:20 war ebenfalls erfolgreich mit +1 Update.

Grüße,
Philip
Bitte warten ..
Mitglied: n4426
08.04.2021 um 12:40 Uhr
Hallo jsysde,

bei mir ist der letze Sync 8.4.2021 um 5:25 Uhr erfolgreich.

Grüße,
n4426
Bitte warten ..
Mitglied: em-pie
08.04.2021, aktualisiert um 12:42 Uhr
Moin,

kann ich nicht bestätigen.
Da heute der 08.04.2021 ist und bei uns immer des Abends die Updates synchronisiert werden: letzter Sync am 07.04.21 ~20:30 verlief problemfrei.

Im Eventlog steht auch kein Fehler...

Edit: WSUS läuft auf einem Server 2016 - Patchstand Anfang 03/2021

Gruß
em-pie
Bitte warten ..
Mitglied: tomolpi
08.04.2021, aktualisiert um 12:42 Uhr
Zitat von @psannz:

Sers,
Tach zusammen,
bei mir gab es heute morgen um 6:11 Uhr einen erfolgreichen Sync mit ein paar Updates. WSUS ist ein 2012R2.
Manueller Sync um 12:20 war ebenfalls erfolgreich mit +1 Update.
meiner hat sich heute Nacht, 2:15 Uhr erfolgreich synchronisiert. Fehlgeschlagen ist es laut Log aber am 06.04. und am 07.04.
Grüße,
Philip
Grüße
tomolpi
Bitte warten ..
Mitglied: yumper
08.04.2021, aktualisiert um 13:05 Uhr
Hallo

mein 2019 WSUS synchronisiert jeden Tag um 21:14 fehlerlos. Kommen auch jedes mal mindestens Defender Updates. Etwas komisch - Seit der Sommerzeit wird 1 Stunde später synchronisiert.

So long

Yumper
Bitte warten ..
Mitglied: Ex0r2k16
08.04.2021 um 14:06 Uhr
Nöp, alles gut. Gerade eben Win2012R2
Bitte warten ..
Mitglied: departure69
08.04.2021 um 14:15 Uhr
Letzter erfolgreicher Synch. am 07.04.2021, 19.45 Uhr, seither nur noch Fehler:

susunbenannt - Klicke auf das Bild, um es zu vergrößern

Viele Grüße

von

departure69


P.S.: Danke für den Hinweis, ich hätte es selber vorerst nicht bemerkt.
Bitte warten ..
Mitglied: Delta9
08.04.2021 um 15:05 Uhr
Mal bei Günni geklaut:

"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“. Sobald ich die beiden Produkte deaktiviere geht der Sync wieder."

https://www.borncity.com/blog/2021/04/08/wsus-hat-kein-sync-mehr-7-4-202 ...
Bitte warten ..
Mitglied: jsysde
08.04.2021, aktualisiert um 15:52 Uhr
Servus.

Zitat von @Delta9:
"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“.
Hier ebenfalls - beide Produkte rausgenommen, Sync läuft wieder erfolgreich. *thumbs up*

Cheers,
jsysde

EDITH:
Habe erst 2017 wieder rein => Fehler
2017 raus, dafür 2019 rein => Fehler
Liegt also wohl an der Kombi aus beiden.
Bitte warten ..
Mitglied: Tommy70
08.04.2021 um 15:56 Uhr
Zitat von @Delta9:

Mal bei Günni geklaut:

"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“. Sobald ich die beiden Produkte deaktiviere geht der Sync wieder."


Bei mir hat es ebenfalls wieder funktioniert nachdem ich Visual Studio 2019 in den Produkten deaktiviert habe.

Tom
Bitte warten ..
Mitglied: departure69
08.04.2021 um 15:59 Uhr
VS raus - geht wieder.
Bitte warten ..
Mitglied: MysticFoxDE
08.04.2021, aktualisiert um 20:55 Uhr
Moin jsysde,

Zitat von @Delta9:
"Bei mir liegt (lag) es an „Visual Studio 2017“ und „Visual Studio 2019“.
Hier ebenfalls - beide Produkte rausgenommen, Sync läuft wieder erfolgreich. *thumbs up*

Cheers,
jsysde

EDITH:
Habe erst 2017 wieder rein => Fehler
2017 raus, dafür 2019 rein => Fehler
Liegt also wohl an der Kombi aus beiden.

das Problem kenne ich.
Was hast du für eine FW/UTM davor geschaltet?
Schaut dir mal die IPS/WEB-Proxy Logs nach der IP des WSUS und Blocks durch.
(Bitte prüfen ob der Datenverkehr des WSUS auch geloggt wird.)
Diese funken den Downloads des WSUS und auch dessen Synchronisierung gerne mal dazwischen.
Meistens justieren die FW/UTM Hersteller, paar Tage nachdem ein solches Problem auftritt,
die Signaturen nach und dann geht's wieder von alleine.

Manchmal hilft in solchen Fällen auch eine WSUS Bereinigung.

An einer zu trägen Datenbank kann der Sync auch zerbrechen.
Für diesen Fall hilft das folgende.
https://administrator.de/content/detail.php?id=554097
Das optimieren der Indexe hilft aber auch bei vielen anderen WSUS Problemchen. 😀
Dank diesem Zauber sind bei unseren Kunden sämtlich Downloadkategorien, inklusive Treiber 🤪 angehack und die WSUSe schnurren dennoch wie ein Kätzchen. (Die WSUS DB kann dann aber gut und gerne 20 GB und mehr erreichen.)

Grüsse aus BaWü
Alex
Bitte warten ..
Mitglied: jsysde
08.04.2021 um 21:06 Uhr
N'Abend.

Zitat von @MysticFoxDE:
[...]Was hast du für eine FW/UTM davor geschaltet?[...]
Unterschiedlichste. Sophos UTM, FritzBox, Cisco ASA, Unifi - soll ich jetzt alle Möglichkeiten aufzählen? ;-) face-wink
Deine Idee in alle Ehren, aber die Firewall ist hier nicht das Problem sondern leider einmal mehr MS - das Entfernen von VS2017/2019 hat bei allen KollegInnen, mit denen ich darüber gesprochen habe, das Problem behoben. Sobald eines der beiden Produkte wieder reingenommen wird, tritt der Fehler wieder auf - zumindest meinem analytisch denkenden Teil des Hirns genügt das als Beleg dafür, wo hier der Schuldige zu suchen ist.

Ich behalte das Thema natürlich weiter im Auge und lasse mich mal überraschen, ob und wann sich MS dazu äußert. Und wie deren Problemlösung und/oder Workaround dann ausschaut. Und natürlich lasse ich mich eines besseren belehren, wenn es dann doch auf ein IPS-Szenario hinausläuft. ;-) face-wink

Cheers,
jsysde
Bitte warten ..
Mitglied: MysticFoxDE
09.04.2021 um 06:48 Uhr
Moin jsysde,

an den FW's & Co scheint das Problem dieses Mal wirklich nicht zu hängen.
Habe gestern auf anhieb einen WSUS bei einem Kunden gefunden, der dasselbe Problem aufweist.

Bei diesem Server schlägt auch seit neustem die Serverbereinigung bei dem folgenden Schritt fehl.


🤔

Gruss Alex
Bitte warten ..
Mitglied: Ex0r2k16
09.04.2021 um 08:40 Uhr
Update: Irrtum. Doch kaputt. Thx 4 Info.
Bitte warten ..
Mitglied: jsysde
09.04.2021 um 11:03 Uhr
Servus.

Augenscheinlich ist das Problem behoben - VS2017/2019 wieder reingenommen, Sync ist erfolgreich durchgelaufen.
Danke für's Mitlesen.

Cheers,
jsysde
Bitte warten ..
Mitglied: Looser27
09.04.2021 um 13:53 Uhr
Hab gerade mal geschaut....unser WSUS hat ohne Fehler synchronisiert; das letzte Mal heute morgen um 10:00 Uhr.

Gruß

Looser
Bitte warten ..
Mitglied: kgborn
10.04.2021, aktualisiert um 23:37 Uhr
Kleiner Nachtrag - ich habe es bei mir im Blog im weiter oben verlinkten Blog-Beitrag nachgetragen. Das Produktteam hat inzwischen bestätigt, dass es ein Problem mit Visual Studio gab und das Ganze gefixt. Daher synchronisiert der WSUS inzwischen wieder. Schönes WE.
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 22 StundenFrageWindows 1036 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 17 StundenFrageOff Topic17 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 18 StundenTippHumor (lol)9 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 1 TagFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming11 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server8 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...

SAN, NAS, DAS
Synology DS213j - Volume nach HDD Austausch vergrößern
gelöst JasperBeardleyVor 1 TagFrageSAN, NAS, DAS4 Kommentare

Moin, ich hab meinem NAS zwei neue 8TB spendiert, da die 3TB Platten jetzt 6 Jahre alt sind. Da die beiden Platten im JBOD ...