VPN-PPTP zwischen zwei ALL130DSLBv2

sinnlos98
Hallo Leute,

habe diesmal ein Problem zwischen zwei Allnet Routern bzw. zwischen Windows XP Prof. und Windows 2003. Ich versuche eine VPN-PPTP Verbindung zwischen dem Standort A (Internetanbindung via ALL130DSLBv2 und Windows XP Prof.) und dem Standort B (Internetanbindung via ALL130DSLBv2 und Windows 2003) einzurichten. Dies jedoch ohne Erfolg. Habe auf Windows 2003 Routing- und RAS eingerichtet und auch mit einem alten ALL130DSL ohne Probleme hinbekommen. Portforwarding TCP 1732 auf den internen Windows 2003 Server geleitet. Nun ist es so, dass die Verbindung aufgebaut wird, jedoch die Verifizierung des Benutzernamens und Passworts abbricht. Auf dem Windows 2003 Server wird im Ereignisprotokoll Rasman und 20209 protokolliert, mit dem Inhalt, dass eventuell ein GRE unterstützt wird bzw. zustande kommt. Ich bin langsam am verzweifeln, da ich schon fast alles durchgetestet habe.

1. Lösungsweg

Windows XP Prof. mit Modem und PPPOE Verbindung konfiguriert. Einwahl funktioniert jedoch eine Verifizierung des BN und PW. (gleiches Phänomena).

2. Lösungsweg (werde ich noch ausprobieren)

Alten ALL130DSL vor Windows 2003 Server setzen und das gleiche Spiel testen. Kommt Verbindung und Verifizierung zustande liegt das Problem beim Router (ALL130DSLBv2). Falls es jedoch auch Probleme machen wird, kann es nur noch am Provider liegen. Damals funktionierte es mit HanseNet ohne Probleme. Jetzt bin ich bei Versatel.

Wäre über jeden Denkansatz und eventuelle Lösung von euch sehr dankbar!

Content-Key: 38875

Url: https://administrator.de/contentid/38875

Ausgedruckt am: 27.01.2022 um 12:01 Uhr

Mitglied: aqui
aqui 28.08.2006 um 13:26:49 Uhr
Goto Top
Wer initiert denn die PPTP Verbindung ??? Ein Cleint hinter dem Router oder der Server ???

Bei ersterem sollte es kein Problem sein, da der Server nach deiner Beschreibung direkt im Internet hängt (höchst bedenklich....nebenbei bemerkt) und eingehende Verbindungen nicht weitergereicht werden müssen.
Bei der 2. Variante musst du natürlich mit Port Forwarding arbeiten im Router. Die TCP Verbindung auf Port 1723 eröffnet nur eine Authentisierungssequenz zum Aushandeln des Schlüssels für den parallelen GRE (Generic Route Encapsulation) Tunnel in dem dann die Verbindungsdaten fliessen.
Du musst also 2 Portforwarding Einträge haben:
1.) TCP Port 1723 auf das Endgerät (IP Adresse) hinter dem Router
2.) GRE, Protokoll 47 (Achtung das ist die Protokoll Nummer nicht der TCP Port !!!)

Kann der Router kein GRE forwarden hast du keine Chance. Meist machen einige Router automatisch ein VPN passthrough was dann die GRE Daten automatisch parallel an die IP des TCP 1723 Ports forwardet. Das Feature muss aber der Router unterstützen sonst klappt es nicht bzw. du musst es statisch eintragen !

Ein aktiver DynDNS Account um den Router zu erreichen sei mal vorausgesetzt....
Mitglied: sinnlos98
sinnlos98 28.08.2006 um 15:59:10 Uhr
Goto Top
Hi, vielen Dank für die Antwort!

Nein, der Server hängt nicht im Internet. Er sitzt hinter einer Firewall die im Router integriert ist. Diese Blockt alles außer die benötigten Ports. Diese werden wiederum im lokalen LAN direkt auf die Server IP geforwardet. Keine Sorge ;-) face-wink.
Tja, so wie es aussieht kann der Router nur ein Forwarding realisieren von TCP und UDP, jedoch nicht von anderen Protokollen. Das merkwürdige an der ganzen Sache ist, dass es vorher mit dem ALL130DSL ging, obwohl dieser auch keine GRE Funktion hatte (auch nur TCP und UDP).

Alles sehr merkwürdig!

PS.: Der Client versucht eine Verbindung zum Server zu initieren.

Nach einem telefonischen Gespräch mit dem Allnet Support stellte sich der o.g. Verdacht heraus. Der neue ALL130DSLBv2 kann kein GRE bzw. VPN Pass-Trough. Sie konnte mir aber nicht erklären warum es beim Vorgänger ging. Diese konnte es nämlich ebenfalls nicht. Ich könnte mir nur vorstellen, dass GRE in einer neuen Firmware versteckt eingebunden wurde und die Informationen nicht intern bei Allnet veröffentlicht wurden.
Mitglied: aqui
aqui 29.08.2006 um 22:01:08 Uhr
Goto Top
Vielleicht gibt es ein neueres Image Update das das supported hat die Hotline mal was dazu gesagt ? Allnet ist nicht gerade eine Marke die für gut supportete Features steht und an der Aussage von der Hotline kannst du sehen welche Kundengruppe die im Auge haben: Massenmarkt, Consumer die solche Features nicht interessieren. Also niicht für eine seriöse Firmenanwendung. Preis ist halt nicht alles und das ist ein schmerzvolles Beispiel dafür :-( face-sad
Da solltest du besser mal auf Alternativen setzen.....(Draytek, Fritz, BinTec, Lancom etc.)
Heiß diskutierte Beiträge
question
Marode Netzwerk-Infrastruktur im kleinen Unternehmen - wo anfangen?StephanXVor 1 TagFrageNetzwerkmanagement48 Kommentare

Guten Abend zusammen, es geht um einen kleinen Betrieb (Kfz-Werkstatt) mit einer recht wirren und planlosen Netzwerkstruktur und Datensicherung, welche ich so langsam mal richten ...

general
Generator für endlose, kostenlose Energie? Ein gut gemachter Schwindel? gelöst beidermachtvongreyscullVor 23 StundenAllgemeinOff Topic25 Kommentare

Mahlzeit Kollegen! Wenn ich mich strikt an physikalische Grundsätze halte, müsste ich sagen: Nein. Es ist nicht möglich. Ich stieß aber im Internet auf ein ...

question
Fritzbox mir Batterie betreibenberndsilberoVor 1 TagFrageHardware11 Kommentare

Hallo, welche Akkus bzw. Batterien oder Möglichkeiten gibt es wenn ich die Fritzbox mobil nutzen möchte, da wo kein Stromnetz vefügbar ist. Der Akku darf ...

question
Tips für Raid-Controller für bis zu 24 Platten?coltseaversVor 1 TagFrageSAN, NAS, DAS7 Kommentare

Hallo zusammen, ich möchte mir ein Datengrab für bis zu 24 HDDs 3,5 Zoll basteln, welches unter Windows Server laufen soll. Rack-Gehäuse mit entsprechend vielen ...

question
APC USV - Zugriff über die Konsole gelöst newit1Vor 1 TagFrageSicherheit10 Kommentare

Hallo zusammen, ich habe eine APC Smart UPS 1000 (RackMount) im Einsatz und komme nicht auf die Konsole. Die eingebaute "Network Management Card 1" zieht ...

question
NAS-Platz aufbohren, ohne TEMP-Platte?winackerVor 1 TagFrageSAN, NAS, DAS6 Kommentare

Hallo, ich muß ein 4-Bay QNAP-NAS, bestückt mit 4 x 4TB in RAID5, aufrüsten. Da sind heute ca. 10TB Daten drauf. Ziel ist 3 x ...

general
FYI: In zwei Tagen zieht LetsEncrypt zahlreiche Zertifikate zurückipzipzapVor 15 StundenAllgemeinVerschlüsselung & Zertifikate1 Kommentar

Hallo, zur Info, falls bei Euch übermorgen was knallt: Ruhiges Wochenende! ipzipzap ...

question
"minimale" Cloud-Telefonanlage gesuchtDatenreiseVor 21 StundenFrageVoice over IP10 Kommentare

Hallo zusammen, ich bin auf der Suche nach einer Cloud-Telefonanlage, die sich für einen einzelnen Arbeitsplatz eignet und wollte hier fragen, ob jemand dazu einen ...