retro71
Goto Top

2 Netzwerke und keinen Plan

Hallo an alle!

Bitte schlagt mich nicht ich habe hier eine wirkliche Anfängerfrage. Was Netzwerke angeht bin ich absoluter Noob. Ich hab mich versucht einzulesen aber irgendwie verstehe ich die ganze Materie nicht.
Ich habe hier folgende Konstellation. Ein Netzwerk via FB 7530 192.168.178.1/24 und einen weiteren Router WR710N mit OpenWrt. Dieser hängt mit fester IP 192.168.178.100 per WLAN an der Fritze. Hinter der. WR710N hängt per Lan ein Gerät. Das Netzwerk hat die IP 192.168.1.1 /24. IPv6 lass ich gleich erstmal weg weil mir die Adressen zu kryptisch sind. Jetzt möchte ich von einem anderem Gerät aus dem FB Netz das Gerät hinter dem WR710N erreichen. Umgekehrt soll das Gerät aus dem WR710N Netz auch Geräte aus dem FB Netz sehen können. Ich habe diverse Sachen ausprobiert aber hinbekommen habe ich nichts. Das Gerät hinter dem WR710N kommt ins Internet, das war's.
Mir ist nicht klar wie die Konfiguration in WR710N aussehen muss? Vielleicht hat mal jemand eine kleine Anleitung für mich.
Ich habe versucht hier und auch aus anderen Quellen einiges zu lesen und zu verstehen aber so richtig verstanden habe ich das alles nicht🥴

Danke schon einmal im Voraus 👍

MfG
Rene

Content-Key: 33263821800

Url: https://administrator.de/contentid/33263821800

Printed on: February 29, 2024 at 21:02 o'clock

Member: commodity
commodity Nov 14, 2023 updated at 21:16:36 (UTC)
Goto Top
Hallo,
Dein WR710N verwendet NAT. Deshalb kommst Du vom FB-LAN 192.168.178.0 nicht in dessen Netz 192.1681.0.
Bei dieser Konstellation müsstest Du aus dem Netz 192.168.1.0 aber eigentlich in das FB-LAN kommen.

Hast Du mal probiert, aus diesem Netz die FB-Oberfläche zu erreichen? Wenn das nicht geht, werden in der Firewall des OpenWRT u.U. lokale Netze nach RFC 1918 geblockt und nur der Traffic in das Internet durchgelassen.

Erläuterungen und Beispiele zur Einrichtung der Firewall von OpenWRT findest Du zB hier. Ja, das sieht mühselig aus, weil alles abgedeckt werden soll, aber das ziemlich knapp ist. Ich finde OpenWRT zum Lernen nicht so toll. Wenn Du dabei bleiben willst, schau Dir die jeweiligen Menüs an, die Dir passend erscheinen und probiere mit Google-Begleitung. Das finde ich am effektivsten.

Konkrete Fragen dann gerne wieder hier im Forum face-smile

Viele Grüße, commodity
Member: PC-Helfer
PC-Helfer Nov 14, 2023 at 22:09:38 (UTC)
Goto Top
Hallo,

konfiguriere den WR710N als Access Point mit einer Adresse aus dem Fritzbox Netzwerk. Somit hättest du nur ein Netzwerk und kannst alle Geräte ohne Hürde netzwerktechnisch erreichen.

SG
Member: kpunkt
kpunkt Nov 15, 2023 at 05:36:23 (UTC)
Goto Top
Kurze Frage: sollen das zwei Netze sein?
Wenn ja, dann trägst du bei den Routern eben eine statische Route ins jeweils andere Netz ein.
Findet sich in der Fritzbox unter Heimnetz - Netzwerk - Netzwerkeinstellungen - Tabelle für statische Routen

Sollte bei WRT ähnlich sein. Hab da schon ewig nicht mehr reingeschaut.

Wenns die zwei Netze gar nicht braucht, dann lass den WRT als reinen AP im Netz der Fritzbox laufen.
Member: aqui
aqui Nov 15, 2023 updated at 07:38:24 (UTC)
Goto Top
Routing von 2 und mehr IP Netzen mit Windows, Linux und Router
und auch
Mit einem WLAN zwei LAN IP Netzwerke verbinden
Lesen und verstehen.
Nach der Lektüre solltest du dann vom Noob ins Profi Lager gewechselt sein... 😉
Member: commodity
commodity Nov 15, 2023 updated at 11:20:48 (UTC)
Goto Top
+1 Das kannte ich noch gar nicht. Passt ja wie die Faust aufs Auge und ist wie immer perfekt alles drin, was man zum Verständnis braucht.

Insbesondere der Hinweis, dass natürlich eine statische Route gleichermaßen genügt, wie erforderlich ist.

Allerdings nützt IMO die schönste Route nichts, wenn am WR710N ein Source-NAT (hier: masquerading) aktiv ist. Darstellung hier. Aus der knappen Beschreibung des TO schließe ich, dass der WR710N mit seinem WAN-Port im FB-Netz hängt. In diesem Fall müsste am WR710N noch ein Destination-NAT eingerichtet sein, um an das in dessen Netz liegende Gerät zu kommen.

Wie man dann den Zugriff von außen einrichtet, steht zB hier.


Viele Grüße, commodity
Member: retro71
retro71 Nov 15, 2023 at 14:41:42 (UTC)
Goto Top
Ne der WR hängt per WLAN im FB Netz. Wan Buchse ist nicht benutzt. Ich danke euch erstmal und werde mir erst einmal aqui's links reinziehen und euch danach wieder nerven oder Erfolg verkünden.
Btw.: Ich dachte ja ich betreibe den WR710 im AP Modus.😳
Vielen Dank erstmal für die konstruktiven Vorschläge.

Grüße
Rene
Member: commodity
commodity Nov 15, 2023 updated at 19:01:37 (UTC)
Goto Top
... der WR hängt per WLAN im FB Netz.
Oh, jetzt leide ich an Leseschwäche... Sorry!

In diesem Falle sind es doch nur zwei LANs, um die es geht (schreibst Du ja auch). Dann brauchst Du aus dem FB-Netz nur die beschriebene Route zum WR. Wenn es dann immer noch nicht (Richtung: FB -> WR) geht, würde ich die Firewall checken.
Für die Richtung WR -> FB brauchst Du keine Route. Die erste Route ist aber auch hier von Bedeutung, weil sonst keine Pakete aus dem FB-Netz zurück zum WR-Netz kommen.

Viele Grüße, commodity
Member: aqui
aqui Nov 16, 2023 updated at 11:57:10 (UTC)
Goto Top
Ich dachte ja ich betreibe den WR710 im AP Modus.
Wäre ja Quatsch, denn eine AP zu AP Kopplung sieht der WiFi Standard gar nicht vor, sprich ist also technisch unmöglich. Das geht nur wenn der WR im WLAN Client- oder im Bridge Mode konfiguriert ist...sofern er diese Modi im Setup supportet.
Client oder Bridge Mode arbeiten WLAN üblich bei solch billigen Geräten immer nur im Layer 2 und können technisch in der Regel gar nicht routen. Folglich spielt dort also IP Routing auch keinerlei Rolle.
Fazit: Nicht denken sondern Nachdenken!! 😉
Member: commodity
commodity Nov 16, 2023 at 13:53:36 (UTC)
Goto Top
arbeiten WLAN üblich bei solch billigen Geräten immer nur im Layer 2
Da meinst Du jetzt aber die WLAN-Ebene, oder?
Routen in das LAN des WR muss das Gerät doch trotzdem. Das WLAN liegt ja im FB-LAN.

Viele Grüße, commodity
Member: retro71
retro71 Nov 16, 2023 at 16:47:14 (UTC)
Goto Top
Hui jetzt wird's schon wieder ziemlich technisch. Am Wochenende schau ich mal bezüglich der Möglichkeiten, welches das OpenWrt bietet. Mit Layer 2 kann ich erst einmal nichts anfangen. Aber ihr habt viele gute Hinweise gegeben.
@commodity du hast geschrieben ich benötige eine Route von der FB zum WR aber was soll ich da Routen? Müsste nicht der WR irgendwie ein Routing in Richtung FB Netzwerk übernehmen?
Ich muss erstmal eure Schulungslinks studieren vlt
Wird mir dann einiges klarer.
Member: aqui
aqui Nov 16, 2023 at 17:48:03 (UTC)
Goto Top
jetzt wird's schon wieder ziemlich technisch.
Ist das nicht der Normalfall in einem Administrator Forum? 🤔
Mit Layer 2 kann ich erst einmal nichts anfangen.
https://de.wikipedia.org/wiki/OSI-Modell
Lesen und verstehen!!
ich benötige eine Route von der FB zum WR
Nein, nicht wenn der WR als WLAN Client an den Fritz AP angebunden ist.
Auch nicht in einer stinknormalen Router Kaskade. Siehe hier:
Kopplung von 2 Routern am DSL Port
hier
Mit einem WLAN zwei LAN IP Netzwerke verbinden
und hier
Routing von 2 und mehr IP Netzen mit Windows, Linux und Router
Wenn NAT (IP Adress Translation) dazwischen ist, ist kein IP Routing erforderlich.
Member: commodity
Solution commodity Nov 16, 2023 updated at 21:12:06 (UTC)
Goto Top
aber was soll ich da Routen...
Das Prinzip von Routing versteht sich vielleicht leichter, wenn man sich die Daten als kleine Postpakete vorstellt. Die Router sind die Verteilzentren, aber ziemlich strenge. Sie schicken das Paket nur weiter, wenn das Ziel in ihrem Versandgebiet liegt, d.h. sie das Zielnetz "kennen". Ansonsten leiten sie das Paket an den nächstzuständigen Router weiter oder werfen es in die Tonne. Ein Netz wiederum kennt ein Router nur, wenn er mindestens ein Interface (Port) selbst in diesem Netz hat.

Dies vorausgesetzt, will Dein Client im FB-LAN nun also ein Paket an einen Client im WR-Netz schicken. Der Client im FB-LAN (zB) 192.168.178.48 kennt das Gerät mit der Zieladresse des Clients im WR-LAN (zB) 192.168.1.25 selbst nicht. Also schickt er das mit "an 192.168.1.25 adressierte" Paket an sein "Standardgateway" (das ist der Router im Netz, der für den Client das zuständige Verteilzentrum dieses Netzes ist). Das nun ist in seinem Netz die Fritzbox, also geht das Paket erstmal an 192.168.178.1. Die FB kennt die Adresse 192.168.1.25 aber selbst auch nicht, denn sie selbst steht nicht mit einem Interface in diesem Netz. Das Ziel liegt also nicht in ihrem Versandgebiet.

Die FB würde das Paket daher im Prinzip ins Internet routen, ins Netz des Providers, in dem sie ja ein weiteres Interface hat (das WAN-Interface), zum Router des Providers, der für alle der Fritzbox nicht bekannten Adressen das zuständige Gateway ist. Private Netze (RFC 1918) werden jedoch nicht im Internet geroutet. Das weiß die Fritzbox und verwirft das an die private Adresse 192.168.1.25 gerichtete Paket.
So weit ohne Route.

Hast Du hingegen auf der FB eine Route eingetragen, die für das Netz 192.168.1.0/24 den WR mit seiner IP 192.168.178.100 als zuständiges Versandzentrum (Gateway) angibt, würde die FB das eingehende Paket nun nicht an den Provider weiter leiten, sondern an den WR mit der IP 192.168.178.100. Der WR nimmt das Paket entgegen und schaut, ob das Ziel 192.168.1.25 in seinem Verteilgebiet liegt und er zuständig ist. Der WR hat ja nicht nur die IP 192.168.178.100, sondern auch ein Interface im Netz 192.168.1.0/24. Er kennt also das Netz 192.168.1.0/24 und nimmt das Paket an. Da er der Router des Netzes ist, kennt er zugleich (aufgrund vorheriger netzinterner Kommunikation) die vorhandenen Endgeräte (ansonsten erfragt er das Ziel per - Broadcast - siehe sogleich) und stellt das Paket nun an 192.168.1.25 zu. Mit Route klappt es also.

Der Client 192.168.1.25 beantwortet das Paket nun mit einem eigenen Paket. Er sendet dieses an 192.168.178.48. Da er das Ziel selbst nicht kennt, schickt er es an sein Standard-Gateway, das in seinem Netz 192.168.1.0/24 der WR ist. Dieser wiederum kennt entweder das Ziel bereits, weil er ja ebenfalls ein Interface im Netz 192.168.178.0/24 hat oder er erfragt es im Zielnetz 192.168.178.0/24 durch einen sog. Broadcast, das ist ein Rundruf an alle angeschlossenen Teilnehmer. Er leitet es nicht mehr an die Fritzbox weiter, die als Gateway hier nur für Netze zuständig wäre, die der WR nicht kennt. Spätestens also nach Eingang der Anwort auf den Broadcast, kann der WR das Paket von 192.168.1.25 direkt an 192.168.178.48 zustellen. Du brauchst also auf diesem Weg keine Route, weil der WR eben in beiden Netzen steht.

Der Kollege @aqui kann den genauen Ablauf technisch noch deutlich exakter darstellen, aber im Prinzip sollte es das sein.

Viele Grüße, commodity
Member: retro71
retro71 Nov 17, 2023 updated at 16:31:36 (UTC)
Goto Top
HEUTEKA! Ich glaub ich hab's. Mein Ansatz im Kopf war falsch. Vielen vielen Dank für die wirklich klasse Erklärung 👍👍👍 Jetzt ist mir erstmal klar geworden das die FB Routen muss! dieser Kommentar sollte irgendwo angepinnt werden. Saubere Arbeit!

Danke nochmals an alle hier für die Hilfe.
Werde morgen gleich mal Routen😁

Grüße Rene
Member: aqui
aqui Nov 17, 2023 updated at 18:34:19 (UTC)
Goto Top
HeuReka bitte...soviel Zeit muss am Freitag sein sonst würde sich der gute, alte Archimedes grämen. face-wink
Member: retro71
retro71 Nov 18, 2023 at 08:24:52 (UTC)
Goto Top
Ja die olle Autokorrektur macht mich wahnsinnig...
Member: commodity
commodity Nov 18, 2023 at 13:44:24 (UTC)
Goto Top
Zitat von @retro71:
HEUTEKA!
Danke für's Feedback und die netten Worte!
Viel Freude beim Routen face-smile

Viele Grüße, commodity
Member: retro71
retro71 Nov 19, 2023 updated at 07:03:43 (UTC)
Goto Top
Moin!

Soooo. Hab jetzt in der FB ne Route eingetragen:
zwischenablage01

Ping aus FB Netz -> 192.18.1.1 CHECK!
Ping aus WR Netz -> 192.168.178.1 CHECK!
Ping vom WR Netz auf beliebes Gerät in FB Netz -> CHECK!
Ping vom FB Netz auf Gerät in WR Netz NOPE

Hmm ich bin ja schonmal weiter. Im WR sind keine Routen eingetragen. Vielleicht hat @commodity noch nen Tip. Irgendwie scheint es mir diesmal ein WR Problem zu sein...

Hier noch kurz die Adressen:
FB hat 192.168.178.1
WR hat 192.168.178.10 im FB Netz
WR hat 192.168.1.1 im WR Netz
Gerät an lan: hinter dem WR hat 192.168.1.218 im WR Netz.

Grüße
Rene
Member: aqui
aqui Nov 19, 2023 updated at 14:11:20 (UTC)
Goto Top
Im WR sind keine Routen eingetragen.
Das geht so logischerweise nicht. Mindestens eine Default Route oder Default Gateway ist bekanntlich immer zwingend in einem Routing Umfeld!
Routing von 2 und mehr IP Netzen mit Windows, Linux und Router
Lesen und verstehen... face-wink

Dein Setup ist ein simples Banalszenario was der Azubi in 10 Minuten am Fliegen hat...

2netze
(Mit "LAN-1 Port" ist hier natürlich dann dein WLAN Port gemeint wenn du den OpenWRT mit WiFi angebunden hast!!)
Member: retro71
retro71 Nov 19, 2023 at 14:01:07 (UTC)
Goto Top
Letzteres fällt mir schwer 😄 Ich hab das mit den Paketen jetzt ja auch verstanden. Ich versuche nachher beim WR auch noch eine Route einzutragen da ich mir denke, um es mit commodity's Sprache zu sprechen, dass ja der WR beim Senden eines Pings aus dem FB Netz an das Gerät im WR Netz den Absender nicht kennt und darum die Ping Anfrage. Icht weitersendet.
Member: aqui
aqui Nov 19, 2023 updated at 15:10:17 (UTC)
Goto Top
jetzt ja auch verstanden.
Wirklich?? 🤔 Besser noch einmal HIER genau nachlesen. face-wink
beim Senden eines Pings aus dem FB Netz an das Gerät im WR Netz den Absender nicht kennt
Das ist technischer Unsinn, denn der Absender und Empfänger steht ja in jedem Netzwerk Paket immer drin! Sowohl im Layer 2 mit seinen Mac Adressen als auch im Layer 3 mit seinen IP Adressen. Vergiss das also schnell wieder...
Schmeiss einfach einen Wireshark bei dir auf dem Rechner an, dann kannst du es doch selber schwarz auf weiß sehen! 😉
Member: retro71
retro71 Nov 19, 2023 at 18:59:40 (UTC)
Goto Top
Hallo aqui,

ich habe beim WR eigentlich alles wie oben in dem Link beschrieben außer das ich kein IPv4 forwarding finde und nicht weiß was das ist. Siehe hier:
screenshot 2023-11-19 at 18-53-35 wr710n - routing - luci
Member: commodity
commodity Nov 19, 2023 updated at 21:27:13 (UTC)
Goto Top
Ok, das liegt an der ungewöhnlichen Anschlussweise des WR. Du hast ihn ja nicht als Router mit seinem WAN-Port am Netz, sondern per WLAN im LAN der Fritzbox. Normal ist der WAN-Port eines Routers als Standardgateway ausgelegt.

Du musst folgendes sicher stellen:
  • Falls noch nicht vorhanden, musst Du die IP-Adresse der Fritzbox als Gateway des WLAN im WR eintragen, sonst weiß der WR nicht, wohin mit den Paketen.

Hier ist das sinngemäß abgebildet - für Dich ist das auf das Interface des WR, das im FB-LAN hängt, umzusetzen.
46cd3c1b396886ce529772a6f269d23801cfdb19

  • Dann muss natürlich die Standardroute für die Adresse 0.0.0.0/0, die normaler Weise auf das WAN-Gateway zeigt, nun auf das WLAN-Interface zeigen (denn die Pakete für außerhalb des WR-LAN sollen ja (bei Dir) nicht zum WAN-Interface des WR, sondern zum WLAN). Dies führt dann dazu, dass Pakete vom LAN des WR für das Internet nun zum das WLAN-Interface des WR geleitetet werden, das diese Pakete seinerseits dann an sein Standardgateway, nämlich die Fritzbox, schickt.

  • Wenn es dann noch nicht geht, kann es sein, dass das WAN-Interface für die Standardroute eine höhere Priorität hat. Das solltest Du aber in der Routing-Tabelle des WR sehen.

Unabhängig davon wäre jetzt, wie der Kollege @aqui zutreffend anmerkt, auch ein bisschen Theorie angesagt, wenn man OpenWRT manuell konfiguriert. Z.B.: https://www.youtube.com/watch?v=M5shMJfcFa8

Sagte ich schon, dass ich OpenWRT zum lernen nicht so toll finde? face-smile

Viele Grüße, commodity

Edit: Das Bild sieht ja ganz gut aus. Schau nochmal, ob im wwan das richtige Gateway (Fritzbox) eingetragen ist. Dann ist natürlich immer noch die Firewall im Blick zu behalten. Du leitest ja hier Pakete von einem Netz (lan) in ein anderes (wwan). Ist das erlaubt? In beide Richtungen?
Member: retro71
retro71 Nov 20, 2023 at 04:45:13 (UTC)
Goto Top
Moin,

ich denke auch das es wohl etwas mit der Firewall zu tun haben könnte. Vielleicht denkt der WR, das das WLAN ein WAN ist und blockt da die Weiterleitungen? Danke für das Video. Ich werde mich einmal damit befassen.

Beim Thema Einrichten von OpenWrt gebe ich dir Recht😔

Grüße
Rene
Member: commodity
commodity Nov 20, 2023 at 11:28:25 (UTC)
Goto Top
Vielleicht denkt der WR, das das WLAN ein WAN ist
Er denkt auf jeden Fall, dass das ein anderes Interface ist, aber eine Regel ist ja schnell erstellt. Oder Du packst wwan in dieselbe Zone wie lan, das sollte an sich schon reichen.

Wenn Dich das Thema interessiert, leiste Dir bei Gelegenheit mal einen hEX oder hAP. Die sind auch nicht gerade easy zu konfigurieren, aber es ist insgesamt schlüssiger, sehr gut dokumentiert und man wird gezwungen, das Netzwerken zu lernen face-wink

Viele Grüße, commodity
Member: aqui
aqui Nov 20, 2023 at 12:02:29 (UTC)
Goto Top
außer das ich kein IPv4 forwarding finde und nicht weiß was das ist.
IPv4 Forwarding = Routing
Bei einem dedizierten Router ist das Routing aber logischerweise prinzipbedingt IMMER aktiviert.
Es kann nur 2 Gründe geben für eine Fehlfunktion:
  • Der OpenWRT macht auf dem Koppelport (WLAN) NAT (IP Adress Translation). Damit ist dann kein transparentes Routing zwischen den beiden IP Netzen möglich, da du das NAT Gateway nicht üerwinden kannst in der inbound Richtung. Routing Einbahnstrasse also. Diese Thematik ist auch HIER explizit beschrieben!!
  • Das Firewall Regelwerk sofern eine Firewall aktiv ist.
Member: retro71
retro71 Nov 29, 2023 at 20:53:57 (UTC)
Goto Top
Guten Abend!

Ich hab's jetzt hinbekommen, mein Problem ist nur es war trial and error und ob alles korrekt ist weiß ich nicht.
Ich habe mich an dieser Seite orientiert, auch wenn dort alles per CLI konfiguriert worden ist.
Leider war gerade der hintere Teil mit dem Routing für mich sehr verwirrend weil die IPs in den Grafiken nicht mehr mit dem übereingestimmt haben, was dort beschrieben wurde.
Ich wäre dankbar, wenn ihr vielleicht einmal kurz drüberschaut und mir einfach sagt, ok oder nicht ok.

Leider funktioniert es noch nicht, das ich z.B. fritz.box am Gerät hinter dem WR eingebe, da muss wohl noch etwas mit dem DNS eingestellt werden.

Hier kurz meine Konfig zum meckern face-smile
screenshot 2023-11-29 at 20-36-24 openwrt - interfaces - luci
So habe ich die Interfaces eingestellt.

screenshot 2023-11-29 at 20-37-22 openwrt - routing - luci
Das ist das Routing, hier bin ich mir nicht sicher ob ich bei den IP Adressen hinten .1/24 oder .0/24 einstellen muss.


screenshot 2023-11-29 at 20-37-54 openwrt - general settings - luci
Und das sind die FW Zonen. Auch hier weiß ich nicht ob alles auf accept stehen sollte.
Das Ganze hat erst wirklich funktioniert nachdem ich die Haken bei Masquerading gesetzt habe. Was das bedeutet muss ich erstmal verstehen.

Ich danke schonmal für hilfreiche Tipps. Vielleicht gibt es ja für die DNS Geschichte auch eine ganz einfache Lösung von euch?

MfG
Rene
Member: commodity
commodity Nov 29, 2023 at 21:16:28 (UTC)
Goto Top
hier bin ich mir nicht sicher ob ich bei den IP Adressen hinten .1/24 oder .0/24 einstellen muss.
Eigentlich .0/24 - Die 0 ist (im 24er Netz) die Adresse für das gesamte Netz, die 1 nur die Bezeichnung des einen Interfaces. Ist in der von Dir verlinkten Anleitung doch auch genau so beschrieben.
Auch hier weiß ich nicht ob alles auf accept stehen sollte.
Forward accept sollte reichen.
Wenn man lernt, lohnt es sich immer auch zu Googlen oder mal Wikipedia zu bemühen.
Input: Pakete, die direkt an den Router gehen.
Output: Pakete, die der Router direkt versendet.
Forward: Pakete die geroutet werden.
Das Ganze hat erst wirklich funktioniert nachdem ich die Haken bei Masquerading gesetzt habe.
Was das ist, bekommst Du noch heraus face-wink An sich sollte es aber ohne Masquerading funktionieren - vorausgesetzt Du hast die Route in der Fritzbox noch aktiv. Wenn es ohne nicht funktioniert, liegt das wahrscheinlich an der fehlerhaften Einstellung bei den Routen (1 statt 0).

Viele Grüße, commodity
Member: aqui
aqui Nov 30, 2023 updated at 10:15:48 (UTC)
Goto Top
Leider funktioniert es noch nicht, das ich z.B. fritz.box am Gerät hinter dem WR eingebe
Diese Domain kann nur der DNS Server in der Fritzbox auflösen. Ergo muss am OpenWRT und auch an den Clients im 2ten Netz immer die Fritzbox IP als DNS Server eingegeben werden bzw. der DNS Server für das 2te Segment muss die FB IP als DNS Server an die Clients ausliefern.
Und das sind die FW Zonen. Auch hier weiß ich nicht ob alles auf accept stehen sollte.
Ist richtig wie Kollege @commodity oben schon richtig gesagt hat. Auch was das Thema falsche Netzwerk Adressen Angabe betrifft. Bei Netzwerk Adressen sind die Hostbits immer auf "0"!!

Allerdings hast du noch einen groben Kardinalsfehler begangen und "Masquerading" (IP Adress Translation, NAT) aktiviert und das auch gleich noch an beiden Interfaces.
Das ist falsch und zeigt das du dir scheinbar die obige Topologie Zeichnung nicht oder nur halbherzig angesehen hast! face-sad
Dort wurde explizit drauf hingewiesen das NAT zu deaktivieren weil du sonst eine routingtechnische Einbahnstrasse schaffst.
Warum das so ist erklärt dir dieses Tutorial im Detail und auch für Laien verständlich!!
Lesen und verstehen... 🧐

Wenn es ohne das vollkommen überflüssige Masquerading nicht funktioniert hat das immer 2 Gründe:
  • Du hast vergessen eine Default Route auf dem OpenWRT auf die Fritzbox IP einzutragen
  • Du hast vergessen in der Fritzbox die statische Route auf das 2te IP Netz mit next Hop OpenWRT IP einzutragen.
Tutorial und hiesige Postings einmal wirklich lesen hilft...!