Auflisten der Datenbanken im SQL Server 2014 Management Studio ist sehr langsam

friemler
Goto Top
Ein Hallo an alle MS SQL Server Spezialisten.

Auf meinem Entwicklerrechner (OS: Windows 7 Ultimate 64Bit, 16 GB RAM) läuft eine Hauptinstanz von MS SQL Server 2014 SP2 Standard Edition 64Bit, Cumulative Update 1 (KB3178925) ist ebenfalls installiert.

Falls das wichtig ist - die Installationshistorie ist wie folgt:

  • SQL Server 2014 Standard Edition (ohne Service Pack)
  • SP1 installiert
  • Restore von Datenbank-Backups, die auf einem SQL Server 2008 R2 SP2 Developer Edition erstellt wurden (mit Hilfe des BACKUP DATABASE-Kommandos)
  • CU6 und CU7 für SQL Server 2014 SP1 installiert
  • SP2 installiert
  • CU1 für SQL Server 2014 SP2 installiert

Die Datenbankdateien des SQL Servers sind auf einer lokalen Magnetfestplatte (gemountet als Laufwerk D: ) abgelegt, der Server selbst sowie das OS auf einer SSD-Platte. Für die Entwicklung unserer Software verwaltet der SQL Server 47 Datenbanken zu Testzwecken. Die meisten dieser Datenbanken sind 10 MB groß, einige liegen im Bereich 100 - 500 MB und zwei Ausnahmen sind 1,3 GB und 2,5 GB groß.

Wenn ich ein SQL Server 2014 Management Studio öffne, das ebenfalls auf dem Entwicklerrechner installiert ist, und nach der Anmeldung den Databases-Knoten im Baum des Object Explorers öffne, dauert es 35 Sekunden bis der Ladevorgang abgeschlossen ist und alle Datenbanken zu sehen sind (ich betone: die Datenbanken an sich, nicht die Tabellen einer der Datenbanken).

Wenn ich auf einem anderen Rechner, auf dem noch SQL Server 2008 R2 SP2 installiert ist, das SQL Server 2008 R2 Management Studio öffne, mich über das Netzwerk mit dem SQL Server 2014 verbinde und den Databases-Knoten öffne, werden mir die 47 Datenbanken sofort angezeigt.

Weiß jemand von Euch woran das liegen könnte?

Meine Suche bei Google hat nur Beiträge auf social.technet.microsoft.com zutage gebracht, die die Installation des CU1 für SQL Server 2014 SP1 empfehlen. Es existiert auch ein Eintrag in einem Microsoft Bugtracker, der zu dem gleichen Ergebnis führt, aber auch dort melden schon User, dass die Installation des CU1 nichts gebracht hat.

Grüße
Friemler

Content-Key: 315624

Url: https://administrator.de/contentid/315624

Ausgedruckt am: 06.07.2022 um 18:07 Uhr

Mitglied: sabines
sabines 19.09.2016 um 07:35:02 Uhr
Goto Top
Moin,

wie verbindest Du Dich jeweils mit der Datenbank, sprich wie sprichst Du den Server an?
Der schnellste Weg wäre IP\instanz,Port. Gibt es da Unterschiede?

Gruß
Mitglied: Friemler
Friemler 19.09.2016 aktualisiert um 08:37:10 Uhr
Goto Top
Hallo sabines,

der Server ist als Hauptinstanz installiert und ich verbinde mich mit dem Hostnamen über ein SQL Server 2014 Management Studio, das auf dem gleichen Rechner installiert ist wie der SQL Server selbst.

Aber die Herstellung der Verbindung ist nicht das Problem, das funktioniert sehr gut. Das Auflisten der Datenbanken im Object Explorer ist langsam, aber nur bei der Verbindung über ein SQL Server 2014 Management Studio. Es gibt auch keinen Unterschied in der Geschwindigkeit, wenn ich mich per IP-Adresse auf den Server verbinde (gerade getestet).

Grüße
Friemler
Mitglied: sabines
sabines 19.09.2016 um 08:56:49 Uhr
Goto Top
Moin,

ich hab' das mit dem Auflisten schon verstanden, wie ist denn die MMS Version, hast Du die auch auf die aktuelle Version gebracht?
Wenn Du das langsame Auflisten überwunden hast, wie performant ist denn das Arbeiten mit den Datenbanken, läuft das dann normal schnell?

Das MMS und der SQL Server haben momentan die Version 12.0.5000.0

SELECT SERVERPROPERTY('productversion'), SERVERPROPERTY ('productlevel'), SERVERPROPERTY ('edition')

Du könntest auch noch das MMS 2014 auf einem weiteren PC installieren und dann mal testen, was passiert. (Um auszuschließen, dass der Server selbst das Problem ist)

Wenn andere das Problem ebenfalls haben und es nicht immer mit dem SP/CU gelöst wurde, hast Du leider wenig Chancen.

Gruss
Mitglied: Friemler
Friemler 19.09.2016 aktualisiert um 14:41:27 Uhr
Goto Top
Hallo sabines,

das Arbeiten mit den Datenbanken ist völlig normal, keine Performance-Probleme. Die Versionsnummer des MMS 2014 ist 12.0.5511.0

Das Ergebnis Deiner Query:

  • productversion: 12.0.5511.0
  • productlevel: SP2
  • edition: Standard Edition (64-bit)

Ich habe MMS 2014 Express auch schon in einer VM auf dem Entwicklerrechner installiert (VMware Workstation 12 Pro) und mich von dort mit dem SQL Server verbunden, gleiches Verhalten. MMS 2008 R2 Express aus einer VM ist kein Problem.

Wenn ich einen SQL Server 2014 SP2 Express with Tools in einer VM installiere, dort viele Datenbanken anlege, mich dann mit dem MMS 2014 aus dieser VM auf den Server verbinde und die Datenbanken auflisten lasse ist das auch sehr langsam.

Grüße
Friemler
Mitglied: sabines
sabines 20.09.2016 um 11:55:01 Uhr
Goto Top
Sorry, da fällt mir nichts mehr hilfreiches ein.
Entweder Ticket bei MS aufmachen oder damit leben face-wink
Mitglied: Friemler
Friemler 21.09.2016 aktualisiert um 13:40:58 Uhr
Goto Top
Moin sabines,

Sorry, da fällt mir nichts mehr hilfreiches ein.
Trotzdem danke für Deine Mühe.

Entweder Ticket bei MS aufmachen oder damit leben face-wink
Eher letzteres, die Redmonder haben doch besseres zu tun, als sich um täglich nervende Detailprobleme zu kümmern (z.B. den Virus Win 10 verbreiten oder Daten klauen, auswerten und zu Geld machen bzw. an irgendwelche US-Dienste schicken). face-wink Im Netz finden sich jedenfalls viele Leute mit dem gleichen Problem, die Postings sind meist schon mehrere Monate alt und beziehen sich auf SQL Server 2014 SP1 oder früher - Reaktion seitens MS gleich NULL. face-sad

Grüße
Friemler