Batch-Datei Aufgabenplaner auf WS2008RC2

halbgott
Goto Top
Moin Moin,

ich habe folgendes Problem:

In einer Außenstelle werden die Arbeitszeiten mit einem Zeitstempel-Terminal in Form von einer DAT-Datei gespeichert. Diese DAT-Datei lässt sich mit einer Batch-Datei "per Hand" auslesen und auf ein Verzeichnis eines Servers der Hauptstelle (VPN-Verbindung) übertragen. Dies möchte ich jedoch nicht täglich händisch machen sondern über einen Aufgabenplaner laufen lassen. In einer anderen Außenstelle (WS2003) funktioniert das bisher einwandfrei. Leider habe ich da mit WS2008 RC 2 so meine Probleme. Vorweg, ich habe schon einige Forenbeiträge gelesen, wo ein ähnliches Problem beschrieben wurde doch die Lösungsvorschlägen halfen bei mir nicht.


Folgende Einstellungen habe ich bei mir vorgenommen.
Aktion: Programm starten
Programm/Skript : C:\Windows\SysWOW64\cmd.exe
Argument hinzufügen (optional ): C:\elv\tmwin\Zeitübertragung.bat

Wenn ich das Programm/Skript im Explorer ausführe und anschließend in der sich öffnenden Konsole das Argument eingebe, dann startet die Batch-Datei einwandfrei. Wenn ich jedoch die Aufgabe starte steht dort lediglich, dass die Aufgabe ausgeführt wird. Im Verlauf taucht keine Fehlermeldung auf. Dort steht nur, dass die Aufgabe erfolgreich gestartet wurde. Die Aufgabe stoppt erst wieder, wenn die Einstellung greift, dass die Aufgabe nach 30 Minuten stoppen soll (denn der Vorgang der Übertragung dauert nur maximal 10 Sekunden). Ich führe die Aufgabe mich höchsten Privilegien aus, unabhängig von der Benutzeranmeldung.

Vielen Dank für Vorschläge im Vorraus

PS:

Folgende Einstellungen habe ich ebenfalls ohne erfolg getestet:

Programm/Skript : C:\Windows\SysWOW64\cmd.exe
Argument hinzufügen (optional ): C:\elv\tmwin\Zeitübertragung.cmd

Programm/Skript : C:\Windows\SysWOW64\cmd.exe
Argument hinzufügen (optional ): "/C" "C:\elv\tmwin\Zeitübertragung.bat"

Programm/Skript : C:\elv\tmwin\Zeitübertragung.bat
Argument hinzufügen (optional ): C:\Windows\SysWOW64\cmd.exe

Content-Key: 227376

Url: https://administrator.de/contentid/227376

Ausgedruckt am: 20.05.2022 um 20:05 Uhr

Mitglied: falscher-sperrstatus
Lösung falscher-sperrstatus 22.01.2014 aktualisiert um 12:06:13 Uhr
Goto Top
Hallo,

dann bau mal in die Batch Kontrollroutinen ein (Bspw: Schreibe in txt Datei),

Du musst evtl noch den Pfad zum Programm angeben (drittes Feld unter Programm starten).

LG
Mitglied: colinardo
Lösung colinardo 22.01.2014 aktualisiert um 12:06:08 Uhr
Goto Top
Hallo Halbgott,
diese Frage kommt hier fast jeden Tag und ist auch schon mehrfach beantwortet worden:

Programm/Skript: C:\elv\tmwin\Zeitübertragung.cmd
Starten in : C:\elv\tmwin\

1896ebe8f5159339685f5c66745c26ae

Grüße Uwe
Mitglied: Halbgott
Halbgott 22.01.2014 um 12:06:04 Uhr
Goto Top
Ich stelle jetzt fest,dass wenn ich die Aufgabe ausführe "nur wenn der Benutzer angemeldet ist" dann funktioniert das. Wenn ich dort eingebe "mit höchsten Privilegien ausführen" erscheint das DOS-Fenster mit einer Unterbrechung in der Mitte der Ausgabe und der Fehlermeldung "Ung³ltiger Dateiname".

Jemand eine Idee woher das kommt?
Mitglied: falscher-sperrstatus
falscher-sperrstatus 22.01.2014 um 12:10:02 Uhr
Goto Top
Als höchste Berechtigung hast du ggf. das Netzlaufwerk/Pfad nicht -> Kein Zugriff -> ungültig.
Mitglied: colinardo
colinardo 22.01.2014 aktualisiert um 12:19:04 Uhr
Goto Top
Zitat von @Halbgott:

Ich stelle jetzt fest,dass wenn ich die Aufgabe ausführe "nur wenn der Benutzer angemeldet ist" dann funktioniert
das. Wenn ich dort eingebe "mit höchsten Privilegien ausführen" erscheint das DOS-Fenster mit einer
Unterbrechung in der Mitte der Ausgabe und der Fehlermeldung "Ung³ltiger Dateiname".

Jemand eine Idee woher das kommt?
Trage in der Aufgabe unter "Folgendes Benutzerkonto verwenden ..." einen Benutzer ein der Zugriff auf den jeweiligen UNC-Pfad hat. Dann klappt das.

Grüße Uwe
Mitglied: Halbgott
Halbgott 22.01.2014 um 15:03:41 Uhr
Goto Top
Zitat von @colinardo:

> Zitat von @Halbgott:
>
> Ich stelle jetzt fest,dass wenn ich die Aufgabe ausführe "nur wenn der Benutzer angemeldet ist" dann
funktioniert
> das. Wenn ich dort eingebe "mit höchsten Privilegien ausführen" erscheint das DOS-Fenster mit einer
> Unterbrechung in der Mitte der Ausgabe und der Fehlermeldung "Ung³ltiger Dateiname".
>
> Jemand eine Idee woher das kommt?
Trage in der Aufgabe unter "Folgendes Benutzerkonto verwenden ..." einen Benutzer ein der Zugriff auf den jeweiligen
UNC-Pfad hat. Dann klappt das.

Grüße Uwe

Ich habe bei "folgendes Benutzerkonto verwenden" bereits ein Benutzerkonto mit Zugriff auf dem Pfad eingetragen (nämlich das Benutzerkonto des Aufgabenerstellers) Dennoch funktioniert die Übermittlung nicht. Sie läuft nur wenn ich "nur wenn der Benutzer angemeldet ist" auswähle. Die frage ist, "wer" ist "die höchste Berechtigung". Domänenadministrator, SYSTEM, lokaler Administrator.... Jemand eine Idee?
Mitglied: falscher-sperrstatus
falscher-sperrstatus 22.01.2014 um 15:10:37 Uhr
Goto Top
Imho der lokale Administrator.
Mitglied: colinardo
colinardo 22.01.2014 aktualisiert um 15:22:58 Uhr
Goto Top
Zitat von @Halbgott:
Die frage ist, "wer" ist "die höchste
Berechtigung". Domänenadministrator, SYSTEM, lokaler Administrator.... Jemand eine Idee?

Die Option ist für die Steuerung der UAC:

Bitte verwende UAC-Pfade (\\Server\freigabe) in deinem Script, denn gemappte Netzlaufwerke mit Laufwerksbuchstaben sind mit der Ausführung durch die Aufgabenplanung für das Script nicht sichtbar.

Ohne weitere Info zu deinem Script kommen wir hier sonst nicht weiter ...