Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Cisco-HP-Netgear

Mitglied: homermg

homermg (Level 2) - Jetzt verbinden

01.11.2016 um 11:42 Uhr, 918 Aufrufe, 3 Kommentare

Hey Leute,

habe da ein Problem mit einem Switch.

Habe folgendes Konstellation:

QSC VOIP Switch für VOIP Telfone VLAN10 lakels Netzwerk VLAN 1
| |
Cisco Switch (Mainswitch)---------------- viele kleiner Netgear PoE/VOIP Switch von QSC
|
|
HP Etagen Switch
|
|
kleiner Netgear PoE/VOIP Switch von QSC
| VALN1 | VLAN 10
Rechner Telefone

Irgendwie kriege ich die Telefone nicht ans laufen.
Alles lief bis ein HP Switch (Mainswitch) ausgefallen war und ich einen alten Cisco verbaut habe.
Komme glaube ich mit Trunk und Tagging durcheinander.
Zwichen Cisco (Mainswitch) und HP Etagenswitch habe ich auf Cisco Seite Trunk eingeschlatet um alle VLAN's über die LWL zum HP Etagenswitche zu übertragen.
Auf dem HP Etagenswitch habe ich habe ich auf VLAN 10 und 1 den LWL Port gettagt.
Ist doch richtig oder?
PS. an dem Cisco Mainswitch sind auch ein paar kleiner Netgear PoE/VOIP Switch von QSC direkt angeschlossen da läuft alles ohne Probleme.
VG an alle Helfer


Mitglied: aqui
LÖSUNG 01.11.2016, aktualisiert um 20:53 Uhr
Ist der Cisco Switch ein IOS Switch (Catalyst Modell) oder einer aus der SG-x00 Billigserie ?
Wenn es ein IOS Switch (Catalyst) ist, dann wirst du in dem Netzwerk schon ein sehr gravierendes Problem bekommen sofern du redundante Links hast und oder VLAN Segmentierung machst.

Cisco macht von sich aus als Spanning Tree Protokoll PVSTP+. Hat also pro VLAN eine separate, autarke Spanning Tree Instanz laufen die auch noch proprietäre BPDU Mac Adressen verwendent.
Die billigen HP Gurken und noch viel schlimmer, die üblen NetGears können das natürlich als Billigheimer nicht und verstehen somit NICHT den Spanning Tree des Ciscos.
NetGear supportet einzig und allein nur ein Single Span Verfahren also einen globalen STP Prozess für alle VLANs. HP kann zusätzlich wenigstens noch MSTP.
Da Cisco generell KEIN Single Span Verfahren auf seinen Catalysten supportet weder mit STP noch RSTP hast du also ein Problem das sich die STP Protokolle nicht verstehen sofern du sie nicht sauber konfigurierst !
Bei redundanten Links und VLANs bedeutet das Chaos im Netz.

Du kannst dich also nur einzig auf MSTP einigen, denn das ist das STP Protokoll was alle Switches minimal supporten.
Erfordert das du den Cisco und auch die HPs auf MSTP umstellst, was aber sehr schnell mit 2 Zeilen Konfig gemacht ist.
Ob NetGear auch MSTP als billiger Consumer Switch der untersten Sorte supportet, müsstest du im Handbuch nachlesen. Generell ist aber MSTP zu Single Span RSTP kompatibel so das es auch gehen müsste wenn NG es im schlimmsten Falle nicht kann und nur RSTP kann.
Das nur mal vorweg was du zwingend beachten musst beim Einsatz von Consumer Switches der untersten Kategorie mit Cisco Switches.
Es ist also sehr gut möglich und auch wahrscheinlich das dein o.a. Problem aus dieser Tatsache resultiert, weil du das schlicht und einfach übersehen hast oder aus genereller Unwissenheit in diese Falle getappt bist....?!
Übrigens zeigt dir ein show span auf dem Cisco CLI an ob er seine Nachbarswitches kennt und auch deren Spanning Tree Signalisierung. Bei HP ebenso !
Letzteres sicher nicht wenn er ein Catalyst ist und PVSTP+ macht und nicht auf MSTP umgestellt wurde.

Ein Trunking, also den tagged Uplink, zwischen einem Cisco und einem HP zu konfigurieren ist kein Hexenwerk und schnell erledigt (Beispiel mit 3 VLANs: 1, 10 und 20):
Cisco Switch:
interface FastEthernet0/24
description Tagged Uplink zur HP Gurke, Port 1
switchport mode trunk
(switchport trunk encapsulation dot1q)
--> Nur erforderlich wenn der Switch wirklich alt ist !
switchport trunk allowed vlan all
switchport nonegotiate
!
interface vlan 1
description Management IP in VLAN 1
ip address 172.16.1.1 255.255.255.0


HP Switch:

interface 1
name "VLAN Tagged Link zum Cisco (Port Fa 0/24)
exit
vlan 1
name "DEFAULT_VLAN"
untagged 1-9
ip address 172.16.1.2 255.255.255.0
--> HP Switch Management IP in VLAN 1
exit
vlan 10
name "Firma"
untagged 10-11
tagged 1
exit
vlan 20
name "Firmen WLAN"
untagged 12-13
tagged 1
exit

Hier bei HP reicht es den Port 1 (Uplink zum Cisco) immer nur tagged in das betreffende VLAN zu legen. (außer Default VLAN 1 !)
Somit kommen HP und Cisco problemlos zusammen und ein Ping der jeweiligen Management IPs im VLAN 1 ist problemlos möglich.

Bei der NetGear Gurke ist ist außer der schlechten Performance das VLAN Einrichten eine gerechte Strafe für denjenigen der sich solche Switches kauft.
Hier im Forum weil es so unlogisch ist und viele drüber stolpern leider ein Extra Tutorial wert auf dem du dir das alles nochmal ansehen kannst:
https://www.administrator.de/wissen/vlan-installation-routing-pfsense-mi ...
Das Tutorial sollte auch alle deine restlichen Fragen beantworten !

Ist doch richtig oder?
Nein das ist nicht richtig !
Das VLAN 1 ist das Default VLAN in beiden Switches was man NICHT taggen kann. Das weiss man aber auch als Netzwerker
Cisco und auch HP übertragen das Default VLAN (native VLAN) immer untagged auf einem tagged Uplink (Trunkport) per Default !
Das VLAN 1 hier also taggen zu wollen ist extrem kontraproduktiv und bewirkt das nix geht...jedenfalls im VLAN 1
Bitte warten ..
Mitglied: homermg
01.11.2016 um 22:07 Uhr
Wow! Super Danke für die ausführliche Beschreibung. Noch eine Frage:
Wozu brauche ich switchport trunk allowed vlan all? Wenn davor schon switchport mode trunk steht. Da werden doch schon alle Vlan übertragen. Auch wenn ich switchport trunk allowed vlan all eintrage sehe anschließend den Befehl nicht unter show running-config.
Danke!
Bitte warten ..
Mitglied: aqui
02.11.2016 um 18:48 Uhr
Wozu brauche ich switchport trunk allowed vlan all?
Das bewirkt das ALLE konfigurierten VLANs auf dem Trunkport übertragen werden.
Es ist ein etwas neueres Kommando. Ältere Catalyst Switches haben das nicht. Wenn du dort switchport mode trunk konfigurierst ist das Default.
Kannst du daran sehen wenn du das Kommando switchport trunk allowed vlan all eingibst und er versteht das nicht dann kennt er auch das Kommando nicht und du kannst es ignorieren.
Da werden doch schon alle Vlan übertragen.
Nein bei aktuellen IOS Releases nicht. Da sist allow vlan all Pflicht oder das du eben dediziert die VLAN IDs angibst die über den Uplink Trunk gehen sollen.
sehe anschließend den Befehl nicht unter show running-config.
Dann ist er Default und du kannst es ebenfalls ignorieren
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Cisco 3560 gegen HP 5406
Frage von brammerLAN, WAN, Wireless7 Kommentare

Hallo, Ich hatte heute ein Switch Verhalten das ich nicht ganz nach vollziehen kann Cisco 3560: Ein Port in ...

LAN, WAN, Wireless
Netzhardware Cisco, HP und Huawei
Frage von MeinSenfDazuLAN, WAN, Wireless5 Kommentare

Hallo zusammen, ich bin gerade damit beschäftigt ein neues Netzkonzept und dazugehörige Hardware zu beschaffen. Kurz zur Übersicht was ...

LAN, WAN, Wireless

Loop-Protection - HP ProCurve und Cisco Small Business

Frage von BobDerAzubiLAN, WAN, Wireless

Guten Abend liebe Community, ich hoffe ihr könnt mich aufklären: Was passiert wenn ein 8 Port unmanaged, nicht STP-fähiger ...

Netzwerkmanagement

Hilfe bei VLAN Installation mit L3 Cisco und Netgear im Ruhrpott

gelöst Frage von oefchenNetzwerkmanagement31 Kommentare

Hallo Leute, der Frank hier aus Oberhausen. Hab hier schon gefühlte Jahre beim Mitlesen verbracht und muss / will ...

Neue Wissensbeiträge
Sicherheit
0-day Schwachstelle im Internet Explorer
Information von kgborn vor 2 TagenSicherheit

In Microsofts Internet Explorer gibt es eine 0-day Schwachstelle in der Scripting Engine, die faktisch alle Browser- und Windows-Versionen ...

Internet

Internet-Speedtest Automatisieren via Befehlszeile, cmd, Bash (Windows, Linux, FreeBSD, Mac)

Tipp von anteNope vor 2 TagenInternet3 Kommentare

Also das hier ist irgendwie an mir vorbeigegangen. Einfacher geht es schlicht nicht mehr. Speedtest.cmd Via Aufgabenplanung stündlich oder ...

Administrator.de Feedback

Entwicklertagebuch: Codeblöcke auf unseren Seiten

Information von admtech vor 3 TagenAdministrator.de Feedback8 Kommentare

Hallo Administrator User, Unsere Codeblöcke werden ab sofort anders dargestellt. Die Codeblöcke können nun direkt per Copy&Paste kopiert werden. ...

Humor (lol)
Internet - auch 2020 noch Neuland ?
Erfahrungsbericht von Henere vor 3 TagenHumor (lol)6 Kommentare

Heute eine Mail der Schule meiner Tochter bekommen. Blabla Umweltschutz bla bla siehe Anhang. Dumm nur: Da hab ich ...

Heiß diskutierte Inhalte
Webbrowser
Kann Firefox von Google Suche nicht befreien
Frage von RG2525Webbrowser19 Kommentare

Hallo, Das passiert jetzt in letzter Zeit auf mehreren Computern von mir, dass die Google Suche sich nicht ausschalten ...

Sicherheits-Tools
Passwort Manager mit AD anbindung und dt. Oberfläche
gelöst Frage von sani007Sicherheits-Tools12 Kommentare

Hallo Ich suche kostengünstigen Passwort Manager mit AD-Anbindung mit weboberfläche. Am besten mit VM-Image zur schnellen Installation. Wenn es ...

Peripheriegeräte
Datenstrom Drucker
Frage von FragefuchsPeripheriegeräte12 Kommentare

Moin, kann mir jemand sagen, wie Computer Daten an einen Drucker weitergeben? Gibt es dafür ein Protokoll oder Format? ...

DSL, VDSL
O2 Router mit Fritzbox ersetzen - Problem?
gelöst Frage von Daniel.HuferDSL, VDSL11 Kommentare

Hallo, habe eine o2 Router von o2 früher hatte ich einen Alice Vertrag. Die hatte da vor paar Monaten ...