Druckerzuweisung per Batch rundll32 (printui.dll)

DMeyer
Hallo,

ich habe irgendwie Probleme Drucker per Batch zuzuweisen. In den Beiträgen hier werde ich nicht schlau.

Zur Umgebung: Wir nutzen Windows 2003 Server die Clients sind durchgängig XP SP2 Rechner. Der Windows 2003 Server dient als Druckserver und gibt alle Drucker als Netzwerkdrucker frei.

Ich habe in ADS eine Gruppenrichtlinie mit Anmeldescript (Batch) erstellt.

In die Batchdatei habe ich folgenden Befehl eingetragen: rundll32 printui.dll,PrintUIEntry /in /n "\\Fileserver-fs\DP4520EK"
Die zwei zusätzlichen Backslashes wurden vom Board hinzugefügt!

Ich habe zum Testen ob der Batch läuft, diesen auf meinen Rechner durch Doppelklick ausgeführt. Der Drucker wurde einwandfrei hinzugefügt. Der selbe Befehl in der Gruppenrichtlinie fügt aber einen Drucker namens DP-4520EK/ LanMan Druckdienste hinzu. Da es diesen Drucker nicht gibt funktioniert dieser natürlich nicht. Was mache ich falsch?

Vielen Dank!

Daniel

Content-Key: 35254

Url: https://administrator.de/contentid/35254

Ausgedruckt am: 18.01.2022 um 19:01 Uhr

Mitglied: whitefox
whitefox 03.07.2006 um 10:09:43 Uhr
Goto Top
hallo DMeyer

Schau mal hier:

http://www.haferbeck.de/support/techtalk/tt-auto-di/?list=Windows2000&a ...

Man kann den Syntax des Druckbefehls sehen, und mit /j wird irgendwie der Name angegeben, der standardmässig lanman Druckdienste heisst. Versuch doch mal, mit diesem Parameter den Namen entsprechnd anzupassen oder so. Ausserdem denke ich nicht, dass der "Name" dafür verantwortlich ist, dass es NICHT klappt, denn verbunden wird auf jeden Fall den Drucker, den du mit der Freigabe definierst...

Es ist aber trotzdem sehr komisch, da ich den absolut gleichen Befehl hier verwende, allerdings verbinde ich den Drucker mit einem BAT-Script per Loginscript, welches beim Benutzer im AD definiert wurde...

Naja, bin auf dein Feedback gespannt und hoffe, dass ich helfen konnte :) face-smile

whitefox
Mitglied: DMeyer
DMeyer 03.07.2006 um 17:35:48 Uhr
Goto Top

Vielen Dank für den Link!

Man kann den Syntax des Druckbefehls sehen,
und mit /j wird irgendwie der Name
angegeben, der standardmässig lanman
Druckdienste heisst. Versuch doch mal, mit
diesem Parameter den Namen entsprechnd
anzupassen oder so. Ausserdem denke ich
nicht, dass der "Name" dafür
verantwortlich ist, dass es NICHT klappt,
denn verbunden wird auf jeden Fall den
Drucker, den du mit der Freigabe
definierst...

Auf der Seite steht das der Parameter /j: gibt den Namen Druckanbieters/Drucksystems an. Wird mit dem Windows Drucksystem gearbeitet lautet der Name stets 'LanMan-Druckdienste'

Wie bekomme ich denn den Namen des Druckanbieters heraus? ist das Vielleicht einfach der Hersteller des Druckers?

Es ist aber trotzdem sehr komisch, da ich
den absolut gleichen Befehl hier verwende,
allerdings verbinde ich den Drucker mit
einem BAT-Script per Loginscript, welches
beim Benutzer im AD definiert wurde...

genau so mache ich das ja auch! Ich habe mir nur die Batch-Datei aus dem Netloglon Verzeichnis kopiert und wollte die einfach mal lokal testen, damit ich mich nicht immer anmelden muß! Fürhre ich die Batch-datei auf dem Desktop aus, fuktioniert alles einwandfrei. Nehme ich sie beim Anmelden gehts nicht mehr! *amkopfkratz*

Gruß

Daniel
Mitglied: DMeyer
DMeyer 03.07.2006 um 17:46:12 Uhr
Goto Top
Hallo,

habe etwas herausgefunden. Wenn ich die Batchdatei nicht per Gruppenrichtlinie ausführen lasse, sondern diese dem Benutzer in seinem Konto als Batch, dann funktioniert es einwandfrei!

Komisch!

Gruß

Daniel
Mitglied: whitefox
whitefox 03.07.2006 um 18:38:32 Uhr
Goto Top
Yepp, seeeeeeehhhhr komisch :) face-smile

Die Frage ist nun, ob du mit dieser Lösung leben kannst... Mit Umlauten kann es ja auch nichts zu tun haben oder?

Gruss

whitefox
Mitglied: DMeyer
DMeyer 03.07.2006 um 19:21:47 Uhr
Goto Top
Yepp, seeeeeeehhhhr komisch :) face-smile

Die Frage ist nun, ob du mit dieser
Lösung leben kannst... Mit Umlauten
kann es ja auch nichts zu tun haben oder?

Nein mit Umlauten kanns auch nichts zu tun haben und nei ich kann damit nicht leben.

Könnte es daran liegen das der eine DC mit windows 2003 Sp1 installiert hat und der andere nicht? Eigentlich dürfte das nix ausmachen, die Batchdatei wird doch lokal ausgeführt.

ist das eine fummelei!

Gruß

Daniel
Mitglied: whitefox
whitefox 03.07.2006 um 19:30:57 Uhr
Goto Top
Eine gute Frage wegen dem SP1. Installier doch auf jeden Fall dieselbe Version und bring beide Server auf den neuesten Stand. Eventuell funktionierts ja, wenn du mal einen DC vom Netz nimmst, nimm aber nicht den PDC :) face-smile

Gruss und wünsche dir noch viel Erfolg beim Lösen dieses Problems, kann dir im Moment zwar nicht weiterhelfen, aber vielleicht fällt mir noch was ein :) face-smile

whitefox
Heiß diskutierte Beiträge
question
Windows Exchange-Server benötige ich eine Domain?Bella21Vor 1 TagFrageWindows Server21 Kommentare

Hallo alle zusammen, ich bin neu auf dem Gebiet. Ich habe Exchange Server auf einen Windows Server 2012 installiert. Nach der Installation fertig war, ist ...

question
WEBSEITE zerschossen. Brauche dringend hilfe! :) gelöst wieoderwasVor 1 TagFrageWebentwicklung5 Kommentare

Hallo zusammen, ich wollte eben auf der Typo3 Seite von unseren Unternehmen die Erweiterung der IT Kanzlei installieren. Nun erhalte ich beim Webseiten aufruf folgenden ...

question
Scanner Log4JjoergVor 1 TagFrageSicherheits-Tools15 Kommentare

Hallo zusammen, Log4J ist ja mittlerweile schon ein paar Tage her aber immer noch aktuell. Ich bin aktuell auf der Suche nach einem Scanner der ...

question
Welcher Switch Hersteller kann trotz Silikonknappheit ordentlich liefern?NordicMikeVor 1 TagFrageSwitche und Hubs7 Kommentare

Moin zusammen, dieses Ubiquiti Zeug muss weg, das kann ja nicht einmal QoS, auch, wenn der Unifi Controller mit seiner zentralen Verwaltung gut zu bedienen ...

question
DNS neu einrichtensmschmidtVor 1 TagFrageDNS14 Kommentare

Hallo zusammen, hab wieder ein Problem: Hab einen neuen Windows Server 2022 (Server3) in unsere Domain aufgenommen, zum DC gemacht und DHCP und DNS installiert. ...

question
Telefonie noch im alten Standort erneuern?GrinskeksVor 1 TagFrageTK-Netze & Geräte7 Kommentare

Hallo zusammen, bei meinem neuen Arbeitgeber steht der Umzug in ein neues Firmengebäude und eine Aktualisierung der Telekommunikation an. Wir hatten einen Support zur betagten ...

question
Eigene Hardware + VLAN an Vodafone Kabel gelöst darkness08Vor 1 TagFrageInternet12 Kommentare

Guten Morgen Zusammen, ich möchte gerne an einen Vodafone Kabelanschluss eigene Hardware betreiben. Da es sich hierbei nicht um meinen eigenen Anschluss handelt fehlt mir ...

question
Reverse Proxy über 2 netzwerkegiorgio123Vor 1 TagFrageNetzwerke13 Kommentare

Hallo Zusammen Ich habe einen Problem und komme alleine nicht weiter Ich habe einen Revers Proxy im NAT-Bereich der Firewall2. Nun muss dieser Reverseproxy muss ...