roland123
Goto Top

Email kann nicht auf dem Webserver verschickt werden

allo,
ich habe Joomla 1.0.15. Auf meiner Seite habe ich ein Gästebuch und ein Kontaktformular. Leider läuft das kontaktformular immer auf Fehler und sagt Ihre Mail konnte nicht versendet werden. Auch bekomme ich von Gästebuch keine Nachricht, wenn ein Eintrag freigegeben werden muss. In beiden habe ich meine Mailadresse hinterlegt aber ich bekomme keine Nachricht. Muss ich irgendwo noch was hinterlegen damit mich meine HP anmailt?

Content-Key: 106859

Url: https://administrator.de/contentid/106859

Printed on: December 9, 2022 at 00:12 o'clock

Member: maxwave
maxwave Jan 22, 2009 at 16:50:20 (UTC)
Goto Top
Wie sieht denn die Fehlermeldung genau aus?

Kann es sein, dass die Module (Kontaktformular, Gästebuch) bestimmte Einstellungen für den Versand benötigen (Benutzer & Passwort für SMTP-Postfach) ?

Gruß Maxwave
Member: godlie
godlie Jan 23, 2009 at 07:49:57 (UTC)
Goto Top
Hm sieht mehr nach einem Mailserver nicht konfiguriert Problem aus face-smile=

Versuchs mal mit einem externen smtp.
Member: roland123
roland123 Jan 23, 2009 at 09:29:28 (UTC)
Goto Top
hi godlie,

ja das meine ich auch das es am rausschicken liegt.

wie kann ich das Problem lösen? Wie muss ich da vorgehen?
Member: godlie
godlie Jan 23, 2009 at 09:36:05 (UTC)
Goto Top
gib uns mal mehr infos über das system das unter der seite liegt, so unwesentlixche sachen wie
welches betriebssystem?
welcher mailserver?
welche anbindung .......
Member: roland123
roland123 Jan 26, 2009 at 09:08:17 (UTC)
Goto Top
hi
Betriebssystem XP Pro
Mailserver keiner
Anbindung über DYN DNS.

UPS kann es daran liegen, dass ich keinen Mailserver drauf habe?
Member: maxwave
maxwave Jan 26, 2009 at 09:40:52 (UTC)
Goto Top
Hi Rolandhu,

also wenn du einen Mailserver ansprichst der nicht vorhanden ist, dann geht es sicherlich nicht. face-smile
Wenn du die Möglichkeit hast, dann versuch mal einen externen Mailserver mit deinem Modul (Kontaktformular) einzutragen.
Member: roland123
roland123 Jan 26, 2009 at 09:49:55 (UTC)
Goto Top
hi
also ich wollte das ganze über meine Adresse bei web.de laufen lassen. Das müsste doch gehen oder?

Ich habe unter Globale Configuration Reiter Mail folgende Einstellungen

Mailer: SMTP Server
MAIL From da habe ich meine Mail add drin
From Name : joomla
Sendmail Path: /urs/sbin/sendmail
SMTP Auth Nein
SMTP USER nichts
SMTP Pass nichts
SMTP Host: localhost


Muss ich da nicht vielleicht etwas verändern damit es geht?
Member: maxwave
maxwave Jan 26, 2009 at 09:58:05 (UTC)
Goto Top
Ich gehe mal davon aus, dass du einen Apache-Server nutzt um Joomla zum laufen zu bekommen.
Solltest du XAMPP installiert haben, dann gibt es meines Wissens noch Mercury als Dienst. Mercury ist ein Mail Transport System. Ich bin mir da aber auch nicht ganz sicher, da die einzige Joomla-Installation von mir auf einem externen Webserver läuft.

Ansonsten hier mal schaun, da hat glaub ich jemand das gleiche Problem gehabt und gelöst (nur andere Joomla-Version)

http://www.funpic.de/forum/webhosting/ltopic,36403,0,asc,0.html
Member: roland123
roland123 Jan 26, 2009 at 10:08:17 (UTC)
Goto Top
hi
ne XAMPP habe ich nicht. Ich habe die Komponenten einzelnt zusammen gebaut apache php mysql und joomla
Member: godlie
godlie Jan 26, 2009 at 10:12:01 (UTC)
Goto Top
Du wirst sehr wohl in dem SMTP bereich was eintragen müssen
und zwar:

smtp auth <-- stmp Autentifizierung
smtp user <-- deine email addresse
smtp poass <-- dieno mail passwort
smtp host <-- der web.de smtp host

dann dürfte das mit den versenden hinhauen.
Member: roland123
roland123 Jan 26, 2009 at 10:17:30 (UTC)
Goto Top
Zitat von @maxwave:
Ich gehe mal davon aus, dass du einen Apache-Server nutzt um Joomla
zum laufen zu bekommen.
Solltest du XAMPP installiert haben, dann gibt es meines Wissens noch
Mercury als Dienst. Mercury ist ein Mail Transport System. Ich bin mir
da aber auch nicht ganz sicher, da die einzige Joomla-Installation von
mir auf einem externen Webserver läuft.

Ansonsten hier mal schaun, da hat glaub ich jemand das gleiche
Problem gehabt und gelöst (nur andere Joomla-Version)

http://www.funpic.de/forum/webhosting/ltopic,36403,0,asc,0.html




Hi
jo danke für den Link. Der hat mir aber leider auch net weitergeholfen, da das Problem da auch nicht gelöst wurde.
Member: roland123
roland123 Jan 26, 2009 at 10:30:06 (UTC)
Goto Top
so die Eisntellungen habe ich gemacht.
Es kommt die Fehlermeldung: Fehler: Die Email wurde nicht gesendet, bitte versuchen Sie es später noch einmal.
Kann es vielleicht sein, dass auf dem Router ein Port freigeschaltet werden muss?? Vielleicht ein SMTP Port?
Member: maxwave
maxwave Jan 26, 2009 at 10:32:01 (UTC)
Goto Top
Es würde mich wundern wenn der gesperrt ist, aber schauen kannst du ja mal.

SMTP-Port --> 25
Member: godlie
godlie Jan 26, 2009 at 10:32:43 (UTC)
Goto Top
wie wärs denn wenn deine logs mal befragst diesbezüglich?
Ich glaube das ein SMTP auth fehler auftritt.
Sprich benutzer oder passwort falsch.
oder SMTP AUTH vergessen.

ich würd die error.log von php ins Auge fassen.
Member: roland123
roland123 Jan 26, 2009 at 10:52:23 (UTC)
Goto Top
Moin Leute,
merkwürdig mit dem in Joomla eingebauten Modul geht es allerdings nicht mit DF Contakt. Auch das Gästebuch meldet keine Nachricht.